Autor Tópico: Caixa Econômica Federal compatibiliza seu Internet Banking com Ubuntu, Debian e  (Lida 16318 vezes)

paulinho1971

  • Visitante
Re:Caixa Econômica Federal compatibiliza seu Internet Banking com Ubuntu, Debian e
« Resposta #15 Online: 26 de Outubro de 2015, 13:40 »
Pelo nos conta o Visterine que é meu conhecido de longa data e sei que posta sempre soluções posso dizer que a coisa funciona então?!!

Quando eu (hehehe) for solicitado por alguns de meus (hehehe) pupilos/testers que usam o Linux por aqui sei onde ver a coisa.

Já que no meu caso, ainda não precisei de nenhum adicional, pois o único banco que tenho conta é o Bradesco e ainda não notei nenhuma incompatibilidade com o Linux nele.

Off: seria bom se você também adicionasse lá no tópico do LMBR, não? ;)

Valeu a todos, valeu Visterine!

T+

Offline rodrigo.miguel

  • Usuário Ubuntu
  • *
  • Mensagens: 722
    • Ver perfil
    • LinuxUserVlog
Re:Caixa Econômica Federal compatibiliza seu Internet Banking com Ubuntu, Debian e
« Resposta #16 Online: 26 de Outubro de 2015, 20:18 »
ATENÇÃO - ALERTA SOBRE NOVO GOLPE: mensagens falsas estão circulando pela Internet com arquivos e links maliciosos. Não clique em links recebidos por e-mail ou mensagem eletrônica. Não instale arquivos "warsaw" recebidos por e-mail ou mensagem eletrônica. Em caso de dúvida, acesse o site do desenvolvedor do Warsaw: http://www.gastecnologia.com/

Isso provavelmente vale mais para usuários Windows e/ou smartphones. Mas...
« Última modificação: 26 de Outubro de 2015, 20:20 por rodrigo.miguel »

Offline Visterine

  • Usuário Ubuntu
  • *
  • Mensagens: 80
    • Ver perfil
Re:Caixa Econômica Federal compatibiliza seu Internet Banking com Ubuntu, Debian e
« Resposta #17 Online: 26 de Outubro de 2015, 22:02 »
Obrigado pelo feedback companheiro Paulinho71.
Vou colocar lá no LMBR conforme sua sugestão.
Assim podemos alargar as possibilidades e encontrar sempre as melhores soluções para o Linux.
Linux Mint 17.2 Cinnamon AMD Athlon II X4 2.8Ghz Ram 8Gb NVidia GeForce GT 610
Ubuntu 14.04 / Linux Mint 17.2 XFCE Intel Core 2 Duo 3Ghz Ram 4Gb

Offline Visterine

  • Usuário Ubuntu
  • *
  • Mensagens: 80
    • Ver perfil
Re:Caixa Econômica Federal compatibiliza seu Internet Banking com Ubuntu, Debian e
« Resposta #18 Online: 27 de Outubro de 2015, 21:50 »
Pelo nos conta o Visterine que é meu conhecido de longa data e sei que posta sempre soluções posso dizer que a coisa funciona então?!!

Quando eu (hehehe) for solicitado por alguns de meus (hehehe) pupilos/testers que usam o Linux por aqui sei onde ver a coisa.

Já que no meu caso, ainda não precisei de nenhum adicional, pois o único banco que tenho conta é o Bradesco e ainda não notei nenhuma incompatibilidade com o Linux nele.

Off: seria bom se você também adicionasse lá no tópico do LMBR, não? ;)

Valeu a todos, valeu Visterine!

T+

Caro Paulinho71,
O Francis do LMBR me retornou dizendo que o problema persiste com relação ao cadastramento do computador para acesso ao Site da CEF, o mesmo pede instalação do Java.
Linux Mint 17.2 Cinnamon AMD Athlon II X4 2.8Ghz Ram 8Gb NVidia GeForce GT 610
Ubuntu 14.04 / Linux Mint 17.2 XFCE Intel Core 2 Duo 3Ghz Ram 4Gb

Offline antoniodosantosor

  • Usuário Ubuntu
  • *
  • Mensagens: 255
    • Ver perfil
Re:Caixa Econômica Federal compatibiliza seu Internet Banking com Ubuntu, Debian e
« Resposta #19 Online: 27 de Outubro de 2015, 23:32 »
Parou de vez e mostrando como o sistema de acesso a caixa é amador, com dois atendentes, via 0800, não puderam me atender por estarem sem sistema. Desorganização total, fruto do serviço público em que a competência não é cobrada. Continuo afirmando que os programadores (se é que podemos chamá-los de programadores} da CAIXA deveriam estagiar nos Centro de Processamento dos bancos particulares para aprenderem

Offline hugoleal85

  • Usuário Ubuntu
  • *
  • Mensagens: 508
    • Ver perfil
    • Recanto do Tux
Re:Caixa Econômica Federal compatibiliza seu Internet Banking com Ubuntu, Debian e
« Resposta #20 Online: 28 de Outubro de 2015, 08:01 »
Parou de vez e mostrando como o sistema de acesso a caixa é amador, com dois atendentes, via 0800, não puderam me atender por estarem sem sistema. Desorganização total, fruto do serviço público em que a competência não é cobrada. Continuo afirmando que os programadores (se é que podemos chamá-los de programadores} da CAIXA deveriam estagiar nos Centro de Processamento dos bancos particulares para aprenderem

A questão não é porque a CEF é pública (o BB também é e mesmo assim tem um ótimo sistema no Linux). A questão é incompetência mesmo.  >:( >:( >:(
« Última modificação: 16 de Janeiro de 2016, 10:27 por hugoleal85 »
"Cada homem que encontro é superior a mim em alguma coisa; e nisto posso aprender dele." [Ralph W. Emerson]
Meu blog

Offline rodrigo.miguel

  • Usuário Ubuntu
  • *
  • Mensagens: 722
    • Ver perfil
    • LinuxUserVlog
Re:Caixa Econômica Federal compatibiliza seu Internet Banking com Ubuntu, Debian e
« Resposta #21 Online: 28 de Outubro de 2015, 08:13 »
Um truque para acesso com Java é colocar o endereço "https://internetbanking.caixa.gov.br" na lista de exceção de segurança do Java (painel de controle do Java, comando jcontrol, aba Segurança).

E em cada tela do Internet Banking, aguardar o prompt de segurança e dar permissão de execução. O prompt irá aparecer várias vezes. Se pular um prompt, o site não funciona e/ou dá erro no cadastramento da máquina.

Offline arcanjoebc

  • Usuário Ubuntu
  • *
  • Mensagens: 65
    • Ver perfil
Re:Caixa Econômica Federal compatibiliza seu Internet Banking com Ubuntu, Debian e
« Resposta #22 Online: 28 de Dezembro de 2015, 18:06 »
Bom pode ser feita a instalação manual:

Passo a passo: instruções e comandos

1. Acessar a sua conta no Internet Banking da CEF.

2. Vai pedir para baixar o pacote .deb parta a instalação do Warsaw. Salve na pasta Downloads.

3. Abrir o Terminal. Instalar a dependência:

sudo apt-get install libnss3-tools

4. Instalar o pacote warsaw_setup_64.deb(isso para sistemas 64bits, se 32bits certifique-se de baixar a versão correspondente:

cd Downloads

sudo dpkg -i warsaw_setup_64.deb

4.1. O instalador irá solicitar o fechamento do navegador (Firefox, etc).

5. Reiniciar o computador.

6. Tente acessar a sua conta no IB da CEF.

Se não funcionar tente limpar o cache do Firefox. Use a ferramenta de diagnóstico da GAS Tecnologia para verificar: http://gastecnologia.com.br:8080/diagnostico/index.jsp

Alguns usuários realmente tem relatado que parou de funcionar, conforme postagens no site do Diolinux http://www.diolinux.com.br/2015/10/internet-banking-caixa-linux-sem-java.html. Uns precisaram instalar o Java, outros não. O ideal é fazer os testes.

Visterine, estou usando o Ubuntu 15.10 64 bits e já tentei com a dica de instalação do Java, como na versão 15.04 do Ubuntu ... porém, agora, não está funcionando, só dá a mensagem que o "sistema temporariamente indisponível, tente mais tarde" e nada. Liguei para o 0800 da caixa e eles dizem que não dão mais suporte ao Ubuntu 64 bits, somente 32 bits, o que achei um "absurdo"!!! Quanto a dica mencionada por ti, quando entro no site da caixa, não pede para baixar nenhum pacote .deb e pelo site http://gastecnologia.com.br:8080/diagnostico/index.jsp, não tem a opção downloads ... olha, está sendo um sacrifício tentar acessar a caixa com o ubuntu e infelizmente não sei mais o que fazer!!! Tens alguma solução?

Everaldo
Hardware   :  POSITIVO UNION UB3010
Processador:  Intel Dual-Core 1.58 GHz 64 bits 2 GB RAM
S. Os.           :    Ubuntu 15.10, Kubuntu 15.10 e Windows 10 64 bits


Offline arcanjoebc

  • Usuário Ubuntu
  • *
  • Mensagens: 65
    • Ver perfil
Re:Caixa Econômica Federal compatibiliza seu Internet Banking com Ubuntu, Debian e
« Resposta #24 Online: 28 de Dezembro de 2015, 18:40 »
Bom pode ser feita a instalação manual:

Passo a passo: instruções e comandos

1. Acessar a sua conta no Internet Banking da CEF.

2. Vai pedir para baixar o pacote .deb parta a instalação do Warsaw. Salve na pasta Downloads.

3. Abrir o Terminal. Instalar a dependência:

sudo apt-get install libnss3-tools

4. Instalar o pacote warsaw_setup_64.deb(isso para sistemas 64bits, se 32bits certifique-se de baixar a versão correspondente:

cd Downloads

sudo dpkg -i warsaw_setup_64.deb

4.1. O instalador irá solicitar o fechamento do navegador (Firefox, etc).

5. Reiniciar o computador.

6. Tente acessar a sua conta no IB da CEF.

Se não funcionar tente limpar o cache do Firefox. Use a ferramenta de diagnóstico da GAS Tecnologia para verificar: http://gastecnologia.com.br:8080/diagnostico/index.jsp

Alguns usuários realmente tem relatado que parou de funcionar, conforme postagens no site do Diolinux http://www.diolinux.com.br/2015/10/internet-banking-caixa-linux-sem-java.html. Uns precisaram instalar o Java, outros não. O ideal é fazer os testes.

Visterine, estou usando o Ubuntu 15.10 64 bits e já tentei com a dica de instalação do Java, como na versão 15.04 do Ubuntu ... porém, agora, não está funcionando, só dá a mensagem que o "sistema temporariamente indisponível, tente mais tarde" e nada. Liguei para o 0800 da caixa e eles dizem que não dão mais suporte ao Ubuntu 64 bits, somente 32 bits, o que achei um "absurdo"!!! Quanto a dica mencionada por ti, quando entro no site da caixa, não pede para baixar nenhum pacote .deb e pelo site http://gastecnologia.com.br:8080/diagnostico/index.jsp, não tem a opção downloads ... olha, está sendo um sacrifício tentar acessar a caixa com o ubuntu e infelizmente não sei mais o que fazer!!! Tens alguma solução?

Everaldo

Olha, tentei ainda a pouco entrar no site da Caixa, logo após ter postado a dúvida acima e, dessa vez, funcionou!!! Só pediu para eu recadastrar o computador em uso ... ufa!!! Isso é o que eu chamo de "serviço público lenga lenga" eh, eh! Abaixo posto como fiz a instalação do Java para o Firefox no Ubuntu 15.10 64 bits, veja abaixo:

sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update
sudo apt-get install oracle-java8-installer

Veja pelo terminal se instalou (ctrl + alt + T):

andrei@andrei-desktop:~$ java -version
java version "1.8.0_31"
Java(TM) SE Runtime Environment (build 1.8.0_31-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.31-b07, mixed mode)

Para aceitar a licença automaticamente:

echo oracle-java8-installer shared/accepted-oracle-license-v1-1 select true | sudo /usr/bin/debconf-set-selections

Para selecionar ou Java 7 ou Java 8:

sudo update-java-alternatives -s java-7-oracle

ou

sudo update-java-alternatives -s java-8-oracle


Para selecionar automaticamente o Java 8:

sudo apt-get install oracle-java8-set-default

Depois de toda essa maratona, no dash, digite a palavra "Java" e clique na opção "Oracle Java Plugin Control Panel" e escolha a aba "Segurança", "Editar lista de sites ..." e coloque os endereços abaixo:


    https://internetbanking.caixa.gov.br/siwinstatic/applet/gbas/gbas.jar
    https://internetbanking.caixa.gov.br
    https://internetbanking.caixa.gov.br/SIIBC/index.processa
    https://internetbankingpf.caixa.gov.br/SIIBC/siwinCtrl


Após os procedimentos acima, experimente entrar no site. Irá aparecer uma janela pedindo permissão para tu executares o Java, escolha "permitir e memorizar" ou algo assim e, depois, as janelas para dar execução ao Java ... escolha a opção apropriada e não se preocupe dele(o site) dizendo que " ... biblioteca não suportada", apenas ignore isso. Muitas vezes, tu terás que cadastrar o computador novamente, infelizmente, para esse caso, tem-se que cadastrar novamente com outro nome que não o que estava em uso ... bom, acho que é isso, espero ter ajudado, tudo de bom a todos!

Everaldo
« Última modificação: 28 de Dezembro de 2015, 19:40 por arcanjoebc »
Hardware   :  POSITIVO UNION UB3010
Processador:  Intel Dual-Core 1.58 GHz 64 bits 2 GB RAM
S. Os.           :    Ubuntu 15.10, Kubuntu 15.10 e Windows 10 64 bits

Offline Visterine

  • Usuário Ubuntu
  • *
  • Mensagens: 80
    • Ver perfil
Re:Caixa Econômica Federal compatibiliza seu Internet Banking com Ubuntu, Debian e
« Resposta #25 Online: 12 de Janeiro de 2016, 21:40 »
Arcanjoebc,

Parece que o Banco voltou a dar suporte ao acesso por Linux.

Obrigado por compartilhar.
Linux Mint 17.2 Cinnamon AMD Athlon II X4 2.8Ghz Ram 8Gb NVidia GeForce GT 610
Ubuntu 14.04 / Linux Mint 17.2 XFCE Intel Core 2 Duo 3Ghz Ram 4Gb

Offline rodrigo.miguel

  • Usuário Ubuntu
  • *
  • Mensagens: 722
    • Ver perfil
    • LinuxUserVlog
Re:Caixa Econômica Federal compatibiliza seu Internet Banking com Ubuntu, Debian e
« Resposta #26 Online: 13 de Janeiro de 2016, 11:34 »
O Warsaw é o novo Módulo Adicional de Segurança do Internet Banking da Caixa Econômica Federal.

Não é mais necessário ter o JAVA instalado.
Sim, livres do Java!

Sobre o Warsaw: http://www.gastecnologia.com/suporte/warsaw

Pré-requisitos para a instalação: ter os pacotes libnss3-tools e libcurl3 instalados.
Pelo Terminal, execute:

Código: [Selecionar]
sudo apt-get install libnss3-tools libcurl3
...ou instale pela Central de programas.

Instalação: acessar o Internet Banking, baixar o pacote GBPCEFwr64.deb e instalar...

VÍDEO demonstrativo: https://youtu.be/gqZoalfZ2f4

No vídeo é utilizado o instalador GDebi. Você pode utilizar a Central de programas ou o Terminal.
No vídeo, o GDebi pede para reinstalar o pacote. Isso acontece porque tenho o módulo Warsaw do Itaú instalado.

Tutorial para instalação via linha de comando (Terminal): https://imagem.caixa.gov.br/asc/tutorial_warsaw.htm

Mais informações, no blog: http://linuxuserlog.blogspot.com.br/
« Última modificação: 13 de Janeiro de 2016, 19:23 por rodrigo.miguel »

Offline EdvaldoSCruz

  • Usuário Ubuntu
  • *
  • Mensagens: 2.326
  • Deus é bom e JESUS CRISTO é o filho dEle.(Jo14:23)
    • Ver perfil
Re:Caixa Econômica Federal compatibiliza seu Internet Banking com Ubuntu, Debian e
« Resposta #27 Online: 13 de Janeiro de 2016, 21:46 »

Não é mais necessário ter o JAVA instalado.
Sim, livres do Java!


Corrigindo o colega:

 Livre somente para a CEF, mas para os outros bancos continuam a usar o Java Oracle normalmente.
« Última modificação: 13 de Janeiro de 2016, 21:48 por EdvaldoSCruz »
Ignorância é não aceitar e não submeter-se a CRISTO JESUS.
Para os Iniciantes, como eu, links de solucionar problemas rapidamente.

Offline rodrigo.miguel

  • Usuário Ubuntu
  • *
  • Mensagens: 722
    • Ver perfil
    • LinuxUserVlog
Re:Caixa Econômica Federal compatibiliza seu Internet Banking com Ubuntu, Debian e
« Resposta #28 Online: 13 de Janeiro de 2016, 22:32 »

Não é mais necessário ter o JAVA instalado.
Sim, livres do Java!


Corrigindo o colega:

 Livre somente para a CEF, mas para os outros bancos continuam a usar o Java Oracle normalmente.

Corrigindo o colega [2]:

CEF, Itaú, entre outros:
http://gastecnologia.com.br:8080/diagnostico/index.jsp?lingua=br

Offline EdvaldoSCruz

  • Usuário Ubuntu
  • *
  • Mensagens: 2.326
  • Deus é bom e JESUS CRISTO é o filho dEle.(Jo14:23)
    • Ver perfil
Re:Caixa Econômica Federal compatibiliza seu Internet Banking com Ubuntu, Debian e
« Resposta #29 Online: 14 de Janeiro de 2016, 18:42 »

Não é mais necessário ter o JAVA instalado.
Sim, livres do Java!


Corrigindo o colega:

 Livre somente para a CEF, mas para os outros bancos continuam a usar o Java Oracle normalmente.

Corrigindo o colega [2]:

CEF, Itaú, entre outros:
http://gastecnologia.com.br:8080/diagnostico/index.jsp?lingua=br

Não funciona no Banco do Brasil
Ignorância é não aceitar e não submeter-se a CRISTO JESUS.
Para os Iniciantes, como eu, links de solucionar problemas rapidamente.