Autor Tópico: Elementary OS 0.3.2 não reconhece todos os núcleos do processador  (Lida 2252 vezes)

Offline Anderson Dantas

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
Olá amigos,

Tenho o Elementary OS Freya instalado em um notebook com as seguintes configurações:

  • Sistema operacional: Elementary OS 0.3.2 (freya), 64 bits, Kernel 3.19.0-54-generic
  • Processador: Intel® Core™ i3 CPU,  M 380  @ 2.53GH, 1466.000 MHz
  • Memória: 3,7 GiB
  • Gráficos: Intel Corporation Core Processor Integrated Graphics Controller (rev 18)

O problema é que ele reconhece apenas um núcleo do meu processador, em vez dos quatro, deixando o sistema lento.

http://i67.tinypic.com/qy5ylw.png

Esta é a resposta do comando "cat /proc/cpuinfo":

Código: [Selecionar]
processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 37
model name : Intel(R) Core(TM) i3 CPU       M 380  @ 2.53GHz
stepping : 5
microcode : 0x2
cpu MHz : 2533.000
cache size : 3072 KB
physical id : 0
siblings : 1
core id : 0
cpu cores : 1
apicid : 0
initial apicid : 0
fpu : yes
fpu_exception : yes
cpuid level : 11
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 popcnt lahf_lm arat dtherm tpr_shadow vnmi flexpriority ept vpid
bugs :
bogomips : 5053.85
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

Lembro que ele reconheceu os quatro núcleos na primeira inicialização do sistema, logo depois que instalei. Depois que atualizei e reiniciei o notebook foi quando o problema surgiu.

Já tentei atualizar o kernel para uma versão mais recente, mas isso não resolveu.
Reinstalei o sistema e nada também.
Até instalar a versão Elementary OS 0.3.1 eu já tentei. A mesma coisa acontece.

Alguém aqui já enfrentou esse problema e pode me ajudar?

Desde já fico muito agradecido!

---
Imagem irregular. Editado pela moderação.
« Última modificação: 10 de Março de 2016, 16:47 por irtigor »


Offline Anderson Dantas

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
Re:Elementary OS 0.3.2 não reconhece todos os núcleos do processador
« Resposta #2 Online: 08 de Março de 2016, 22:13 »
O comando "cat /etc/default/grub" retornou o seguinte:

Código: [Selecionar]
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

O que devo modificar?

Offline Azebadam

  • Usuário Ubuntu
  • *
  • Mensagens: 8
    • Ver perfil
Re:Elementary OS 0.3.2 não reconhece todos os núcleos do processador
« Resposta #3 Online: 09 de Março de 2016, 14:19 »
Ola  Anderson Dantas,



você já experimentou dar boot com um live CD do Ubuntu, só para verificar se esse erro persiste ?
.:: User Linux #369769 ::.

Offline Anderson Dantas

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
Re:Elementary OS 0.3.2 não reconhece todos os núcleos do processador
« Resposta #4 Online: 09 de Março de 2016, 14:31 »
Pessoal, acredito que encontrei a causa do problema :)

Aparentemente a culpada era a bateria da placa mãe (CMOS). Ela estava descarregada há várias semanas e somente hoje eu substituí por uma nova.

http://i.imgur.com/gWzJA1i.png?1

Agora tudo está funcionando como deveria! Embora não tenha entendido direito a relação entre uma coisa e outra.

Mas de qualquer forma, fico muito agradecido pela atenção de vocês.

Forte abraço!
« Última modificação: 10 de Março de 2016, 16:47 por irtigor »