Autor Tópico: Tela piscando usando o browser no Ubuntu 16.04  (Lida 4330 vezes)

Offline Djjr

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Tela piscando usando o browser no Ubuntu 16.04
« Online: 20 de Maio de 2016, 18:14 »
Olá pessoal,
Uso o Ubuntu 16.04 em um notebook cce e jogo a imagem da tela do note em um monitor via cabo hdmi. Ocorre que quando eu uso o navegador OPERA e outros navegadores por diversas vezes, em vários sites a tela fica dando uma piscada, geralmente quando esta carregando imagens e na execução de vídeos. Vale destacar que não é a tela inteira, mas partes dentro do proprio navegador, da umas piscadas, tipo falhas. O que pode ser? Qual a solução?
Fiz uma instalação limpa a uma semana.
OBS 1.: A uma semana usava o ubuntu 15.10 nas mesmas condições e não acontecia isso.
OBS 2.: Estou usando o Ubuntu 16.04 junto com os temas/icon paper e ta show. Tenho o ubuntu em dual boot e faz tempo que não inicio o windows!!!
Atualização 1: Observei que nada disso acontece quando uso o firefox, será que preciso instalar o flash player, ou é o navegador opera que ainda não esta totalmente compatível com o ubuntu 16.04?
Obrigado.
« Última modificação: 20 de Maio de 2016, 21:29 por Djjr »

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.293
    • Ver perfil
Re:Tela piscando usando o browser no Ubuntu 16.04
« Resposta #1 Online: 21 de Maio de 2016, 04:16 »
Então, /Djjr/,

Há muito tempo que não tinha contato e não usava o Ópera, porém motivado pelo seu tópico baixei (versão 37.0.2178.32) e instalei no Ubuntu 16.04 padrão (Unity) 64-bit.

Foi uma boa surpresa, o Ópera está muito bom e rápido!

Usei bastante, em váriados sites, alguns com bastante uso de imagens (por exemplo, UOL) e também em vários vídeos do YouTube, especialmente nesses que relaciono abaixo, os três primeiros em HD (720p), o seguinte em 480p, todos eles vistos em tela cheia.

Aqui não apresentou nenhum problema, não consegui reproduzir a falha, o que inicialmente leva a pensar possa não ser problema no Ópera.

Para sermos mais específicos, faça um teste nesses links abaixo do Trio Sinhá Flor, aproveite para apreciar as maravilhosas meninas e a música deliciosa que produzem, de alta qualidade, a exemplo do que fizeram no programa SuperStar 2015, na Globo, talento em estado puro, o gênero é específico, mas elas são espetaculares na boa música e instrumentistas, virei fã.  ;D


Trio Sinhá Flor

Forró Floreado - Sr. Brasil - TVCultura

https://youtu.be/egwY2MDlz8Q

"Pout Pourri" : Raça / Maria Maria / Faca Amolada - Sr. Brasil - TVCultura

https://youtu.be/R2-BJ_PkOoY

Trio Sinhá Flor encontra Leila Pinheiro --> isso aqui ficou uma obra-prima!

https://youtu.be/oHkZHQxa3dQ

Trio Dona Flor - A velha debaixo da cama - TVCultura

https://youtu.be/uuj-swtmDCI

Trio Sinhá Flor - site oficial

http://www.triosinhaflor.com.br

Toda a instalação aqui está original, isto é, os vídeos foram assistidos em HTML5, sem nenhuma instalação de flashplayer, bem como a instalação do Ubuntu 16.04 também é ela mesma toda original, sem adicionais de nenhuma espécie fora do padrão e que pudesse distorcer o resultado, entretanto nessa mesma instalação tenho o Google Chrome instalado.

Se assistindo esses vídeos o problema não se reproduzir, então indique especificamente sites e/ou vídeos em que o problema objetiva e repetidamente ocorre para tentarmos reproduzir a questão e, se o caso, tentar analisar o problema.

Dê alguma informação adicional sobre o seu computador e o cenário aí existente:

1) hardware: cpu, ram, motherboard, gpu. Marca e modelo, se existirem, podem auxiliar na solução do problema.
Você disse que é um CCE, mas qual modelo mais exatamente?

2) marca e modelo do monitor externo que está conectado via hdmi?

3) não ficou muito claro, a falha que você relata acontece simultaneamente na tela do notebook e na tela externa hdmi ou apenas na tela externa hdmi?

4) instale o inxi e poste aqui o resultado do comando abaixo para que tenhamos um panorama técnico da sua máquina:

Para instalar:

Código: [Selecionar]
sudo apt install inxi
Execute, copie e cole o resultado aqui no tópico:

Código: [Selecionar]
inxi -b
5) execute também os dois comandos abaixo e igualmente traga o resultado:

Código: [Selecionar]
lspci
Código: [Selecionar]
sudo lshw -c display
6) Você está dizendo que o problema não se reproduz quando usa o Firefox, então instale também o Google Chrome para termos mais um elemento de comparação.
Ocorre o mesmo problema também no Chrome ou não?

Fiquei muito bem impressionado com o retorno do Ópera.  :)

« Última modificação: 21 de Maio de 2016, 04:57 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Djjr

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re:Tela piscando usando o browser no Ubuntu 16.04
« Resposta #2 Online: 22 de Maio de 2016, 14:02 »
Cara primeiramente agradecer pela sua disponibilidade em me ajudar.
Os erros ocorrem em varias páginas como G1, UOL, YouTube. Da umas piscadas bem toscas em lugares alternativos na página, até o speed dial do próprio navegador opera da umas falhadas. O mesmo erro ocorre com o Chome, Vivald e no Opera. Apenas no FIrefox não ocorre o erro.
Já tentei reinstalar os programas e nada.
A tela do note esta com problema por isso eu uso o note no motinor via cabo HDMI, até segunda agora estava tudo normal, ai eu na segunda atualizei para o ubuntu 16.04 e ja instalei os pacotes extras de codecs e outros programas.

Baixo os dados que vc solicitou:

System:    Host: XXXXnote Kernel: 4.4.0-22-generic x86_64 (64 bit)
           Desktop: Unity 7.4.0  Distro: Ubuntu 16.04 xenial
Machine:   System: Intel product: HuronRiver Platform v: 0.1
           Mobo: Intel model: Emerald Lake v: FAB1
           Bios: Phoenix v: 2.07_ date: 03/24/2011
CPU:       Quad core Intel Core i7-2630QM (-HT-MCP-) speed/max: 1039/2900 MHz
Graphics:  Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
           Display Server: X.Org 1.18.3 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.00hz
           GLX Renderer: Mesa DRI Intel Sandybridge Mobile
           GLX Version: 3.0 Mesa 11.2.0
Network:   Card-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
           driver: r8169
           Card-2: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express)
           driver: ath9k
Drives:    HDD Total Size: 500.1GB (17.1% used)
Info:      Processes: 266 Uptime: 1:44 Memory: 2101.9/3865.0MB
           Client: Shell (bash) inxi: 2.2.35




00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b5)
00:1c.2 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 3 (rev b5)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation HM65 Express Chipset Family LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 05)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller (rev 05)
07:00.0 Network controller: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

*-display               
       descrição: VGA compatible controller
       produto: 2nd Generation Core Processor Family Integrated Graphics Controller
       fabricante: Intel Corporation
       ID físico: 2
       informações do barramento: pci@0000:00:02.0
       versão: 09
       largura: 64 bits
       clock: 33MHz
       capacidades: msi pm vga_controller bus_master cap_list rom
       configuração: driver=i915 latency=0
       recursos: irq:26 memória:d0000000-d03fffff memória:c0000000-cfffffff porta de E/S:4000(tamanho=64)

Offline Djjr

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re:Tela piscando usando o browser no Ubuntu 16.04
« Resposta #3 Online: 22 de Maio de 2016, 14:07 »
Talvez algum drive esta incompatível, pois os três navegadores que estão com problemas :Opera, Chrome e Vivald usam a mesma base, o Chromiun. Será que é algo com o pacote de codecs ubuntu-restricted-extras?
Tem um outro problema que vou postar depois, eu configurei para a saída de som ser a do monitor via cabo hdmi, ocorre que toda vez que ligo o pc ou a tela bloqueia e apaga, volta o som para o notebook, tipo como ele não salvesse minha opção para a saída de som ser a hdmi.
« Última modificação: 22 de Maio de 2016, 14:23 por Djjr »

Offline Djjr

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re:Tela piscando usando o browser no Ubuntu 16.04
« Resposta #4 Online: 22 de Maio de 2016, 22:41 »
Para ajudar fiz um vídeo do problema. Se quiser ir logo para parte que passa o problema adiantar o vídeo para 4:40 min e 6.50min.
https://www.youtube.com/watch?v=-ji4A4BO9O4

Alguém saber dizer como corrijo essas falhas ou piscadas não sei como chama.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.293
    • Ver perfil
Re:Tela piscando usando o browser no Ubuntu 16.04
« Resposta #5 Online: 23 de Maio de 2016, 03:21 »
Se vi direito no vídeo que você gravou parece um a espécie de flash, mais ou menos semelhante ao de máquina fotográfica, por detrás da tela.

Observe que no vídeo que você gravou para demonstrar o problema você está o tempo todo fazendo intervenção na tela através do mouse, não é uma situação fluída, contínua, constante, precisa delimitar isso melhor, para poder ter uma ideia de onde procurar.

Mas precisamos estabelecer uma base comum de pesquisa para a questão não ficar totalmente errática.

Assistiu usando o Opera especificamente aqueles vídeos que linkei do Trio Sinhá Flor, tanto o de 720p como o de 480p?

Qual foi o resultado? O mesmo problema se manifestou naqueles específicos vídeos dos links indicados ou não?



www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Djjr

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re:Tela piscando usando o browser no Ubuntu 16.04
« Resposta #6 Online: 23 de Maio de 2016, 08:49 »
Assisti sem problema. Esses flash ocorrem geralmente nos menus do you tube, nas propagandas. Aqueles flash ocorrem usando o Opera, Vivald e Chome. Algo relacionado as imagens deve esta incompatível, algum codec ou drive.
« Última modificação: 23 de Maio de 2016, 08:55 por Djjr »

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.293
    • Ver perfil
Re:Tela piscando usando o browser no Ubuntu 16.04
« Resposta #7 Online: 23 de Maio de 2016, 14:03 »
Citar
Mobo: Intel model: Emerald Lake v: FAB1
CPU:       Quad core Intel Core i7-2630QM (-HT-MCP-) speed/max: 1039/2900 MHz
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:1f.0 ISA bridge: Intel Corporation HM65 Express Chipset Family LPC Controller (rev 05)
configuração: driver=i915 latency=0
A tela do note esta com problema por isso eu uso o note no motinor via cabo HDMI [...]
Aqueles flash ocorrem usando o Opera, Vivald e Chome.
 A uma semana usava o ubuntu 15.10 nas mesmas condições e não acontecia isso.


Bem, o que temos: seu sistema é baseado em Intel, um processador muito bom (i7) e vídeo padrão Intel Graphics baseado no chipset H65, executando driver padrão i915. É uma configuração muito boa e tipicamente não problemática, nada obstante, a tela do notebbok está com problemas, fazendo uso de um monitor externo, via hdmi. Usando a versao 15.10 o problema não ocorre.

1) Pois bem, você diz que no Firefox não ocorre o problema e agora menciona as "propagandas" das páginas.
Confirme no Firefox que tem instalado, vendo em 'Complementos', como está a configuração do Shockwave Flash (Nunca ativar / Perguntar para ativar /Sempre ativar), qual delas está configurada?

2) Se usar o bloqueador de propagandas nativo do Opera o problema ainda ocorre ou não?

« Última modificação: 23 de Maio de 2016, 14:05 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Djjr

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re:Tela piscando usando o browser no Ubuntu 16.04
« Resposta #8 Online: 23 de Maio de 2016, 15:57 »
Colega vai as respostas:
1)Esta na opção sempre ativado
2)Os problemas ocorrem com o bloqueador ativo, desativado, com extensão de bloqueio e até com tudo desabilitado(todos os bloqueadores)

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.215
    • Ver perfil
Re:Tela piscando usando o browser no Ubuntu 16.04
« Resposta #9 Online: 23 de Maio de 2016, 17:09 »
OLá Djjr. Achei mais relatos sobre o seu problema. Está realmente afetando a placa de  vídeo Intel.  É um  problema do kernel.  Parece que foi resolvido com o kernel 4.6, ainda em desenvolvimento para o Ubuntu, apesar de já ser estável na árvore do kernel Linux! Você já pode ir testando, por sua conta e risco: http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-intel-nightly/current/


Se preferir não arriscar, você pode contornar o problema desabilitando a "Rolagem Suave" ou "smooth scrolling" em inglês,  no Navegador!

Outra alternativa é alterar a configuração do driver Intel, fazendo ele usar o UXA ao invés do SNA:

Código: [Selecionar]
Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "uxa"
EndSection

Adicione isso a configuração do xorg colocando isso no arquivo /usr/share/X11/xorg.conf.d .


Postagem original em inglês com as possíveis soluções: http://askubuntu.com/questions/752743/ubuntu-16-04-skylake-6th-generation-screen-flickering

Então preste atenção! Não  é pra usar as 3 soluções ao mesmo tempo!  Tente uma de cada vez!  A do kernel é a que realmente resolve segundo a maioria dos relatos do link acima!
« Última modificação: 23 de Maio de 2016, 17:12 por galactus »
* Linux Mint 18 Mate 64bits / Windows 10 64bits Casa! * CentOS 7 64bits Servidor de arquivos em modo texto - Casa * MacOS Sierra  - Mac Mini servidor multimidia - Casa * DELL Inspiron 14R + Ubuntu Mate 17.04 64bits.

Offline Djjr

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re:Tela piscando usando o browser no Ubuntu 16.04
« Resposta #10 Online: 23 de Maio de 2016, 17:37 »
Poxa vida. Não entendo muito bem de linux e não queria arriscar alterando essas configurações e quebrar o sistema. Será que vai demorar muito a atualização do kernel para 4.6 pelas vias normais, acho que repositórios do ubuntu?

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.215
    • Ver perfil
Re:Tela piscando usando o browser no Ubuntu 16.04
« Resposta #11 Online: 24 de Maio de 2016, 21:55 »
Com certeza o kernel 4.6 não vai aparecer nos repositórios oficiais do Ubuntu 16.04! Talvez apareça no "proposed", ou seja, para quem gosta de aventuras e fortes emoções!

Neste aspecto o Ubuntu não segue o Fedora , por exemplo, aonde eles trocam a versão do kernel da distro dentro de uma mesma versão.

Mas as duas primeiras mudanças, em especial a segunda, você não vai correr risco.  Mudar uma opção do navegador não vai quebrar o seu sistema.

E instalar o kernel 4.6 também não deve quebrar o sistema. É uma versão feita para o Ubuntu, é do PPA mainline para kerneis do Ubuntu.  O máximo que vai acontecer é não dar o boot.  Ele pode ficar instável ou travar tudo.  Daí você reinicia o sistema e usa o kernel que você sabe que funciona!   Eu testo vários kerneis nas minhas máquinas. Quando não funciona um novo eu não uso, simples assim.

Então pra escolher o kernel antigo que funciona na hora do boot, você terá que alterar o Grub para que ele mostre os kerneis instalados, aí você poderá escolher entre eles e voltar para o kernel que funciona. Se, eu disse  se você quiser mudar de kernel.

Mude a opção de rolagem do navegador e vê se resolve!
* Linux Mint 18 Mate 64bits / Windows 10 64bits Casa! * CentOS 7 64bits Servidor de arquivos em modo texto - Casa * MacOS Sierra  - Mac Mini servidor multimidia - Casa * DELL Inspiron 14R + Ubuntu Mate 17.04 64bits.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.293
    • Ver perfil
Re:Tela piscando usando o browser no Ubuntu 16.04
« Resposta #12 Online: 24 de Maio de 2016, 22:59 »
Citar
E instalar o kernel 4.6 também não deve quebrar o sistema.

Tenho o kernel 4,6 rodando no Ubuntu 16.04 padrão (Unity) numa derteminada instalação, por enquanto sem nenhuma dificuldade, funcionamento absolutamente normal.

Claro que quando se instala kernel descasado da atualização normal da distribuição sempre há um potencial de  vir a dar problemas numa atualização futura, mas no momento aqui está totalmente funcional.

Código: [Selecionar]
$ uname -a
Linux dellchristest1604 4.6.0-040600-generic #201605151930 SMP Sun May 15 23:32:59 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
:~$

Como o /galactus/ muito bem explicou, não há exatamente um "problemão" em instalar um outro kernel, desde que se mantenha aqueles que são o padrão para o caso de alguma emergência, de algum descasamento futuro que, em tese, possa vir a ocorrer, mas se for fazer algo, comece mesmo pelo mais simples.

« Última modificação: 25 de Maio de 2016, 02:43 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Djjr

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re:Tela piscando usando o browser no Ubuntu 16.04
« Resposta #13 Online: 24 de Maio de 2016, 23:30 »
Pessoal instalei o Kernel 4.6 no ubuntu 16.04 e esta absolutamente normal, aprendi como da boot com uma versão antiga do kernel e ainda tenho uma live cd do ubuntu no gatilho. Infelizmente o problema não foi resolvido, diminuiu um poco só, mas continua. Assim resolvi voltar para o Firefox como padrão. Personalizei o firefox para ficar com as funcionalidades parecidas do Opera. Pessoal o problema não foi resolvido, mas acho que por enquanto só. Obrigado a todos que ajudaram.

Offline Qwertyc

  • Usuário Ubuntu
  • *
  • Mensagens: 32
    • Ver perfil
Re:Tela piscando usando o browser no Ubuntu 16.04
« Resposta #14 Online: 25 de Maio de 2016, 07:47 »
Pessoal,não sei se vai servir,mas o computador do meu filho estava com a tela piscando em alguns jogos,e no youtube,e resolvemos trocando o cabo hdmi,já tinhamos trocado o driver de video,verificamos a placa,e no final era o cabo!