Autor Tópico: Instalar pacote lsb-core no Ubuntu 16.04  (Lida 1612 vezes)

Offline jkmsjq

  • Usuário Ubuntu
  • *
  • Mensagens: 3.325
  • Ubuntu Member
    • Ver perfil
Instalar pacote lsb-core no Ubuntu 16.04
« Online: 28 de Junho de 2016, 15:22 »
Para quem necessitar, por um acaso, instalar o pacote lsb-core no Ubuntu 16.04 (por exemplo, para instalar o Google Earth), necessitará realizar uma gambiarra para tal feito.

O que eu realizei foi o seguinte. Em terminal, digitei o seguinte comando:

Código: [Selecionar]
sudo add-apt-repository "deb http://cz.archive.ubuntu.com/ubuntu trusty main" && sudo apt-get update && sudo apt-get install lsb-core
Com este comando inseri um repositório do Ubuntu 15.10 no sources.list do Ubuntu Xenial e realizei a instalação normalmente do pacote.

Bom, fica a dica!

P.S.: Se alguém quiser desativar este repositório para evitar de dar problema de conflito com algum pacote do Ubuntu Xenial, basta fazer o seguinte. Em terminal (Ctrl + Alt + T) digite:

Código: [Selecionar]
sudo nano /etc/apt/sources.list
Busque pelo repositório instalado no comando do início do post e basta apenas comentá-lo, ou seja, colocar um # no começo da linha.

Este repositório provavelmente estará no fim do arquivo.
« Última modificação: 28 de Junho de 2016, 15:27 por jkmsjq »
LinuxUser: 548942 / Dando um tópico como resolvido
"A verdade só é agressiva a quem vive de mentiras". Autor desconhecido.
Twitter: @jeisonkertesz

Offline ronaldofas

  • Usuário Ubuntu
  • *
  • Mensagens: 8
    • Ver perfil
Re:Instalar pacote lsb-core no Ubuntu 16.04
« Resposta #1 Online: 17 de Fevereiro de 2017, 10:09 »
Olá, estou tentando instalar o LSB e dá conflito de dependências, como resolvo?

Código: [Selecionar]
ronaldo@ronaldo-Lenovo-G460:~/Downloads$ sudo apt-get install lsb
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
 lsb : Depende: lsb-core (>= 9.20160110ubuntu0.2)
       Depende: lsb-printing (>= 9.20160110ubuntu0.2) mas não será instalado
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.


Offline creto

  • Expectador
  • Usuário Ubuntu
  • *
  • Mensagens: 294
  • Vivemos esperando dias melhores
    • Ver perfil
    • Blog do Creto
Re:Instalar pacote lsb-core no Ubuntu 16.04
« Resposta #2 Online: 17 de Fevereiro de 2017, 10:46 »
Mas caro jkmsjq há algum problema com o pacote lsb-core dos repositórios oficiais do ubuntu?

Código: [Selecionar]
benedito@lubuntu:~$ apt-cache showpkg lsb-core
Package: lsb-core
Versions:
9.20160110ubuntu0.2 (/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_xenial-updates_universe_binary-i386_Packages)
 Description Language:
                 File: /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_xenial-updates_universe_binary-i386_Packages
                  MD5: 390d8738603a81a9f136aad6064a4b28
 Description Language: en
                 File: /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_xenial-updates_universe_i18n_Translation-en
                  MD5: 390d8738603a81a9f136aad6064a4b28


Reverse Depends:
  lsb,lsb-core 9.20160110ubuntu0.2
  lsb-security,lsb-core 9.20160110ubuntu0.2
  lsb-printing,lsb-core 9.20160110ubuntu0.2
  console-setup-mini,lsb-core 2.0-6
  console-setup,lsb-core 2.0-6
  console-setup,lsb-core 2.0-6
  matlab-support,lsb-core
  qmail-run,lsb-core
  console-setup-mini,lsb-core 2.0-6
Dependencies:
9.20160110ubuntu0.2 - lsb-release (2 9.20160110ubuntu0.2) libc6 (4 2.3.5) libz1 (0 (null)) libncurses5 (0 (null)) libpam0g (0 (null)) lsb-invalid-mta (18 9.20160110ubuntu0.2) mail-transport-agent (0 (null)) at (0 (null)) bc (0 (null)) binutils (0 (null)) bsdmainutils (0 (null)) bsdutils (0 (null)) cpio (0 (null)) cron (16 (null)) cron-daemon (0 (null)) ed (0 (null)) file (0 (null)) libc6-dev (16 (null)) libc-dev (0 (null)) locales (0 (null)) cups-bsd (16 (null)) lpr (0 (null)) lprng (16 (null)) cups-client (0 (null)) m4 (0 (null)) mailx (16 (null)) mailutils (0 (null)) make (0 (null)) man-db (0 (null)) mawk (16 (null)) gawk (0 (null)) ncurses-term (0 (null)) passwd (0 (null)) patch (0 (null)) pax (0 (null)) procps (0 (null)) psmisc (0 (null)) rsync (0 (null)) alien (2 8.36) python3 (0 (null)) python3:any (2 3.4~) lsb-base (2 9.20160110ubuntu0.2) lsb-security (2 9.20160110ubuntu0.2) time (0 (null)) cups-filters-lsb (0 (null)) cups-filters-lsb (0 (null))
Provides:
9.20160110ubuntu0.2 - lsb-core-noarch (= ) lsb-core-ia32 (= )
Reverse Provides:
benedito@lubuntu:~$

Não entendi o motivo do PPA o google earth daria problema com o pacote do repositório oficial, é isso?

T+
Perguntas-me qual foi o meu progresso? Comecei a ser amigo de mim mesmo. (Lúcio Aneu Séneca)
Blog do Creto - Teste Blog do Creto