Autor Tópico: De novo eles.... Os "Pacotes Quebrados"  (Lida 1023 vezes)

Offline JoaoDamasceno.ufc

  • Usuário Ubuntu
  • *
  • Mensagens: 1.189
    • Ver perfil
De novo eles.... Os "Pacotes Quebrados"
« Online: 11 de Dezembro de 2016, 10:55 »
é impressionante como me deparo com esse erro.

Fui pedalar agora há pouco e fiz meia dúzia de vídeos. Agora desejo juntá-los e enviar pra galera e eis que "o CAT não está instalado", "o mencoder não está instalado" "o OpenShot não está instalado", mas beleza, instalo tudo agora e problema resolvido certo?? Não...

mencoder
E: Não foi possível abrir arquivo de trava /var/lib/dpkg/lock - open (13: Permissão negada)
E: Não foi possível criar acesso exclusivo ao directório de administração (/var/lib/dpkg/), é root?

em seguida...
┌─[jdt]@[JDT]:~
└──> $ apt-get update && apt-get upgrade
W: chmod 0700 of directory /var/lib/apt/lists/partial failed - SetupAPTPartialDirectory (1: Operação não permitida)
E: Não foi possível abrir arquivo de trava /var/lib/apt/lists/lock - open (13: Permissão negada)
E: Impossível criar acesso exclusivo ao directório /var/lib/apt/lists/
W: Problema ao remover o link do ficheiro /var/cache/apt/pkgcache.bin - RemoveCaches (13: Permissão negada)
W: Problema ao remover o link do ficheiro /var/cache/apt/srcpkgcache.bin - RemoveCaches (13: Permissão negada)
E: Não foi possível abrir arquivo de trava /var/lib/dpkg/lock - open (13: Permissão negada)
E: Não foi possível criar acesso exclusivo ao directório de administração (/var/lib/dpkg/), é root?

o Winff
┌─[jdt]@[JDT]:~
└──> $ sudo apt-get install winff
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
 winff : Depende: winff-gtk2 mas não será instalado ou
                  winff-qt mas não será instalado
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.

Novamente o mencoder
sudo apt-get install mencoder
[sudo] senha para jdt:
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
 mencoder : Depende: libdirac-decoder0 mas não é instalável
            Depende: libdirac-encoder0 mas não é instalável
            Depende: libgif4 (>= 4.1.4) mas não é instalável
            Depende: libgnutls-deb0-28 (>= 3.3.0) mas não é instalável
            Depende: libjpeg62-turbo (>= 1.3.1) mas não é instalável
            Depende: libvpx1 (>= 1.0.0) mas não é instalável
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.
 
Pacotes quebrados Pacotes quebrados Pacotes quebrados... Hold Hold Hold... Dependências desencontradas etc etc etc...    ÊiÊ.....




Offline Mario Limão

  • Usuário Ubuntu
  • *
  • Mensagens: 128
  • Gremista, Arquiteto, Monarquista-Absolutista
    • Ver perfil
Re:De novo eles.... Os "Pacotes Quebrados"
« Resposta #1 Online: 11 de Dezembro de 2016, 16:56 »
Enquanto aguardamos  os mestres ...
Comento a titulo informativo, até onde sei, que não usa-se mais o Winff nem o Mencoder e não irá encontrá-los nos repositórios atuais.
Considere converter vídeos com programas mais modernos, pesquisando e experimentando FFMPEG, AVCONV no  pacote LIBAV-TOOLS,  DVD95, o DivX Converter, o K9copy, entre outros.
Até!
Ubuntu 14.04.5-LTS;  Desktop Amazon; Intel Core 2 Duo CPU E4500 @ 2.20 GHz x2; 4 GB; Intel 945Gx86/MM/SSE2; 32-Bit; 160GB.

Offline JoaoDamasceno.ufc

  • Usuário Ubuntu
  • *
  • Mensagens: 1.189
    • Ver perfil
Re:De novo eles.... Os "Pacotes Quebrados"
« Resposta #2 Online: 12 de Dezembro de 2016, 10:05 »
Enquanto aguardamos  os mestres ...
Comento a titulo informativo, até onde sei, que não usa-se mais o Winff nem o Mencoder e não irá encontrá-los nos repositórios atuais.
Considere converter vídeos com programas mais modernos, pesquisando e experimentando FFMPEG, AVCONV no  pacote LIBAV-TOOLS,  DVD95, o DivX Converter, o K9copy, entre outros.
Até!

ôpa, em parte muito obrigado. Digo "em parte" porque esses foram só alguns exemplos dos muitos erros de pacotes que tenho me deparado. Aliás, é enorme a lista de defeitos no meu Ubuntu 10.04. Esses dias entro em recesso e verei se reinstalo tuuuuudo de novo e quem sabe volto a testar distros diversas... rsrsrsrs...

Offline Mario Limão

  • Usuário Ubuntu
  • *
  • Mensagens: 128
  • Gremista, Arquiteto, Monarquista-Absolutista
    • Ver perfil
Re:De novo eles.... Os "Pacotes Quebrados"
« Resposta #3 Online: 12 de Dezembro de 2016, 10:16 »
Amigo,
atualize seu SO - urgente - para a versão 14.04.5 -LTS e pare de se aborrecer.
Até!
Ubuntu 14.04.5-LTS;  Desktop Amazon; Intel Core 2 Duo CPU E4500 @ 2.20 GHz x2; 4 GB; Intel 945Gx86/MM/SSE2; 32-Bit; 160GB.

Offline JoaoDamasceno.ufc

  • Usuário Ubuntu
  • *
  • Mensagens: 1.189
    • Ver perfil
Re:De novo eles.... Os "Pacotes Quebrados"
« Resposta #4 Online: 12 de Dezembro de 2016, 15:13 »
Amigo,
atualize seu SO - urgente - para a versão 14.04.5 -LTS e pare de se aborrecer.
Até!

Não me leve a mal, mas como é essa atualização? dist upgrade?

Offline creto

  • Expectador
  • Usuário Ubuntu
  • *
  • Mensagens: 291
  • Vivemos esperando dias melhores
    • Ver perfil
    • Blog do Creto
Re:De novo eles.... Os "Pacotes Quebrados"
« Resposta #5 Online: 12 de Dezembro de 2016, 18:46 »
Olá,

Poste aqui a saída desses dois comandos abaixo, por favor:

Código: [Selecionar]
sudo apt update
E também

Código: [Selecionar]
sudo apt install -f
T+
Perguntas-me qual foi o meu progresso? Comecei a ser amigo de mim mesmo. (Lúcio Aneu Séneca)
Blog do Creto - Teste Blog do Creto

Offline jkmsjq

  • Usuário Ubuntu
  • *
  • Mensagens: 3.313
  • Ubuntu Member
    • Ver perfil
Re:De novo eles.... Os "Pacotes Quebrados"
« Resposta #6 Online: 12 de Dezembro de 2016, 22:31 »

[...] Ubuntu 10.04. [...]


Se sua versão do Ubuntu for a 10.04, mude sua sources.list para old.release ou então, como sugerido acima, atualiza para uma versão LTS mais atual.
LinuxUser: 548942 / Dando um tópico como resolvido
"A verdade só é agressiva a quem vive de mentiras". Autor desconhecido.
Twitter: @jeisonkertesz

Offline creto

  • Expectador
  • Usuário Ubuntu
  • *
  • Mensagens: 291
  • Vivemos esperando dias melhores
    • Ver perfil
    • Blog do Creto
Re:De novo eles.... Os "Pacotes Quebrados"
« Resposta #7 Online: 13 de Dezembro de 2016, 12:56 »
Olá João,

Recentemente eu contei uma história sobre o Ubuntu 10.04 LTS Lucid Lynx no meu blog, dê uma lida e veja se lhe ajuda a desmistificar esse quiproquó:

>>> ubuntu 10.04 LTS para que serve

Espero que seja útil de alguma forma.

Boa sorte!

T+
Perguntas-me qual foi o meu progresso? Comecei a ser amigo de mim mesmo. (Lúcio Aneu Séneca)
Blog do Creto - Teste Blog do Creto

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.383
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:De novo eles.... Os "Pacotes Quebrados"
« Resposta #8 Online: 15 de Dezembro de 2016, 10:55 »
Amigo,
atualize seu SO - urgente - para a versão 14.04.5 -LTS e pare de se aborrecer.
Até!

Não me leve a mal, mas como é essa atualização? dist upgrade?
Use o comando "do-release-upgrade" para atualizar entre uma versão LTS e a seguinte.

No seu caso, isso significa atualizar para a versão 12.04, que já vai perder suporte ano q vem.

Ou seja, nem vale a pena tentar atualizar; melhor instalar o 14.04 ou o 16.04 do zero.

Enviado do meu smartphone.

Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline nomade

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 1.096
  • O negócio não tem alma
    • Ver perfil
Re:De novo eles.... Os "Pacotes Quebrados"
« Resposta #9 Online: 15 de Dezembro de 2016, 11:43 »
Enquanto aguardamos  os mestres ...
Comento a titulo informativo, até onde sei, que não usa-se mais o Winff nem o Mencoder e não irá encontrá-los nos repositórios atuais.
Considere converter vídeos com programas mais modernos, pesquisando e experimentando FFMPEG, AVCONV no  pacote LIBAV-TOOLS,  DVD95, o DivX Converter, o K9copy, entre outros.
Até!
O Winff ainda está no repositório sim e ainda é muito usado. Quem disse isso a você, brother!? Eu ainda o uso algumas vezes, pois ele usa exatamente o FFmpeg que você citou, Mario. O software de autoração e conversão DeVeDe é um dos que usa o mencoder e eu também o uso algumas vezes para alguns fins, como embutir legendas em  vídeos.

João, como o zekkerj falou, melhor baixar o 14.04, ou 16.04 para fazer o upgrade pelo DVD de instalação, ou melhor, fazer uma nova instalação limpa.

« Última modificação: 15 de Dezembro de 2016, 11:48 por nomade »
Rodando Ubuntu Studio 16.10 com: AMD Bulldozer FX-6100 3.3GHz 6-Core Black Edition/ Gigabyte 78LMT-S2P/ 8GB de Ram/ Radeon R7 260X 2GB GDDR5 128bit

Offline Mario Limão

  • Usuário Ubuntu
  • *
  • Mensagens: 128
  • Gremista, Arquiteto, Monarquista-Absolutista
    • Ver perfil
Re:De novo eles.... Os "Pacotes Quebrados"
« Resposta #10 Online: 16 de Dezembro de 2016, 19:57 »
Ubuntu 14.04.5-LTS;  Desktop Amazon; Intel Core 2 Duo CPU E4500 @ 2.20 GHz x2; 4 GB; Intel 945Gx86/MM/SSE2; 32-Bit; 160GB.

Offline creto

  • Expectador
  • Usuário Ubuntu
  • *
  • Mensagens: 291
  • Vivemos esperando dias melhores
    • Ver perfil
    • Blog do Creto
Re:De novo eles.... Os "Pacotes Quebrados"
« Resposta #11 Online: 16 de Dezembro de 2016, 20:41 »
Para saber se um pacote esta presente em uma determinada versão do ubuntu há algumas maneiras, mas as que uso são, o proprio APT e o site PKGS.org que diz:

>> search Winff Ok!

>>search mencoder Ok!

Então winff e mencoder estão sim presentes nas versões 12.04; 14.04; 16.04 e 16.10 do ubuntu

No 14.04 eu garanto, pois:
Código: [Selecionar]
cretokaiana@cretokaiana:~$ apt-cache policy winff mencoder
winff:
  Instalado: (nenhum)
  Candidato: 1.5.3-3
  Tabela de versão:
     1.5.3-3 0
        500 http://br.archive.ubuntu.com/ubuntu/ trusty/universe i386 Packages
mencoder:
  Instalado: 2:1.1+dfsg1-0ubuntu3
  Candidato: 2:1.1+dfsg1-0ubuntu3
  Tabela de versão:
 *** 2:1.1+dfsg1-0ubuntu3 0
        500 http://br.archive.ubuntu.com/ubuntu/ trusty/universe i386 Packages
        100 /var/lib/dpkg/status
cretokaiana@cretokaiana:~$

T+
Perguntas-me qual foi o meu progresso? Comecei a ser amigo de mim mesmo. (Lúcio Aneu Séneca)
Blog do Creto - Teste Blog do Creto

Offline Mario Limão

  • Usuário Ubuntu
  • *
  • Mensagens: 128
  • Gremista, Arquiteto, Monarquista-Absolutista
    • Ver perfil
Re:De novo eles.... Os "Pacotes Quebrados"
« Resposta #12 Online: 16 de Dezembro de 2016, 23:44 »
Amigos,
 :-[
Peço desculpas.
Sim, winff (interface gráfica) e Mencoder (Mplayer's-Movie-Encoder) estão nos repositórios, é só instalar.
Obrigado pela correção.
Até!
Ubuntu 14.04.5-LTS;  Desktop Amazon; Intel Core 2 Duo CPU E4500 @ 2.20 GHz x2; 4 GB; Intel 945Gx86/MM/SSE2; 32-Bit; 160GB.

Offline JoaoDamasceno.ufc

  • Usuário Ubuntu
  • *
  • Mensagens: 1.189
    • Ver perfil
Re:De novo eles.... Os "Pacotes Quebrados"
« Resposta #13 Online: 16 de Dezembro de 2016, 23:53 »
Primeiramente perdão pela demora (ocorre que durante a semana é péssimo pra que eu possa interagir com vocês).
Vamos lá...

┌─[jdt]@[JDT]:~
└──> $ sudo apt install hollywood
[sudo] senha para jdt:
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
 hollywood : Depende: mplayer
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.
┌─[jdt]@[JDT]:~
└──> $ sudo apt update
Atingido:1 http://br.archive.ubuntu.com/ubuntu xenial InRelease
Atingido:2 http://br.archive.ubuntu.com/ubuntu xenial-updates InRelease                                                         
Atingido:3 http://br.archive.ubuntu.com/ubuntu xenial-backports InRelease                                                       
Obter:4 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]                                                   
Atingido:5 http://ppa.launchpad.net/audio-recorder/ppa/ubuntu xenial InRelease                                       
Atingido:6 http://www.deb-multimedia.org jessie InRelease                                                             
Atingido:7 http://ppa.launchpad.net/maarten-baert/simplescreenrecorder/ubuntu xenial InRelease
Atingido:8 http://ppa.launchpad.net/me-davidsansome/clementine/ubuntu xenial InRelease   
Atingido:9 http://ppa.launchpad.net/noobslab/icons/ubuntu xenial InRelease
Atingido:10 http://ppa.launchpad.net/openshot.developers/ppa/ubuntu xenial InRelease
Atingido:11 http://ppa.launchpad.net/paul-climbing/ppa/ubuntu xenial InRelease
Atingido:12 http://ppa.launchpad.net/saiarcot895/chromium-beta/ubuntu xenial InRelease
Atingido:13 http://ppa.launchpad.net/shutter/ppa/ubuntu xenial InRelease
Atingido:14 http://ppa.launchpad.net/sunab/kdenlive-release/ubuntu xenial InRelease
Atingido:15 http://ppa.launchpad.net/videolan/stable-daily/ubuntu xenial InRelease
Atingido:16 http://ppa.launchpad.net/webupd8team/sublime-text-3/ubuntu xenial InRelease
Baixados 102 kB em 2s (39,2 kB/s)
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
3 packages can be upgraded. Run 'apt list --upgradable' to see them.

┌─[jdt]@[JDT]:~
└──> $ sudo apt install -f
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 3 não atualizados.

┌─[jdt]@[JDT]:~
└──> $ sudo apt-get install winff
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
 winff : Depende: winff-gtk2 mas não será instalado ou
                  winff-qt mas não será instalado
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.

┌─[jdt]@[JDT]:~
└──> $ sudo apt-get install mencoder
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
 mencoder : Depende: libdirac-decoder0 mas não é instalável
            Depende: libdirac-encoder0 mas não é instalável
            Depende: libgif4 (>= 4.1.4) mas não é instalável
            Depende: libgnutls-deb0-28 (>= 3.3.0) mas não é instalável
            Depende: libjpeg62-turbo (>= 1.3.1) mas não é instalável
            Depende: libvpx1 (>= 1.0.0) mas não é instalável
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.
┌─[jdt]@[JDT]:~
└──> $

Complementando: Uso Ubuntu 16.04LTS em um Lenovo Intel i3 com 4giga de memória RAM.

P.S. O "Hollywood" lá no início é só um programinha que achei legal e gostaria de testá-lo. Mas... naaaada feito também.

Offline creto

  • Expectador
  • Usuário Ubuntu
  • *
  • Mensagens: 291
  • Vivemos esperando dias melhores
    • Ver perfil
    • Blog do Creto
Re:De novo eles.... Os "Pacotes Quebrados"
« Resposta #14 Online: 17 de Dezembro de 2016, 08:50 »
Olá,

Amigo primeiramente pergunto porque tantos PPAs de aplicativos que funcionam perfeitamente direto dos repositórios estáveis?
Código: [Selecionar]
Atingido:7 http://ppa.launchpad.net/maarten-baert/simplescreenrecorder/ubuntu xenial InRelease
Atingido:8 http://ppa.launchpad.net/me-davidsansome/clementine/ubuntu xenial InRelease   
Atingido:9 http://ppa.launchpad.net/noobslab/icons/ubuntu xenial InRelease
Atingido:10 http://ppa.launchpad.net/openshot.developers/ppa/ubuntu xenial InRelease
Atingido:11 http://ppa.launchpad.net/paul-climbing/ppa/ubuntu xenial InRelease
Atingido:12 http://ppa.launchpad.net/saiarcot895/chromium-beta/ubuntu xenial InRelease
Atingido:13 http://ppa.launchpad.net/shutter/ppa/ubuntu xenial InRelease
Atingido:14 http://ppa.launchpad.net/sunab/kdenlive-release/ubuntu xenial InRelease
Atingido:15 http://ppa.launchpad.net/videolan/stable-daily/ubuntu xenial InRelease
Atingido:16 http://ppa.launchpad.net/webupd8team/sublime-text-3/ubuntu xenial InRelease

A minha sugestão é que desabilite todos eles, remova os aplicativos provenientes desses repositórios PPA e depois rode esse comando abaixo (copie e cole daqui)

Para remover as listas de PPA's você pode apagar todos eles dentro da pasta: /etc/apt/sources.list.d, exemplo:
Código: [Selecionar]
sudo rm /etc/apt/sources.list.d/*
Código: [Selecionar]
sudo rm /var/lib/apt/lists/* ; sudo rm /var/lib/apt/lists/partial/* ; sudo apt-get -f install ; sudo apt-get clean ; sudo apt update
Depois de executar esse comando tente novamente instalar o que você precisa.

T+
« Última modificação: 17 de Dezembro de 2016, 08:55 por creto »
Perguntas-me qual foi o meu progresso? Comecei a ser amigo de mim mesmo. (Lúcio Aneu Séneca)
Blog do Creto - Teste Blog do Creto