Autor Tópico: Grub: Mudar o tempo de espera para zero  (Lida 486 vezes)

Offline lynxmedeiros

  • Usuário Ubuntu
  • *
  • Mensagens: 36
    • Ver perfil
Grub: Mudar o tempo de espera para zero
« Online: 20 de Dezembro de 2016, 14:43 »
Olá pessoal,
Estou com um problema no Grub do Lubuntu 16.04.1
O Lubuntu está em dual boot com o Windows, e gostaria de deixar o tempo de espera como 0 (zero), já editei o arquivo do Grub consegui mudar para 1 (um) segundo, mas para 0 (zero) ainda não consegui.
Quando coloco 0 (zero) ao reiniciar o tempo de espera está em 10 (dez) segundos.
Volto a editar o arquivo e coloco 1 (um) novamente e desta vez fica certo.

A linha que eu mudo é essa:
GRUB_TIMEOUT=1

Talvez falte alterar alguma linha, mas não sei qual.

Obs.: sempre que faço alguma alteração uso o comando:
sudo update-grub

« Última modificação: 13 de Janeiro de 2017, 11:36 por lynxmedeiros »
Machine Dell:OptiPlex 7010 / Intel Core i5@ 3.20GHz / 4 Gb Ram
Graphics: Card: Intel Xeon E3-1200 Core processor Graphics Controller
Linux User  #616349

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.203
    • Ver perfil
Re:Grub: Mudar o tempo de espera para zero
« Resposta #1 Online: 20 de Dezembro de 2016, 14:50 »
Pode ser que seja uma questão de lógica intrínseca, se for para deixar em 0 (zero), então não precisa ter o menu do grub, não é mesmo?  :)

Se for para não aparecer o menu do grub, precisa estar ativa a linha

GRUB_HIDDEN_TIMEOUT=0

Também pode mudar o default dessa linha.
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline lynxmedeiros

  • Usuário Ubuntu
  • *
  • Mensagens: 36
    • Ver perfil
Re:Grub: Mudar o tempo de espera para zero
« Resposta #2 Online: 20 de Dezembro de 2016, 15:19 »
Olá Druidaobelix,

No caso é descomentar, ou seja, tirar o simbolo # da linha:
#GRUB_HIDDEN_TIMEOUT=0

Seria isso?

Machine Dell:OptiPlex 7010 / Intel Core i5@ 3.20GHz / 4 Gb Ram
Graphics: Card: Intel Xeon E3-1200 Core processor Graphics Controller
Linux User  #616349

Offline lynxmedeiros

  • Usuário Ubuntu
  • *
  • Mensagens: 36
    • Ver perfil
Re:Grub: Mudar o tempo de espera para zero
« Resposta #3 Online: 20 de Dezembro de 2016, 16:28 »
Eu tirei o símbolo # da linha:
GRUB_HIDDEN_TIMEOUT=0

Mas não tive sucesso, o Grub continua aparecendo.

Editei novamente o arquivo e com o tempo de espera com 1 (um) está ok, e vai para o Lubuntu.
O arquivo do Grub está assim:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=1
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX="locale=pt_BR"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
« Última modificação: 20 de Dezembro de 2016, 16:33 por lynxmedeiros »
Machine Dell:OptiPlex 7010 / Intel Core i5@ 3.20GHz / 4 Gb Ram
Graphics: Card: Intel Xeon E3-1200 Core processor Graphics Controller
Linux User  #616349

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.203
    • Ver perfil
Re:Grub: Mudar o tempo de espera para zero
« Resposta #4 Online: 20 de Dezembro de 2016, 21:43 »
É como você fez, só que depois de salvar e sair precisa atualizar o grub

Código: [Selecionar]
sudo update-grub
reinicie o sistema e veja o resultado
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline lynxmedeiros

  • Usuário Ubuntu
  • *
  • Mensagens: 36
    • Ver perfil
Re:Grub: Mudar o tempo de espera para zero
« Resposta #5 Online: 21 de Dezembro de 2016, 12:06 »
Fiz a mudança, descomentei a linha:
GRUB_HIDDEN_TIMEOUT=0

Mas mesmo assim continua aparecendo o menu do Grub.
Machine Dell:OptiPlex 7010 / Intel Core i5@ 3.20GHz / 4 Gb Ram
Graphics: Card: Intel Xeon E3-1200 Core processor Graphics Controller
Linux User  #616349

Offline creto

  • Expectador
  • Usuário Ubuntu
  • *
  • Mensagens: 291
  • Vivemos esperando dias melhores
    • Ver perfil
    • Blog do Creto
Re:Grub: Mudar o tempo de espera para zero
« Resposta #6 Online: 21 de Dezembro de 2016, 23:27 »
Só uma observação:

Você descomentou a linha:
GRUB_HIDDEN_TIMEOUT=0

Mas, deixou essa abaixo com um valor diferente:
GRUB_TIMEOUT=1

Coloque 0 nela também e novamente um update-grub

Ah, tenho uma curiosidade também em que arquivo você está fazendo essas alterações?

T+
« Última modificação: 21 de Dezembro de 2016, 23:29 por creto »
Perguntas-me qual foi o meu progresso? Comecei a ser amigo de mim mesmo. (Lúcio Aneu Séneca)
Blog do Creto - Teste Blog do Creto

Offline lynxmedeiros

  • Usuário Ubuntu
  • *
  • Mensagens: 36
    • Ver perfil
Re:Grub: Mudar o tempo de espera para zero
« Resposta #7 Online: 22 de Dezembro de 2016, 12:39 »
O arquivo é esse:
/etc/default/grub

Já tentei também colocar 0 (zero) na linha:
GRUB_TIMEOUT=0
Quando descomentei a linha:
GRUB_HIDDEN_TIMEOUT=0
Mas mesmo assim continua a aparecer o menu do Grub.

A mudança que consegui fazer é colocar o tempo de espera por 1 (um) segundo, mas agradeço a todos pelas dicas, com o tempo de espera de 1 (um) segundo já está ótimo.

« Última modificação: 22 de Dezembro de 2016, 12:40 por lynxmedeiros »
Machine Dell:OptiPlex 7010 / Intel Core i5@ 3.20GHz / 4 Gb Ram
Graphics: Card: Intel Xeon E3-1200 Core processor Graphics Controller
Linux User  #616349

Offline lynxmedeiros

  • Usuário Ubuntu
  • *
  • Mensagens: 36
    • Ver perfil
Re:Grub: Mudar o tempo de espera para zero
« Resposta #8 Online: 13 de Janeiro de 2017, 11:18 »
Pessoal, consegui acertar deixando da seguinte maneira:

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=1
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=.01


Obs.: Você pode definir um atraso menor usando .01, ou mesmo .001, tão rápido que você provavelmente não notará as opções do Grub!

Espero que ajude a outros usuários.
Machine Dell:OptiPlex 7010 / Intel Core i5@ 3.20GHz / 4 Gb Ram
Graphics: Card: Intel Xeon E3-1200 Core processor Graphics Controller
Linux User  #616349