Autor Tópico: Como instalar o drive ATI RS690M - Radeon Xpress 1200/1250/1270 no Ubuntu 16.04  (Lida 1068 vezes)

Offline alienline

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Boa tarde pessoal.

Agradeço a criarem tópicos muito interessantes nesse fórum o qual me deram uma ajuda enorme na minha caminhada no conhecimento do Ubuntu.

Pórem, estou com problema com o meu laptop TOSHIBA A215 - S7422, possuidor de uma "Integrated Motherboard Graphics", dá família Radeon X1200 Series. Nele possui uma Radeon X1200 de simples 128 MB. Estou tendo um enorme problema em instala-la no meu Ubuntu 16.04 LTS. Acho que já fiz de tudo, do Google ao Manual do Laptop e nada resolve. Consultei o seguinte tópico desse fórum e segui alguns passo que ao caminhar desse iniciante fiquei recioso em continuar, porém gostaria que houvesse uma ajuda dos foristas nessa instalação.

O tópico que acessei foi: http://ubuntuforum-br.org/index.php?topic=106005.0 (Resolvido) Drive ATI RS690M [Radeon Xpress 1200/1250/1270] Como instalar?). O qual tive respostas do meu sistema diferente do forista em dúvida com seu Dell.

Então vamos lá com a resposta do meu Toshiba aos comandos do Terminal:

1 - lspci | grep -E 'VGA|Display'

01:05.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RS690M [Radeon Xpress 1200/1250/1270]

2 - X -version ## (Para ver qual versão é o Xorg). Fazendo uma observação que no outro tópico o forista havia resaltado na necessidade de fazer um downgrade do Xorg. Não imagino como faz. Podem me ajudar? 

.Org X Server 1.18.4
Release Date: 2016-07-19
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.4.0-45-generic x86_64 Ubuntu
Current Operating System: Linux Alienline 4.4.0-59-generic #80-Ubuntu SMP Fri Jan 6 17:47:47 UTC 2017 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.4.0-59-generic root=UUID=79c2cd06-079c-41fd-88ac-b07bc0e35430 ro quiet splash vt.handoff=7
Build Date: 02 November 2016  10:06:10PM
xorg-server 2:1.18.4-0ubuntu0.2 (For technical support please see http://www.ubuntu.com/support)
Current version of pixman: 0.33.6
   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.

3 - uname -a ##

Linux Alienline 4.4.0-59-generic #80-Ubuntu SMP Fri Jan 6 17:47:47 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

4 - cat /etc/*-release ##

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=16.04
DISTRIB_CODENAME=xenial
DISTRIB_DESCRIPTION="Ubuntu 16.04.1 LTS"
NAME="Ubuntu"
VERSION="16.04.1 LTS (Xenial Xerus)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 16.04.1 LTS"
VERSION_ID="16.04"
HOME_URL="http://www.ubuntu.com/"
SUPPORT_URL="http://help.ubuntu.com/"
BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/"
VERSION_CODENAME=xenial
UBUNTU_CODENAME=xenial

5 - Existe alguma opção em "Drives Adicionais"?

Aqui encontro:
Desconhecido(a): Desconhecido(a)
O dispisitivo esta usando um drive alternativo
(x) Utilizando processador microcode firmware for AMD CPUs de amd64-microcode (proprietário) > Esta opção esta marcada.
( ) Não usar este dispositivo.

6 - Fez o download do drive da sua placa no site da AMD?

Sim. Fiz ele com o prefixo: Linux x86_64; tinha Linux x86 mas escolhi o 64, porque meu sistema é 64 bits. O nome do arquivo é: ati-driver-installer-9-3-x86.x86_64 de 80.9 MB com da versão 9.3 e revisão de 26/03/2009. O arquivo esta configurado com permissão para executa-lo como programa. Porém logo após essa tela no topo diz: 

(EN) The drivers above support English only. The display driver requires POSIX shared memory to be enabled on the system. Kernal Sources package is no longer required if Kernel Header package is installed. 32-Bit packages must be installed for 64-Bit Linux drivers to install or work.

(BR) Os drivers acima suportam apenas inglês. O driver de vídeo requer memória POSIX compartilhada para ser habilitado no sistema.O pacote Kernal Sources não é mais necessário se o pacote do cabeçalho do kernel estiver instalado. Os pacotes de 32 bits devem ser instalados para que os drivers Linux de 64 bits sejam instalados ou funcionem.

No meu sistema habilitei o POSIX, isso antes de eu instalar o programa.

7 - mount | grep shm

tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)

8 - "Os pacotes de 32 bits devem ser instalados para que os drivers Linux de 64 bits sejam instalados ou funcionem."

Independente de qual pacote eu instale tanto a Linux x86 ou a Linux x86_64 dá a mesma resposta no terminal.

9 - sudo ./ati-driver-installer-9-3-x86.x86_64.run

Created directory fglrx-install.Gmg83S
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.593...
==================================================
 ATI Technologies Linux Driver Installer/Packager
==================================================

Error: ./default_policy.sh does not support version
default:v2:x86_64:lib::none:4.4.0-59-generic; make sure that the version is being
correctly set by --iscurrentdistro

Removing temporary directory: fglrx-install.Gmg83S

10 - No tópico anterior o que consultei, lá dizia pra fazer uma lista de 3 comandos. Que são:

sudo add-apt-repository ppa:makson96/fglrx

sudo apt-get update

sudo apt-get upgrade

OBS: O estranho é que no inicio do tópico que mencionei dizia pra não instalar o ATI Catalyst 13.1, mas o forista "nomade" diz que tem que fazer. Vide: Resposta #7 Online: 23 de Maio de 2013, 18:33 »

11 - Fiz os 3 procedimentos

12 - sudo add-apt-repository ppa:makson96/fglrx

This repository is no longer maintained.

This repository provides AMD Catalyst Lagacy 13.1 (fglrx 8.97.100.7) drivers for Radeon HD 2xxx - 4xxx for Ubuntu:
12.04 Precise Pangolin
12.10 Quantal Quetzal
13.04 Raring Ringtail

If you are using Ubuntu 12.04.2 make sure you got linux-headers-generic-lts-quantal package installed.

Ubuntu 12.04.3 is not supported.

If you are using Ubuntu 13.04 the driver might not work very well with Unity. If that the case please consider resetting Unity configuration to default or use other DE.

The driver might not work very well with KDE. Adding lines:
"export KWIN_DIRECT_GL=1"
"export KWIN_COMPOSE=O2"
in /etc/profile file might help.

To use Catalyst Legacy 13.1 you need to do following commands:

sudo add-apt-repository ppa:makson96/fglrx
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install fglrx-legacy (ESSE EU NÃO FIZ - SÓ OS 3 PRIMEIROS)

And restart your computer.

This repository is downgradeing X-Server to 1.12.4 (which is maximum version supported by the drivers).

To remove the repository and its packages from the system do following command:
sudo ppa-purge ppa:makson96/fglrx

P.S. It was pointed to me, that Radeon HD4670 AGP card is EXCLUDED from the Legacy Driver support.
 Mais informações: https://launchpad.net/~makson96/+archive/ubuntu/fglrx
Pressione [ENTER] para continuar ou ctrl-c para cancelar a adição

gpg: chaveiro `/tmp/tmp3xyd277n/secring.gpg' criado
gpg: chaveiro `/tmp/tmp3xyd277n/pubring.gpg' criado
gpg: requisitando chave 940F55D6 de servidor hkp - keyserver.ubuntu.com
gpg: /tmp/tmp3xyd277n/trustdb.gpg: banco de dados de confiabilidade criado
gpg: chave 940F55D6: chave pública "Launchpad PPA for Tomasz Makarewicz" importada
gpg: Número total processado: 1
gpg:               importados: 1  (RSA: 1)
OK

13 - sudo apt-get update

Atingido:1 http://br.archive.ubuntu.com/ubuntu xenial InRelease
Atingido:2 http://br.archive.ubuntu.com/ubuntu xenial-updates InRelease                                                                   
Atingido:3 http://br.archive.ubuntu.com/ubuntu xenial-backports InRelease                                                                 
Atingido:4 http://archive.ubuntu.com/ubuntu xenial InRelease                                                                               
Atingido:5 http://archive.canonical.com/ubuntu xenial InRelease                                                                           
Ign:7 http://ppa.launchpad.net/stikonas/ubuntu hardy InRelease                                                                             
Ign:8 http://dl.google.com/linux/chrome/deb stable InRelease                                                                               
Obter:9 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]                                                               
Atingido:10 http://dl.google.com/linux/chrome/deb stable Release                                                                           
Atingido:11 http://repository.spotify.com stable InRelease                                                                                 
Atingido:12 http://ppa.launchpad.net/danielrichter2007/grub-customizer/ubuntu xenial InRelease                                             
Atingido:6 http://screenshots.getdeb.net xenial-getdeb InRelease                                                       
Atingido:13 http://ppa.launchpad.net/diesch/testing/ubuntu xenial InRelease                                           
Ign:14 http://ppa.launchpad.net/makson96/fglrx/ubuntu xenial InRelease                   
* Para não exceder os limites do post apaguei.
Baixados 102 kB em 32s (3.103 B/s)
Lendo listas de pacotes... Pronto
W: The repository 'http://ppa.launchpad.net/stikonas/ubuntu hardy Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: The repository 'http://ppa.launchpad.net/makson96/fglrx/ubuntu xenial Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Falhou ao buscar http://ppa.launchpad.net/stikonas/ubuntu/dists/hardy/main/binary-amd64/Packages  403  Forbidden
E: Falhou ao buscar http://ppa.launchpad.net/makson96/fglrx/ubuntu/dists/xenial/main/binary-amd64/Packages  404  Not Found
E: Falhou o download de alguns ficheiros de índice. Foram ignorados ou os antigos foram usados em seu lugar.

14 - sudo apt-get upgrade

Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Calculando atualização... Pronto
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.

15 - Reiniciei o laptop.

16 – Executei:  sudo ./ati-driver-installer-9-3-x86.x86_64.run

Created directory fglrx-install.HxAiqK
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.593...
==================================================
 ATI Technologies Linux Driver Installer/Packager
==================================================

Error: ./default_policy.sh does not support version
default:v2:x86_64:lib::none:4.4.0-59-generic; make sure that the version is being
correctly set by --iscurrentdistro

Removing temporary directory: fglrx-install.HxAiqK

17 - Então fiz os testes que o forista “nomade” indicou.

18 - sudo apt-get install mesa-utils

Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
mesa-utils is already the newest version (8.3.0-1).
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.

19 -  glxinfo | grep OpenGL

OpenGL vendor string: X.Org R300 Project
OpenGL renderer string: Gallium 0.4 on ATI RS690
OpenGL version string: 2.1 Mesa 11.2.0
OpenGL shading language version string: 1.20
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 2.0 Mesa 11.2.0
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 1.0.16
OpenGL ES profile extensions:

20 - glxinfo | grep render

direct rendering: Yes
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
Extended renderer info (GLX_MESA_query_renderer):
OpenGL renderer string: Gallium 0.4 on ATI RS690
    GL_NV_blend_square, GL_NV_conditional_render, GL_NV_fog_distance,
    GL_OES_fbo_render_mipmap, GL_OES_get_program_binary, GL_OES_mapbuffer,

21 -  /usr/lib/nux/unity_support_test -p

OpenGL vendor string:   X.Org R300 Project
OpenGL renderer string: Gallium 0.4 on ATI RS690
OpenGL version string:  2.1 Mesa 11.2.0

Not software rendered:    yes
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported:       yes

22 - Em "Drives Adicionais" continua a mesma coisa.

Se houver um forista que me ajude com o meu caso, agradeço.

Atenciosamente

Leonardo.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.068
    • Ver perfil
Re:Como instalar o drive ATI RS690M - Radeon Xpress 1200/1250/1270 no Ubuntu 16.04
« Resposta #1 Online: 29 de Janeiro de 2017, 19:41 »
Bom trabalho de pesquisa, "alienline", bom trabalho, entretanto, infelizmente os resultados estão fora do contexto atual da questão, as realidades se alteram com o decorrer do tempo.

Sua gpu (=placa de vídeo) é uma antiga Radeon RS690M

Sugiro a leitura do seguinte tópico do colega "nomade":

Como estão os drivers para AMD Radeon no Ubuntu?

http://ubuntuforum-br.org/index.php/topic,119532.0.html

Eventualmente, dependendo da espécie de problema que venha a surgir, esse aqui do colega "Sampayu" também pode ajudar:

Elimine o travamento / kernel panic do Ubuntu 16.04 com gráficos AMD

http://ubuntuforum-br.org/index.php/topic,120620.0.html

« Última modificação: 29 de Janeiro de 2017, 19:45 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline alienline

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Re:Como instalar o drive ATI RS690M - Radeon Xpress 1200/1250/1270 no Ubuntu 16.04
« Resposta #2 Online: 29 de Janeiro de 2017, 20:25 »
Boa noite "druidaobelix".

Obrigado pela ajuda e a indicação de outros tópicos; irão me ajudar a entender essa juventude programadora sedenta por FPS e imagens cada vez mais realistas. Realmente, o tempo passa e as atualizações param. Os programadores das grandes industrias de tecnologia se encantam tanto com as novas possibilidades "nano" que esqueçem que ainda há gente de óculos, precisando de lupa para encaixar plugs do gabinete na placa mãe pelo simples piscar do HDD LED e POWER LED.

Até agora a pouco, estava tentando instalar a minha HP LaserJet P1005, pesquisando sites como manuais e nenhum adiantou. Mas ainda não desmereço o equipamento que tenho, apesar da idade dele e uso diário que o faço a quase 10 anos.

A equipe do Ubuntu deixo um grande abraço pela gama de conteúdo e ao amigo pela rapidez da resposta.

Atenciosamente

Leonardo.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.068
    • Ver perfil
Re:Como instalar o drive ATI RS690M - Radeon Xpress 1200/1250/1270 no Ubuntu 16.04
« Resposta #3 Online: 29 de Janeiro de 2017, 20:54 »
Impressora HP no Linux é sempre uma boa ideia, é o melhor suporte de fabricantes de impressora para Linux.

Embora pessoalmente não tenha uma impressora igual a essa, não deveria estar existindo dificuldade e nenhuma espécie de problema para colocar a funcionar a HP LaserJet p1005 Printer.

A página do "HP Linux Imaging and Printing" (hplipopensource) diz que o suporte é full.

Confira aqui:

http://hplipopensource.com/hplip-web/models/laserjet/hp_laserjet_p1005.html

Normalmente é só fazer o download do HPLIP e o restante funciona quase igual ao sistema operacional comercial na base do next, next, basta ir concordando com tudo e dando um <enter>, não costuma dar problemas nisso.

Possivelmenhte você saiba, mas enfim, o arquivo de instalação é um .run, no caso específico hplip-3.16.11.run, então atribua permissão para execução, botão direito do mouse, propriedades, etc. ou então numa janela de terminal, dentro do diretório onde baixou:

Código: [Selecionar]
chmod +x  hplip-3.16.11.run
Ai é só executar:

Código: [Selecionar]
sudo ./hplip-3.16.11.run
Note que há um ponto (.) antes da barra inclinada para a direita.

Antes de executar a instalação certifique-se que seu sistema esteja devidamente atualizado.

« Última modificação: 29 de Janeiro de 2017, 21:23 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.