Autor Tópico: Solução para acessar o home banking do Banco do Brasil no Ubuntu (com warsaw)  (Lida 30023 vezes)

Offline silva francisco

  • Usuário Ubuntu
  • *
  • Mensagens: 8
    • Ver perfil
Re:Solução para acessar o home banking do Banco do Brasil no Ubuntu (com warsaw)
« Resposta #150 Online: 28 de Junho de 2017, 16:52 »
Obrigado por responder minha pergunta, fiz o que disse mas não está funcionando ainda no chrome, como fazer o que sugeriu acima para warsaw do banco do brasil para o warwaw do banco itau?

Oi, Francisco, você pode voltar ao Google Chrome, acessar o endereço chrome://flags/#run-all-flash-in-allow-mode e mudar o valor para Enabled (Habilitado / Ativado).

Se isso não funcionar, infelizmente não tenho como ajudá-lo mais, pois sou cliente somente do Banco do Brasil: não sou cliente do Itaú e por isto não tenho como simular acesso ao banco Itaú. O Warsaw tem vários instaladores diferentes (um para cada banco) e cada instalador desses tem versões diferentes, também, sendo que algumas versões de alguns instaladores funcionam, outras não, às vezes o instalador de 1 banco não funciona no website do banco mas ironicamente funciona para acessar contas em outro banco. É uma confusão danada.

Eu acessei o banco Itaú pelo Google Chrome e vi que o website não detectou o "Guardião" (Warsaw) que foi desenvolvido para o Itaú, mas isso é porque estou usando o Warsaw do BB (Banco do Brasil): se eu estivesse com o Warsaw do Itaú instalado, talvez funcionasse no Google Chrome. Mas não sei. Mesmo que eu instale esse outro Warsaw (do Itaú), eu posso conseguir acessar a tela de login mas não consultar dados bancários (caso eu tivesse conta no Itaú, para poder testar o acesso).

Pelo visto, por ora a solução consiste em acessar o banco Itaú somente pelo navegador Firefox mesmo.  :(

Você também pode testar o acesso com o navegador Opera: os passos 11 e 12 da resposta 59 servem para (re)instalar o Google Chrome e o Opera. Eu não sei se com o Opera você conseguirá acesso do Warsaw no Itaú, mas não custa tentar. O meu Google Chrome (versão 59.0.3071.109) está funcionando com o Warsaw de 64 bits do Banco do Brasil, que instalei usando o método lá da resposta 59. Mas veja como o fato de você estar acessando o Itaú muda as coisas: o mesmo Warsaw que funciona no meu Google Chrome não funciona no seu, pelo fato de o website do Itaú pelo visto esperar que alguma outra versão do Warsaw (ou componente dele) esteja em execução.

Por fim: o Warsaw é "software fechado", daí a dificuldade de desvendarmos os meandros dele e identificarmos o que exatamente o website do banco está solicitando que não está sendo encontrado.


Muito obrigado pela atenção, e estou retornando a pergunta por que resolvi parcialmente a instalação do warsaw do itau no chrome.

Primeiro clique com botão direito do  mouse no arquivo de instação do chrome e escolha gdebi, e clique em desistalar o chrome. Agora clique em warsaw (feche os navegadores), e  clique com botão direito do  mouse no arquivo de instação, escolha o gdebi e desistale o warsaw.
Reinicie o computador, e baixe nesse site o chrome64_57.0.2987.133.deb :

https://www.slimjet.com/chrome/google-chrome-old-version.php

Vai baixar a versão 57 que podemos instalar ao clicar o arquivo chrome64_57.0.2987.133.deb com botão direito do mouse e escolher abrir com instalador de pacotes gdebi, e instalar, demora um tempo.
Depois fiz a ativação do flash como você sugeriu anteriormente.

Agora feche os navegadores, firefox e chrome, não é minimizar , é fechar mesmo. E abra o warsaw baixado do banco itau com botão direito do mouse e abra com gdebi, e clique em instalar.
Depois reinicie o computador, abra o chrome e vá site itau, www.itau.com.br e digite sua agencia e conta, e o cadeado guardião itau vai aparecer fechado, significa que warsaw foi instalado.
Conclusão : como chrome versão 57 o warsaw do itau funciona, queria partilhar a informação com todos.

Offline Sampayu

  • Usuário Ubuntu
  • *
  • Mensagens: 366
  • "Não é possível semear de mãos fechadas"
    • Ver perfil
    • YouTube
Re:Solução para acessar o home banking do Banco do Brasil no Ubuntu (com warsaw)
« Resposta #151 Online: 28 de Junho de 2017, 17:04 »
Muito obrigado pela atenção, e estou retornando a pergunta por que resolvi parcialmente a instalação do warsaw do itau no chrome.

Primeiro clique com botão direito do  mouse no arquivo de instação do chrome e escolha gdebi, e clique em desistalar o chrome. Agora clique em warsaw (feche os navegadores), e  clique com botão direito do  mouse no arquivo de instação, escolha o gdebi e desistale o warsaw.
Reinicie o computador, e baixe nesse site o chrome64_57.0.2987.133.deb :

https://www.slimjet.com/chrome/google-chrome-old-version.php

Vai baixar a versão 57 que podemos instalar ao clicar o arquivo chrome64_57.0.2987.133.deb com botão direito do mouse e escolher abrir com instalador de pacotes gdebi, e instalar, demora um tempo.
Depois fiz a ativação do flash como você sugeriu anteriormente.

Agora feche os navegadores, firefox e chrome, não é minimizar , é fechar mesmo. E abra o warsaw baixado do banco itau com botão direito do mouse e abra com gdebi, e clique em instalar.
Depois reinicie o computador, abra o chrome e vá site itau, www.itau.com.br e digite sua agencia e conta, e o cadeado guardião itau vai aparecer fechado, significa que warsaw foi instalado.
Conclusão : como chrome versão 57 o warsaw do itau funciona, queria partilhar a informação com todos.

Bacana, obrigado por compartilhar. :) Então pelo visto as atualizações sofridas pelo Google Chrome tornaram-no incompatível com o Warsaw que foi desenvolvido para o banco Itaú.

Foi como comentei antes: infelizmente, a empresa que desenvolve esse Warsaw não tem feito um trabalho muito bom. Ela cria diferentes versões do Warsaw para cada banco, o que por si só já é um problema para quem tem conta em dois ou mais bancos. Para piorar, cada nova versão tem certos requisitos e cada requisito inclui certas bibliotecas e outros componentes que funcionam com certos navegadores, mas não com outros (daí uma das estratégias consistir em instalar vários navegadores - Firefox, Chrome, Opera... - e ver se o Warsaw funciona com ao menos um deles).

Não é recomendável usar uma versão anterior do Google Chrome, pois normalmente falhas de segurança e bugs são corrigidos e esses aprimoramentos só estão presentes na versão mais atual do navegador. Ainda mais se o navegador for usado para compras online ou para acessar dados financeiros (se há movimentação de dinheiro, por exemplo). Eu manteria o Google Chrome atualizado e usaria o Warsaw somente no Firefox atualizado (já que, de acordo com o seu relato inicial, o Warsaw funciona no Firefox atualizado). É sempre preferível usar tudo atualizado (sistema operacional, navegador etc.), para evitar usar algum software que possua alguma falha de segurança que está corrigida somente na versão mais atual.  :)
« Última modificação: 28 de Junho de 2017, 19:30 por Sampayu »
Yuri Sucupira ("Sampayu")

Offline DidBrother

  • Usuário Ubuntu
  • *
  • Mensagens: 10
    • Ver perfil
Re:Solução para acessar o home banking do Banco do Brasil no Ubuntu (com warsaw)
« Resposta #152 Online: 28 de Junho de 2017, 19:04 »

Não é recomendável usar uma versão anterior do Google Chrome, pois normalmente falhas de segurança e bugs são corrigidos e lançados na versão mais atual do navegador. Ainda mais se o navegador for usado para compras online ou para acessar dados financeiros (se há movimentação de dinheiro, por exemplo). Eu manteria o Google Chrome atualizado e usaria o Warsaw somente no Firefox atualizado (já que, de acordo com o seu relato inicial, o Warsaw funciona no Firefox atualizado). É sempre preferível usar tudo atualizado (sistema operacional, navegador etc.), para evitar usar algum software que possua alguma falha de segurança que está corrigida somente na versão mais atual.  :)

Caro Silva Francisco.

Conforme citação acima do colega não seria de forma alguma oportuna usar a versão desatualizada de qualquer de programa.

Fiz um pequeno teste aqui em uma maquina virtual com lubuntu 16.04 instalado, 64 bits,   GUFW ativado, tcp_syncookies valor 1;  navegadores Firefox 54.0; Chromium  58.0.3029; opera 46.0.2597 e  Chrome 59.0.3071. 

foi utilizado o warsaw obtido da pagina https://cloud.gastecnologia.com.br/cef/warsaw/install/GBPCEFwr64.deb

Resultado: inserindo numero de agência e uma conta do banco itau  apareceu o nome de usuario  e na parte inferior da página  a msg: "guardião itaú instalado" para os 04 navegadores citados acima. Mas  como não sou correntista do banco, não pude efetivamente avaliar o acesso.

Caso disponha de tempo, sugiro que experimente o warsaw obtido a partir do link acima e caso obtenha sucesso, poste  o resultado.

DidBrother

Offline Lostados

  • Usuário Ubuntu
  • *
  • Mensagens: 10
    • Ver perfil
Re:Solução para acessar o home banking do Banco do Brasil no Ubuntu (com warsaw)
« Resposta #153 Online: 30 de Junho de 2017, 09:51 »
Citar
Citação de Sampayu em 26 de junho de 2017, 17:20

Sugestão para você resolver o problema:

1) Obtenha o XUbuntu 17.04 de 64 bits (esse link aí é para obter o torrent para download do arquivo ISO).

2) Use o arquivo ISO para instalar o XUbuntu 17.04 de 64 bits.

3) Use o Mozilla Firefox que vem pré-instalado no XUbuntu e então acesse a resposta 59 e execute somente os seguintes passos (nesta exata sequência): 6, 7, 8, 11 e 13.

4) Após executar o passo 13, seu computador reiniciará. Após ele reiniciar, abra o Google Chrome, acesse o endereço chrome://flags/#prefer-html-over-flash e mude o valor para Disabled (desabilitado), em seguida acesse o endereço chrome://flags/#run-all-flash-in-allow-mode e mude o valor para Enabled (habilitado).

5) Feche o navegador Google Chrome, em seguida abra os navegadores Chrome, Opera e Firefox e em cada um deles acesse o endereço https://www2.bancobrasil.com.br/aapf/login.jsp


Sampayu,
obrigado pelos comentários e pela sugestão. Migrei para o Xubuntu e segui à risca cada uma das suas recomendações - com exatamente o resultado de minhas tentativas anteriores. O home banking do BB não funciona, o sistema diz que tenho o módulo de segurança mas esse não é identificado.
Tentei também instalar o módulo seguindo as instruções do próprio BB mas tampouco funcionou.
A esta altura, me pergunto se o problema não é do HD do meu computador...

Offline Lostados

  • Usuário Ubuntu
  • *
  • Mensagens: 10
    • Ver perfil
Re:Solução para acessar o home banking do Banco do Brasil no Ubuntu (com warsaw)
« Resposta #154 Online: 30 de Junho de 2017, 10:11 »
Sampayu,
fui ao site do Warsaw  (http://www.dieboldnixdorf.com.br/warsaw). Eles fazem uma verificação a partir da instituição da qual vc é cliente.
Resultado do diagnóstico:

Verificando o módulo de segurança Warsaw.
 Warsaw instalado com as configurações do Banco do Brasil
 Verificando atualizações.
 Atualização realizada com sucesso.
 Parabéns! Você está devidamente protegido.

O BB primeiro diz que o "módulo de segurança está instalado". Quando vou acessar a conta, no entanto, vem a a seguinte mensagem:

Problemas no Módulo de Segurança W01
 
Para acessar sua conta é necessário carregar o modulo de segurança.
Se já possui o Módulo instalado, reinicie o computador para atualização.
Para nova instalação, acesse seg.bb.com.br e clique em "instalar agora".
Após a instalação, reinicie o computador.
Tire suas dúvidas sobre o Módulo de Segurança em https://seg.bb.com.br/duvidas.html

Precisa de ajuda?

Offline Sampayu

  • Usuário Ubuntu
  • *
  • Mensagens: 366
  • "Não é possível semear de mãos fechadas"
    • Ver perfil
    • YouTube
Re:Solução para acessar o home banking do Banco do Brasil no Ubuntu (com warsaw)
« Resposta #155 Online: 30 de Junho de 2017, 12:01 »
Sampayu,
obrigado pelos comentários e pela sugestão. Migrei para o Xubuntu e segui à risca cada uma das suas recomendações - com exatamente o resultado de minhas tentativas anteriores. O home banking do BB não funciona, o sistema diz que tenho o módulo de segurança mas esse não é identificado.
Tentei também instalar o módulo seguindo as instruções do próprio BB mas tampouco funcionou.
A esta altura, me pergunto se o problema não é do HD do meu computador...

Isso para mim também não faz sentido.  :o

Veja esta imagem:

https://1drv.ms/i/s!AvGdllDm3m3njyUgaFdi1A_r0Fwn

A imagem acima mostra que instalei o Oracle VirtualBox no meu sistema (XUbuntu 16.04 de 64 bits), criei uma máquina virtual dentro do VirtualBox, instalei o XUbuntu 17.04 de 64 bits nessa máquina virtual, instalei o Warsaw nesse XUbuntu 17.04 virtualizado, e que nesse XUbuntu 17.04 virtualizado os navegadores Google Chrome, Mozilla Firefox e Opera Browser estão todos abrindo normalmente o URL https://www2.bancobrasil.com.br/aapf/login.jsp

Vocês testou com os três navegadores (Firefox, Chrome e Opera) e nenhum deles abriu o URL https://www2.bancobrasil.com.br/aapf/login.jsp? Isso é muito esquisito e eu realmente não imagino o que possa ser, mas no seu lugar eu experimentaria então retornar à resposta 59 e executar o passo 9, para instalar umas dependências do Warsaw (embora isso teoricamente não devesse ser necessário, pois se no meu XUbuntu 17.04 virtualizado o Warsaw funcionou, o que significa que as tais dependências já estão satisfeitas). Anyway...

Se após a execução do passo 9 o problema persistir, execute o passo 10: ele criará um arquivo /etc/rc.local personalizado que forçará a ativação da proteção contra ataques "TCP Syn Flood Cookies". Novamente: essa ação não deveria ser necessária, pois no XUbuntu 17.04 que instalei não foi necessário fazer isso (até porque o passo 8 da resposta 59 já ativa essa proteção, sendo portanto redundante - embora inofensivo - criar o tal arquivo /etc/rc.local). Mas esse passo 10 (assim como o 9) são tentativas de eliminar qualquer "picuinha" que o programa Warsaw possa estar criando.

Se após isso o problema persistir, acesse as configurações avançadas dos navegadores Firefox, Opera e Chrome e veja se na aba de Autoridades (CA / Certificate Authorities / Autoridades Certificadoras) o certificado Warsaw Personal CA está aparecendo, pois sem esse certificado a URL https://www2.bancobrasil.com.br/aapf/login.jsp dá erro mesmo. Se o certificado estiver faltando nesses navegadores, execute novamente o passo 13 da resposta 59, para fazer o Warsaw ser reinstalado, pois daí o certificado será (re)instalado, também.

Ah, sim: se os testes acima não funcionarem, pode ser porque você fez a instalação padrão do Banco (que costuma ser mais problemática e obscura que a explicada na resposta 59). Se as dicas acima não funcionarem, pode ser porque o módulo em execução aí esteja com problema. Em tal caso, é melhor desinstalar o Warsaw que você instalou aí e em seguida instalar como explicado na resposta 59, então após fazer isso abra uma janela do terminal do shell, execute os comandos abaixo e cole-os numa resposta aqui no tópico, para eu ver as configurações do seu sistema, verificar se o daemon de serviço do Warsaw está em execução e se as portas TCP estão abertas etc.:

Código: [Selecionar]
sudo netstat -tulapv |grep -i /core
Código: [Selecionar]
sudo ps -ef |grep -i warsaw |grep -v grep
Código: [Selecionar]
lsb_release -a
Código: [Selecionar]
uname -a
Também cole aqui o conteúdo do arquivo warsaw.txt, que estará na sua pasta pessoal de downloads após você executar este comando, no terminal do shell:
Código: [Selecionar]
sudo updatedb ; locate -i warsaw > ~/Downloads/warsaw.txt
Notas de rodapé:
1) No Google Chrome, as opções avançadas de certificados estão no URL chrome://settings/certificates
2) No Mozilla Firefox, as opções avançadas de certificados estão no URL about:preferences#advanced
3) No Opera Browser, as opções avançadas de certificados estão no URL opera:settings/certificates
« Última modificação: 30 de Junho de 2017, 12:33 por Sampayu »
Yuri Sucupira ("Sampayu")

Offline Sampayu

  • Usuário Ubuntu
  • *
  • Mensagens: 366
  • "Não é possível semear de mãos fechadas"
    • Ver perfil
    • YouTube
Re:Solução para acessar o home banking do Banco do Brasil no Ubuntu (com warsaw)
« Resposta #156 Online: 30 de Junho de 2017, 12:13 »
Sampayu,
fui ao site do Warsaw  (http://www.dieboldnixdorf.com.br/warsaw). Eles fazem uma verificação a partir da instituição da qual vc é cliente.
Resultado do diagnóstico:

Verificando o módulo de segurança Warsaw.
 Warsaw instalado com as configurações do Banco do Brasil
 Verificando atualizações.
 Atualização realizada com sucesso.
 Parabéns! Você está devidamente protegido.

O BB primeiro diz que o "módulo de segurança está instalado". Quando vou acessar a conta, no entanto, vem a a seguinte mensagem:

Problemas no Módulo de Segurança W01
 
Para acessar sua conta é necessário carregar o modulo de segurança.
Se já possui o Módulo instalado, reinicie o computador para atualização.
Para nova instalação, acesse seg.bb.com.br e clique em "instalar agora".
Após a instalação, reinicie o computador.
Tire suas dúvidas sobre o Módulo de Segurança em https://seg.bb.com.br/duvidas.html

Precisa de ajuda?


Não dá para confiar nem no URL http://www.dieboldnixdorf.com.br/warsaw nem no URL https://seg.bb.com.br/home.html - ambos são problemáticos. No meu caso, por exemplo, o primeiro URL informa que não tenho o Warsaw instalado e o segundo informa que meu navegador é de 32 bits, embora com o navegador (tanto Chrome quanto Opera, ambos de 64 bits) eu consiga acessar minha conta no Banco do Brasil, rs. ;D Enfim: não confie nesses testes, eles são tão ruins quanto o próprio Warsaw. :P
« Última modificação: 30 de Junho de 2017, 14:20 por Sampayu »
Yuri Sucupira ("Sampayu")

Offline faubuiso

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Re:Solução para acessar o home banking do Banco do Brasil no Ubuntu (com warsaw)
« Resposta #157 Online: 06 de Julho de 2017, 16:42 »
Prezados,

Com o mesmo problema em acessar contas do BB e Sicredi fui em busca de ajuda na internet e neste post https://talesam.org/2017/03/14/instalando-o-modulo-de-seguranca-banco-brasil-warsaw/ foi onde encontrei o caminho que naquela época me ajudou.

No computador 01 e no 02 (chamarei assim) tinha o Linx Mint 18.1 instalado e minha solução foi esta:

Juntando várias dicas acho que finalmente resolvi o meu caso para acessar o BB e Sicredi. Uso LinuxMint 18.1/64bits. Descrevo aqui o fiz:
- Fechei todos os browsers
- Desinstalei o Warsaw 'sudo dpkg --purge warsaw'
- Desinstalei módulos antigos do BB 'sudo dpkg --purge hda-bb'
- Desliguei o Firewall
- Reiniciei o computador
- Instalei o módulo conforme o BB orienta (diagbb-1.0.mint18.amd64.deb). Utilizando os links do post acima não tive sucesso.
- Assim já consegui acessar as páginas de login do dois bancos
- Porém ao habilitar de novo o firewall voltei a ter erros e problemas no acesso. Foi necessário reiniciar o computador com o firewall desligado.
- Conforme comentário abaixo do Yuri Sucupira segui alguns passos do item 2) e executei no terminal 'sudo sed -i -e 's|syncookies=0|syncookies=1|' "/etc/ufw/sysctl.conf" ; sudo ufw enable'. Neste link do comentário que citei estão algumas explicações do que ocorre: http://disq.us/url?url=http%3A%2F%2Fubuntuforum-br.org%2Findex.php%2Ftopic%2C121558.msg668201.html

Foi neste post que tive contato com as orientações do Sampayu (muito obrigado!).

Mas agora resolvi fazer o upgrade dos computadores para o Linux Mint 18.2 e o caso é o seguinte:

Computador 01: fiz o upgrade pelo Update Manager e segue tudo ok. Acesso pelo Firefox, Opera e Chrome.

Computador 02: Fiz uma instalação limpa para a versão 18.2 do Mint. Tentei seguir os mesmos passos que tinha realizado porém não consigo acessar a conta. O módulo parece estar instalado (nos 3 browsers) e então preencho os dados e ao avançar recebo esta mensagem

Problemas no Módulo de Segurança W01
Não foi possível carregar o Módulo de Segurança.
Efetue a limpeza de cache do navegador (ctrl+shift+del).
Acesse a Página de Diagnóstico seg.bb.com.br para tentar corrigir o problema.
Após a instalação do Módulo de Segurança, reinicie o computador.
Tire suas dúvidas sobre o Módulo de Segurança em https://seg.bb.com.br/duvidas.html

Já tentei desinstalar tudo conforme o post #59. Não tive sucesso ao instalar o Warsaw. Só consigo visualizar a página para preencher os dados de acesso se utilizo o pacote diagbb-1.0.mint18.amd64.deb. De outras formas não acesso nem isso.

Enfim, meu caso neste Computador 02 me parece que o módulo está ok (até comparei algumas respostas pelo terminal conforme dicas deste tópico e os dois me parecem iguais). Como não sou expert em Linux quem sabe posso ter me passado em algo na configuração do firewall.

Obrigado.
« Última modificação: 06 de Julho de 2017, 16:51 por faubuiso »

Offline DidBrother

  • Usuário Ubuntu
  • *
  • Mensagens: 10
    • Ver perfil
Re:Solução para acessar o home banking do Banco do Brasil no Ubuntu (com warsaw)
« Resposta #158 Online: 07 de Julho de 2017, 11:28 »
Prezados,


............. se utilizo o pacote diagbb-1.0.mint18.amd64.deb. De outras formas não acesso nem isso.



Caro colega,

recomendo que utilize o o pacote warsaw baixado a partir do endereço abaixo:

https://cloud.gastecnologia.com.br/cef/warsaw/install/GBPCEFwr64.deb

Sem sombra de dúvidas o melhor pacote. Com ele é possível acesso ao BB, CEF, Itau pelos 04 principais navegadores utilizados no Linux.
(firefox, chrome, opera e até mesmo pelo chromium).

não se esqueça de conferir a presença do certificado no navegador:
Warsaw Personal CA.

Did

Offline Sampayu

  • Usuário Ubuntu
  • *
  • Mensagens: 366
  • "Não é possível semear de mãos fechadas"
    • Ver perfil
    • YouTube
Re:Solução para acessar o home banking do Banco do Brasil no Ubuntu (com warsaw)
« Resposta #159 Online: 08 de Julho de 2017, 00:29 »
Prezados,

Com o mesmo problema em acessar contas do BB e Sicredi fui em busca de ajuda na internet e neste post https://talesam.org/2017/03/14/instalando-o-modulo-de-seguranca-banco-brasil-warsaw/ foi onde encontrei o caminho que naquela época me ajudou.

No computador 01 e no 02 (chamarei assim) tinha o Linx Mint 18.1 instalado e minha solução foi esta:

Juntando várias dicas acho que finalmente resolvi o meu caso para acessar o BB e Sicredi. Uso LinuxMint 18.1/64bits. Descrevo aqui o fiz:
- Fechei todos os browsers
- Desinstalei o Warsaw 'sudo dpkg --purge warsaw'
- Desinstalei módulos antigos do BB 'sudo dpkg --purge hda-bb'
- Desliguei o Firewall
- Reiniciei o computador
- Instalei o módulo conforme o BB orienta (diagbb-1.0.mint18.amd64.deb). Utilizando os links do post acima não tive sucesso.
- Assim já consegui acessar as páginas de login do dois bancos
- Porém ao habilitar de novo o firewall voltei a ter erros e problemas no acesso. Foi necessário reiniciar o computador com o firewall desligado.
- Conforme comentário abaixo do Yuri Sucupira segui alguns passos do item 2) e executei no terminal 'sudo sed -i -e 's|syncookies=0|syncookies=1|' "/etc/ufw/sysctl.conf" ; sudo ufw enable'. Neste link do comentário que citei estão algumas explicações do que ocorre: http://disq.us/url?url=http%3A%2F%2Fubuntuforum-br.org%2Findex.php%2Ftopic%2C121558.msg668201.html

Foi neste post que tive contato com as orientações do Sampayu (muito obrigado!).

Mas agora resolvi fazer o upgrade dos computadores para o Linux Mint 18.2 e o caso é o seguinte:

Computador 01: fiz o upgrade pelo Update Manager e segue tudo ok. Acesso pelo Firefox, Opera e Chrome.

Computador 02: Fiz uma instalação limpa para a versão 18.2 do Mint. Tentei seguir os mesmos passos que tinha realizado porém não consigo acessar a conta. O módulo parece estar instalado (nos 3 browsers) e então preencho os dados e ao avançar recebo esta mensagem

Problemas no Módulo de Segurança W01
Não foi possível carregar o Módulo de Segurança.
Efetue a limpeza de cache do navegador (ctrl+shift+del).
Acesse a Página de Diagnóstico seg.bb.com.br para tentar corrigir o problema.
Após a instalação do Módulo de Segurança, reinicie o computador.
Tire suas dúvidas sobre o Módulo de Segurança em https://seg.bb.com.br/duvidas.html

Já tentei desinstalar tudo conforme o post #59. Não tive sucesso ao instalar o Warsaw. Só consigo visualizar a página para preencher os dados de acesso se utilizo o pacote diagbb-1.0.mint18.amd64.deb. De outras formas não acesso nem isso.

Enfim, meu caso neste Computador 02 me parece que o módulo está ok (até comparei algumas respostas pelo terminal conforme dicas deste tópico e os dois me parecem iguais). Como não sou expert em Linux quem sabe posso ter me passado em algo na configuração do firewall.

Obrigado.

Acabei de instalar o Linux Mint XFCE 18.2 de 64 bits em uma máquina virtual e, dentro dele, executar os passos 6, 7, 8 e 11 da resposta 59. Após isso, no Google Chrome eu acessei chrome://flags/#prefer-html-over-flash e mudei o valor para Disabled, então acessei chrome://flags/#run-all-flash-in-allow-mode e mudei o valor para Enabled, e então fechei o Google Chrome.

Após isso, inicializei o Firefox, o Opera e o Google Chrome e acessei https://www2.bancobrasil.com.br/aapf/login.jsp e o Warsaw foi executado normalmente, nesses três navegadores.
« Última modificação: 08 de Julho de 2017, 01:23 por Sampayu »
Yuri Sucupira ("Sampayu")

Offline faubuiso

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Re:Solução para acessar o home banking do Banco do Brasil no Ubuntu (com warsaw)
« Resposta #160 Online: 17 de Julho de 2017, 00:36 »
Citar
Caro colega,

recomendo que utilize o o pacote warsaw baixado a partir do endereço abaixo:

https://cloud.gastecnologia.com.br/cef/warsaw/install/GBPCEFwr64.deb

Sem sombra de dúvidas o melhor pacote. Com ele é possível acesso ao BB, CEF, Itau pelos 04 principais navegadores utilizados no Linux.
(firefox, chrome, opera e até mesmo pelo chromium).

não se esqueça de conferir a presença do certificado no navegador:
Warsaw Personal CA.

Did

Tentei este pacote e não tive resultado.

Citar
Acabei de instalar o Linux Mint XFCE 18.2 de 64 bits em uma máquina virtual e, dentro dele, executar os passos 6, 7, 8 e 11 da resposta 59. Após isso, no Google Chrome eu acessei chrome://flags/#prefer-html-over-flash e mudei o valor para Disabled, então acessei chrome://flags/#run-all-flash-in-allow-mode e mudei o valor para Enabled, e então fechei o Google Chrome.

Após isso, inicializei o Firefox, o Opera e o Google Chrome e acessei https://www2.bancobrasil.com.br/aapf/login.jsp e o Warsaw foi executado normalmente, nesses três navegadores.

Refiz os passos e a página fica carregando e não aparecem os campos para preenchimento dos dados.
Em seguida instalei o arquivo conforme disponibilizado pelo BB: diagbb-1.0.mint18.amd64.deb (já havia instalado e removido este pacote).
E então funcionou! Agora tenho acesso aos bancos nos 3 browsers.

Obrigado.

Offline Sampayu

  • Usuário Ubuntu
  • *
  • Mensagens: 366
  • "Não é possível semear de mãos fechadas"
    • Ver perfil
    • YouTube
Re:Solução para acessar o home banking do Banco do Brasil no Ubuntu (com warsaw)
« Resposta #161 Online: 17 de Julho de 2017, 19:59 »
Refiz os passos e a página fica carregando e não aparecem os campos para preenchimento dos dados.
Em seguida instalei o arquivo conforme disponibilizado pelo BB: diagbb-1.0.mint18.amd64.deb (já havia instalado e removido este pacote).
E então funcionou! Agora tenho acesso aos bancos nos 3 browsers.

Obrigado.

Às vezes a instalação do Warsaw, por alguma razão misteriosa e esotérica que não sabemos qual é porque o Warsaw é um programa proprietário, é concluída sem a instalação do certificado ter sido bem sucedida, no navegador. Daí o módulo é detectado mas a tentativa de acesso ao serviço bancário não funciona (o website do banco não identifica o certificado, no navegador, e bloqueia o uso do módulo Warsaw, embora ele - o módulo Warsaw - tenha sido detectado).

A reinstalação do Warsaw resolve isso (porque durante a reinstalação o certificado é instalado/reinstalado nos seus navegadores). Aparentemente, esse foi o seu caso e foi por isso que a reinstalação do módulo resolveu o problema.
« Última modificação: 21 de Julho de 2017, 13:43 por Sampayu »
Yuri Sucupira ("Sampayu")

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.526
    • Ver perfil
Re:Solução para acessar o home banking do Banco do Brasil no Ubuntu (com warsaw)
« Resposta #162 Online: 25 de Julho de 2017, 07:03 »
Olá pessoal!

Alguém já tinha visto este tutorial bastante recente de como usar o Warsaw no firefox 54?

https://www.vivaolinux.com.br/artigo/Transacoes-Financeiras-Warsaw-vs-User-Agent-Overrider-Itau-Bankline-30-horas

O tuto é a para o  Itau 30 horas mas acho que serve para o BB também! 

Alguém já testou?

Se funcionar, acho que seria ótimo dar uma atualizada nos tutos sobre o assunto aqui do Fórum!
OpenSuse  42.3 64bits / Windows 10 64bits - PC * CentOS 7 64bits Servidor Samba/DNS * MacOS High Sierra * Kbuntu 17.10 64bits - Note1 * Ubuntu 17.10 64bits - Note 2

Offline Mikael

  • Usuário Ubuntu
  • *
  • Mensagens: 370
    • Ver perfil
Re:Solução para acessar o home banking do Banco do Brasil no Ubuntu (com warsaw)
« Resposta #163 Online: 02 de Outubro de 2017, 20:27 »
Boa Tarde.
Sou novo aqui e passei pelo mesmo problema. Consegui uma solução parcial para o problema. Funcionou comigo e resolvi compartilhar com todos. Dando uma pesquisada pela net descobri que o problema é que o sistema pensava que havia um ataque de SYN FLOOD (eu acho que é assim que se escreve) e bloqueava a porta 30900. sem desativar o ufw, eu usei este comando:


echo 1 > /proc/sys/net/ipv4/tcp_syncookies

e funcionou, consegui acessar minha conta no BB.
O problema é que depois que reinicia a máquina, volta ao normal e o acesso é bloqueado.
Funcionou comigo e espero que com vocês também.
Eu não sei como colocar este comando na inicialização e nem se isso vá comprometer alguma coisa no sistema.

Fui!!!!

gr9942: OBRIGADO pela dica. :D Funcionou! ;D Era mesmo esse o problema. Tô aqui me perguntando por que foi que não pensei nisso antes, ao invés de ficar me matando com o iptables, rs. ::)

A respeito da mudança de argumento dentro do arquivo /proc/sys/net/ipv4/tcp_syncookies: mudar o valor de 0 para 1 não apenas não compromete nada no sistema como é recomendável que se faça, pois na realidade aumenta a segurança do sistema. Isso porque a mudança no valor para 1 torna mais difícil (e reduz bastante o eventual impacto de) um ataque denominado "localhost SYN flood". Portanto, pode ativar isso sem medo de ser feliz.  ;)


Método para o Warsaw já instalado não dar erro de soquete / socket / websocket

Conforme comentei aqui, o serviço "Warsaw" utiliza as portas TCP 30800 e 30900, porém o firewall do Linux bloqueia a porta TCP 30900, deste modo inviabilizando o funcionamento do (web)socket.
Para resolver esse problema, acesse o terminal do shell e execute este supercomando:
Código: [Selecionar]
sudo apt-get install ufw gufw --reinstall -y ; sudo sed -i -e 's|syncookies=0|syncookies=1|' "/etc/ufw/sysctl.conf" ; sudo ufw enable
...e depois acesse https://www2.bancobrasil.com.br/aapf/login.jsp para verificar se agora os campos "Agência", "Conta" e "Senha de autoatendimento" aparecem. Se eles aparecerem é porque o módulo está funcionando e foi detectado, dentro do seu navegador.

Obs.: se após executar o supercomando acima você não conseguir acessar sua conta no website do Banco do Brasil, reinicie o computador e tente novamente.

O supercomando acima ativará o firewall do Linux com algumas proteções adicionais (impedirá conexões de entrada e pedidos de encaminhamento de porta que não façam parte da lista de exceções do firewall), mas ao mesmo tempo permitirá ao Warsaw utilizar as portas TCP 30800 e 30900 (porque essa conexão será executada com uma proteção adicional contra um tipo de ataque denominado "SYN Flood").

Nota: em alguns casos, pode acontecer de https://seg.bb.com.br não detectar o módulo de segurança, embora o módulo esteja instalado, funcionando, acessando as portas TCP e você consiga acessar sua conta por intermédio do URL https://www2.bancobrasil.com.br/aapf/login.jsp. Essa é a razão por que não se deve confiar no resultado mostrado em https://seg.bb.com.br.  Esse problema que ocorre com https://seg.bb.com.br também ocorre com http://www.dieboldnixdorf.com.br/warsaw, portanto também não confie no resultado que http://www.dieboldnixdorf.com.br/warsaw lhe mostrar. A única maneira de realmente confirmar se o módulo está ou não funcionando no seu navegador é acessar https://www2.bancobrasil.com.br/aapf/login.jsp e verificar se os campos "Agência", "Conta" e "Senha de autoatendimento" aparecem. :P

Se após executar o supercomando acima e reiniciar o computador você continuar não conseguindo acessar sua conta no website do Banco do Brasil, execute este segundo supercomando:

Código: [Selecionar]
if [ -a /etc/rc.local ]; then sudo mv /etc/rc.local /etc/rc.local.bak; fi; echo \#\!/bin/bash | sudo tee /etc/rc.local; echo ' ' | sudo tee -a /etc/rc.local; echo \echo 1 \> /proc/sys/net/ipv4/tcp_syncookies | sudo tee -a /etc/rc.local; echo ' ' | sudo tee -a /etc/rc.local; echo exit 0 | sudo tee -a /etc/rc.local; sudo telinit 6
O segundo supercomando reiniciará seu computador. Após ele reiniciar, acesse novamente o website do Banco do Brasil, para tentar acessar sua conta.


Um dos aspectos mais bacanas da comunidade Linux, na minha opinião, é essa capacidade de atuarmos colaborativamente: cada um vai investigando o problema, tentando contribuir com o que consegue descobrir, e no fim das contas o resultado (e o "prêmio") é que chegamos a uma solução completa para o problema. 8)

=> Caso queira "zerar tudo" e fazer uma instalação e configuração "limpa", leia este post.


Obrigado! Resolveu o meu problema!