Autor Tópico: Problema para atualizar a nova versão do Adobe Flash Player 25.0.0.127 no Opera  (Lida 312 vezes)

Offline Serial

  • Usuário Ubuntu
  • *
  • Mensagens: 53
    • Ver perfil
Olá Pessoal

Ao atualizar este aplicativo pelo synaptic fica tudo normal no Firefox. OK.
Mas não atualiza no Opera ou Google Chrome.

Consegui atualizar no Google Chrome a versão mais recente e nada do Opera.

Utilizando o site oficial, aparece a seguinte mensagem para APT DEBIAN/UBUNTU: usando o Navegado Opera.

Habilitar canal de software adicional
Você deseja habilitar o seguinte canal de software: 'xenial-partner'?

"The Ubuntu 16.04 partner channel contains applications that are available for Ubuntu from third-party software partners for the 16.04 release."

Ao clicar em SIM e aceitar, instala normalmente, só que a versão anterior sendo a 24.0.0.194 e não a nova 25.0.0.127.
Obs. Quando atualizo esta versão pelo Opera, no firefox volta a versão anterior também.

Já tentei algumas formas e comandos e não estou conseguindo.
Baixei o arquivo, extrai, mas não deixa jogar na pasta /usr/lib/pepperflashplugin-nonfree
Existe uma forma destas atualizações serem automáticas quando necessário no caso, Opera e Firefox?

Grato!

Serial
« Última modificação: 19 de Março de 2017, 08:48 por Serial »

Offline Serial

  • Usuário Ubuntu
  • *
  • Mensagens: 53
    • Ver perfil
Re:Problema para atualizar a nova versão do Adobe Flash Player 25.0.0.127 no Opera
« Resposta #1 Online: 19 de Março de 2017, 09:17 »
Olá Pessoal

Apanhei um pouco, mas aprendi  :D

O problema é simples!

Quando atualizamos o flash player pelo Firefox ou Opera diretamente da página da adobe, ele instala automaticamente o PPAPI e NPAP, mas a adobe acaba instalando a versão mais antiga sendo a 24.0.0.225 e não a mais recente sendo a 25.0.0.127.  Porque a adobe não corrigi isso?  :-\

Sendo assim, se faz necessário baixar as versões mais recentes e envia-las para a pasta padrão da instalação do flash, ficando mais ou menos assim:

Para plataformas 32bits.
wget https://fpdownload.adobe.com/get/flashplayer/pdc/25.0.0.127/flash_player_npapi_linux.i386.tar.gz -O flash.tar.gz

wget https://fpdownload.adobe.com/pub/flashplayer/pdc/25.0.0.127/flash_player_ppapi_linux.i386.tar.gz -O flash.tar.gz

Para plataformas 64bits
wget https://fpdownload.adobe.com/get/flashplayer/pdc/25.0.0.127/flash_player_npapi_linux.x86_64.tar.gz -O flash.tar.gz

wget https://fpdownload.adobe.com/pub/flashplayer/pdc/25.0.0.127/flash_player_ppapi_linux.x86_64.tar.gz -O flash.tar.gz

Em seguida é só descompactar na sequencia o  NPAP e PPAPI.

tar -zxvf flash.tar.gz

Apos descompactação transporte o arquivo ao destino:

sudo cp libflashplayer.so /usr/lib/adobe-flashplugin/

sudo cp libpepflashplayer.so /usr/lib/adobe-flashplugin/

Editado: No caso do Opera é preciso também transportar o arquivo manifest.json, caso contrário no about:plugins do Opera continuará aparecendo a versão mais antiga.

sudo cp manifest.json /usr/lib/adobe-flashplugin/

Pronto! Vc estará com o adobe flash player atualizado !  :)

Só não entendo porque a adobe já não disponibiliza a versão mais recente diretamente aos usuários do Linux como faz para as outras plataformas. Enfim! Como dizia um professor de matemática, se podemos complicar para que facilitar, não é?  ;)

Serial
« Última modificação: 19 de Março de 2017, 09:32 por Serial »