Autor Tópico: Libreoffice Base  (Lida 1637 vezes)

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.389
    • Ver perfil
Re:Libreoffice Base
« Resposta #30 Online: 27 de Julho de 2017, 14:02 »
Olá pessoal!

Então, descobri mais coisas.

Não é toda versão do 4.8 que funciona!

Usando a versão 4.8.0-36 o Base funciona.  Se eu atualizar para última versão 4.8 ( 4.8.0-58) o base não funciona mais!

Então existe um limite já no kernel 4.8, que não sei qual é.


É possível manter o pacote sem atualização. Tem 4 maneiras de fazer isso, pleo Synaptic, o mai simples:  selecionando o pacote em questão, aba pacote > bloquear versão.

Pelo apt, pelo dpkg e pelo preferences do apt! 

De qualquer maneira eu não sei como funciona o gerenciamento dessa máquina.  Se é pra ligar e usar, com vários usuários, ou se apenas uma pessoa mexe.  Se apenas uma pessoa mexer, não tem dificuldade nenhuma.  Só bloquear atualização deste pacote e atualizar o resto.  Já que essa só pessoa saberia do problema em questão.

Pra testar na minha máquina, eu removi todos os kerneis, incluindo o meta-pacote que manda atualizar a versão, deixando só o 4.8.0-36. Daí bloqueei ele no Synaptic. Pronto!  Só se alguém entrar no sistema e mandar instalar outro kernel mais novo.  Ele pode instalar outro kernel mais novo o que fica bloqueado é a versão do 4.8.0-36!

Não sei qual versão do 4.8 está aí também.  Mas se funciona, mantenha essa!

Outra maneira mais fácil, se não quiser se preocupar com atualizações, seria utilizar a versão 4.4 LTS do kernel.  Se tudo aí funcionar na máquina, fica muito mais fácil. Só deixaria este instalado, com o meta-pacote responsável pelas atualizações, e não teria medo de atualizar.


   

* Linux Mint 18 Mate 64bits / Windows 10 64bits Casa! * CentOS 7 64bits Servidor de arquivos em modo texto - Casa * MacOS Sierra  - Mac Mini servidor multimidia - Casa * DELL Inspiron 14R + Ubuntu Mate 17.04 64bits.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.846
    • Ver perfil
Re:Libreoffice Base
« Resposta #31 Online: 27 de Julho de 2017, 16:55 »
Pra testar na minha máquina, eu removi todos os kerneis, incluindo o meta-pacote que manda atualizar a versão, deixando só o 4.8.0-36.

É uma constatação importante, pode não ser a solução perfeita para o caso concreto, porque o sistema dele na prática já atualizou para o 4.10 hwe, porém se testou aí e funcionou bem desse modo, então é uma solução praticável  que pode ser bem razoável, se funciona, funciona, então está bom.


Não sei qual versão do 4.8 está aí também.  Mas se funciona, mantenha essa!

A versão da 4.8 que tem lá é exatamente a 4.8.0-36, conforme o resultado trazido pelo post #11

Outra maneira mais fácil, se não quiser se preocupar com atualizações, seria utilizar a versão 4.4 LTS do kernel.  Se tudo aí funcionar na máquina, fica muito mais fácil. Só deixaria este instalado, com o meta-pacote responsável pelas atualizações, e não teria medo de atualizar.

Se for por esse caminho então precisa reinstalar o Lubuntu no sistema, porém não pode ser usando o iso do release 16.04.2, porque esse já vem com o kernel 4.8 e vai atualizar para o mais recente. Nessa opção precisa reinstalar o sistema usando o iso 16.04.1 que vem com o kernel 4.4 e irá manter essa série, não evoluindo para o 4.8.

www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.846
    • Ver perfil
Re:Libreoffice Base
« Resposta #32 Online: 27 de Julho de 2017, 17:01 »
Então, @loalexandre77,

Uma questão crucial para orientar algum caminho: é possível reinstalar o Lubuntu aí no sistema sem maiores dificuldades ou isso é um problema considerando o que já há aí instalado?

A reintalação pode não ser uma solução elegante, porém nesse caso pode ser a mais prática e mais facilmente operacional.
« Última modificação: 27 de Julho de 2017, 17:17 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.389
    • Ver perfil
Re:Libreoffice Base
« Resposta #33 Online: 27 de Julho de 2017, 19:40 »
Fiz mais testes druidaobelix, não é necessário reinstalar o sistema. 

Olha só, ele instala o meta pacote linux-generic-lts-xenial, assim vai instalar a última versão do kernel 4.4 com todas as suas dependências, tudo dos repositórios do Lubuntu, reinicia o sistema e seleciona o kernel 4.4 LTS no Grub. 

Entra no sistema e testa o que for preciso, se funcionar tudo, remove todos os outros kerneis, incluindo os meta-pacotes, deixa só o kernel 4.4 LTS.  Pronto!

Fiz aqui um apt update + apt dist-upgrade ,  ele atualiza tudo sem  problemas!  Daí não vai ter medo de bugar o sistema por causa de um kernel mais novo.
* Linux Mint 18 Mate 64bits / Windows 10 64bits Casa! * CentOS 7 64bits Servidor de arquivos em modo texto - Casa * MacOS Sierra  - Mac Mini servidor multimidia - Casa * DELL Inspiron 14R + Ubuntu Mate 17.04 64bits.

Offline loalexandre77

  • Usuário Ubuntu
  • *
  • Mensagens: 18
    • Ver perfil
Re:Libreoffice Base
« Resposta #34 Online: 27 de Julho de 2017, 23:52 »
4.11 e 4.12 não funcionaram. Posso desinstalá-los e versão 4.10 também?

1) Conseguiu fazer aparecer a tela do menu do grub de forma permanente, como mencionado lá no post #22?

Lembre-se que do lado de cá não estamos vendo o que está acontecendo aí, você precisa ir dizendo, sendo os "olhos" do Fórum, dando retorno das informações e do cenário existente.

2) Pena que não tenham funcionado nem o 4.11.12 nem o 4.12.3, teriam facilitado as coisas.  :(

Se não funcionaram, então desinstale:

Código: [Selecionar]
sudo apt-get --purge remove linux-image-4.11.12-041112-generic
Código: [Selecionar]
sudo apt-get --purge remove linux-image-4.12.3-041203
Em seguida:

Código: [Selecionar]
sudo update-grub
Reinicie o sistema

Muito importante:

**Não desinstale** de forma alguma o kernel 4.10.0-27 hwe já existente no sistema e instalado conforme as atualizações normais, pois isso pode potencialmente ser desastroso, porque a ele estão vinculados outros subsistemas importantes, como o servidor X, driver de vídeo e outras coisas, assim sendo, como disse antes, agora precisamos estudar isso melhor, para fazer o sistema sempre iniciar automaticamente pelo 4.8.0-36 hwe existente.

Consegui colocar de forma permanente o grub. Obrigado
Já desinstalei as versões 4.11 e 4.12

Offline loalexandre77

  • Usuário Ubuntu
  • *
  • Mensagens: 18
    • Ver perfil
Re:Libreoffice Base
« Resposta #35 Online: 28 de Julho de 2017, 00:08 »

Traga ao tópico o resultado para:

Código: [Selecionar]
apt-cache policy linux-generic-hwe-16.04
linux-generic-hwe-16.04:
  Instalado: 4.10.0.28.31
  Candidato: 4.10.0.28.31
  Tabela de versão:
 *** 4.10.0.28.31 500
        500 http://br.archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages
        500 http://security.ubuntu.com/ubuntu xenial-security/main i386 Packages
        100 /var/lib/dpkg/status

Código: [Selecionar]
apt-cache policy xserver-xorg-core-hwe-16.04
xserver-xorg-core-hwe-16.04:
  Instalado: 2:1.19.3-1ubuntu1~16.04.2
  Candidato: 2:1.19.3-1ubuntu1~16.04.2
  Tabela de versão:
 *** 2:1.19.3-1ubuntu1~16.04.2 500
        500 http://br.archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages
        100 /var/lib/dpkg/status
     2:1.18.4-1ubuntu6.1~16.04.2 500
        500 http://security.ubuntu.com/ubuntu xenial-security/main i386 Packages


Código: [Selecionar]
apt-cache policy xserver-xorg-input-all-hwe-16.04
xserver-xorg-input-all-hwe-16.04:
  Instalado: 1:7.7+16ubuntu3~16.04.1
  Candidato: 1:7.7+16ubuntu3~16.04.1
  Tabela de versão:
 *** 1:7.7+16ubuntu3~16.04.1 500
        500 http://br.archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages
        100 /var/lib/dpkg/status

Código: [Selecionar]
apt-cache policy xserver-xorg-video-all-hwe-16.04
xserver-xorg-video-all-hwe-16.04:
  Instalado: 1:7.7+16ubuntu3~16.04.1
  Candidato: 1:7.7+16ubuntu3~16.04.1
  Tabela de versão:
 *** 1:7.7+16ubuntu3~16.04.1 500
        500 http://br.archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages
        100 /var/lib/dpkg/status



Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.846
    • Ver perfil
Re:Libreoffice Base
« Resposta #36 Online: 28 de Julho de 2017, 00:41 »
Olá, @ loalexandre77,

Recuperado, tirou o sono atrasado, depois de 3 dias sem dormir?   :)

Voltando ao tema, haja vista os estudos e testes que o @galactus fez, parece que o mais viável é mesmo ir para a versão 4.4 do kernel, da forma como ele explicou no post # 33, depois atualiza como também lá mencionado.

No momento parece ser a melhor opção para resolver a questão.
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline loalexandre77

  • Usuário Ubuntu
  • *
  • Mensagens: 18
    • Ver perfil
Re:Libreoffice Base
« Resposta #37 Online: 28 de Julho de 2017, 00:41 »
É possível manter o pacote sem atualização. Tem 4 maneiras de fazer isso, pleo Synaptic, o mai simples:  selecionando o pacote em questão, aba pacote > bloquear versão.

bloquiei a versão no synaptic. Posso desinstalar a versão 10 do kernel? A 8 tá show

   
[/quote]

Offline loalexandre77

  • Usuário Ubuntu
  • *
  • Mensagens: 18
    • Ver perfil
Re:Libreoffice Base
« Resposta #38 Online: 28 de Julho de 2017, 00:46 »
Fiz mais testes druidaobelix, não é necessário reinstalar o sistema. 

Olha só, ele instala o meta pacote linux-generic-lts-xenial, assim vai instalar a última versão do kernel 4.4 com todas as suas dependências, tudo dos repositórios do Lubuntu, reinicia o sistema e seleciona o kernel 4.4 LTS no Grub. 

Entra no sistema e testa o que for preciso, se funcionar tudo, remove todos os outros kerneis, incluindo os meta-pacotes, deixa só o kernel 4.4 LTS.  Pronto!

Fiz aqui um apt update + apt dist-upgrade ,  ele atualiza tudo sem  problemas!  Daí não vai ter medo de bugar o sistema por causa de um kernel mais novo.

Como faço para instalar o meta pacote: linux-generic-lts-xenial? Pelo synaptic? Posso desinstalar todas as outras versões do kernel e atualizar o grub?

Offline loalexandre77

  • Usuário Ubuntu
  • *
  • Mensagens: 18
    • Ver perfil
Re:Libreoffice Base
« Resposta #39 Online: 28 de Julho de 2017, 00:49 »
Olá, @ loalexandre77,

Recuperado, tirou o sono atrasado, depois de 3 dias sem dormir?   :)

Voltando ao tema, haja vista os estudos e testes que o @galactus fez, parece que o mais viável é mesmo ir para a versão 4.4 do kernel, da forma como ele explicou no post # 33, depois atualiza como também lá mencionado.

No momento parece ser a melhor opção para resolver a questão.

 ;D ;D ;D
Recuperei um pouco do sono, mas não muito. tive que ficar lançando no sistema o atrasado.
Vlw pela força druidaobelix e galacticus

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.846
    • Ver perfil
Re:Libreoffice Base
« Resposta #40 Online: 28 de Julho de 2017, 00:55 »
É possível manter o pacote sem atualização. Tem 4 maneiras de fazer isso, pleo Synaptic, o mai simples:  selecionando o pacote em questão, aba pacote > bloquear versão.
bloquiei a versão no synaptic. Posso desinstalar a versão 10 do kernel? A 8 tá show

O receio que eu tinha parece que não se materializou, conforme os testes do @galactus, então também até pode.

Note, porém, que essa é uma solução imperfeita, pelas razões já explicadas.
Mas se quiser testar, vá em frente.

Veja o seguinte, precisamos ter clareza quanto ao que agora estamos conversando.

O problema central do tópico já foi resolvido, já se conhece a solução.

A questão central era o LO-Base não funcionar.

Agora sabemos que não funciona a partir de determinada versão do kernel 4.8 e seguintes.

Que se retornar a uma versão anterior o LO-Base funciona normalmente.

Então o objetivo central do tópico encerrou-se aí, a questão está resolvida.

Agora é só uma questão de operacionalizar isso, o que pode ser feito de diversas formas.

Tudo depende da relevância de manter o que já existe, do que já há instalado ou não.

Parece, a julgar pelos seus post anteriores, que não há grande preocupação em manter o sistema (suponho que você tenha backup externo confiável dos seus dados), pois segundo um dos seus posts, dá a entender que já reinstalou e ainda experimentou outros sabores, logo, isso sugere ser irrelevante manter ou não o sistema atual, já que a solução nuclear sempre irá funcionar. Solução nuclear é isso mesmo que o nome sugere, igual bomba atômica, destrói absolutamente tudo e depois reconstrói de novo. A solução nuclear sempre funciona.

Se isso for fato, então não há maiores preocupações de que retirando o kernel 4.10 haja alguma dificuldade, toca em frente se essa for sua opção.

Do ponto de vista do rigor técnico parece ser melhor ir para o kernel 4.4, conforme o @galactus explicou, mas nada impede de também abater o 4.10 e experimente o 4.8 já instalado. Depois, se quiser, ainda dá para ir para o 4.4 daquela hipótese.

Agora é escolher por onde quer ir.  :)
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.846
    • Ver perfil
Re:Libreoffice Base
« Resposta #41 Online: 28 de Julho de 2017, 01:11 »
Vamos caminhar dessa forma:

Inicie o sistema escolhendo lá no menu do grub o kernel 4.8.0-36

Vou colocar aqui neste post a forma mais tradicional de "travar" um kernel, fazendo diretamente um 'pinning' no apt.
Também pode ser feito pelo Synaptic, mas vamos pela forma mais tradicional, que não depende de nenhum programa externo:

Código: [Selecionar]
sudo gedit /etc/apt/preferences.d/preferences
Isso acima vai abrir um arquivo em branco, porque o arquivo "preferences" não existia antes, está sendo criado agora.

Cole nesse arquivo em branco esse conteúdo:

Código: [Selecionar]
Package: linux-generic
Pin: version 4.8.0-36
Pin-Priority: 1000

Package: linux-headers-generic
Pin: version 4.8.0-36
Pin-Priority: 1000

Package: linux-image-generic
Pin: version 4.8.0-36
Pin-Priority: 1000

Package: linux-libc-dev
Pin: version 4.8.0-36
Pin-Priority: 1000

Salvar e sair


Editando (28/07/17-15:46):

Ver complemento no post #51
« Última modificação: 28 de Julho de 2017, 15:47 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.846
    • Ver perfil
Re:Libreoffice Base
« Resposta #42 Online: 28 de Julho de 2017, 01:16 »
Desintale agora o kernel 4.10.0-27 que existe aí no sistema:

Código: [Selecionar]
sudo apt-get remove --purge linux-image-4.10.0-27-generic
Depois do processamento confirme se removeu fazendo novamente:

Código: [Selecionar]
dpkg-query -l | awk '/linux-image-*/ {print $2}'
Atualize o grub:

Código: [Selecionar]
sudo update-grub
Reinicie o sistema, o kernel 4.8.0-36 deverá ser o primeiro da lista lá no menu do grub.

Em princípio termina aí, deverá ser possível ir usando o sistema dessa forma.
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline loalexandre77

  • Usuário Ubuntu
  • *
  • Mensagens: 18
    • Ver perfil
Re:Libreoffice Base
« Resposta #43 Online: 28 de Julho de 2017, 01:22 »
druidaobelix,

vou aceitar o seu conselho e instalar a versão 16.04.01 LTS do lubuntu. Pode ocorrer um problema futuro em outro aplicativo.

Obrigado por tudo. Aprendi muito aqui :)

Mas vou fazer isso futuramente.

Enquanto isso como faço para instalar o kernel 4.4 conforme o galacticus disse?
« Última modificação: 28 de Julho de 2017, 01:30 por loalexandre77 »

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.846
    • Ver perfil
Re:Libreoffice Base
« Resposta #44 Online: 28 de Julho de 2017, 01:26 »
vou aceitar o seu conselho e instalar a versão 16.04.01 LTS do lubuntu. Pode ocorrer um problema futuro em outro aplicativo.

Veja, @loalexandre77,

Fazer uma nova instalação você sempre pode, é a solução nuclear.  :)

Experimente antes as outras alternativas, até para aprender o manuseio disso.

Depois, finalmente, querendo, instale a versão 16.04.1
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.