Autor Tópico: Instalaão do PHP5  (Lida 169 vezes)

Offline Marquinh0-pe

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Instalaão do PHP5
« Online: 09 de Agosto de 2017, 18:15 »
Sou iniciante  no Ubuntu sem  nenhuma  experiencia e  estou tentando instalar  um servidor  web  e ja instalei o apache o mysql mas  estou tendo  problemas  para instalar o PHP5  e o phpmyadmin sendo que quando  tento instalar o PHP5 recebo a  mensagem: php nao  encontrado impossivel instalar.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.859
    • Ver perfil
Re:Instalacão do PHP5
« Resposta #1 Online: 09 de Agosto de 2017, 18:35 »
[...] estou tendo  problemas  para instalar o PHP5  e o phpmyadmin sendo que quando  tento instalar o PHP5 recebo a  mensagem: php nao  encontrado impossivel instalar.

E qual é a versão do Ubuntu?

Código: [Selecionar]
lsb_release -rd
No Ubuntu versão atual 16.04 o padrão do PhP é 7.0

Código: [Selecionar]
apt-cache pkgnames | grep php7.0
Por qual razãop especificamente precisa da 5.0?

Na instalação do Php7.0:

Código: [Selecionar]
sudo apt install php7.0
deverá resultar:

Código: [Selecionar]
php -v
Citar
PHP 7.0.18-0ubuntu0.16.04.1 (cli) ( NTS )
Copyright (c) 1997-2017 The PHP Group
Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies
    with Zend OPcache v7.0.18-0ubuntu0.16.04.1, Copyright (c) 1999-2017, by Zend Technologies

Se for baseado em LAMP, supondo que já tenha feito:

Código: [Selecionar]
sudo apt-get install -y apache2
pode ser interessante fazer algo assim:

Código: [Selecionar]
sudo apt-get install -y php7.0 libapache2-mod-php7.0 php7.0-cli php7.0-common php7.0-mbstring php7.0-gd php7.0-intl php7.0-xml php7.0-mysql php7.0-mcrypt php7.0-zip
« Última modificação: 09 de Agosto de 2017, 19:15 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.859
    • Ver perfil
Re:Instalaão do PHP5
« Resposta #2 Online: 09 de Agosto de 2017, 19:24 »
Faltou dizer: se por alguma razão precisar mesmo do PhP5 tenha em conta que deverá usar o release PHP 5.6, isto é, **não** use PHP 5.4 ou PHP 5.5, os quais não mais possuem atualizações de segurança.
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.