Autor Tópico: [Resolvido] Erro ao tentar instalar pacotes (atualizações)  (Lida 1006 vezes)

Offline Edmor_t

  • Usuário Ubuntu
  • *
  • Mensagens: 11
    • Ver perfil
[Resolvido] Erro ao tentar instalar pacotes (atualizações)
« Online: 15 de Agosto de 2017, 17:52 »
Estou com esse problema faz uma semana. As vezes o sistema roda normal sem erros. As vezes aparece aquele sinal de STOP (circulo vermelho com um traço). Quando clico nele aparece que:

dpkg: erro ao processar o pacote ubuntu-release-upgrader-gtk (--configure)

Quando rodo "apt upgrade" ou nesse caso o "autoremove":

:~$ sudo apt autoremove
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Os pacotes a seguir serão REMOVIDOS:
  linux-headers-4.4.0-83 linux-headers-4.4.0-83-generic linux-headers-4.4.0-87
  linux-headers-4.4.0-87-generic linux-image-4.4.0-83-generic
  linux-image-4.4.0-87-generic linux-image-extra-4.4.0-83-generic
  linux-image-extra-4.4.0-87-generic
0 pacotes atualizados, 0 pacotes novos instalados, 8 a serem removidos e 4 não atualizados.
4 pacotes não totalmente instalados ou removidos.
É preciso baixar 0 B/29,5 kB de arquivos.
Depois desta operação, 594 MB de espaço em disco serão liberados.
Você quer continuar? [S/n] s
dpkg: aviso: falta ficheiro de lista de ficheiros 'ubuntu-release-upgrader-gtk'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'ubuntu-release-upgrader-core'; assumindo que o pacote não tem actualmente ficheiros instalados
(Lendo banco de dados ... 290893 ficheiros e directórios actualmente instalados.)
A remover linux-headers-4.4.0-83-generic (4.4.0-83.106) ...
A remover linux-headers-4.4.0-83 (4.4.0-83.106) ...
A remover linux-headers-4.4.0-87-generic (4.4.0-87.110) ...
A remover linux-headers-4.4.0-87 (4.4.0-87.110) ...
A remover linux-image-extra-4.4.0-83-generic (4.4.0-83.106) ...
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.4.0-83-generic /boot/vmlinuz-4.4.0-83-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.4.0-83-generic /boot/vmlinuz-4.4.0-83-generic
update-initramfs: Generating /boot/initrd.img-4.4.0-83-generic
run-parts: executing /etc/kernel/postinst.d/pm-utils 4.4.0-83-generic /boot/vmlinuz-4.4.0-83-generic
run-parts: executing /etc/kernel/postinst.d/unattended-upgrades 4.4.0-83-generic /boot/vmlinuz-4.4.0-83-generic
run-parts: executing /etc/kernel/postinst.d/update-notifier 4.4.0-83-generic /boot/vmlinuz-4.4.0-83-generic
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 4.4.0-83-generic /boot/vmlinuz-4.4.0-83-generic
Generating grub configuration file ...
Atenção: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.
Encontrado imagem linux: /boot/vmlinuz-4.4.0-92-generic
Encontrado imagem initrd: /boot/initrd.img-4.4.0-92-generic
Encontrado imagem linux: /boot/vmlinuz-4.4.0-89-generic
Encontrado imagem initrd: /boot/initrd.img-4.4.0-89-generic
Encontrado imagem linux: /boot/vmlinuz-4.4.0-87-generic
Encontrado imagem initrd: /boot/initrd.img-4.4.0-87-generic
Encontrado imagem linux: /boot/vmlinuz-4.4.0-83-generic
Encontrado imagem initrd: /boot/initrd.img-4.4.0-83-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
concluído
A remover linux-image-4.4.0-83-generic (4.4.0-83.106) ...
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 4.4.0-83-generic /boot/vmlinuz-4.4.0-83-generic
update-initramfs: Deleting /boot/initrd.img-4.4.0-83-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 4.4.0-83-generic /boot/vmlinuz-4.4.0-83-generic
Generating grub configuration file ...
Atenção: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.
Encontrado imagem linux: /boot/vmlinuz-4.4.0-92-generic
Encontrado imagem initrd: /boot/initrd.img-4.4.0-92-generic
Encontrado imagem linux: /boot/vmlinuz-4.4.0-89-generic
Encontrado imagem initrd: /boot/initrd.img-4.4.0-89-generic
Encontrado imagem linux: /boot/vmlinuz-4.4.0-87-generic
Encontrado imagem initrd: /boot/initrd.img-4.4.0-87-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
concluído
A remover linux-image-extra-4.4.0-87-generic (4.4.0-87.110) ...
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.4.0-87-generic /boot/vmlinuz-4.4.0-87-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.4.0-87-generic /boot/vmlinuz-4.4.0-87-generic
update-initramfs: Generating /boot/initrd.img-4.4.0-87-generic
run-parts: executing /etc/kernel/postinst.d/pm-utils 4.4.0-87-generic /boot/vmlinuz-4.4.0-87-generic
run-parts: executing /etc/kernel/postinst.d/unattended-upgrades 4.4.0-87-generic /boot/vmlinuz-4.4.0-87-generic
run-parts: executing /etc/kernel/postinst.d/update-notifier 4.4.0-87-generic /boot/vmlinuz-4.4.0-87-generic
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 4.4.0-87-generic /boot/vmlinuz-4.4.0-87-generic
Generating grub configuration file ...
Atenção: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.
Encontrado imagem linux: /boot/vmlinuz-4.4.0-92-generic
Encontrado imagem initrd: /boot/initrd.img-4.4.0-92-generic
Encontrado imagem linux: /boot/vmlinuz-4.4.0-89-generic
Encontrado imagem initrd: /boot/initrd.img-4.4.0-89-generic
Encontrado imagem linux: /boot/vmlinuz-4.4.0-87-generic
Encontrado imagem initrd: /boot/initrd.img-4.4.0-87-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
concluído
A remover linux-image-4.4.0-87-generic (4.4.0-87.110) ...
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 4.4.0-87-generic /boot/vmlinuz-4.4.0-87-generic
update-initramfs: Deleting /boot/initrd.img-4.4.0-87-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 4.4.0-87-generic /boot/vmlinuz-4.4.0-87-generic
Generating grub configuration file ...
Atenção: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.
Encontrado imagem linux: /boot/vmlinuz-4.4.0-92-generic
Encontrado imagem initrd: /boot/initrd.img-4.4.0-92-generic
Encontrado imagem linux: /boot/vmlinuz-4.4.0-89-generic
Encontrado imagem initrd: /boot/initrd.img-4.4.0-89-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
concluído
dpkg: erro ao processar o pacote ubuntu-release-upgrader-core (--configure):
 O pacote está num mau estado de inconsistência; deve
 reinstala-lo antes de tentar configura-lo.
Nenhum relatório apport escrito pois a mensagem de erro indica que é um erro de seguimento de um erro anterior.
                               Nenhum relatório apport escrito pois a mensagem de erro indica que é um erro de seguimento de um erro anterior.
                                                              dpkg: problemas com dependências impedem a configuração de update-manager-core:
 update-manager-core depende de ubuntu-release-upgrader-core; porém:
  Pacote ubuntu-release-upgrader-core não está configurado ainda.

dpkg: erro ao processar o pacote update-manager-core (--configure):
 problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de update-manager:
 update-manager depende de update-manager-core (= 1:16.04.8); porém:
  Pacote update-manager-core não está configurado ainda.

dpkg: erro ao processar o pacote update-manager (--configure):
 problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de ubuntu-release-upgrader-gtk:
 ubuntu-release-upgrader-gtk depende de ubuntu-release-upgrader-core (= 1:16.04.22); porém:
  Pacote ubuntu-release-upgrader-core não está configurado ainda.
 ubuntu-release-upgrader-gtk depende de update-manager; porém:
  Pacote update-manager nNenhum relatório apport escrito pois MaxReports já foi atingido
        ão está configurado ainda.

dpkg: erro ao processar o pacote ubuntu-release-upgrader-gtk (--configure):
 problemas de dependência - deixando desconfigurado
Erros foram encontrados durante o processamento de:
 ubuntu-release-upgrader-core
 update-manager-core
 update-manager
 ubuntu-release-upgrader-gtk
E: Sub-process /usr/bin/dpkg returned an error code (1)
« Última modificação: 23 de Agosto de 2017, 12:05 por Edmor_t »

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.438
    • Ver perfil
Re:Erro ao tentar instalar pacotes (atualizações)
« Resposta #1 Online: 15 de Agosto de 2017, 18:35 »
Olá Edmor_t, tente os seguintes comandos na sequencia no terminal:

 
sudo dpkg --configure -a

sudo apt-get install -f

sudo apt-get update

sudo apt-get dist-upgrade


Se isso não resolver, copie e cole a saída dos comandos aqui pra gente ver!

Tem muitos PPAs instalados na sua source.list?  Algum tem haver com python?

* Linux Mint 18 Mate 64bits / Windows 10 64bits Casa! * CentOS 7 64bits Servidor de arquivos em modo texto - Casa * MacOS Sierra  - Mac Mini servidor multimidia - Casa * DELL Inspiron 14R + Ubuntu Mate 17.04 64bits.

Offline Edmor_t

  • Usuário Ubuntu
  • *
  • Mensagens: 11
    • Ver perfil
Re:Erro ao tentar instalar pacotes (atualizações)
« Resposta #2 Online: 16 de Agosto de 2017, 13:52 »
O erro é persistente, se apresenta em quase todas as situações:

sudo dpkg --configure -a

dpkg: erro ao processar o pacote ubuntu-release-upgrader-core (--configure):
 O pacote está num mau estado de inconsistência; deve
 reinstala-lo antes de tentar configura-lo.
dpkg: problemas com dependências impedem a configuração de ubuntu-release-upgrader-gtk:
 ubuntu-release-upgrader-gtk depende de ubuntu-release-upgrader-core (= 1:16.04.22); porém:
  Pacote ubuntu-release-upgrader-core não está configurado ainda.

dpkg: erro ao processar o pacote ubuntu-release-upgrader-gtk (--configure):
 problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de update-manager-core:
 update-manager-core depende de ubuntu-release-upgrader-core; porém:
  Pacote ubuntu-release-upgrader-core não está configurado ainda.

dpkg: erro ao processar o pacote update-manager-core (--configure):
 problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem o processamento de triggers para update-notifier-common:
 update-notifier-common depende de update-manager-core (>= 1:16.04.6); porém:
  Pacote update-manager-core não está configurado ainda.

dpkg: erro ao processar o pacote update-notifier-common (--configure):
 problemas com dependências - a deixar triggers por processar
dpkg: problemas com dependências impedem a configuração de update-manager:
 update-manager depende de update-manager-core (= 1:16.04.8); porém:
  Pacote update-manager-core não está configurado ainda.
 update-manager depende de ubuntu-release-upgrader-gtk; porém:
  Pacote ubuntu-release-upgrader-gtk não está configurado ainda.

dpkg: erro ao processar o pacote update-manager (--configure):
 problemas de dependência - deixando desconfigurado
Erros foram encontrados durante o processamento de:
 ubuntu-release-upgrader-core
 ubuntu-release-upgrader-gtk
 update-manager-core
 update-notifier-common
 update-manager

PPA's instalados:

$ grep -RoPish "ppa.launchpad.net/[^/]+/[^/ ]+" /etc/apt | sort -u | sed -r 's/\.[^/]+\//:/'

ppa:george-edison55/webp
ppa:i-nex-development-team/stable
ppa:oibaf/graphics-drivers


« Última modificação: 16 de Agosto de 2017, 13:56 por Edmor_t »

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.438
    • Ver perfil
Re:Erro ao tentar instalar pacotes (atualizações)
« Resposta #3 Online: 16 de Agosto de 2017, 14:27 »
Tá, você mostrou a saída de um comando!

E os outros? Você tentou?

Então tente:

sudo apt-get install --reinstall ubuntu-release-upgrader-core ubuntu-release-upgrader-gtk  update-manager-core  update-notifier-common  update-manager
* Linux Mint 18 Mate 64bits / Windows 10 64bits Casa! * CentOS 7 64bits Servidor de arquivos em modo texto - Casa * MacOS Sierra  - Mac Mini servidor multimidia - Casa * DELL Inspiron 14R + Ubuntu Mate 17.04 64bits.

Offline Edmor_t

  • Usuário Ubuntu
  • *
  • Mensagens: 11
    • Ver perfil
Re:Erro ao tentar instalar pacotes (atualizações)
« Resposta #4 Online: 17 de Agosto de 2017, 16:30 »
sudo apt-get install --reinstall ubuntu-release-upgrader-core ubuntu-release-upgrader-gtk  update-manager-core  update-notifier-common  update-manager

Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
0 pacotes atualizados, 0 pacotes novos instalados, 5 reinstalados, 0 a serem removidos e 21 não atualizados.
4 pacotes não totalmente instalados ou removidos.
É preciso baixar 165 kB/194 kB de arquivos.
Depois desta operação, 0 B adicionais de espaço em disco serão usados.
Obter:1 http://br.archive.ubuntu.com/ubuntu xenial-updates/main amd64 update-notifier-common all 3.168.4 [165 kB]
Baixados 165 kB em 0s (676 kB/s)           
E: Internal Error, No file name for update-manager-core:amd64

Um detalhe, depois e usar o comando sudo apt update e upgrade o Ubuntu funciona sem falhas e sem avisos. Mas não posso nem chegar perto do Ubuntu Software pois ele começa a instalar e para no meio do caminho. Estou achando que a Canonical se contaminou com a M$, pois isso é coisa de Ruindows.
« Última modificação: 17 de Agosto de 2017, 16:55 por Edmor_t »

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.438
    • Ver perfil
Re:Erro ao tentar instalar pacotes (atualizações)
« Resposta #5 Online: 17 de Agosto de 2017, 19:55 »
Vamos tentar outra coisa, você está com o Synaptic instalado?  Vou pedir pra você mudar o país da lista de repositórios, do Brasil para o servidor principal!  Se tiver com o Synaptic instalado fica fácil fazer isso.

Se não estiver instalado, instale-o:  apt-get install synaptic

Sabe usar o Synaptic? Se souber fica fácil mudar a lista. Quando você trocar de source.list ele vai pedir para você atualizar a lista, faça isso.

Depois de mudar o país da lista, tente instalar o aptitude, se já não estiver instalado.

apt-get install aptitude

apt-get clean

aptitude update

aptitude --full-resolver safe-upgrade



No aguardo.
* Linux Mint 18 Mate 64bits / Windows 10 64bits Casa! * CentOS 7 64bits Servidor de arquivos em modo texto - Casa * MacOS Sierra  - Mac Mini servidor multimidia - Casa * DELL Inspiron 14R + Ubuntu Mate 17.04 64bits.

Offline Edmor_t

  • Usuário Ubuntu
  • *
  • Mensagens: 11
    • Ver perfil
Re:Erro ao tentar instalar pacotes (atualizações)
« Resposta #6 Online: 18 de Agosto de 2017, 10:52 »
sudo apt-get install aptitude

Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
The following additional packages will be installed:
  aptitude-common libcwidget3v5
Pacotes sugeridos:
  apt-xapian-index aptitude-doc-en | aptitude-doc debtags tasksel
  libcwidget-dev
Os NOVOS pacotes a seguir serão instalados:
  aptitude aptitude-common libcwidget3v5
0 pacotes atualizados, 3 pacotes novos instalados, 0 a serem removidos e 26 não atualizados.
4 pacotes não totalmente instalados ou removidos.
É preciso baixar 2.345 kB/2.374 kB de arquivos.
Depois desta operação, 9.865 kB adicionais de espaço em disco serão usados.
Você quer continuar? [S/n] s
Obter:1 http://br.archive.ubuntu.com/ubuntu xenial/main amd64 aptitude-common all 0.7.4-2ubuntu2 [747 kB]
Obter:2 http://br.archive.ubuntu.com/ubuntu xenial/main amd64 libcwidget3v5 amd64 0.5.17-4ubuntu2 [292 kB]
Obter:3 http://br.archive.ubuntu.com/ubuntu xenial/main amd64 aptitude amd64 0.7.4-2ubuntu2 [1.306 kB]
Baixados 2.345 kB em 0s (2.436 kB/s)
A seleccionar pacote anteriormente não seleccionado aptitude-common.
dpkg: aviso: falta ficheiro de lista de ficheiros 'ubuntu-release-upgrader-gtk'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'ubuntu-release-upgrader-core'; assumindo que o pacote não tem actualmente ficheiros instalados
(Lendo banco de dados ... 226271 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar .../aptitude-common_0.7.4-2ubuntu2_all.deb ...
A descompactar aptitude-common (0.7.4-2ubuntu2) ...
A seleccionar pacote anteriormente não seleccionado libcwidget3v5:amd64.
A preparar para desempacotar .../libcwidget3v5_0.5.17-4ubuntu2_amd64.deb ...
A descompactar libcwidget3v5:amd64 (0.5.17-4ubuntu2) ...
A seleccionar pacote anteriormente não seleccionado aptitude.
A preparar para desempacotar .../aptitude_0.7.4-2ubuntu2_amd64.deb ...
A descompactar aptitude (0.7.4-2ubuntu2) ...
A processar 'triggers' para man-db (2.7.5-1) ...
A processar 'triggers' para libc-bin (2.23-0ubuntu9) ...
A processar 'triggers' para menu (2.1.47ubuntu1) ...
dpkg: erro ao processar o pacote ubuntu-release-upgrader-core (--configure):
 O pacote está num mau estado de inconsistência; deve
 reinstala-lo antes de tentar configura-lo.
Nenhum relatório apport escrito pois a mensagem de erro indica que é um erro de seguimento de um erro anterior.
                               Nenhum relatório apport escrito pois a mensagem de erro indica que é um erro de seguimento de um erro anterior.
                                                              dpkg: problemas com dependências impedem a configuração de update-manager-core:
 update-manager-core depende de ubuntu-release-upgrader-core; porém:
  Pacote ubuntu-release-upgrader-core não está configurado ainda.

dpkg: erro ao processar o pacote update-manager-core (--configure):
 problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de update-manager:
 update-manager depende de update-manager-core (= 1:16.04.8); porém:
  Pacote update-manager-core não está configurado ainda.

dpkg: erro ao processar o pacote update-manager (--configure):
 problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de ubuntu-release-upgrader-gtk:
 ubuntu-release-upgrader-gtk depende de ubuntu-release-upgrader-core (= 1:16.04.22); porém:
  Pacote ubuntu-release-upgrader-core não está configurado ainda.
 ubuntu-release-upgrader-gtk depende de update-manager; porém:
  Pacote update-manager nNenhum relatório apport escrito pois MaxReports já foi atingido
        ão está configurado ainda.

dpkg: erro ao processar o pacote ubuntu-release-upgrader-gtk (--configure):
 problemas de dependência - deixando desconfigurado
Configurando aptitude-common (0.7.4-2ubuntu2) ...
Configurando libcwidget3v5:amd64 (0.5.17-4ubuntu2) ...
Configurando aptitude (0.7.4-2ubuntu2) ...
update-alternatives: a usar /usr/bin/aptitude-curses para disponibilizar /usr/bin/aptitude (aptitude) em modo auto
A processar 'triggers' para libc-bin (2.23-0ubuntu9) ...
A processar 'triggers' para menu (2.1.47ubuntu1) ...
Erros foram encontrados durante o processamento de:
 ubuntu-release-upgrader-core
 update-manager-core
 update-manager
 ubuntu-release-upgrader-gtk
E: Sub-process /usr/bin/dpkg returned an error code (1)

sudo apt-get clean

sudo aptitude update

Encontrado http://br.archive.ubuntu.com/ubuntu xenial InRelease
Encontrado http://br.archive.ubuntu.com/ubuntu xenial-updates InRelease         
Encontrado http://br.archive.ubuntu.com/ubuntu xenial-backports InRelease       
Ign http://dl.google.com/linux/chrome/deb stable InRelease                     
Encontrado http://security.ubuntu.com/ubuntu xenial-security InRelease         
Encontrado http://dl.google.com/linux/chrome/deb stable Release                 
Encontrado http://ppa.launchpad.net/george-edison55/webp/ubuntu xenial InRelease
Encontrado http://ppa.launchpad.net/i-nex-development-team/stable/ubuntu xenial InRelease
Encontrado http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu xenial InRelease

Continua....

Offline Edmor_t

  • Usuário Ubuntu
  • *
  • Mensagens: 11
    • Ver perfil
Re:Erro ao tentar instalar pacotes (atualizações)
« Resposta #7 Online: 18 de Agosto de 2017, 10:53 »
... continuando

sudo aptitude --full-resolver safe-upgrade
Os pacotes a seguir serão atualizados:       
  firefox firefox-locale-en firefox-locale-pt gnome-software
  gnome-software-common libdrm-amdgpu1 libdrm-intel1 libdrm-nouveau2
  libdrm-radeon1 libdrm2 libegl1-mesa libgbm1 libgl1-mesa-dri
  libgl1-mesa-glx libglapi-mesa libgles2-mesa libmspack0
  libwayland-egl1-mesa libxatracker2 logrotate mesa-vdpau-drivers snapd
  ubuntu-software xserver-xorg-video-amdgpu xserver-xorg-video-ati
  xserver-xorg-video-radeon
Os pacotes a seguir, parcialmente instalados, serão configurados:
  flashplugin-installer ubuntu-release-upgrader-core
  ubuntu-release-upgrader-gtk update-manager update-manager-core
  update-notifier-common
26 pacotes atualizados, 0 novos instalados, 0 a serem removidos e 0 não atualizados.
É preciso obter 68,3 MB de arquivos. Depois do desempacotamento, 4.363 kB serão usados.
Você deseja continuar? [Y/n/?] s

Mudanças de tamanho serão exibidas.

Os pacotes a seguir serão atualizados:
  firefox <+1.024 B>  firefox-locale-en  firefox-locale-pt 
  gnome-software <+49,2 kB>  gnome-software-common <+311 kB> 
  libdrm-amdgpu1  libdrm-intel1  libdrm-nouveau2  libdrm-radeon1  libdrm2 
  libegl1-mesa <+4.096 B>  libgbm1  libgl1-mesa-dri  libgl1-mesa-glx 
  libglapi-mesa  libgles2-mesa  libmspack0 <-24,6 kB> 
  libwayland-egl1-mesa  libxatracker2  logrotate  mesa-vdpau-drivers 
  snapd <+4.022 kB>  ubuntu-software  xserver-xorg-video-amdgpu 
  xserver-xorg-video-ati  xserver-xorg-video-radeon 
Os pacotes a seguir, parcialmente instalados, serão configurados:
  flashplugin-installer  ubuntu-release-upgrader-core 
  ubuntu-release-upgrader-gtk  update-manager  update-manager-core 
  update-notifier-common 
26 pacotes atualizados, 0 novos instalados, 0 a serem removidos e 0 não atualizados.
É preciso obter 68,3 MB de arquivos. Depois do desempacotamento, 4.363 kB serão usados.
Você deseja continuar? [Y/n/?] Y
Obter: 1 http://br.archive.ubuntu.com/ubuntu xenial-updates/main amd64 ubuntu-release-upgrader-core all 1:16.04.22 [29,5 kB]
Obter: 2 http://br.archive.ubuntu.com/ubuntu xenial-updates/main amd64 logrotate amd64 3.8.7-2ubuntu2.16.04.2 [37,7 kB]
Obter: 3 http://br.archive.ubuntu.com/ubuntu xenial-updates/main amd64 firefox amd64 55.0.2+build1-0ubuntu0.16.04.1 [41,1 MB]
Obter: 4 http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu xenial/main amd64 libdrm2 amd64 2.4.82+git1708170630.9d133d~gd~x [37,6 kB]
Obter: 5 http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu xenial/main amd64 libdrm-amdgpu1 amd64 2.4.82+git1708170630.9d133d~gd~x [27,8 kB]
Obter: 6 http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu xenial/main amd64 libdrm-intel1 amd64 2.4.82+git1708170630.9d133d~gd~x [68,3 kB]
Obter: 7 http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu xenial/main amd64 libdrm-nouveau2 amd64 2.4.82+git1708170630.9d133d~gd~x [24,6 kB]
Obter: 8 http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu xenial/main amd64 libdrm-radeon1 amd64 2.4.82+git1708170630.9d133d~gd~x [29,8 kB]
Obter: 9 http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu xenial/main amd64 libwayland-egl1-mesa amd64 17.3~git1708180730.c03eef~gd~x [46,7 kB]
Obter: 10 http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu xenial/main amd64 libegl1-mesa amd64 17.3~git1708180730.c03eef~gd~x [119 kB]
Obter: 11 http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu xenial/main amd64 libgbm1 amd64 17.3~git1708180730.c03eef~gd~x [64,8 kB]
Obter: 12 http://br.archive.ubuntu.com/ubuntu xenial-updates/main amd64 firefox-locale-en amd64 55.0.2+build1-0ubuntu0.16.04.1 [687 kB]
Obter: 13 http://br.archive.ubuntu.com/ubuntu xenial-updates/main amd64 firefox-locale-pt amd64 55.0.2+build1-0ubuntu0.16.04.1 [819 kB]
Obter: 14 http://br.archive.ubuntu.com/ubuntu xenial-updates/main amd64 ubuntu-software amd64 3.20.5-0ubuntu0.16.04.5 [11,6 kB]
Obter: 15 http://br.archive.ubuntu.com/ubuntu xenial-updates/main amd64 gnome-software amd64 3.20.5-0ubuntu0.16.04.5 [238 kB]
Obter: 16 http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu xenial/main amd64 libgl1-mesa-dri amd64 17.3~git1708180730.c03eef~gd~x [8.249 kB]
Obter: 17 http://br.archive.ubuntu.com/ubuntu xenial-updates/main amd64 gnome-software-common all 3.20.5-0ubuntu0.16.04.5 [2.520 kB]
Obter: 18 http://br.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libmspack0 amd64 0.5-1ubuntu0.16.04.1 [37,0 kB]
Obter: 19 http://br.archive.ubuntu.com/ubuntu xenial-updates/main amd64 snapd amd64 2.26.10 [10,1 MB]
Obter: 20 http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu xenial/main amd64 libgl1-mesa-glx amd64 17.3~git1708180730.c03eef~gd~x [165 kB]
Obter: 21 http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu xenial/main amd64 libgles2-mesa amd64 17.3~git1708180730.c03eef~gd~x [54,4 kB]
Obter: 22 http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu xenial/main amd64 libglapi-mesa amd64 17.3~git1708180730.c03eef~gd~x [63,1 kB]
Obter: 23 http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu xenial/main amd64 libxatracker2 amd64 17.3~git1708180730.c03eef~gd~x [1.155 kB]
Obter: 24 http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu xenial/main amd64 mesa-vdpau-drivers amd64 17.3~git1708180730.c03eef~gd~x [2.392 kB]
Obter: 25 http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu xenial/main amd64 xserver-xorg-video-amdgpu amd64 1.3.99+git1708161933.e15b23~gd~x [57,8 kB]
Obter: 26 http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu xenial/main amd64 xserver-xorg-video-radeon amd64 1:7.9.99+git1708171933.3e2477~gd~x [156 kB]
Obter: 27 http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu xenial/main amd64 xserver-xorg-video-ati amd64 1:7.9.99+git1708171933.3e2477~gd~x [17,4 kB]
Buscados 68,3 MB em 36s (1.851 kB/s)                                           
dpkg: aviso: falta ficheiro de lista de ficheiros 'ubuntu-release-upgrader-gtk'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'ubuntu-release-upgrader-core'; assumindo que o pacote não tem actualmente ficheiros instalados
(Lendo banco de dados ... 226400 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar .../logrotate_3.8.7-2ubuntu2.16.04.2_amd64.deb ...
A descompactar logrotate (3.8.7-2ubuntu2.16.04.2) sobre (3.8.7-2ubuntu2.16.04.1) ...
A preparar para desempacotar .../firefox_55.0.2+build1-0ubuntu0.16.04.1_amd64.deb ...
A descompactar firefox (55.0.2+build1-0ubuntu0.16.04.1) sobre (55.0.1+build2-0ubuntu0.16.04.2) ...
A preparar para desempacotar .../firefox-locale-en_55.0.2+build1-0ubuntu0.16.04.1_amd64.deb ...
A descompactar firefox-locale-en (55.0.2+build1-0ubuntu0.16.04.1) sobre (55.0.1+build2-0ubuntu0.16.04.2) ...
A preparar para desempacotar .../firefox-locale-pt_55.0.2+build1-0ubuntu0.16.04.1_amd64.deb ...
A descompactar firefox-locale-pt (55.0.2+build1-0ubuntu0.16.04.1) sobre (55.0.1+build2-0ubuntu0.16.04.2) ...
A preparar para desempacotar .../ubuntu-software_3.20.5-0ubuntu0.16.04.5_amd64.deb ...
A descompactar ubuntu-software (3.20.5-0ubuntu0.16.04.5) sobre (3.20.1+git20170509.0.8292905-0ubuntu1~xenial1) ...
A preparar para desempacotar .../gnome-software_3.20.5-0ubuntu0.16.04.5_amd64.deb ...
A descompactar gnome-software (3.20.5-0ubuntu0.16.04.5) sobre (3.20.1+git20170509.0.8292905-0ubuntu1~xenial1) ...
A preparar para desempacotar .../gnome-software-common_3.20.5-0ubuntu0.16.04.5_all.deb ...
A descompactar gnome-software-common (3.20.5-0ubuntu0.16.04.5) sobre (3.20.1+git20170509.0.8292905-0ubuntu1~xenial1) ...
A preparar para desempacotar .../libdrm2_2.4.82+git1708170630.9d133d~gd~x_amd64.deb ...
A descompactar libdrm2:amd64 (2.4.82+git1708170630.9d133d~gd~x) sobre (2.4.82+git1708151830.7ec689~gd~x) ...
A preparar para desempacotar .../libdrm-amdgpu1_2.4.82+git1708170630.9d133d~gd~x_amd64.deb ...
A descompactar libdrm-amdgpu1:amd64 (2.4.82+git1708170630.9d133d~gd~x) sobre (2.4.82+git1708151830.7ec689~gd~x) ...
A preparar para desempacotar .../libdrm-intel1_2.4.82+git1708170630.9d133d~gd~x_amd64.deb ...
A descompactar libdrm-intel1:amd64 (2.4.82+git1708170630.9d133d~gd~x) sobre (2.4.82+git1708151830.7ec689~gd~x) ...
A preparar para desempacotar .../libdrm-nouveau2_2.4.82+git1708170630.9d133d~gd~x_amd64.deb ...
A descompactar libdrm-nouveau2:amd64 (2.4.82+git1708170630.9d133d~gd~x) sobre (2.4.82+git1708151830.7ec689~gd~x) ...
A preparar para desempacotar .../libdrm-radeon1_2.4.82+git1708170630.9d133d~gd~x_amd64.deb ...
A descompactar libdrm-radeon1:amd64 (2.4.82+git1708170630.9d133d~gd~x) sobre (2.4.82+git1708151830.7ec689~gd~x) ...
A preparar para desempacotar .../libwayland-egl1-mesa_17.3~git1708180730.c03eef~gd~x_amd64.deb ...
A descompactar libwayland-egl1-mesa:amd64 (17.3~git1708180730.c03eef~gd~x) sobre (17.3~git1708151930.d65396~gd~x) ...
A preparar para desempacotar .../libegl1-mesa_17.3~git1708180730.c03eef~gd~x_amd64.deb ...
A descompactar libegl1-mesa:amd64 (17.3~git1708180730.c03eef~gd~x) sobre (17.3~git1708151930.d65396~gd~x) ...
A preparar para desempacotar .../libgbm1_17.3~git1708180730.c03eef~gd~x_amd64.deb ...
A descompactar libgbm1:amd64 (17.3~git1708180730.c03eef~gd~x) sobre (17.3~git1708151930.d65396~gd~x) ...
A preparar para desempacotar .../libgl1-mesa-dri_17.3~git1708180730.c03eef~gd~x_amd64.deb ...
A descompactar libgl1-mesa-dri:amd64 (17.3~git1708180730.c03eef~gd~x) sobre (17.3~git1708151930.d65396~gd~x) ...
A preparar para desempacotar .../libgl1-mesa-glx_17.3~git1708180730.c03eef~gd~x_amd64.deb ...
A descompactar libgl1-mesa-glx:amd64 (17.3~git1708180730.c03eef~gd~x) sobre (17.3~git1708151930.d65396~gd~x) ...
A preparar para desempacotar .../libgles2-mesa_17.3~git1708180730.c03eef~gd~x_amd64.deb ...
A descompactar libgles2-mesa:amd64 (17.3~git1708180730.c03eef~gd~x) sobre (17.3~git1708151930.d65396~gd~x) ...
A preparar para desempacotar .../libglapi-mesa_17.3~git1708180730.c03eef~gd~x_amd64.deb ...
A descompactar libglapi-mesa:amd64 (17.3~git1708180730.c03eef~gd~x) sobre (17.3~git1708151930.d65396~gd~x) ...
A preparar para desempacotar .../libmspack0_0.5-1ubuntu0.16.04.1_amd64.deb ...
A descompactar libmspack0:amd64 (0.5-1ubuntu0.16.04.1) sobre (0.5-1) ...
A preparar para desempacotar .../libxatracker2_17.3~git1708180730.c03eef~gd~x_amd64.deb ...
A descompactar libxatracker2:amd64 (17.3~git1708180730.c03eef~gd~x) sobre (17.3~git1708151930.d65396~gd~x) ...
A preparar para desempacotar .../mesa-vdpau-drivers_17.3~git1708180730.c03eef~gd~x_amd64.deb ...
A descompactar mesa-vdpau-drivers:amd64 (17.3~git1708180730.c03eef~gd~x) sobre (17.3~git1708151930.d65396~gd~x) ...
A preparar para desempacotar .../snapd_2.26.10_amd64.deb ...
Warning: Stopping snapd.service, but it can still be activated by:
  snapd.socket
A descompactar snapd (2.26.10) sobre (2.25) ...
A preparar para desempacotar .../xserver-xorg-video-amdgpu_1.3.99+git1708161933.e15b23~gd~x_amd64.deb ...
A descompactar xserver-xorg-video-amdgpu (1.3.99+git1708161933.e15b23~gd~x) sobre (1.3.99+git1708031933.9caa9d~gd~x) ...
A preparar para desempacotar .../xserver-xorg-video-radeon_1%3a7.9.99+git1708171933.3e2477~gd~x_amd64.deb ...
A descompactar xserver-xorg-video-radeon (1:7.9.99+git1708171933.3e2477~gd~x) sobre (1:7.9.99+git1708021933.5309bd~gd~x) ...
A preparar para desempacotar .../xserver-xorg-video-ati_1%3a7.9.99+git1708171933.3e2477~gd~x_amd64.deb ...
A descompactar xserver-xorg-video-ati (1:7.9.99+git1708171933.3e2477~gd~x) sobre (1:7.9.99+git1708021933.5309bd~gd~x) ...
A processar 'triggers' para man-db (2.7.5-1) ...
A processar 'triggers' para bamfdaemon (0.5.3~bzr0+16.04.20160824-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
A processar 'triggers' para gnome-menus (3.13.3-6ubuntu3.1) ...
A processar 'triggers' para desktop-file-utils (0.22-1ubuntu5.1) ...
A processar 'triggers' para mime-support (3.59ubuntu1) ...
A processar 'triggers' para hicolor-icon-theme (0.15-0ubuntu1) ...
A processar 'triggers' para libglib2.0-0:amd64 (2.48.2-0ubuntu1) ...
A processar 'triggers' para libc-bin (2.23-0ubuntu9) ...
dpkg: erro ao processar o pacote ubuntu-release-upgrader-core (--configure):
 O pacote está num mau estado de inconsistência; deve
 reinstala-lo antes de tentar configura-lo.
Nenhum relatório apport escrito pois a mensagem de erro indica que é um erro de seguimento de um erro anterior.
                               Nenhum relatório apport escrito pois a mensagem de erro indica que é um erro de seguimento de um erro anterior.
                                                              dpkg: problemas com dependências impedem a configuração de update-manager-core:
 update-manager-core depende de ubuntu-release-upgrader-core; porém:
  Pacote ubuntu-release-upgrader-core não está configurado ainda.

dpkg: erro ao processar o pacote update-manager-core (--configure):
 problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de update-manager:
 update-manager depende de update-manager-core (= 1:16.04.8); porém:
  Pacote update-manager-core não está configurado ainda.

dpkg: erro ao processar o pacote update-manager (--configure):
 problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de ubuntu-release-upgrader-gtk:
 ubuntu-release-upgrader-gtk depende de ubuntu-release-upgrader-core (= 1:16.04.22); porém:
  Pacote ubuntu-release-upgrader-core não está configurado ainda.
 ubuntu-release-upgrader-gtk depende de update-manager; porém:
  Pacote update-manager nNenhum relatório apport escrito pois MaxReports já foi atingido
        ão está configurado ainda.

dpkg: erro ao processar o pacote ubuntu-release-upgrader-gtk (--configure):
 problemas de dependência - deixando desconfigurado
Configurando logrotate (3.8.7-2ubuntu2.16.04.2) ...
Configurando firefox (55.0.2+build1-0ubuntu0.16.04.1) ...
Please restart all running instances of firefox, or you will experience problems.
Configurando firefox-locale-en (55.0.2+build1-0ubuntu0.16.04.1) ...
Configurando firefox-locale-pt (55.0.2+build1-0ubuntu0.16.04.1) ...
Configurando gnome-software-common (3.20.5-0ubuntu0.16.04.5) ...
Configurando gnome-software (3.20.5-0ubuntu0.16.04.5) ...
Configurando ubuntu-software (3.20.5-0ubuntu0.16.04.5) ...
Configurando libdrm2:amd64 (2.4.82+git1708170630.9d133d~gd~x) ...
Configurando libdrm-amdgpu1:amd64 (2.4.82+git1708170630.9d133d~gd~x) ...
Configurando libdrm-intel1:amd64 (2.4.82+git1708170630.9d133d~gd~x) ...
Configurando libdrm-nouveau2:amd64 (2.4.82+git1708170630.9d133d~gd~x) ...
Configurando libdrm-radeon1:amd64 (2.4.82+git1708170630.9d133d~gd~x) ...
Configurando libglapi-mesa:amd64 (17.3~git1708180730.c03eef~gd~x) ...
Configurando libgl1-mesa-dri:amd64 (17.3~git1708180730.c03eef~gd~x) ...
Configurando libgbm1:amd64 (17.3~git1708180730.c03eef~gd~x) ...
Configurando libegl1-mesa:amd64 (17.3~git1708180730.c03eef~gd~x) ...
Configurando libwayland-egl1-mesa:amd64 (17.3~git1708180730.c03eef~gd~x) ...
Configurando libgl1-mesa-glx:amd64 (17.3~git1708180730.c03eef~gd~x) ...
Configurando libgles2-mesa:amd64 (17.3~git1708180730.c03eef~gd~x) ...
Configurando libmspack0:amd64 (0.5-1ubuntu0.16.04.1) ...
Configurando libxatracker2:amd64 (17.3~git1708180730.c03eef~gd~x) ...
Configurando mesa-vdpau-drivers:amd64 (17.3~git1708180730.c03eef~gd~x) ...
Configurando snapd (2.26.10) ...
Instalando nova versão do arquivo de configuração /etc/apparmor.d/usr.lib.snapd.snap-confine.real ...
Configurando xserver-xorg-video-amdgpu (1.3.99+git1708161933.e15b23~gd~x) ...
Configurando xserver-xorg-video-radeon (1:7.9.99+git1708171933.3e2477~gd~x) ...
Configurando xserver-xorg-video-ati (1:7.9.99+git1708171933.3e2477~gd~x) ...
A processar 'triggers' para libc-bin (2.23-0ubuntu9) ...
Erros foram encontrados durante o processamento de:
 ubuntu-release-upgrader-core
 update-manager-core
 update-manager
 ubuntu-release-upgrader-gtk
E: Sub-process /usr/bin/dpkg returned an error code (1)
Falhou a execução da operação pedida no pacote.  A tentar recuperar:
dpkg: erro ao processar o pacote ubuntu-release-upgrader-core (--configure):
 O pacote está num mau estado de inconsistência; deve
 reinstala-lo antes de tentar configura-lo.
dpkg: problemas com dependências impedem a configuração de ubuntu-release-upgrader-gtk:
 ubuntu-release-upgrader-gtk depende de ubuntu-release-upgrader-core (= 1:16.04.22); porém:
  Pacote ubuntu-release-upgrader-core não está configurado ainda.

dpkg: erro ao processar o pacote ubuntu-release-upgrader-gtk (--configure):
 problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de update-manager-core:
 update-manager-core depende de ubuntu-release-upgrader-core; porém:
  Pacote ubuntu-release-upgrader-core não está configurado ainda.

dpkg: erro ao processar o pacote update-manager-core (--configure):
 problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem o processamento de triggers para update-notifier-common:
 update-notifier-common depende de update-manager-core (>= 1:16.04.6); porém:
  Pacote update-manager-core não está configurado ainda.

dpkg: erro ao processar o pacote update-notifier-common (--configure):
 problemas com dependências - a deixar triggers por processar
dpkg: problemas com dependências impedem a configuração de update-manager:
 update-manager depende de update-manager-core (= 1:16.04.8); porém:
  Pacote update-manager-core não está configurado ainda.
 update-manager depende de ubuntu-release-upgrader-gtk; porém:
  Pacote ubuntu-release-upgrader-gtk não está configurado ainda.

dpkg: erro ao processar o pacote update-manager (--configure):
 problemas de dependência - deixando desconfigurado
Erros foram encontrados durante o processamento de:
 ubuntu-release-upgrader-core
 ubuntu-release-upgrader-gtk
 update-manager-core
 update-notifier-common
 update-manager
                                             
Estado atual: 0 (-26) upgradable.

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.438
    • Ver perfil
Re:Erro ao tentar instalar pacotes (atualizações)
« Resposta #8 Online: 18 de Agosto de 2017, 20:46 »
Edmor_t, a coisa tá complicada!

Além de não termos resolvido o problema, você não faz e nem responde tudo o que eu te peço pra fazer.

Não trocou o source.list e não disse nada do synaptic!

Eu tentei resolver sem remover os pacotes problemáticos, porque sei que ao remover esses pacotes, ele vai remover outros pacotes importantes do sistema e se estes pacotes não forem reinstalados novamente, seu sistema pode não funcionar! Daí você não faz tudo o que eu coloco pra fazer, então como vai ficar?

Você se garante sozinho?  Se decidir fazer os passos seguintes, faça cópia do seus dados antes, e prepara-se para uma possível reinstalação do sistema.

Por sua conta e risco!


No terminal:

apt-get purge ubuntu-release-upgrader-core


Com isso ele vai remover:

ubuntu-release-upgrader-core
ubuntu-release-upgrader-gtk
update-manager
update-manager-core
update-notifier
update-notifier-common


Além de outros pacotes importantes.  Se ele remover tudo sem erros, anote o que foi removido e instale-os novamente.

apt-get install  ubuntu-release-upgrader-core ubuntu-release-upgrader-gtk update-manager update-manager-core update-notifier update-notifier-common

Mais os outros pacotes que ele removeu!

Espero que isso resolva!

Boa sorte!
« Última modificação: 18 de Agosto de 2017, 20:49 por galactus »
* Linux Mint 18 Mate 64bits / Windows 10 64bits Casa! * CentOS 7 64bits Servidor de arquivos em modo texto - Casa * MacOS Sierra  - Mac Mini servidor multimidia - Casa * DELL Inspiron 14R + Ubuntu Mate 17.04 64bits.

Offline Edmor_t

  • Usuário Ubuntu
  • *
  • Mensagens: 11
    • Ver perfil
Re:Erro ao tentar instalar pacotes (atualizações)
« Resposta #9 Online: 18 de Agosto de 2017, 22:39 »
Desculpe. Eu tentei isso:

sudo sed -i 's/br.archive.ubuntu.com/us.archive.ubuntu.com/g' /etc/apt/sources.list

Mas quando dei o comando:

apt-get update

Ficou parado e sem resposta do servidor. Dei Ctrl+C para sair e voltei para BR.

Ou é como esta neste post:

https://askubuntu.com/questions/682532/ubuntu-repository-change

Qual a melhor fonte?

Eu sei um pouco de linha de comando, mas não estou me safando desta situação. Por isso eu estou aqui. Tenha um pouco de paciência e acho que nos entenderemos.

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.438
    • Ver perfil
Re:Erro ao tentar instalar pacotes (atualizações)
« Resposta #10 Online: 18 de Agosto de 2017, 23:39 »
Vamos lá então!

Entre no Ubuntu Software Center, Editar > Fonte de programas (Software Sources) > Baixar de (Download from)   e mude para Main Server !
Verifique se todos os repositórios desta aba estão marcados: Main, Universe, Restricted, Multiverse. Verifique também na aba "updates" se os repositórios estão marcados!

Ele vai querer atualizar a lista de repositórios! Atualize!


Volte ao terminal e execute os três comandos na ordem, não importa o erro, execute os três comandos na ordem!!!


1) sudo apt-get clean

2) sudo dpkg --configure -a

3) sudo apt-get install -f


Copie e cole a saída dos dois últimos dois comandos aqui pra gente ver!


* Linux Mint 18 Mate 64bits / Windows 10 64bits Casa! * CentOS 7 64bits Servidor de arquivos em modo texto - Casa * MacOS Sierra  - Mac Mini servidor multimidia - Casa * DELL Inspiron 14R + Ubuntu Mate 17.04 64bits.

Offline Edmor_t

  • Usuário Ubuntu
  • *
  • Mensagens: 11
    • Ver perfil
Re:Erro ao tentar instalar pacotes (atualizações)
« Resposta #11 Online: 21 de Agosto de 2017, 12:23 »
Ao tentar mudar para o servidor principal, deu isso ao fechar (recarregar listas):

Falha ao carregar a lista de pacotes
Este é um problema grave. Tente novamente mais tarde. Se o problema persistir, por favor relate um erro para os desenvolvedores.
Detalhes>
E:The package ubuntu-release-upgrader-core needs to be reinstalled, but I can't find an archive for it.

Não vai mesmo. Tem que reinstalar o sistema?

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.438
    • Ver perfil
Re:Erro ao tentar instalar pacotes (atualizações)
« Resposta #12 Online: 21 de Agosto de 2017, 13:12 »
No seu caso acho mais fácil reinstalar o sistema do zero mesmo!
* Linux Mint 18 Mate 64bits / Windows 10 64bits Casa! * CentOS 7 64bits Servidor de arquivos em modo texto - Casa * MacOS Sierra  - Mac Mini servidor multimidia - Casa * DELL Inspiron 14R + Ubuntu Mate 17.04 64bits.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.086
    • Ver perfil
Re:Erro ao tentar instalar pacotes (atualizações)
« Resposta #13 Online: 21 de Agosto de 2017, 13:33 »
Não vai mesmo. Tem que reinstalar o sistema?

Já que não está indo de maneira alguma, perdido, perdido e meio, então antes da solução nuclear, que é a reinstalação do sistema, dois centavos de contribuição ao tópico: tanto o apt como o aptitude são apenas front-end do dpkg, que é quem faz o trabalho de fato, então como a situação está complicada, talvez seja melhor manipular diretamente o dpkg e fazer ele substituir os pacotes mencionados no post #8.

A ideia é baixar manualmente tais pacotes, usando por exemplo o wget, e usar diretamente o dpkg para sobrescrever o que quer que já exista deles, ou seja, não remove antes, sobrescreve mesmo.

Evidentemente não é habitual fazer dessa forma e geralmente tampouco recomendável, porque subverte todo o sistema de gerenciamento de pacotes, mas como parece não estar andando pra lado algum, então pode ser um caminho.

Algo nessa linha:

Mover-se para um diretório onde não haja nenhum outro .deb para não gerar confusão adicional.

Código: [Selecionar]
mkdir ~/Downloads/prov
Código: [Selecionar]
cd ~/Downloads/prov
Baixar manual e diretamente os pacotes supostamente envolvidos.

Código: [Selecionar]
wget -c http://mirrors.kernel.org/ubuntu/pool/main/u/ubuntu-release-upgrader/ubuntu-release-upgrader-core_16.04.22_all.deb

wget -c http://mirrors.kernel.org/ubuntu/pool/main/u/ubuntu-release-upgrader/ubuntu-release-upgrader-gtk_16.04.22_all.deb

wget -c http://mirrors.kernel.org/ubuntu/pool/main/u/update-manager/update-manager_16.04.8_all.deb

wget -c http://mirrors.kernel.org/ubuntu/pool/main/u/update-manager/update-manager-core_16.04.8_all.deb

wget -c http://mirrors.kernel.org/ubuntu/pool/main/u/update-notifier/update-notifier_3.168.4_amd64.deb

wget -c http://mirrors.kernel.org/ubuntu/pool/main/u/update-notifier/update-notifier-common_3.168_all.deb

Uma vez baixado, experimente inicialmente instalar apenas o que mais diretamente está apontando problema e o decorrente dele:

Código: [Selecionar]
sudo dpkg -i --force-overwrite --force-configure-any ubuntu-release-upgrader-core_16.04.22_all.deb
Código: [Selecionar]
sudo dpkg -i --force-overwrite --force-configure-any update-manager-core_16.04.8_all.deb
Código: [Selecionar]
sudo dpkg -i --force-overwrite --force-configure-any update-manager_16.04.8_all.deb
Como de praxe execute:

Código: [Selecionar]
sudo apt update
Código: [Selecionar]
sudo apt upgrade
Os comandos acima devem terminar sem quaisquer erros, caso contrário prossiga reinstalando os demais:

Se persistir alguma mensagem de erro, então faça o mesmo com os demais pacotes baixados, prossiga instalando os demais com overwrite:

Código: [Selecionar]
sudo dpkg -i --force-overwrite --force-configure-any ubuntu-release-upgrader-gtk_16.04.22_all.deb
Código: [Selecionar]
sudo dpkg -i --force-overwrite --force-configure-any update-notifier_3.168.4_amd64.deb
Código: [Selecionar]
sudo dpkg -i --force-overwrite --force-configure-any update-notifier-common_3.168_all.deb.
Note o duplo hífen antes das opções.

« Última modificação: 21 de Agosto de 2017, 13:51 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Edmor_t

  • Usuário Ubuntu
  • *
  • Mensagens: 11
    • Ver perfil
Re:Erro ao tentar instalar pacotes (atualizações)
« Resposta #14 Online: 21 de Agosto de 2017, 18:31 »
Baixei os pacotes .deb.
Instalei usando os três primeiros comandos. Sem erros.
Executei o update e upgrade sem erros também.
Resolvido?

Fiz o procedimento e mudei do servidor principal para servidor brasil e deu erro ao recarregar listas (uma penca).

Mudei para o principal de novo e ao recarregar foi de boa.

Temos Ruindows, Ruindroid e agora Ruinbuntu. Estamos ferrados!

Vou experimentar o Debian 9 e ver se me dou melhor.

Por enquanto as instalações automáticas estão off-line, só vai atualizar por linha de comando e "quando eu quiser".