Autor Tópico: Configuração manual de teclados com padrão internacional (para Notebooks e PCs)  (Lida 195580 vezes)

Offline alexmatos

  • Usuário Ubuntu
  • *
  • Mensagens: 792
  • Arch Linux / Ubuntu 7.04
    • Ver perfil
Re: Configuração manual de teclados com padrão internacional (para Notebooks e P
« Resposta #30 Online: 31 de Janeiro de 2008, 00:14 »
Alex,

cara, não funcionou! Ou eu to fazendo alguma coisa mto errado ou esse negócio tá mais difícil do que parece.

[]'s

Faz o seguinte, coloca aí o conteúdo do seu arquivo Xmodmap_TESTE e do .Xmodmap pra eu dar uma olhada.

Offline _sic_

  • Usuário Ubuntu
  • *
  • Mensagens: 17
    • Ver perfil
Re: Configuração manual de teclados com padrão internacional (para Notebooks e P
« Resposta #31 Online: 05 de Fevereiro de 2008, 09:47 »
Cara,

era besteira minha mesmo, no arquivo .Xmodmap eu fiz o famoso erro de crtl+c e ctrl+v coloquei xmodmap -e 'keycode 51 = backslash bar' ao invés de deixar somente keycode 51 = backslash bar :-(.

Agora está funcionando, quando entro no Gnome a tecla já está funcionando sem eu ter que executar o script.

Agora outra dúvida, isso só vai funcionar quando eu logar no Gnome? Caso eu escolha ir para o terminal de segurança a tecla não irá funcionar? Ou vai?

Obrigado pela ajuda epeço desculpas pelha minha falta de atenção!

[]'s

Offline alexmatos

  • Usuário Ubuntu
  • *
  • Mensagens: 792
  • Arch Linux / Ubuntu 7.04
    • Ver perfil
Re: Configuração manual de teclados com padrão internacional (para Notebooks e P
« Resposta #32 Online: 07 de Fevereiro de 2008, 10:59 »
Cara,

era besteira minha mesmo, no arquivo .Xmodmap eu fiz o famoso erro de crtl+c e ctrl+v coloquei xmodmap -e 'keycode 51 = backslash bar' ao invés de deixar somente keycode 51 = backslash bar :-(.

Agora está funcionando, quando entro no Gnome a tecla já está funcionando sem eu ter que executar o script.

Agora outra dúvida, isso só vai funcionar quando eu logar no Gnome? Caso eu escolha ir para o terminal de segurança a tecla não irá funcionar? Ou vai?

Obrigado pela ajuda epeço desculpas pelha minha falta de atenção!

[]'s

Cara, isso vai funcionar só no X, a interface gráfica (que provavelmente é o único lugar em que a tecla não estava funcionando). Teste a configuração do seu teclado no modo texto, acessando via Ctrl+Alt+F1 (lembrando que para voltar para a interface gráfica você deve apertar Alt+F7).

Offline gi2k15

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Re: Configuração manual de teclados com padrão internacional (para Notebooks e P
« Resposta #33 Online: 08 de Fevereiro de 2008, 14:43 »
Caso o seu problema seja somente o cedilha que não está aparecendo quando você digita acento agudo + "c" ao utilizar um teclado internacional, alterando o arquivo immodules resolve o problema. Porém, na versão 7.10, este arquivo mudou de lugar. Faça agora da seguinte maneira:

1. Abra o terminal e digite:

Código: [Selecionar]
sudo gedit /usr/lib/gtk-2.0/2.10.0/immodule-files.d/libgtk2.0-0.immodules
2. Localize a seguinte linha:

Código: [Selecionar]
"cedilla" "Cedilla" "gtk20" "/usr/share/locale" "az:ca:co:fr:gv:oc:pt:sq:tr:wa"
3. Adicione ":en" ao final dela, desta forma:

Código: [Selecionar]
"cedilla" "Cedilla" "gtk20" "/usr/share/locale" "az:ca:co:fr:gv:oc:pt:sq:tr:wa:en"
4. Reinicie o X

Funcionou perfeitamente aqui.


Offline _sic_

  • Usuário Ubuntu
  • *
  • Mensagens: 17
    • Ver perfil
Re: Configuração manual de teclados com padrão internacional (para Notebooks e P
« Resposta #34 Online: 09 de Fevereiro de 2008, 13:25 »
Alex,

fiz o que falou de alternar para o modo texto e lá a tecla não funciona não, só no X dentro do X está funcionando. Pelo menos no X está tudo ok, ainda bem.

Valeu

Offline Joaozava

  • Usuário Ubuntu
  • *
  • Mensagens: 53
    • Ver perfil
Olá,

Só não consegui fazer funcionar o ç
Todas as outras teclas estão funcionando, meu teclado é padrão americano... olha como fica quando tendo fazer o ç -> ć

Mesmo alterando o arquivo  /etc/gtk-2.0/gtk.immodules
na linha
"cedilla" "Cedilla" "gtk+" "/usr/share/locale" "az:ca:co:fr:gv:oc:pt:sq:tr:wa"
para
"cedilla" "Cedilla" "gtk+" "/usr/share/locale" "az:ca:co:fr:gv:oc:pt:sq:tr:wa:en"

Conforme falaram, não deu certo!

Obrigado.
 
« Última modificação: 03 de Maio de 2008, 12:05 por Joaozava »

Offline joseff

  • Usuário Ubuntu
  • *
  • Mensagens: 173
  • O sabio é aquele que sabe que não sabe nada..
    • Ver perfil
    • tisolucoes
Pra quem tem o notebook Gateway T-1628 que tem o teclado sem Ç ou seja teclado americano(acho), é só trocar(colocar) “ "us_intl" no xorg.conf igual a dica do amigo abaixo,  ;Dnão necessita alterar os outros dados só o xkblayout para "us_intl".

Olá, consegui resolver o meu problema da seuinte forma:
no xorg.conf configurei o xkblayout para "us_intl".
Código:
Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xfree86"
   Option      "XkbModel"   "pc104"
   Option      "XkbLayout"   "us_intl"
EndSection
« Última modificação: 06 de Maio de 2008, 18:58 por joseff »

Offline luosuporte1

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Pessoal
Tenho um notebook da Lenovo 3000 c100.
É uma tecla apenas não funciona, esse problema tinha quando usava o windows e para resolver o suporte da LENOVO me mandou um arquivo de de extenção .reg para adiconar ao registro fazendo a tecla funcionar.

No linux usei o comando xev no terminal e apertei a tecla "/" é "?" (tecla que não funciona)
Retornou a seguinte mensagem

KeyRelease event, serial 31, synthetic NO, window 0x3600001,
    root 0x55, subw 0x0, time 62092596, (100,458), root:(776,510),
    state 0x4, keycode 109 (keysym 0xffe4, Control_R), same_screen YES,
    XLookupString gives 0 bytes:
    XFilterEvent returns: False


Ou seja o Linux está identificando como tecla Control... já vi alguns fórum explicando como mapear usando o xmodMap mais até agora não consegui nada.

Obrigado!!! :-[

Offline tuta_rs

  • Usuário Ubuntu
  • *
  • Mensagens: 14
    • Ver perfil
Re: Configuração manual de teclados com padrão internacional (para Notebooks e PCs)
« Resposta #38 Online: 28 de Outubro de 2008, 19:04 »
Pessoal, tenho um teclado A4-Tech KBS-720.

TODAS as teclas funcionam, menos uma tecla que fica a esquerda do Z e que contém os caracteres barra inclinada e barra na posição vertical.

E também não funciona a tecla ao lado do ;: que contém a barra invertidoa e o ponto de interrogação.

Já fiz de tudo e não rola...

ps: estou plugando meu teclado via um adaptador USB, apesar dele ser PS2.

Offline Darcamo

  • Usuário Ubuntu
  • *
  • Mensagens: 1.315
    • Ver perfil
Re: Configuração manual de teclados com padrão internacional (para Notebooks e PCs)
« Resposta #39 Online: 01 de Novembro de 2008, 12:45 »
O teclado do meu notebook foi corretamente reconhecido pelo ubuntu.
No entanto, ele possui o teclado numérico e as únicas teclas Home, End PgUp, etc. são as do teclado numérico.

O keysym delas é diferente (KP_Home, KP_End, etc). Isso não é problema em alguns programas mas em outros sim. Não posso, por exemplo, usar o atalho Ctrl+PgUp para mudar a aba no gnome-terminal (já no firefox funciona).

A solução então é mudar KP_Home para Home (e demais teclas) com o comando
xmodmap -e "keysym KP_Home = Home"
Funciona que é uma beleza, mas a tecla deixa de respeitar o numlock. Se eu ativar o numlock e teclar o 7 "vai sair Home". O que eu não mexi continua respeitando o numlock como mudar entre 8 e a seta para cima de acordo com o numlock.

Como então fazer essa mudança sem ficar sem os números do teclado numérico?

Offline alexmatos

  • Usuário Ubuntu
  • *
  • Mensagens: 792
  • Arch Linux / Ubuntu 7.04
    • Ver perfil
Re: Configuração manual de teclados com padrão internacional (para Notebooks e PCs)
« Resposta #40 Online: 02 de Novembro de 2008, 21:15 »
O teclado do meu notebook foi corretamente reconhecido pelo ubuntu.
No entanto, ele possui o teclado numérico e as únicas teclas Home, End PgUp, etc. são as do teclado numérico.

O keysym delas é diferente (KP_Home, KP_End, etc). Isso não é problema em alguns programas mas em outros sim. Não posso, por exemplo, usar o atalho Ctrl+PgUp para mudar a aba no gnome-terminal (já no firefox funciona).

A solução então é mudar KP_Home para Home (e demais teclas) com o comando
xmodmap -e "keysym KP_Home = Home"
Funciona que é uma beleza, mas a tecla deixa de respeitar o numlock. Se eu ativar o numlock e teclar o 7 "vai sair Home". O que eu não mexi continua respeitando o numlock como mudar entre 8 e a seta para cima de acordo com o numlock.

Como então fazer essa mudança sem ficar sem os números do teclado numérico?

Darcamo, estou dando um tiro no escuro, mas acho que se você tentar remapear a combinação de teclas "NumLock + 7" pra "7" ele vá funcionar. Se não der certo, tenta arrumar uma foto do seu teclado pra gente entender melhor a disposição das teclas, e aí a gente pensa em outra solução.

Offline Darcamo

  • Usuário Ubuntu
  • *
  • Mensagens: 1.315
    • Ver perfil
Re: Configuração manual de teclados com padrão internacional (para Notebooks e PCs)
« Resposta #41 Online: 02 de Novembro de 2008, 23:41 »
O problema é que o keycode é o mesmo com ou sem o numlock.
O que muda é o state (o state também muda quando se pressiona shift, ctrl, etc.).

Ou seja, o Numlock parece ser uma tecla modificadora da mesma forma que o shift, ctrl e outras, só que com a diferença que o Numlock precisa ser "ativado" ao invés de "pressionado" como as demais..
Tenho que saber então como mapear o 7/Home com e sem a modificação do Numlock semelhantemente ao que se faz com o shift.

O notebook é um asus M70.

Offline Dimito

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Re: Configuração manual de teclados com padrão internacional (para Notebooks e PCs)
« Resposta #42 Online: 17 de Novembro de 2008, 23:25 »
Olá carissimos!
Estou tendo problema com apenas uma tecla!
é o til (~)
N~ao consigo fazer ele ficar em cima das letrinhas.....(como puderam perceber nesta frase)
p~ao; n~ao, aç~oes;.....
Ele sempre sai antes!
Alguém saberia o que eu devo fazer????
Tenho um Acer, Aspire 5570-2405

Offline Darcamo

  • Usuário Ubuntu
  • *
  • Mensagens: 1.315
    • Ver perfil
Re: Configuração manual de teclados com padrão internacional (para Notebooks e PCs)
« Resposta #43 Online: 18 de Novembro de 2008, 01:32 »
Sistema>Preferências>Teclado
Escolha o modelo de teclado e adicione um layout com dead keys.

Basta clicar em adicionar layout, escolher pelo idioma e selecionar inglês. Em "variantes" escolha "EUA Internacional (com teclas acentuáveis)".
É o que uso aqui.

Obiviamente isso é se seu teclado tiver o layout americano como o meu. O que importa mesmo é "variantes". Escolha algo como "internacional", "com teclas acentuáveis", "with deadkeys", ou algo assim.

Offline reynaldohortensi

  • Usuário Ubuntu
  • *
  • Mensagens: 41
    • Ver perfil
Re: Configuração manual de teclados com padrão internacional (para Notebooks e PCs)
« Resposta #44 Online: 10 de Dezembro de 2008, 22:03 »
Oi pessoal,
eu tenho um vostro 1000 da dell com o ubuntu 8.10 e o teclado numérico funciona no modo texto mas no modo gráfico é uma confusão.
Quando eu executo o xev aparece uma coisa, mas quando eu digito no terminal do gnome aparece outra e algumas das teclas tem efeito de botões do mouse.
O seguinte comando não tem efeito algum sobre algumas teclas: xmodmap -e 'keycode X = Y'
O que eu faço?
abraço
Reynaldo
« Última modificação: 10 de Dezembro de 2008, 22:05 por reynaldohortensi »