Fórum Ubuntu Linux - PT
17 de Abril de 2014, 06:34 *
Olá, Visitante. Faça o login ou registre-se.
Perdeu o seu e-mail de ativação?

Login com nome de usuário, senha e duração da sessão
Notícias: Atualização no plugin de busca para Firefox e Internet Explorer.
 
   Home   Ajuda Regras Pesquisa Login Registre-se  
Anúncios
Páginas: 1 2 [3] 4 5   Ir para o fundo
  Imprimir  
Autor Tópico: America"s Army - Instalando America"s Army no Ubuntu 64bits  (Lida 19311 vezes)
rmsraph
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 3


Ver Perfil
« Responder #30 em: 28 de Dezembro de 2010, 22:32 »

na terceira postagem eu já estava jogando com som...

Muito obrigado pela ajuda pessoal...

Até mais
Registrado
rdeprera
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 9



Ver Perfil WWW
« Responder #31 em: 27 de Fevereiro de 2011, 08:42 »

Bom, eu resolvi este mesmo problema de outra forma.

Como o a 2.5 utiliza bibliotecas que não são mais nativas do ubuntu >10.10, o jeito foi executar o jogo utilizando o padsp
No caso fica <padsp> <link simbolico do jogo>

Ex.:
Código:
padsp /usr/local/games/armyops/armyops
ou
padsp /diretório que você pediu para instalar o jogo/executável do jogo

Se ainda não funcionar, mate os serviço(s) de audio:
Código:
lsof /dev/snd/*
Código:
sudo kill -9 PID do(s) serviço(s)

Exemplo:
Código:
lsof /dev/snd/*
COMMAND     PID     USER   FD   TYPE DEVICE SIZE/OFF NODE NAME
pulseaudi 17665 reinaldo   29u   CHR  116,8      0t0 7156 /dev/snd/controlC0
pulseaudi 17665 reinaldo   36u   CHR  116,8      0t0 7156 /dev/snd/controlC0

Código:
sudo kill -9 17665

...e execute o procedimento novamente:


« Última modificação: 27 de Fevereiro de 2011, 11:23 por rdeprera » Registrado

Distr.  : Ubuntu 10.10 x64
ASUS M4A88TD-M ATHLON II X4 635
platao
Equipe Ubuntu
Usuário Ubuntu
*****
Deslogado Deslogado

Mensagens: 4.445



Ver Perfil
« Responder #32 em: 27 de Fevereiro de 2011, 09:55 »

Ola otima dica, nao tentei dessa forma ainda mas nao vai faltar oportunidade!!! atualmente instalo dessa forma no ubuntu 32 e 64 bits;

Americas Army Assist2.5--->http://ubuntuforum-br.org/index.php/topic,67847.0.html

E bem pratico e simples ele automaticamente ja instala o jogo na sua home se desejar, baixa o game e as bibliotecas que estao faltando e ainda pode escolher o servidor de audio entre outras.
« Última modificação: 27 de Fevereiro de 2011, 09:57 por platao » Registrado

Gabr1990
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 83


@Gabr1990


Ver Perfil WWW
« Responder #33 em: 28 de Fevereiro de 2011, 13:22 »

Bom, eu resolvi este mesmo problema de outra forma.

Como o a 2.5 utiliza bibliotecas que não são mais nativas do ubuntu >10.10, o jeito foi executar o jogo utilizando o padsp
No caso fica <padsp> <link simbolico do jogo>

Ex.:
Código:
padsp /usr/local/games/armyops/armyops
ou
padsp /diretório que você pediu para instalar o jogo/executável do jogo

Se ainda não funcionar, mate os serviço(s) de audio:
Código:
lsof /dev/snd/*
Código:
sudo kill -9 PID do(s) serviço(s)

Exemplo:
Código:
lsof /dev/snd/*
COMMAND     PID     USER   FD   TYPE DEVICE SIZE/OFF NODE NAME
pulseaudi 17665 reinaldo   29u   CHR  116,8      0t0 7156 /dev/snd/controlC0
pulseaudi 17665 reinaldo   36u   CHR  116,8      0t0 7156 /dev/snd/controlC0

Código:
sudo kill -9 17665

...e execute o procedimento novamente:




Rapaz, eu instalei e tive o problema de som e tal, aí a sua primeira dica funcionou beleza!! O som ficou com a qualidade mais ou menos, mas está funcionando legal, muito obrigado mesmo!!

 Sem Graça
Registrado

Conteúdo interessante e bom humor: http://menteabduzida.net/ Contente
Gabr1990
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 83


@Gabr1990


Ver Perfil WWW
« Responder #34 em: 28 de Fevereiro de 2011, 23:22 »

Alguém sabe onde encontro pach pra versões mais utilizadas, tais como 2.8.x etc? No site original só tem pach para windows .... pelo menos para essas versões...
Registrado

Conteúdo interessante e bom humor: http://menteabduzida.net/ Contente
platao
Equipe Ubuntu
Usuário Ubuntu
*****
Deslogado Deslogado

Mensagens: 4.445



Ver Perfil
« Responder #35 em: 01 de Março de 2011, 14:53 »

Ola, a ultima versao para Linux foi a 2.5 e acho que para Mac tbm.
Registrado

Gabr1990
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 83


@Gabr1990


Ver Perfil WWW
« Responder #36 em: 02 de Março de 2011, 16:31 »

Tenso, o ruim é que essa versão só tem uns 6 servers online, e o que sempre tem gente diz que eu não tenho honor suficiente para jogar!

Será que matando aqueles treinamentos depois dos básicos ganha honor?  Hein?
Registrado

Conteúdo interessante e bom humor: http://menteabduzida.net/ Contente
platao
Equipe Ubuntu
Usuário Ubuntu
*****
Deslogado Deslogado

Mensagens: 4.445



Ver Perfil
« Responder #37 em: 02 de Março de 2011, 17:55 »

Ola sao poucos servers mesmo, mas o pessoal e frequente, viciado mesmo e varios usam linux, Vc sempre começa com 10 de honor e geralmente e suficiemte para jogar na maiora dos servidores.
Registrado

rdeprera
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 9



Ver Perfil WWW
« Responder #38 em: 03 de Março de 2011, 04:17 »

Bom, o problema do som o luiz fernando descobriu que ele precisava instalar o oss e eu acabei utilizando a pulseaudio, como ja fico claro neste tópico. Ou seja, o problema do som já está resolvido.

Agora eu pergunto a vocês: Alguem ai está conseguindo jogar online? Porque eu completei os treinamentos mas estou tento problemas com o punkbuster.  O meu cliente pb não consegue atualizar automaticamente, e de forma manual também não consegui pois o script deles está com vários erros de codificação de caracter que não da nem pra ler os erros, e o pbsetup.run esta com problema na sua GUI pois só apresenta 2 opções no input <games> (só aparece battlefield e e battlefild 2142).

Já até abri um ticket no suporte deles, que alias foi respondido rápido mas de maneira incorreta (me mandaram fazer a atualização manul com o pbsetup do windows Triste ) ....enfim segue o erro retornado no console do jogo quando o pb tenta atualizar automaticamente:

PB client in distress - Cannot authenticate with PB server

Ai após tentar e retornar o erro supra-citado várias vezes o pb retorna o erro (http header de redirecionamento temporário) a seguir, e me kika:
302 not found

Alguém ai consegue joga a 2.5 online?
Se conseguir, seria legal alguém postar link pra download do diretorio /usr/local/games/armyops/System/pb pra mim e pra quem mais nao consegui atualizar o jogo. Porque ao que tudo indica, pela menos na arquitetura 64 bits os métodos manuais de atualização do PB não funcionarão
Registrado

Distr.  : Ubuntu 10.10 x64
ASUS M4A88TD-M ATHLON II X4 635
Gabr1990
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 83


@Gabr1990


Ver Perfil WWW
« Responder #39 em: 03 de Março de 2011, 08:15 »

Bom, o problema do som o luiz fernando descobriu que ele precisava instalar o oss e eu acabei utilizando a pulseaudio, como ja fico claro neste tópico. Ou seja, o problema do som já está resolvido.

Agora eu pergunto a vocês: Alguem ai está conseguindo jogar online? Porque eu completei os treinamentos mas estou tento problemas com o punkbuster.  O meu cliente pb não consegue atualizar automaticamente, e de forma manual também não consegui pois o script deles está com vários erros de codificação de caracter que não da nem pra ler os erros, e o pbsetup.run esta com problema na sua GUI pois só apresenta 2 opções no input <games> (só aparece battlefield e e battlefild 2142).

Já até abri um ticket no suporte deles, que alias foi respondido rápido mas de maneira incorreta (me mandaram fazer a atualização manul com o pbsetup do windows Triste ) ....enfim segue o erro retornado no console do jogo quando o pb tenta atualizar automaticamente:

PB client in distress - Cannot authenticate with PB server

Ai após tentar e retornar o erro supra-citado várias vezes o pb retorna o erro (http header de redirecionamento temporário) a seguir, e me kika:
302 not found

Alguém ai consegue joga a 2.5 online?
Se conseguir, seria legal alguém postar link pra download do diretorio /usr/local/games/armyops/System/pb pra mim e pra quem mais nao consegui atualizar o jogo. Porque ao que tudo indica, pela menos na arquitetura 64 bits os métodos manuais de atualização do PB não funcionarão

Então, tenho a solução para você, pois passei pelo mesmo problema! Aí eu descobri um "assistente" para o America's Army 2.5, este aqui http://aa25assist.sourceforge.net/ ele baixa as atualizações que forem precisas, e então você precisa abrir o jogo através dele, que irá funcionar!

Porém direto pelo jogo ainda não consigo entrar em função do PunkBuster, mas pelo assistente o Punkbuster funciona 100%.
Registrado

Conteúdo interessante e bom humor: http://menteabduzida.net/ Contente
platao
Equipe Ubuntu
Usuário Ubuntu
*****
Deslogado Deslogado

Mensagens: 4.445



Ver Perfil
« Responder #40 em: 03 de Março de 2011, 10:36 »

Ola, agregando ao que ja foi reportado pelo Gabr1990, vc faz o download do assistente do Punkbuster aqui http://www.evenbalance.com/index.php?page=pbsetup.php agora o "pulo do gato".........vc nao pega a versao 64bits do instalador, vc pega a versao 32bits http://websec.evenbalance.com/downloader/download.php?file=4 que vai listar pra vc o Americas Army sem problema e atualizar mas dependendo como vc instalou se nao foi na sua /home tera que executa-lo como root em /usr caminho.do.game, mas isso vc ja sabe Sorridente.


O assistente http://aa25assist.sourceforge.net/ ja esta la no primeiro post desse topico Piscada



« Última modificação: 03 de Março de 2011, 11:11 por platao » Registrado

platao
Equipe Ubuntu
Usuário Ubuntu
*****
Deslogado Deslogado

Mensagens: 4.445



Ver Perfil
« Responder #41 em: 03 de Março de 2011, 11:18 »

Outra coisa, se vcs por algum motivo estiverem encontrando problemas para atualizar a lista de servidores, tentar pegar o ip pelo Battletracker http://battletracker.com/index.php?page=AAOServerlist&sortField=ClientCount&sortOrder=DESC&map=&gametype=&country=&mod=&version=2.5.0 clicando com o direito do mouse na tela onde apareceriam os servidores e "open ip" manualmente, por exemplo 206.217.134.234:1716 esse server e bacana.
Registrado

rdeprera
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 9



Ver Perfil WWW
« Responder #42 em: 03 de Março de 2011, 22:38 »

Bom, o problema do som o luiz fernando descobriu que ele precisava instalar o oss e eu acabei utilizando a pulseaudio, como ja fico claro neste tópico. Ou seja, o problema do som já está resolvido.

Agora eu pergunto a vocês: Alguem ai está conseguindo jogar online? Porque eu completei os treinamentos mas estou tento problemas com o punkbuster.  O meu cliente pb não consegue atualizar automaticamente, e de forma manual também não consegui pois o script deles está com vários erros de codificação de caracter que não da nem pra ler os erros, e o pbsetup.run esta com problema na sua GUI pois só apresenta 2 opções no input <games> (só aparece battlefield e e battlefild 2142).

Já até abri um ticket no suporte deles, que alias foi respondido rápido mas de maneira incorreta (me mandaram fazer a atualização manul com o pbsetup do windows Triste ) ....enfim segue o erro retornado no console do jogo quando o pb tenta atualizar automaticamente:

PB client in distress - Cannot authenticate with PB server

Ai após tentar e retornar o erro supra-citado várias vezes o pb retorna o erro (http header de redirecionamento temporário) a seguir, e me kika:
302 not found

Alguém ai consegue joga a 2.5 online?
Se conseguir, seria legal alguém postar link pra download do diretorio /usr/local/games/armyops/System/pb pra mim e pra quem mais nao consegui atualizar o jogo. Porque ao que tudo indica, pela menos na arquitetura 64 bits os métodos manuais de atualização do PB não funcionarão

Então, tenho a solução para você, pois passei pelo mesmo problema! Aí eu descobri um "assistente" para o America's Army 2.5, este aqui http://aa25assist.sourceforge.net/ ele baixa as atualizações que forem precisas, e então você precisa abrir o jogo através dele, que irá funcionar!

Porém direto pelo jogo ainda não consigo entrar em função do PunkBuster, mas pelo assistente o Punkbuster funciona 100%.

Vlw. Eu ja tinha tentado instala o a pelo assistente mas o assistente deu um bugada louca, onde ele baixou mais de 4gb sem termina a instalação, e vi que nao ia termina nunca. por isso instalei o a pelo scrtipt .run
Ai resolvi tenta a solução do platão antes de tentar novamente pelo assistente. Foi batata, consegui!
Registrado

Distr.  : Ubuntu 10.10 x64
ASUS M4A88TD-M ATHLON II X4 635
rdeprera
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 9



Ver Perfil WWW
« Responder #43 em: 03 de Março de 2011, 22:42 »

Ola, agregando ao que ja foi reportado pelo Gabr1990, vc faz o download do assistente do Punkbuster aqui http://www.evenbalance.com/index.php?page=pbsetup.php agora o "pulo do gato".........vc nao pega a versao 64bits do instalador, vc pega a versao 32bits http://websec.evenbalance.com/downloader/download.php?file=4 que vai listar pra vc o Americas Army sem problema e atualizar mas dependendo como vc instalou se nao foi na sua /home tera que executa-lo como root em /usr caminho.do.game, mas isso vc ja sabe Sorridente.


O assistente http://aa25assist.sourceforge.net/ ja esta la no primeiro post desse topico Piscada

Muito obrigado! Funciou que uma beleza. Usei o pbsetup para 32 bits e nao demorou nem 2 min eu ja estava jogando multiplayer. Vou reportar o problema pra empresa que mantem o punkbuster. Pois a GUi do pbsetup 64 bits deve ter alguma dependencia nao informada ou esta com pau mesmo.
Registrado

Distr.  : Ubuntu 10.10 x64
ASUS M4A88TD-M ATHLON II X4 635
Joseph
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 794



Ver Perfil
« Responder #44 em: 07 de Março de 2011, 09:52 »

Bom, eu resolvi este mesmo problema de outra forma.

Como o a 2.5 utiliza bibliotecas que não são mais nativas do ubuntu >10.10, o jeito foi executar o jogo utilizando o padsp
No caso fica <padsp> <link simbolico do jogo>

Ex.:
Código:
padsp /usr/local/games/armyops/armyops
ou
padsp /diretório que você pediu para instalar o jogo/executável do jogo

Se ainda não funcionar, mate os serviço(s) de audio:
Código:
lsof /dev/snd/*
Código:
sudo kill -9 PID do(s) serviço(s)

Exemplo:
Código:
lsof /dev/snd/*
COMMAND     PID     USER   FD   TYPE DEVICE SIZE/OFF NODE NAME
pulseaudi 17665 reinaldo   29u   CHR  116,8      0t0 7156 /dev/snd/controlC0
pulseaudi 17665 reinaldo   36u   CHR  116,8      0t0 7156 /dev/snd/controlC0

Código:
sudo kill -9 17665

...e execute o procedimento novamente:





Não tinha instalado em 64 bits, e quando instalei ficou sem som, segui todas as dicas sem sucesso, até parar nesta que resolveu o problema, agora tenho outro, o mouse e o teclado travam no treinamento, alguma dica?
Registrado
Páginas: 1 2 [3] 4 5   Ir para o topo
  Imprimir  
 
Ir para:  

Powered by MySQL Powered by PHP Tema desenvolvido por FaBMak e n3t0
Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines
© 2014 Canonical Ltd. Ubuntu e Canonical são marcas registradas da Canonical Ltd.
XHTML 1.0 válido! CSS válido!