Autor Tópico: leitor de cartão sony vaio não funciona  (Lida 2792 vezes)

Offline sigur

  • Usuário Ubuntu
  • *
  • Mensagens: 1.026
    • Ver perfil
leitor de cartão sony vaio não funciona
« Online: 05 de Janeiro de 2012, 16:30 »
Pessoal, estou usando
Código: [Selecionar]
Linux vaio 2.6.32-37-generic-pae #81-Ubuntu SMP Fri Dec 2 22:24:22 UTC 2011 i686 GNU/Linux
em um sony vaio vpceg15, com ubuntu 10.04.3 LTS

Porém, ao colocar um cartão no leitor, nada acontece. O gozado é que a unidade de cartão não aparece no menu locais quando insiro o cartão (no caso de pendrive, por exemplo, aparece lá o nome kingston).

pois bem, eu acho que o leitor não está sendo reconhecido, pois pode ser que o laptop seja novo demais pra ele, sei lá....

eis o comando lspci

Código: [Selecionar]
thiago@vaio:~$ lspci
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b4)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b4)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b4)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM65 Express Chipset Family LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 04)
02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5116 PCI Express Card Reader (rev 01)
09:00.0 Ethernet controller: Atheros Communications Inc. AR8151 v2.0 Gigabit Ethernet (rev c0)

alguém poderia explicar o que eles mostram? Alguns eu até sei, como a placa de rede, por ex. Mas e os outros?

Bem, alguma ideia de como fazer o leitor funcionar?

Abraços.

Online Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.427
    • Ver perfil

Offline sigur

  • Usuário Ubuntu
  • *
  • Mensagens: 1.026
    • Ver perfil
Re: leitor de cartão sony vaio não funciona
« Resposta #2 Online: 06 de Janeiro de 2012, 11:51 »
Resolvido. Muito obrigado Tota.

Descobri, fuçando no google, que estava dando errado pois eu digitava o make com o sudo ao invés de logar como root e depois fazer o processo. Usei sudo su e depois deu certo. Agora funciona o meu cartão sd.

Valeu.
« Última modificação: 07 de Janeiro de 2012, 16:18 por sigur »