Autor Tópico: Tutorial para HSP56 MR driver Smartlink  (Lida 797092 vezes)

Offline jamiro

  • Usuário Ubuntu
  • *
  • Mensagens: 124
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #420 Online: 18 de Maio de 2007, 00:31 »
Quando eu usava internet discada, para que meu modem fosse reconhecido eu também tinha que fazer esse procedimento:

Ae mdea, bom dia, seguinte toda vez que vou conectar tenho mais ou menos o mesmo erro, tenho que executar o seguinte comando aqui:

Código: [Selecionar]
sudo /etc/init.d/sl-modem-daemon restart
isso irá fazer com que o modulo do modem seja reiniciado, apos isso ele funciona direitinho, ainda não descobri solução pro problema, por enquanto vou usando assim, se alguem souber, por favor fique a vontade.


Depois que eu coloquei banda larga também tive alguns problemas. Configurava tudo direitinho, demorava até que o Ubuntu encontrasse a rede, e quando reiniciava... a rede sumia! E então o que se seguia eram várias tentativas até conseguir reconfigurar. Então me deram uma dica que repasso, embora não saiba se irá funcionar com a discada: quando conseguir conectar numa boa, vá até Sistemas --> Preferências --> Sessões e na aba opções de sessão salve a sessão atual. E isso uma única vez, será suficiente.

No caso da banda larga funciona direto.

Abraços,


Jamiro

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #421 Online: 22 de Maio de 2007, 14:12 »
Pessoal peço desculpas por não estar respondendo as dúvidas quanto a conexão discada e nem ter feito ainda um novo pacote para a nova versão do Ubuntu. O motivo para isso é que estou sem PC por que a memória RAM do mesmo está com defeito e como o computador estava na garantia, levei o mesmo para a Assistencia Técnica Autorizada. O conserto, acreditem vocês, demoraia 28 dias para ser feito e que o computador seria enviado para São Paulo para isso, moro em Fortaleza/Ceará. Só que já estou com mais de 35 dias sem o mesmo e a previsão da HP é que só virá no dia 31 de Maio, portanto ficarei ausente por enquanto. Assim que possível voltarei a escrever neste tópico.

Offline gaucho.online

  • Usuário Ubuntu
  • *
  • Mensagens: 29
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #422 Online: 26 de Maio de 2007, 19:38 »
Espero que voltes logo, existem muitas duvidas quanto ao 7.04, para muitos é facil fazer a configuração, mas pra quem está chegando e´muito bom este suporte.


Essas informações você deixa em todos os sites que visita.

Offline aleksandre

  • Usuário Ubuntu
  • *
  • Mensagens: 92
  • The future is open
    • Ver perfil
    • Google Profile
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #423 Online: 27 de Maio de 2007, 14:21 »
Alarcon,

Tenho tentado entrar em contato com você por email e não tenho conseguido!
Esse do iBest retorna os emails (como se sua caixa estivesse cheia ou a conta bloqueada), já o do Gmail vai normal mas parece que você não está acessando...
Verifique aí, por favor!
Espero que teu problema com o micro se resolva logo-logo!
Ateh!

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #424 Online: 02 de Junho de 2007, 15:58 »
Voltei!!!

E para comemorar ;D, depois de mais de 40 dias fora do ar, elaborei o pacote modem-arquivos-v16.tar.gz para a instalação do driver Smartlink e ativação dos modems que usam este driver para o Ubuntu 7.04.

Está faltando só fazer o upload e depois disponibilizar o link para que os usuários testem e vejam se realmente está funcionando.

Pretendo fazer isso ainda neste final de semana, depois de atualizar certas coisas por aqui.

Aguardem!!

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #425 Online: 02 de Junho de 2007, 17:20 »
Como prometido, o link para o pacote modem-arquivos-v16.tar.gz para o Ubuntu Linux 7.04 Feisty Fawn é este:

http://prdownloads.sourceforge.net/projeto-messias/modem-arquivos-v16.tar.gz?download

Para instalar siga os mesmos procedimentos dos pacotes anteriores. Dentro do pacote existe um arquivo texto chamado de Leia-me que explica de uma forma resumida como instalar este pacote e um arquivo chamado de guia_instalação.pdf que explica mais detalhadamente com ilustrações e com uma explicação sobre os problemas mais comuns encontrados com este driver.

Atenção: foram usados o driver smartlink mais novo (slmodem-2.9.11-20070505.tar.gz) e o ungrab-winmodem mais novo (ungrab-winmodem-20070430) encontrados no site http://linmodems.technion.ac.il/packages/smartlink/.

Testem e me avisem do seu sucesso ou fracasso com este pacote para que possa corrigir possíveis erros ok.

OBs: Segudo o usuário gabriel.goc autor do tópico Tutorial de instalação do modem smartlink no ubuntu 7.04: Jamais atualize o pacote sl-modem-daemon pelo sistema de atualizações do ubuntu, preste atenção nisso, pois a sua atualização será indicada, se for atualizar o sistema. Certifique-se de ter desmarcado o item referente a atualização desse pacote. Portanto aconselho a seguir o dica do colega para o sl-modem-daemon no update-manager ou gerenciador de atualizações do Ubuntu.
« Última modificação: 03 de Junho de 2007, 15:08 por alarcon »

Offline canha

  • Usuário Ubuntu
  • *
  • Mensagens: 54
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #426 Online: 02 de Junho de 2007, 19:13 »
 Alarcon  o meu modem é onboard HSP 56 MR aquele que usa o slot CNR e que usa o script do kurumin HSP modem onboard AMR  Smartlink...... , pois bem instalei o Ubuntu 7.04 e logico o modem não foi reconhecido neste intervalo da sua ausencia adquiri um outro modem PCI Braview que usa o Chipset Smartlink 2800 e atraves do tutorial do Daniel.Netti consegui conectar porem a conexão é muito baixa 45666 e o modem onboard tem velocidade de 52000 e é justamente este modem interno que eu gostaria de fazer funcionar .
 A pergunta é :
 Como fazer agora ,terei que tirar o modem PCI e deixar o onboard ou posso deixar os dois que usa o drive da Smartlink?
 E os pacotes instalados pelo tutorial do Daniel  deixo ou desinstalo ?
 Abaixo é o modem Onboard :
0000:00:11.6 Communication controller: VIA Technologies, Inc. AC'97 Modem Controller (rev 80)
 Agora me perdi !!
« Última modificação: 02 de Junho de 2007, 19:30 por canha »
BIGLINUX 4
SIDUX 2008.03 OUREA
UBUNTU ULTIMATE EDITION 1.8

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #427 Online: 02 de Junho de 2007, 19:36 »
Alarcon  o meu modem é onboard HSP 56 MR aquele que usa o slot CNR e que usa o script do kurumin HSP modem onboard AMR  Smartlink...... , pois bem instalei o Ubuntu 7.04 e logico o modem não foi reconhecido neste intervalo da sua ausencia adquiri um outro modem PCI Braview que usa o Chipset Smartlink 2800 e atraves do tutorial do Daniel.Netti consegui conectar porem a conexão é muito baixa 45666 e o modem onboard tem velocidade de 52000 e é justamente este modem interno que eu gostaria de fazer funcionar .
 A pergunta é :
 Como fazer agora ,terei que tirar o modem PCI e deixar o onboard ou posso deixar os dois que usa o drive da Smartlink?
 E os pacotes instalados pelo tutorial do Daniel  deixo ou desinstalo ?
 Agora me perdi !!

Primeira coisa, você tentou todos os Init2 que falei já por aqui e nenhum melhorou isto?

Segunda pergunta, você já tentou se conectar sem conectar o fio do computador para o telefone, ou seja, deixando só o fio do computador para a linha telefônica?

Em alguns modems que não sei por qual motivo o telefone causa interferências e ao retirá-lo da linha a velocidade de conexão pode aumentar. Agora aqui o máximo que consigo é uma velocidade de 46666 e muito raramente de 48666k. Este seu modem onboard é rápido heim, bom mais aqui a linha telefônica é muito antiga (analógica).

Se nada funcionar, tente usar somente o modem onboard (retire o outro) e use o pacote que fiz para ver se melhora. Isto se você puder reisntalar o Ubuntu 7.04. Agora eu não testei o pacote que fiz por que uso outro tipo de modem que não usa o driver smartlink e portanto não posso testar mais, entretanto segui a mesma lógica dos outros pacotes feitos por mim.

Não sei como o driver age com dois modems que usam o mesmo driver, ou seja, qual ele usa. Será que ele cria por exemplo: um dispositivo /dev/ttySL0 para um e um dispositivo /dev/ttySL1 para o outro modem?

Nunca passei por uma situação como esta e não sei dizer.
« Última modificação: 02 de Junho de 2007, 19:39 por alarcon »

Offline canha

  • Usuário Ubuntu
  • *
  • Mensagens: 54
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #428 Online: 03 de Junho de 2007, 21:03 »
 Alarcon obrigado pelas dicas ate o momento , em relação a string estou usando esta:
 ATQ0 V1 E1 S0=0 X3 &C1 &D2  +MS=90

 Porque esta estava limitando o modem a uma velocidade baixa
 ATQ0 V1 E1 S0=0 X3 &C1 &D2  +MS=34

 Agora realmente o modem onboard é um espetaculo para conectar ele estabiliza a conexão em torno de 4.5 a 5.6 KBs e sempre a 52000 mas isso no Biglinux 3 que é baseado no Ubuntu 6.06 e no Kurumin 7 mas infelizmente no Ubuntu não está dando apenas o PCI Braview .

 Em relação aos fios está apenas o que vai na linha não há telefone ligado junto.
 E o dispositivo eu fiz um teste e dá para se conectar tanto no /dev/modem como no /dev/ttySL0 o /dev/ttySL1 não conecta.

 Agora está assim o wvdial.conf (eu preenchi os dados abaixo , mas em branco aqui por Segurança) não entendo direito mas acho muito basico é assim mesmo ou não ?

 [Dialer Defaults]
Phone =
Username =
Password =
New PPPD = yes
 Obrigado novamente e se tiver mais alguma dica ou alguma string é só mandar .
BIGLINUX 4
SIDUX 2008.03 OUREA
UBUNTU ULTIMATE EDITION 1.8

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #429 Online: 03 de Junho de 2007, 21:21 »
Alarcon obrigado pelas dicas ate o momento , em relação a string estou usando esta:
 ATQ0 V1 E1 S0=0 X3 &C1 &D2  +MS=90

 Porque esta estava limitando o modem a uma velocidade baixa
 ATQ0 V1 E1 S0=0 X3 &C1 &D2  +MS=34

 Agora realmente o modem onboard é um espetaculo para conectar ele estabiliza a conexão em torno de 4.5 a 5.6 KBs e sempre a 52000 mas isso no Biglinux 3 que é baseado no Ubuntu 6.06 e no Kurumin 7 mas infelizmente no Ubuntu não está dando apenas o PCI Braview .

 Em relação aos fios está apenas o que vai na linha não há telefone ligado junto.
 E o dispositivo eu fiz um teste e dá para se conectar tanto no /dev/modem como no /dev/ttySL0 o /dev/ttySL1 não conecta.

 Agora está assim o wvdial.conf (eu preenchi os dados abaixo , mas em branco aqui por Segurança) não entendo direito mas acho muito basico é assim mesmo ou não ?

 [Dialer Defaults]
Phone =
Username =
Password =
New PPPD = yes
 Obrigado novamente e se tiver mais alguma dica ou alguma string é só mandar .

Bem, se você usa o gnome-ppp, na sua pasta de usuário dentro da pasta /home/ deveria ter um arquivo oculto chamado .wvdial.conf

com a seguinte configuração:

Citar
[Dialer Defaults]
Modem = /dev/ttySL0
ISDN = off
Modem Type = Analog Modem
Baud = 115200
Init = ATZ
Init2 = ATQ0 V1 E1 S0=0 X3 &C1 &D2  +MS=90
Init3 =
Init4 =
Init5 =
Init6 =
Init7 =
Init8 =
Init9 =
Phone = $Fone
Phone1 =
Phone2 =
Phone3 =
Phone4 =
Dial Prefix =
Dial Attempts = 1
Dial Command = ATM1L1DT
Ask Password = off
Password = $Password
Username = $Username
Auto Reconnect = off
Abort on Busy = on
Carrier Check = on
Check Def Route = on
Abort on No Dialtone = on
Stupid Mode = on
Idle Seconds = 0
Auto DNS = on
;Minimize = off
;Dock = on
;Do NOT edit this file by hand!


Onde os dados em negrito são informações pessoais que você deve fornecer. Isso, repito, para quem usa o gnome-ppp, pois o arquivo .wvdial.conf que utiliza é o que fica oculto na pasta do usuário e não o da pasta /etc




Offline Sergio Morgado

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #430 Online: 07 de Junho de 2007, 00:46 »
Ola, Alarcon

Consegui conectar usando o Ubuntu, segui o seu tutorial e deu certo.
O meu modem é um HSP56 MR da placa M810 "AC'97".

Até ai tudo bem, apesar de não conseguir conectar logo de inicio, mas quando conecta fica sem cair a conexão o problema e que a conexão está muito lenta. Vou tentar mudar a string de inicialização como foi dito acima pra ver se melhora, depois posto aqui o resultado.

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #431 Online: 07 de Junho de 2007, 09:30 »
Ola, Alarcon

Consegui conectar usando o Ubuntu, segui o seu tutorial e deu certo.
O meu modem é um HSP56 MR da placa M810 "AC'97".

Até ai tudo bem, apesar de não conseguir conectar logo de inicio, mas quando conecta fica sem cair a conexão o problema e que a conexão está muito lenta. Vou tentar mudar a string de inicialização como foi dito acima pra ver se melhora, depois posto aqui o resultado.


Você está usando o Ubuntu 7.04 e usou o pacote modem-arquivos-v16.tar.gz?

É importante para mim que você informe isto, por que como havia dito não tenho mais modem que usa o driver Smartlink e então não posso mais testar os pacotes que faço para estes modems que usam este driver.

Caso você tenha usado esta versão do ubuntu e do pacote, tente mais isto:

- desconecte o telefone do computador e deixe somente o computador ligado na linha telefônica.
- Tente algum destes strings de inicialização para o Init2 do  arquivo .wvdial.conf oculto na sua pasta de usuário na /home/ :

ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0

ATQ0 V1 E1 S0=0 X3 &C1 &D2 +FCLASS=0

ATQ0 V1 E1 S0=0 X3 &C1 &D2 +MS=34

ATQ0 V1 E1 S0=0 X3 &C1 &D2  +MS=90


Offline Sergio Morgado

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #432 Online: 07 de Junho de 2007, 11:52 »
Alarcon,

Uso o Ubuntu 7.04 (Instalei ele novamente pra ficar limpo) e usei o pacote modem-arquivos-v16.tar.gz.

Intalou o pacote sem problemas. O meu problema estava que a rede estava ativa, segui o seu tutorial do arquivo .PDF e desabilitei a rede e habilitei pra usar o modem como padrão.

Mesmo assim pra conectar (alem de usar o comando restart) eu tinha que tentar algumas vezes pra conseguir conectar pois dava a menssagem que o tempo havia terminado pra tentar se conectar, quando conectava ficava sem cair a linha, o problema e que a conexão está muito lenta, se conecta entre 12000 e 14000 (taxa de download fica em torno de 1.5 Kb/s, isso quando não fica bem a menos), no ruindows se conecta a 115000. Tem alguma configuração pra tentar ver se melhora a velocidade da conexão?

Meu modem é o seguinte:

lspci -d 1039:7013
00:01.6 Modem: Silicon Integrated Systems (SiS) AC'97 Modem controller (rev a0)

E obrigado por ajudar os novatos como eu a se conectar usando discada.


alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #433 Online: 07 de Junho de 2007, 12:12 »
Alarcon,

Uso o Ubuntu 7.04 (Instalei ele novamente pra ficar limpo) e usei o pacote modem-arquivos-v16.tar.gz.

Intalou o pacote sem problemas. O meu problema estava que a rede estava ativa, segui o seu tutorial do arquivo .PDF e desabilitei a rede e habilitei pra usar o modem como padrão.

Mesmo assim pra conectar (alem de usar o comando restart) eu tinha que tentar algumas vezes pra conseguir conectar pois dava a menssagem que o tempo havia terminado pra tentar se conectar, quando conectava ficava sem cair a linha, o problema e que a conexão está muito lenta, se conecta entre 12000 e 14000 (taxa de download fica em torno de 1.5 Kb/s, isso quando não fica bem a menos), no ruindows se conecta a 115000. Tem alguma configuração pra tentar ver se melhora a velocidade da conexão?

Meu modem é o seguinte:

lspci -d 1039:7013
00:01.6 Modem: Silicon Integrated Systems (SiS) AC'97 Modem controller (rev a0)

E obrigado por ajudar os novatos como eu a se conectar usando discada.



Você tentou com cada uma dos string do Init2 que postei logo acima?

Tente usar os Strings do init2 com a combinação da opção verificar portadora marcada ou desmarcada para ver se melhora alguma coisa.

Este modem é o mais complicado dentre os modems que são suportados pelo driver Smartlink. Nunca entendi o porquê dele ter sempre que digitar no terminal:

sudo /etc/init.d/sl-modem-daemon restart

Infelizmente não tenho mais discas para lhe fornecer. quem sabe se você usar outro driver smartlink que não seja este que coloquei no meu pacote funcione melhor.

Usei este:

http://linmodems.technion.ac.il/packages/smartlink/slmodem-2.9.11-20070505.tar.gz

que é o mais novo.

agora se você quiser tentar um mais antigo:

http://linmodems.technion.ac.il/packages/smartlink/slmodem-2.9.11-20070430.tar.gz

Tente mais isto aqui:

sudo /etc/init.d/sl-modem-daemon stop

sudo modprobe ungrab-winmodem

reinicie o computador

depois faça isso:

sudo /etc/init.d/sl-modem-daemon restart


Offline Sergio Morgado

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #434 Online: 07 de Junho de 2007, 14:50 »
Alarcon,

Tentei todas as strings a única que funcionou aqui e não deu problema foi essa:

Alternativo1 ATQ0 V1 E1 S0=0 X3 &C1 &D2 +FCLASS=0

As outras antes de completar a conexão, fechava a conexão.
Estou escrevendo agora pelo ubuntu, a velocidade da conexão melhorou, agora conectou a CONNECT 34667, está bem mais rapida a conexão. Pode ser que seja do IG que a conexão acaba ficando lenta.

Eu alterava a string direto no GNOME PPP e não editando o arquivo .wvdial.conf . Tem alguma diferença ou tem que ser pelo arquivo?

No log de conexão apareceu assim:

Citar
--> Ignoring malformed input line: ";Do NOT edit this file by hand!"
--> WvDial: Internet dialer version 1.56
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 X3 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 X3 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATM1L3DT30096700
--> Waiting for carrier.
ATM1L3DT30096700
CONNECT 34667
--> Carrier detected.  Starting PPP immediately.
--> Starting pppd at Thu Jun  7 14:31:42 2007
--> Warning: Could not modify /etc/ppp/pap-secrets: Permission denied
--> --> PAP (Password Authentication Protocol) may be flaky.
--> Warning: Could not modify /etc/ppp/chap-secrets: Permission denied
--> --> CHAP (Challenge Handshake) may be flaky.
--> Pid of pppd: 6679
--> Using interface ppp0
--> local  IP address 200.226.5.92
--> remote IP address 200.205.111.196
--> primary   DNS address 200.225.159.124
--> secondary DNS address 200.225.159.126

Onde está em negrito o "Warning" é normal ou é algum problema.

O que acho engraçado é que pra conseguir conectar eu tenho que ir nas configurações de rede e configurar novamente para ele se conectar sem erro. Quando não vou nas configurações de rede ele sempre mostra essa mensagem no log da conecção:

Citar
--> Modem initialized.
--> Sending: ATM1L3DT30096700
--> Waiting for carrier.
ATM1L3DT30096700
--> Timed out while dialing.  Trying again.
--> Maximum Attempts Exceeded..Aborting!!
--> Disconnecting at Thu Jun  7 14:17:03 2007

Depois que reconfiguro a conexão de rede desabilitando a rede e usar o modem ele conecta sem problema, Apesar da conexão ficar lenta.

Valeu pela força que vc da para o pessoal conseguir se conectar pelo linux.
« Última modificação: 07 de Junho de 2007, 14:57 por Sergio Morgado »