Autor Tópico: Rodar AutoCad pelo wine [RESOLVIDO]  (Lida 30186 vezes)

Offline Grunbeld

  • Usuário Ubuntu
  • *
  • Mensagens: 74
    • Ver perfil
Re: Rodar AutoCad pelo wine [RESOLVIDO]
« Resposta #15 Online: 30 de Outubro de 2012, 01:07 »
 
Citar
Vc só vai saber se é diferente instalando, vai por mim. Aqui na minha faculdade o pessoal é bitolado em Matlab, mas cansado de ficar pirateando optei por soluções livres. Acabei achando o GNU Octave e o Scilab, ótimos programas equivalentes ao Matlab, estou bastante tempo usando eles. E não são tão diferentes do Matlab.
Sérgio, esses programas que citou tem mais recursos que o AutoCad? são bons ? leves ? a interface deles é fácil de se adaptar ?
 (pergunto isso pois terei que instala-los não só no meu computador, mas no meu netbook que só tem 2 gigas de ram )
« Última modificação: 30 de Outubro de 2012, 16:13 por Grunbeld »

Offline Sergio Benjamim

  • Usuário Ubuntu
  • *
  • Mensagens: 2.902
    • Ver perfil
Re: Rodar AutoCad pelo wine
« Resposta #16 Online: 30 de Outubro de 2012, 01:12 »
Aquele link q passei acabou q não dando certo comigo. Achei alguma coisa no Ask Ubuntu: http://askubuntu.com/questions/39647/how-do-i-install-draftsight-cad
É novo no Ubuntu? Já leu o Ubuntu – Guia do Iniciante 2.0 ?
Experimente o Xubuntu 14.04 !

Offline Sergio Benjamim

  • Usuário Ubuntu
  • *
  • Mensagens: 2.902
    • Ver perfil
Re: Rodar AutoCad pelo wine
« Resposta #17 Online: 30 de Outubro de 2012, 01:30 »
Sucesso total!!! Segue o que eu fiz:

Citar
sudo apt-get install libdirectfb-extra libxcb-render-util0
cd ~/Download  # Foi a pasta de baixei o programa!
sudo dpkg --force-architecture --force-depends -i draftSight.deb

Já está funcionando o programa, e se eu quiser tem como ativar o produto por 6 meses, na primeira vez q abrir o programa vai ser pedido o email e algumas informações, digite seu email e espere chegar na sua conta de email a ativação. Dá para renovar depois desses 6 meses. Se não ativar o produto, ele fica funcionando por 1 mês se não me engano.
É novo no Ubuntu? Já leu o Ubuntu – Guia do Iniciante 2.0 ?
Experimente o Xubuntu 14.04 !

Offline Sergio Benjamim

  • Usuário Ubuntu
  • *
  • Mensagens: 2.902
    • Ver perfil
Re: Rodar AutoCad pelo wine
« Resposta #18 Online: 30 de Outubro de 2012, 01:34 »
Citar
Vc só vai saber se é diferente instalando, vai por mim. Aqui na minha faculdade o pessoal é bitolado em Matlab, mas cansado de ficar pirateando optei por soluções livres. Acabei achando o GNU Octave e o Scilab, ótimos programas equivalentes ao Matlab, estou bastante tempo usando eles. E não são tão diferentes do Matlab.
Sérgio, esses programas que citou tem mais recursos que o AutoCad? são bons ? leves ? a interface deles é fácil de se adaptar ?
 (pergunto isso pois terei que instala-los não só no meu computador, mas no meu netbook que só tem 2 gigas de ram )

Esse programas que citei não tem nada a ver com AutoCad, são programas da área de matemática/engenharia. Só quis dar um exemplo de como há alternativas por aí.
É novo no Ubuntu? Já leu o Ubuntu – Guia do Iniciante 2.0 ?
Experimente o Xubuntu 14.04 !

Offline Sergio Benjamim

  • Usuário Ubuntu
  • *
  • Mensagens: 2.902
    • Ver perfil
Re: Rodar AutoCad pelo wine
« Resposta #19 Online: 30 de Outubro de 2012, 01:39 »
Agora estou com problema de pacote quebrado no sistema. Não consigo achar opção no synaptic para manter um pacote quebrado, ele é simplesmente intolerante. Isso vai dar problema na hora de atualizar o sistema, o Ubuntu vai simplesmente desinstalar o pacote dassault-systemes-draftsight:i386. Soluções serão bem vindas!  ;D

A única solução que me passou pela cabeça foi descompactar o draftSight.deb, e copiar seus arquivos para /opt ou /usr/local, e criar um atalho para ele com ajuda do Alacarte. Inclusive, um cara lá do Ask Ubuntu sugeriu o mesmo:

Citar
I have succeeded in to install draftSight in Ubuntu 12.04 (beta2) 64 bit. I just have installed the required libraries and then extracted the .deb file content.

I copied the extracted folder to /usr/local/ and then just change the owner:

sudo chown -R user:group draftSight/

After that i just have created a launcher in the desktop..

Cheers....

Achei outra solução aqui: http://linuxaideddesign.blogspot.it/2012/03/draftsight-and-ubuntu-1204-lts-64bit.html
Essa solução é mais limpinha q a anterior, mas é meio gambiarra, mas deve funcionar.

O Grunbeld deve estar meio assustado com tudo isso... calma cara, instalar programas no Ubuntu não é tão difícil assim, esse programa é exceção à regra. Se tivesse no Ubuntu de 32 bits não daria tudo isso.


Ahh não tem nada a ver, mas é bom dar uma olhada na política de privacidade desse soft: http://www.solidworks.com/sw/privacypolicy.htm
« Última modificação: 30 de Outubro de 2012, 01:55 por Sergio Benjamim »
É novo no Ubuntu? Já leu o Ubuntu – Guia do Iniciante 2.0 ?
Experimente o Xubuntu 14.04 !

Offline Grunbeld

  • Usuário Ubuntu
  • *
  • Mensagens: 74
    • Ver perfil
Re: Rodar AutoCad pelo wine
« Resposta #20 Online: 30 de Outubro de 2012, 16:12 »
Entendo rsrs..... eu uso Ubuntu 12.10 32 bits rssr

Offline Arthur Bernardes

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re: Rodar AutoCad pelo wine
« Resposta #21 Online: 30 de Outubro de 2012, 16:23 »
Sergio, Grunbeld.. Podem instalar pelo pacote .deb que comigo instalou e funcionou perfeitamente..! Quer que disponibilizo depois o link para o pacote.?

Offline Sergio Benjamim

  • Usuário Ubuntu
  • *
  • Mensagens: 2.902
    • Ver perfil
Re: Rodar AutoCad pelo wine
« Resposta #22 Online: 30 de Outubro de 2012, 19:27 »
Sergio, Grunbeld.. Podem instalar pelo pacote .deb que comigo instalou e funcionou perfeitamente..! Quer que disponibilizo depois o link para o pacote.?

Ueh, não deu problema para você? Aqui deu erro de dependência. Você está usando o Ubuntu de 32 bits?
É novo no Ubuntu? Já leu o Ubuntu – Guia do Iniciante 2.0 ?
Experimente o Xubuntu 14.04 !

Offline Arthur Bernardes

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re: Rodar AutoCad pelo wine
« Resposta #23 Online: 30 de Outubro de 2012, 19:38 »
Sim, 32 Bits..!

Offline Sergio Benjamim

  • Usuário Ubuntu
  • *
  • Mensagens: 2.902
    • Ver perfil
Re: Rodar AutoCad pelo wine
« Resposta #24 Online: 30 de Outubro de 2012, 19:57 »
Sim, 32 Bits..!

Ahhh, é por isso que não deu problemas. Tinha pensado que vc estava usando a versão de 64 bits.

Está rodando legal o programa, testei com uns arquivos que tinha de desenho técnico, e abriu normalmente, muito legal mesmo. Só o 3D que deixa a desejar.
É novo no Ubuntu? Já leu o Ubuntu – Guia do Iniciante 2.0 ?
Experimente o Xubuntu 14.04 !

Offline Arthur Bernardes

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re: Rodar AutoCad pelo wine
« Resposta #25 Online: 30 de Outubro de 2012, 22:04 »
Comigo funcionou beleza..! Podem instalar, quanto ao 64 Bits eu ainda não sei. Vamos dar uma pesquisada. :D

Offline Grunbeld

  • Usuário Ubuntu
  • *
  • Mensagens: 74
    • Ver perfil
Re: Rodar AutoCad pelo wine
« Resposta #26 Online: 31 de Outubro de 2012, 18:00 »
hum... graças a Deus que meu é 32 bits haha ;D O wine roda jogos pesados também ?

Offline Arthur Bernardes

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re: Rodar AutoCad pelo wine
« Resposta #27 Online: 31 de Outubro de 2012, 18:11 »
 ;D ;D Vixi cara, o Sergio Benjamim pode te dizer isso melhor..!

Offline jkmsjq

  • Usuário Ubuntu
  • *
  • Mensagens: 3.343
  • Ubuntu Member
    • Ver perfil
Re: Emular AutoCad pelo wine
« Resposta #28 Online: 31 de Outubro de 2012, 18:49 »
[...]

Então, estou tentando instalar, mas me parece que há versão somente de 32 bits para Ubuntu. [...]

Eu instalo usando os seguintes comandos, a partir da pasta onde baixei o aplicativo:

Código: [Selecionar]
dpkg –i –force-all draftsight.deb
Se houver falta de dependências tenta o seguinte comando:

Código: [Selecionar]
sudo apt-get -f install
LinuxUser: 548942 / Dando um tópico como resolvido
"A verdade só é agressiva a quem vive de mentiras". Autor desconhecido.
Twitter: @jeisonkertesz

Offline Sergio Benjamim

  • Usuário Ubuntu
  • *
  • Mensagens: 2.902
    • Ver perfil
Re: Rodar AutoCad pelo wine e alternativas
« Resposta #29 Online: 01 de Novembro de 2012, 20:51 »
[...]

Então, estou tentando instalar, mas me parece que há versão somente de 32 bits para Ubuntu. [...]

Eu instalo usando os seguintes comandos, a partir da pasta onde baixei o aplicativo:

Código: [Selecionar]
dpkg –i –force-all draftsight.deb
Se houver falta de dependências tenta o seguinte comando:

Código: [Selecionar]
sudo apt-get -f install

Esse último comando vai desinstalar o DraftSight:

Citar
Os pacotes a seguir serão REMOVIDOS:
  dassault-systemes-draftsight:i386 libdirectfb-extra

É o meio que o apt-get acha de corrigir os pacotes quebrados.

Para 64 bits, segui o passo a passo do link que postei anteriormente (esse aqui), segue um resumão do que eu fiz:

Baixei o pacote do DraftSight, joguei em uma pasta qualquer (aqui está lá em Download), abri um terminal e digitei:

Citar
cd ~/Download/
ar x draftSight.deb control.tar.gz

Abri o Nautilus, fui até Download, cliquei com o botão direito no arquivo control.tar.gz, pedi para extrair, entrei na pasta control, e abri o arquivo control com o Gedit mesmo. Procurei por "libdirectfb-extra (>=1.2.7-2)", e exclui de maneira que a sintaxe do arquivo se mantivesse coerente, ou seja:

Isso:
Citar
[...] libatk1.0-0 (>=1.28.0-0), libcairo2 (>=1.8.8-2), libdirectfb-extra (>=1.2.7-2), libfontconfig1 (>=2.6.0-1), libfreetype6 (>=2.3.9-5), [...]

virou isso:
Citar
[...] libatk1.0-0 (>=1.28.0-0), libcairo2 (>=1.8.8-2), libfontconfig1 (>=2.6.0-1), libfreetype6 (>=2.3.9-5), [...]

Cuidado para não deixar espaços em brancos ou virgulas à mais. Faça a alteração e salve.

Depois escolhi todos os arquivos da pasta control, cliquei com o botão direito e pedi para comprimir, escolha a extensão .tar.gz, e a localidade em Download. Vai pedir autorização para sobrescrever o arquivo original, aperte o botão "Sobrescrever".

Digitei no terminal:

Citar
ar r draftSight.deb control.tar.gz

Isso faz com que o draftSight.deb seja alterado com as modificações que vc fez no arquivo. Cliquei duas vezes no draftSight.deb, abriu a Central de Programas, e instalou sem problemas aqui. No site é recomendado instalar o DraftSight pelo Gdebi (clique com o botão direito sobre o draftSight.deb) ou com o dpkg (é preciso terminal no dpkg).

Ainda é preciso instalar alguns pacotes para que ele funcione, procure na Central de Programas por ia32-libs e libdirectfb-extra, ou faça no terminal:

Citar
sudo apt-get install ia32-libs libdirectfb-extra

Parece que não é necessário instalar o ia32-libs (ele é um meta-pacote, irá instalar um monte de pacotes no seu Ubuntu), contanto que vc saiba exatamente quais pacotes de 32 bits o DrafSight precisa. Estou procurando isso, mas ninguém sabe dizer.

Nesse site, é recomendado que vc instale os pacotes sendmail, libglu1-mesa e libglu1-mesa-dev. Não sei se são necessários, acabei instalando.

Pronto! Acabou os problemas de pacotes quebrados na versão 64 bits do Ubuntu!  ;)
« Última modificação: 01 de Novembro de 2012, 21:15 por Sergio Benjamim »
É novo no Ubuntu? Já leu o Ubuntu – Guia do Iniciante 2.0 ?
Experimente o Xubuntu 14.04 !