Autor Tópico: Sem internet após atualização para o 12.04  (Lida 5401 vezes)

Offline sampietri

  • Usuário Ubuntu
  • *
  • Mensagens: 17
    • Ver perfil
Sem internet após atualização para o 12.04
« Online: 09 de Outubro de 2012, 20:52 »
Olá pessoal, sou novo no fórum e no Ubuntu também.

Estou com um "probleminha" de conexão. Depois que atualizei meu Ubuntu para o 12.04 perdi minhas conexões a cabo e wireless.
Depois de mexer muito, consegui conectar-me pelo cabo, mas continuo sem wireless.
Seguem os dados:

lshw -C network

  *-network              
       descrição: Ethernet interface
       produto: 191 Gigabit Ethernet Adapter
       fabricante: Silicon Integrated Systems [SiS]
       physical id: 4
       informações do barramento: pci@0000:00:04.0
       nome lógico: eth0
       versão: 02
       serial: e0:cb:4e:b3:ce:3a
       tamanho: 100Mbit/s
       capacidade: 100Mbit/s
       largura: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuração: autonegotiation=on broadcast=yes driver=sis190 driverversion=1.4 duplex=full ip=192.168.0.104 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       recursos: irq:19 memória:fd5fcc00-fd5fcc7f ioport:cc00(tamanho=128)
  *-network UNCLAIMED
       descrição: Ethernet controller
       produto: AR242x / AR542x Wireless Network Adapter (PCI-Express)
       fabricante: Atheros Communications Inc.
       physical id: 0
       informações do barramento: pci@0000:02:00.0
       versão: 01
       largura: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list
       configuração: latency=0
       recursos: memória:fd7f0000-fd7fffff
  *-network
       descrição: Interface sem fio
       physical id: 1
       nome lógico: ra0
       serial: 00:26:5a:02:8b:5e
       capabilities: ethernet physical wireless
       configuração: broadcast=yes driver=RALINK WLAN ip=192.168.0.103 multicast=yes wireless=Ralink STA

iwconfig

lo        no wireless extensions.

ra0       Ralink STA  ESSID:"dlink"  Nickname:"RT2870STA"
          Mode:Managed  Frequency=2.412 GHz  Access Point: 1C:AF:F7:46:2B:A4  
          Bit Rate=135 Mb/s  
          RTS thr:off   Fragment thr:off
          Link Quality=100/100  Signal level:-41 dBm  Noise level:-68 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

eth0      no wireless extensions.

ifconfig -a


eth0      Link encap:Ethernet  Endereço de HW e0:cb:4e:b3:ce:3a  
          inet end.: 192.168.0.104  Bcast:192.168.0.255  Masc:255.255.255.0
          endereço inet6: fe80::e2cb:4eff:feb3:ce3a/64 Escopo:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Métrica:1
          pacotes RX:8353 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:2791 erros:0 descartados:0 excesso:0 portadora:0
          colisões:1 txqueuelen:1000
          RX bytes:3155124 (3.1 MB) TX bytes:457423 (457.4 KB)
          IRQ:19 Endereço de E/S:0xdead

lo        Link encap:Loopback Local  
          inet end.: 127.0.0.1  Masc:255.0.0.0
          endereço inet6: ::1/128 Escopo:Máquina
          UP LOOPBACK RUNNING  MTU:16436  Métrica:1
          pacotes RX:395 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:395 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:0
          RX bytes:27191 (27.1 KB) TX bytes:27191 (27.1 KB)

ra0       Link encap:Ethernet  Endereço de HW 00:26:5a:02:8b:5e  
          inet end.: 192.168.0.103  Bcast:192.168.0.255  Masc:255.255.255.0
          endereço inet6: fe80::226:5aff:fe02:8b5e/64 Escopo:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Métrica:1
          pacotes RX:0 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:0 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:6136416 (6.1 MB) TX bytes:1472123 (1.4 MB)

nm-tool

NetworkManager Tool

State: connected (global)

- Device: ra0  [Auto dlink] ----------------------------------------------------
  Type:              802.11 WiFi
  Driver:            usb
  State:             connected
  Default:           yes
  HW Address:        00:26:5A:02:8B:5E

  Capabilities:
    Speed:           135 Mb/s

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points (* = current AP)
    TP-LINK_CA3990:  Infra, 00:27:19:CA:39:90, Freq 2437 MHz, Rate 54 Mb/s, Strength 29 WPA2
    *dlink:          Infra, 1C:AF:F7:46:2B:A4, Freq 2412 MHz, Rate 22 Mb/s, Strength 100

  IPv4 Settings:
    Address:         192.168.0.103
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.0.1



- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            sis190
  State:             unmanaged
  Default:           no
  HW Address:        E0:CB:4E:B3:CE:3A

  Capabilities:
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties
    Carrier:         on


rfkill list wifi

sem retorno

Estou usando um D-Link DIR-600 e D-Link DWA-125.
Já desliguei o roteador e religuei horas depois.
« Última modificação: 10 de Outubro de 2012, 19:22 por sampietri »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Sem internet após atualização para o 12.04
« Resposta #1 Online: 10 de Outubro de 2012, 10:47 »
Você tem uma placa wireless onboard sem uso. Pq?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline sampietri

  • Usuário Ubuntu
  • *
  • Mensagens: 17
    • Ver perfil
Re: Sem internet após atualização para o 12.04
« Resposta #2 Online: 10 de Outubro de 2012, 19:31 »
Você tem uma placa wireless onboard sem uso. Pq?

Tive alguns problemas com a conexão wireless: conexão instável, lentidão, "sinal fraco"... Tentei instalar e reinstalar alguns drivers diferentes, mas não funcionou. Então, resolvi testar a conexão com o D-Link DWA-125, deu certo, "acabaram" meus problemas de conexão wireless, aposentei minha placa...  ;D   Porém, agora atualizei para o 12.04 e voltei a ter problemas. Até consigo conectar ao roteador, mas não consigo navegar...
« Última modificação: 10 de Outubro de 2012, 20:17 por sampietri »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Sem internet após atualização para o 12.04
« Resposta #3 Online: 11 de Outubro de 2012, 00:17 »
OK. Execute o comando abaixo e cole o resultado aqui, pra confirmar o modelo exato do chipset do seu adaptador.

lsusb
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline sampietri

  • Usuário Ubuntu
  • *
  • Mensagens: 17
    • Ver perfil
Re: Sem internet após atualização para o 12.04
« Resposta #4 Online: 11 de Outubro de 2012, 06:35 »
OK. Execute o comando abaixo e cole o resultado aqui, pra confirmar o modelo exato do chipset do seu adaptador.

lsusb

ok!

lsusb

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 04f2:b071 Chicony Electronics Co., Ltd 2.0M UVC Webcam / CNF7129
Bus 001 Device 003: ID 07d1:3c0d D-Link System DWA-125 Wireless N 150 Adapter(rev.A1) [Ralink RT3070]
« Última modificação: 11 de Outubro de 2012, 06:37 por sampietri »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Sem internet após atualização para o 12.04
« Resposta #5 Online: 11 de Outubro de 2012, 11:55 »
Ralink 3070... esse adaptador funciona bem com o driver proprietário do RT3090. Se bem que a impressão que está me dando é que vc não tem problema de conexão wireless, e sim com o resto da estrutura.

Pode fazer um teste? Desconecte o cabo, deixe apenas a wireless. Depois execute os comandos abaixo e cole o resultado aqui.

ping -c 4 192.168.0.1
ping -c 4 8.8.8.8
ping -c 4 www.google.com
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline sampietri

  • Usuário Ubuntu
  • *
  • Mensagens: 17
    • Ver perfil
Re: Sem internet após atualização para o 12.04
« Resposta #6 Online: 11 de Outubro de 2012, 21:02 »
Ralink 3070... esse adaptador funciona bem com o driver proprietário do RT3090. Se bem que a impressão que está me dando é que vc não tem problema de conexão wireless, e sim com o resto da estrutura.

Pode fazer um teste? Desconecte o cabo, deixe apenas a wireless. Depois execute os comandos abaixo e cole o resultado aqui.

ping -c 4 192.168.0.1
ping -c 4 8.8.8.8
ping -c 4 www.google.com


ping -c 4 192.168.0.1

PING 192.168.0.1 (192.168.0.1) 56(84) bytes of data.

--- 192.168.0.1 ping statistics ---
4 packets transmitted, 0 received, 100% packet loss, time 3024ms

ping -c 4 8.8.8.8

PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.

--- 8.8.8.8 ping statistics ---
4 packets transmitted, 0 received, 100% packet loss, time 3017ms

ping -c 4 www.google.com

ping: unknown host www.google.com

 :(
« Última modificação: 16 de Outubro de 2012, 08:22 por sampietri »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Sem internet após atualização para o 12.04
« Resposta #7 Online: 16 de Outubro de 2012, 10:49 »
Esse driver que vc está usando, vc lembra como o o instalou?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline sampietri

  • Usuário Ubuntu
  • *
  • Mensagens: 17
    • Ver perfil
Re: Sem internet após atualização para o 12.04
« Resposta #8 Online: 16 de Outubro de 2012, 23:01 »
Esse driver que vc está usando, vc lembra como o o instalou?

Desci da página http://public.twicore.com/DWA-125/dwa-125-ubuntu-11.10-Linux-3.zip
Descompactei em uma pasta que criei em Documentos
Entrei na pasta pelo terminal
Digitei (se não me engano) sudo make e depois sudo make install. Depois configurei o blacklist.conf. Reiniciei.
Tudo deu certo (em parte): a rede wireless reconheceu o roteador e inclusive consigo entrar via wireless. Contudo, não consigo navegar na web.


Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Sem internet após atualização para o 12.04
« Resposta #9 Online: 17 de Outubro de 2012, 00:38 »
É... parece que esse teu driver não funciona. Provavelmente não suporta a criptografia em uso.

Experimente reverter pro driver nativo.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline sampietri

  • Usuário Ubuntu
  • *
  • Mensagens: 17
    • Ver perfil
Re: Sem internet após atualização para o 12.04
« Resposta #10 Online: 17 de Outubro de 2012, 06:11 »
É... parece que esse teu driver não funciona. Provavelmente não suporta a criptografia em uso.

Experimente reverter pro driver nativo.

Como se faz isso?

Offline RaiJorge

  • Usuário Ubuntu
  • *
  • Mensagens: 107
    • Ver perfil
Re: Sem internet após atualização para o 12.04
« Resposta #11 Online: 28 de Novembro de 2012, 13:27 »
eu também estou com problemas para conectar em wifi , alguém pode me ajudar ?