Autor Tópico: Resolvido: Não consigo inicializar o Windows pelo Grub  (Lida 11522 vezes)

Offline zackshinra

  • Usuário Ubuntu
  • *
  • Mensagens: 308
    • Ver perfil
Resolvido: Não consigo inicializar o Windows pelo Grub
« Online: 13 de Setembro de 2006, 13:44 »
  O problema começou com a reinstalação do windows, com isso não consegui mais acesso ao ubuntu. Este problema foi resolvido:
http://ubuntuforum-pt.org/index.php?topic=10450.0

  Mas foi criado outro, agora não consigo acessar o windows pelo grub.
 
  Estou com o acesso ao Ubuntu, já montei a partição do windows no Ubuntu conforme a dica que esta no:http://ubuntuguide.org/wiki/Ubuntu_dapper_pt#Como_montar_parti.C3.A7.C3.B5es_Windows_.28FAT.29_no_arranque.2C_e_permitir_que_todos_os_utilizadores_as_possam_ler.2Fescrever.3F
 
  Mas estou com dois problemas, o mais grave é que não estou conseguindo acessar o windows na inicialização do computador (pelo Grub).
  A partição esta no hda1, e o windows foi instalado como fat.
  No menu.lst esta incluido o windows

Citar
title      Microsoft Windows XP Professional
root      (hd0,0)
savedefault
makeactive
chainloader   +1

  Mas quando seleciono o windows no grub aparece a seguinte mensagem:

Citar
root (hd0,0)
file system type is fat, partition type 0xb
save defalt
makeactive
chainloader +1

Grub Loading stage 2

Grub loading, please wait...
Error 18

  O outro problema, que é mais estetico, e que o icone de drive que fica no computador que representa o windows esta com um simbolo estranho ao inves do nome, o simbolo é .


  Segue o meu fstab:

Citar
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/hda2       /               ext3    defaults,errors=remount-ro 0       1
/dev/hda5       none            swap    sw              0       0
#/dev/hda1       /media/hda1     ntfs    defaults,nls=utf8,umask=007,gid=46 0       1
/dev/hda1    /media/windows vfat  iocharset=utf8,umask=000  0    0
« Última modificação: 14 de Setembro de 2006, 18:24 por zackshinra »
"Ao se deparar com um problema, a primeira atitude deve ser a busca de soluções, e não a de culpados."
Lauro Adriano

arlei

  • Visitante
Re: Não consigo inicializar o Windows pelo Grub
« Resposta #1 Online: 13 de Setembro de 2006, 13:55 »
Edite seu menu.lst e tente configurar a partida do windows da forma como abaixo segue:

Citar
title   Microsoft Windows XP Professional
   rootnoverify (hd0,0)
   chainloader +1

O parâmetro rootnoverify especifica a partição root do sistema, mas ao contrário da opção root, não monta a partição.
Como o boot do Windows é direto e não precisa ser carregado um kernel pelo GRUB (ele tem seu próprio carregador), então não é necessário montar a partição do Windows.

T+
Arlei

Offline LedStyle

  • Usuário Ubuntu
  • *
  • Mensagens: 1.345
    • Ver perfil
    • http://www.tuxresources.org
Re: Não consigo inicializar o Windows pelo Grub
« Resposta #2 Online: 14 de Setembro de 2006, 10:55 »
Não seria (hd0,1) ???

arlei

  • Visitante
Re: Não consigo inicializar o Windows pelo Grub
« Resposta #3 Online: 14 de Setembro de 2006, 11:39 »
Não seria (hd0,1) ???

Olha LedStyle,

agora vc me deixou com a pulga atrás da orelha. ???
Mais seguindo a lógica da classificação adotada pelo Grub, onde hd0 é o primeiro HD (IDE1 Master) acredito que a primeira partição desse HD será a partição 0 (zero), por isso hd0,0.

T+
Arlei

Offline zackshinra

  • Usuário Ubuntu
  • *
  • Mensagens: 308
    • Ver perfil
Re: Não consigo inicializar o Windows pelo Grub
« Resposta #4 Online: 14 de Setembro de 2006, 12:09 »
  Valeu pala ajuda pessoal, mas nada feito :-[.

  O erro persiste:
Citar
rootnoverify (hd0,0)
chain loader +1

Grub Loading stage 2

Grub Loading, please wait...
Error 18

  Estou postando o menu.lst na integra:
Citar
# menu.lst - See: grub(8), info grub, update-grub(8)
#            grub-install(8), grub-floppy(8),
#            grub-md5-crypt, /usr/share/doc/grub
#            and /usr/share/doc/grub-doc/.
#splashimage (hd0,1)/boot/grub/images/nome-do-arquivo
splashimage (hd0,1)/boot/grub/imagens/17871-ubuntu_snow.xpm.gz

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not change this entry to 'saved' or your
# array will desync and will not let you boot your system.
default      0

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout      5

## hiddenmenu
# Hides the menu by default (press ESC to see the menu)
#hiddenmenu

# Pretty colours
#color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line)  and entries protected by the
# command 'lock'
# e.g. password topsecret
#      password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title      Windows 95/98/NT/2000
# root      (hd0,0)
# makeactive
# chainloader   +1
#
# title      Linux
# root      (hd0,1)
# kernel   /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
##      kopt_2_6_8=root=/dev/hdc1 ro
##      kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=/dev/hda2 ro

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,1)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
##      alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
##      lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
##      altoptions=(recovery mode) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
##      howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
##      memtest86=false
# memtest86=true

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## ## End Default Options ##

title      Ubuntu, kernel 2.6.15-26-386
root      (hd0,1)
kernel      /boot/vmlinuz-2.6.15-26-386 root=/dev/hda2 ro quiet splash
initrd      /boot/initrd.img-2.6.15-26-386
savedefault
boot

title      Ubuntu, kernel 2.6.15-26-386 (recovery mode)
root      (hd0,1)
kernel      /boot/vmlinuz-2.6.15-26-386 root=/dev/hda2 ro single
initrd      /boot/initrd.img-2.6.15-26-386
boot

title      Ubuntu, kernel 2.6.15-23-386
root      (hd0,1)
kernel      /boot/vmlinuz-2.6.15-23-386 root=/dev/hda2 ro quiet splash
initrd      /boot/initrd.img-2.6.15-23-386
savedefault
boot

title      Ubuntu, kernel 2.6.15-23-386 (recovery mode)
root      (hd0,1)
kernel      /boot/vmlinuz-2.6.15-23-386 root=/dev/hda2 ro single
initrd      /boot/initrd.img-2.6.15-23-386
boot

title      Ubuntu, memtest86+
root      (hd0,1)
kernel      /boot/memtest86+.bin
boot

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
#title      Other operating systems:
#root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/hda1
title   Microsoft Windows XP Professional
rootnoverify (hd0,0)
chainloader +1

  Procurei no google sobre este "Erro 18", mas não tive muito sucesso. Um site que esta fora do ar, e um que exige ser assinante para ver a resolução dos problemas.

  Vou dar um tempo, se nada der certo, vou re-instalar o Ubuntu.
"Ao se deparar com um problema, a primeira atitude deve ser a busca de soluções, e não a de culpados."
Lauro Adriano

arlei

  • Visitante
Re: Não consigo inicializar o Windows pelo Grub
« Resposta #5 Online: 14 de Setembro de 2006, 12:51 »
zackshinra,

de mais um tempinho na tua reinstalação que ao chegar em casa mais tarde vejo como meu grub esta configurado e tento te ajudar em mais alguma coisa.

T+
Arlei

Offline zackshinra

  • Usuário Ubuntu
  • *
  • Mensagens: 308
    • Ver perfil
Re: Não consigo inicializar o Windows pelo Grub
« Resposta #6 Online: 14 de Setembro de 2006, 16:30 »
  Valeu pelo empenho em me ajudar.

  Dei uma nova procurado no google pelo erro 18 e encontrei o seguinte:
Citar
Aparece o erro 18, que segundo o manual do grub é:

18 : Selected cylinder exceeds maximum supported by BIOS
This error is returned when a read is attempted at a linear block address beyond the end of the BIOS translated area. This generally happens if your disk is larger than the BIOS can handle (512MB for (E)IDE disks on older machines or larger than 8GB in general).

  Achei isso no site: http://www.fedora.org.br/post15464.html

  Traduzindo este erro no Altavista:
Citar
18: O cilindro selecionado excede o máximo suportado por BIOS que este erro é retornado quando lido é tentado em um endereço linear do bloco além do fim da área traduzida BIOS. Isto acontece geralmente se seu disco for maior do que o BIOS pode segurar (512MB para (discos de E)IDE em máquinas mais velhas ou maior do que 8GB no general).

  Não entendi muito bem o que seria isso, mas deve ser relacionado ao windows instalado ( eu o instalei com pouco espaço - 5.86 Gb).



 
« Última modificação: 14 de Setembro de 2006, 16:43 por zackshinra »
"Ao se deparar com um problema, a primeira atitude deve ser a busca de soluções, e não a de culpados."
Lauro Adriano

arlei

  • Visitante
Re: Não consigo inicializar o Windows pelo Grub
« Resposta #7 Online: 14 de Setembro de 2006, 17:48 »
O amigão seguinte,

tô no meu Ubuntu em casa agora e fui conferir meu menu.lst e a entrada para bootar o windows esta assim:

Citar
title      MS-Windows XP Pirated Edition
root      (hd0,0)
savedefault
makeactive
chainloader   +1

Sobre isso que vc achou, ja tinha lido algo a respeito e me recordo agora que existe um parâmetro para ser adicionado ao menu.lst para estas situações, só não me recordo que parâmetro, mais vou continuar pesquisando e retorno se encontrar algo.

T+
Arlei

Offline zackshinra

  • Usuário Ubuntu
  • *
  • Mensagens: 308
    • Ver perfil
Re: Não consigo inicializar o Windows pelo Grub
« Resposta #8 Online: 14 de Setembro de 2006, 18:23 »
 ;D ;D ;D ;D ;D ;D ;D

  Consegui.

  Fiz o seguinte:
-> Instalei o Grub em um disquete: http://ubuntuforum-pt.org/index.php?topic=8323.0
-> Re-instalei o Windows com cerca de 8 Gb. Ntfs desta vez.
-> Entrei no ubuntu pelo disquete e re-instalei o Grub: http://breezy.ubuntuguidebrasil.org/#restoregrubmenuafterwindowsinstallation

  Valeu pela ajuda Arlei.
 
"Ao se deparar com um problema, a primeira atitude deve ser a busca de soluções, e não a de culpados."
Lauro Adriano

arlei

  • Visitante
Re: Resolvido: Não consigo inicializar o Windows pelo Grub
« Resposta #9 Online: 14 de Setembro de 2006, 18:29 »
blz!!!  ;)

T+
Arlei