Autor Tópico: Problemas instalar Ubuntu 12.04 em HD Externo Sata conectado na USB..!!  (Lida 4484 vezes)

Offline Arthur Bernardes

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re: Problemas instalar Ubuntu 12.04 em HD Externo Sata conectado na USB..!!
« Resposta #15 Online: 24 de Fevereiro de 2013, 12:07 »
Tem dados importantes no seu HD Externo..? Se não tiver, crie uma nova tabela de partição..! Crie as partições de raiz "/" e de /swap..!

Instale o Grub no disco..! Veja se deu certo.

Offline zerocoolroot

  • Usuário Ubuntu
  • *
  • Mensagens: 23
    • Ver perfil
Re: Problemas instalar Ubuntu 12.04 em HD Externo Sata conectado na USB..!!
« Resposta #16 Online: 24 de Fevereiro de 2013, 12:12 »
Tem dados importantes no seu HD Externo..? Se não tiver, crie uma nova tabela de partição..! Crie as partições de raiz "/" e de /swap..!

Instale o Grub no disco..! Veja se deu certo.

Não há qualquer tipo de dados no HD, ele está totalmente zerado.

Quando tentei efetuar a instalação fiz as partições /boot, /, /home e swap. Ele faz toda instalação normalmente, mas quando vai no processo grub-install ele da a falha conforme imagem do início do post..!!

Estranho é que faço o mesmo procedimento na versão 12.10 e não ocorre este erro..!! Isso que fico intrigado..!!
Notebook Samsung RF511-SD4 / Intel Core i5 2ª Geração 2.50Ghz Sandy Bridge Overclock 3.0Ghz / 1TB HD Samsung / 8GB Memória Corsair DDR3 1333Mhz / Placa Video 2GB Dedicada NVidia Híbrida

Offline Arthur Bernardes

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re: Problemas instalar Ubuntu 12.04 em HD Externo Sata conectado na USB..!!
« Resposta #17 Online: 24 de Fevereiro de 2013, 12:32 »
Instale assim ==>

Partição 1 ==> Raiz "/"
Partição 2 ==> Home "/home"
Partição 3 ==> Swap "/swap"

Tente assim..! Instale o Grub na MBR do Disco, não na partição Raiz.!

Offline zerocoolroot

  • Usuário Ubuntu
  • *
  • Mensagens: 23
    • Ver perfil
Re: Problemas instalar Ubuntu 12.04 em HD Externo Sata conectado na USB..!!
« Resposta #18 Online: 24 de Fevereiro de 2013, 14:25 »
Instale assim ==>

Partição 1 ==> Raiz "/"
Partição 2 ==> Home "/home"
Partição 3 ==> Swap "/swap"

Tente assim..! Instale o Grub na MBR do Disco, não na partição Raiz.!

Arthur Bernardes, boa tarde..!!

Seguinte, eu estava fazendo da seguinte forma:

Partição 1 ==> Boot "/boot" Aqui que dava o erro quando o grub-install tentava instalar.
Partição 2 ==> Raiz "/"
Partição 3 ==> Home "/home"
Partição 4 ==> Swap "/swap"

Foi então que fiz de acordo com o que você disse, ou seja:

Partição 1 ==> Raiz "/"
Partição 2 ==> Home "/home"
Partição 3 ==> Swap "/swap"

Instalei o grub na MBR do disco conforme você mesmo disse e funcionou perfeitamente..!! Pensei já ter tentado de tudo menos instalar o grub na MBR. Estava instalando na Partição /boot que criei..!!

Fico mutio grato pelo seu apoio caro amigo,

Podem dar o caso como resolvido..!!

Abraços..!!
Notebook Samsung RF511-SD4 / Intel Core i5 2ª Geração 2.50Ghz Sandy Bridge Overclock 3.0Ghz / 1TB HD Samsung / 8GB Memória Corsair DDR3 1333Mhz / Placa Video 2GB Dedicada NVidia Híbrida