Autor Tópico: Vídeos rodando muito lentos no smplayer, vlc, totem  (Lida 15955 vezes)

Offline ubu4ever

  • Usuário Ubuntu
  • *
  • Mensagens: 695
    • Ver perfil
Vídeos rodando muito lentos no smplayer, vlc, totem
« Online: 05 de Abril de 2013, 12:46 »
Pessoal,

Estou com um problema frustrante. Eu tinha o Xubuntu 12.10 x32 Quantal instalado e os vídeos rodavam com alguns cortes na tela em senas de velocidade mas nada que atrapalhasse a visualização. Por diversos motivos e pela versão 12.04.2 ser LTS eu fiz o downgrade e realizei uma instalação "limpa" (do zero - removi todos os arquivos de configuração ocultos antes de instalar através do liveusb).

O problema é que agora meus vídeos em  720p HD estão rodando muito lentos ou travando no meio da exibição não importa o player: VLC, SMPlayer ou Totem.

Meu netbook é um Acer Aspire One 722/AMD C-60 Dual Core 1.0Ghz/2GB de RAM/Radeon HD 6290
Driver de vídeo: Catalyst 13.1 final baixada do site da AMD.

Aí vão alguns comandos para auxiliar:
lspci
Código: [Selecionar]
00:00.0 Host bridge: Advanced Micro Devices [AMD] Family 14h Processor Root Complex
00:01.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Wrestler [Radeon HD 6290]
00:01.1 Audio device: Advanced Micro Devices [AMD] nee ATI Wrestler HDMI Audio [Radeon HD 6250/6310]
00:11.0 SATA controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode]
00:12.0 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:12.2 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:13.0 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:13.2 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:14.0 SMBus: Advanced Micro Devices [AMD] nee ATI SBx00 SMBus Controller (rev 42)
00:14.2 Audio device: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA) (rev 40)
00:14.3 ISA bridge: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 LPC host controller (rev 40)
00:14.4 PCI bridge: Advanced Micro Devices [AMD] nee ATI SBx00 PCI to PCI Bridge (rev 40)
00:15.0 PCI bridge: Advanced Micro Devices [AMD] nee ATI SB700/SB800/SB900 PCI to PCI bridge (PCIE port 0)
00:15.2 PCI bridge: Advanced Micro Devices [AMD] nee ATI SB900 PCI to PCI bridge (PCIE port 2)
00:15.3 PCI bridge: Advanced Micro Devices [AMD] nee ATI SB900 PCI to PCI bridge (PCIE port 3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 0 (rev 43)
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 1
00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 2
00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 3
00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 4
00:18.5 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 6
00:18.6 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 5
00:18.7 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 7
06:00.0 Ethernet controller: Atheros Communications Inc. AR8152 v2.0 Fast Ethernet (rev c1)
07:00.0 Network controller: Atheros Communications Inc. AR9485 Wireless Network Adapter (rev 01)

uname -a
Código: [Selecionar]
Linux NETUBU 3.2.0-39-generic #62-Ubuntu SMP Wed Feb 27 22:05:17 UTC 2013 i686 athlon i386 GNU/Linux
sudo lshw -C video
Código: [Selecionar]
[sudo] password for ****:
  *-display              
       descrição: VGA compatible controller
       produto: Wrestler [Radeon HD 6290]
       fabricante: Hynix Semiconductor (Hyundai Electronics)
       physical id: 1
       informações do barramento: pci@0000:00:01.0
       versão: 00
       largura: 32 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
       configuração: driver=fglrx_pci latency=0
       recursos: irq:42 memória:80000000-8fffffff ioport:4000(tamanho=256) memória:90400000-9043ffff

EDIÇÃO:

Eu fiz o downgrade para o Xubuntu 12.04.2 LTS.
« Última modificação: 05 de Abril de 2013, 14:03 por ubu4ever »

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: Vídeos rodando muito lentos no smplayer, vlc, totem
« Resposta #1 Online: 05 de Abril de 2013, 13:36 »
Ola

Não vou ajudar em nada, mas apenas postar uns questionamentos:

1) A inteface do XUbuntu 12.10 é muito mais leve que a do Gnome-Unity 12.04

2) Os drivers de sua placa ATI Radeon no 12.04 podem não ser tão atualizados/aperfeiçoados do que os da versão 12.10

3) A versão do kernel do 12.04 pode ser diferente da do 12.10 e por isto ter modulos não tão melhorados para sua placa gráfica

Considere estes fatores, um deles ou mais de um podem ser os responsáveis pelo sintoma apresentado.

Você pode tentar usar o Unity 2D, ou o Gnome-shell bem como instalar um kernel mais recente para testar e ver se o simtoma melhora/resolve.

[]'s
« Última modificação: 05 de Abril de 2013, 13:38 por Tota »

Offline HerrSchafer

  • Usuário Ubuntu
  • *
  • Mensagens: 135
  • Sempre aprendendo... isso evita o Alzhimmer!
    • Ver perfil
Re: Vídeos rodando muito lentos no smplayer, vlc, totem
« Resposta #2 Online: 05 de Abril de 2013, 13:57 »
http://www.ubuntubrsc.com/xorg-edgers-melhore-performance-da-sua-placa-de-video-ubuntu.html

Neste link há uma dica para adicionar um repositório que tem drivers atualizados; junto com os drivers, ele atualizará o kernel também.
Notebook HP Pavilion g4 Ubuntu 13.04
Intel(R) Core(TM) i3 CPU M 370 @ 2.40GHz
3GB ram 500 GB hd (ext4 tunado... tks galactus!)

Offline ubu4ever

  • Usuário Ubuntu
  • *
  • Mensagens: 695
    • Ver perfil
Re: Vídeos rodando muito lentos no smplayer, vlc, totem
« Resposta #3 Online: 05 de Abril de 2013, 14:04 »
Acho que não fui claro no primeiro post. Eu fiz o downgrade para o Xubuntu 12.04.2 LTS.

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: Vídeos rodando muito lentos no smplayer, vlc, totem
« Resposta #4 Online: 05 de Abril de 2013, 14:48 »
Ok, então ainda valem os ítens 2) e 3).

[]'s

Offline ubu4ever

  • Usuário Ubuntu
  • *
  • Mensagens: 695
    • Ver perfil
Re: Vídeos rodando muito lentos no smplayer, vlc, totem
« Resposta #5 Online: 05 de Abril de 2013, 15:07 »
Essa lentidão só acontece nos vídeos em HD (720p). Abaixo disso fica ótimo e sem travamentos ou lentidão.

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: Vídeos rodando muito lentos no smplayer, vlc, totem
« Resposta #6 Online: 05 de Abril de 2013, 16:02 »
Bom, ai complica!!!

Os restricted-extras estão instalados?

Realmente se os codecs estiverem ok, é driver de video mesmo...

[]'s

Offline ubu4ever

  • Usuário Ubuntu
  • *
  • Mensagens: 695
    • Ver perfil
Re: Vídeos rodando muito lentos no smplayer, vlc, totem
« Resposta #7 Online: 05 de Abril de 2013, 17:55 »
Bom, ai complica!!!

Os restricted-extras estão instalados?

Realmente se os codecs estiverem ok, é driver de video mesmo...

[]'s

Eu não instalei porque uso o SMPlayer. Preciso instalar?

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: Vídeos rodando muito lentos no smplayer, vlc, totem
« Resposta #8 Online: 05 de Abril de 2013, 18:14 »
Bom, o codec H.264 para "tocar" alta definição está no restricted não?

Se não fizer bem, mal não faz instalar.

[]'s

Offline ubu4ever

  • Usuário Ubuntu
  • *
  • Mensagens: 695
    • Ver perfil
Re: Vídeos rodando muito lentos no smplayer, vlc, totem
« Resposta #9 Online: 05 de Abril de 2013, 18:19 »
Instalei os codecs conforme o artigo abaixo: lembrando que os pacotes instalados foram os do Precise (12.04). O artigo é sobre o Quantal.

http://www.ubuntubrsc.com/que-fazer-apos-instalar-ubuntu-12-10-quantal-quetzal.html

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: Vídeos rodando muito lentos no smplayer, vlc, totem
« Resposta #10 Online: 05 de Abril de 2013, 18:31 »
E como ficou?

Offline ubu4ever

  • Usuário Ubuntu
  • *
  • Mensagens: 695
    • Ver perfil
Re: Vídeos rodando muito lentos no smplayer, vlc, totem
« Resposta #11 Online: 05 de Abril de 2013, 18:48 »
E como ficou?

Não adiantou para o SMPlayer e VLC mas instalei o Totem e ele está reproduzindo com lags menores.

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: Vídeos rodando muito lentos no smplayer, vlc, totem
« Resposta #12 Online: 05 de Abril de 2013, 19:59 »
Bem, agora é "afinar" a placa de video.

E se instalar o kernel do 12.10 ou algumais novo como o 3.8?

Ou algum mais novo que suporte o seu driver?

Faça um teste, se não melhorar remova o kernel

Faça outro teste, rode os 720p em janela e não em tela cheia, quanto menor a janela menos lag? Isto indicaria realmente aceleração de video, o que comprovaria ser deiver de video.

[]'s
« Última modificação: 05 de Abril de 2013, 20:02 por Tota »

Offline ubu4ever

  • Usuário Ubuntu
  • *
  • Mensagens: 695
    • Ver perfil
Re: Vídeos rodando muito lentos no smplayer, vlc, totem
« Resposta #13 Online: 06 de Abril de 2013, 00:08 »
Estou pensando em testar o kernel 3.8.6 que está neste ppa (Raring)
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8.6-raring/

Ou o vanilla seria melhor?

EDIÇÃO:

Porque estou com o kernel 3.2 se o 3.4 (para o Precise) já está no ppa em versão estável?
« Última modificação: 06 de Abril de 2013, 00:26 por ubu4ever »

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: Vídeos rodando muito lentos no smplayer, vlc, totem
« Resposta #14 Online: 06 de Abril de 2013, 10:00 »
O repositorio proposed está habilitado?

[]'s