Autor Tópico: Instalar o XFCE (resolvido)  (Lida 40697 vezes)

Offline Serj Tankian

  • Usuário Ubuntu
  • *
  • Mensagens: 291
  • "I’ll wait here Lost in Hollywood
    • Ver perfil
    • Forum de informática com muitas dicas e suporte a você
Re: Instalar o XFCE
« Resposta #15 Online: 16 de Setembro de 2006, 17:11 »
Assim ó, eu queria instalar um ubuntu peladão, sem todos os programas que vem nele, como jogos, escritório, internet... até mesmo sem ambiente gráfico, pq daí depois de instalado o basicão eu ia e instalava um ambiente gráfico (XFCE), e alguns proigramas necessários...

Na instalação em modo texto a internet é configurada durante a instalação. É necessário apenas apertar uns botões. Depois disso, você tem que usar o vi pra editar o source.list e descomentar os repositorios da internet que são comentados por padrão. Depois é só dar um apt-get update e instalar o pacote mc. Esse pacote tem o mcedit, um editor em modo texto que é muito mais amigável que o vi. Com ele, você configura todo o resto.

Pra instalar o XFCE, além do sistema básico em modo texto, você precisa instalar outros pacotes como, por exemplo, o binário e o devel do servidor X. É claro que o XFCE precisa do X, né? ;-)

Contudo, não acho vantagem nisso. O XFCE não tem muitos programas nativos. Assim, você teria que continuar usando o gedit, Gnomebaker, gaim, etc, etc. Pra instalar esses programas você precisaria das bibliotecas do Gnome. Sendo assim, acho melhor instalar Ubuntu normal, em modo gráfico. Depois disso você instala o XFCE a partir dos fontes.

Daí... De vez em quando, você pode logar no Gnome só pra ver o quanto o XFCE é mais rápido. :-)

eu entendo sua posição com relação aos aplicativos nativos XFCE, e tbm acho que quase não vale à pena instalar o ubuntu peladão, e depois implementar (que não seja para estudo msm), mas o problema é que, se eu instalo o ubuntu normal, e depois instalo outro ambiente gráfico (seja XFCE ou KDE) meus aplicativos 3D no gnome (jogos..) e players de vídeo (diferentes formatos) ficam ridículos, ou seja, jogos ficam com lag que antes não tinha e vídeos não tocam, ficam como se o player quisece travar... tanto no gnome ou na outra ambiente gráfico.

se eu conseguisse resolver este dilema, não tenha dúvidas, era um sudo apt-get install xxxx-desktop e boas, mas são os problemas àcima que atam minhas mãos.
"Viva!! Viva!! Viva a Sociedade Alternativa! À lei do forte, esta é a nossa lei e alegria do mundo!! Viva!! Viva!!"

Offline Blakermago

  • Usuário Ubuntu
  • *
  • Mensagens: 26
    • Ver perfil
Re: Instalar o XFCE
« Resposta #16 Online: 17 de Setembro de 2006, 23:21 »
Eu instalei o XFCE 4.4 RC1, ele ta muito bom mesmo, mas eu to com um problema ele está dando erro na hora de iniciar ele dá essa mensagem

(Unable to contact the Xfce Trash service.

Make sure you have a file manager installed that supports the Xfce Trash service, such as Thunar.)

Alguem tem uma ideia pra me ajudar!!!!!

Offline AlexBR

  • Usuário Ubuntu
  • *
  • Mensagens: 391
    • Ver perfil
Re: Instalar o XFCE
« Resposta #17 Online: 18 de Setembro de 2006, 08:23 »
Eu instalei o XFCE 4.4 RC1, ele ta muito bom mesmo, mas eu to com um problema ele está dando erro na hora de iniciar ele dá essa mensagem

(Unable to contact the Xfce Trash service.

Make sure you have a file manager installed that supports the Xfce Trash service, such as Thunar.)

Alguem tem uma ideia pra me ajudar!!!!!

Esse é um erro bem conhecido. Pode ser corrigido. Dá uma olhada aqui http://forum.xfce.org/index.php?topic=2762.0

Offline Serj Tankian

  • Usuário Ubuntu
  • *
  • Mensagens: 291
  • "I’ll wait here Lost in Hollywood
    • Ver perfil
    • Forum de informática com muitas dicas e suporte a você
Re: Instalar o XFCE
« Resposta #18 Online: 18 de Setembro de 2006, 11:50 »
e quanto ao meu dilema???

eu poderia instalar qqr ambiente gráfico junto ao gnome, para escolher nas sessões na hora de logar, mas o problema é que depois de instalar outro a.g. os aplicativos 3d e videos ficam estranhos...
"Viva!! Viva!! Viva a Sociedade Alternativa! À lei do forte, esta é a nossa lei e alegria do mundo!! Viva!! Viva!!"

Offline AlexBR

  • Usuário Ubuntu
  • *
  • Mensagens: 391
    • Ver perfil
Re: Instalar o XFCE
« Resposta #19 Online: 18 de Setembro de 2006, 14:15 »
e quanto ao meu dilema???

eu poderia instalar qqr ambiente gráfico junto ao gnome, para escolher nas sessões na hora de logar, mas o problema é que depois de instalar outro a.g. os aplicativos 3d e videos ficam estranhos...

Vou falar mais uma vez! Instale o Ubuntu normal com o Gnome. Depois, ao invés de fazer apt-get install xubuntu-desktop, instale o XFCE a partir do código fonte. Instale em um diretório separado, por exemplo, /opt/xfce. Isso não mudará em nada o seu sistema.

Offline Serj Tankian

  • Usuário Ubuntu
  • *
  • Mensagens: 291
  • "I’ll wait here Lost in Hollywood
    • Ver perfil
    • Forum de informática com muitas dicas e suporte a você
Re: Instalar o XFCE
« Resposta #20 Online: 18 de Setembro de 2006, 15:04 »
e quanto ao meu dilema???

eu poderia instalar qqr ambiente gráfico junto ao gnome, para escolher nas sessões na hora de logar, mas o problema é que depois de instalar outro a.g. os aplicativos 3d e videos ficam estranhos...

Vou falar mais uma vez! Instale o Ubuntu normal com o Gnome. Depois, ao invés de fazer apt-get install xubuntu-desktop, instale o XFCE a partir do código fonte. Instale em um diretório separado, por exemplo, /opt/xfce. Isso não mudará em nada o seu sistema.

rapaz, mas é exatamente oq eu faço, meu amigo... ^^
daí eu entro nele pelo gerenciador de sessões do gnome.
mas os aplicativos 3d e videos ficam bugados :( (praga de sogra, só pode!!!)
"Viva!! Viva!! Viva a Sociedade Alternativa! À lei do forte, esta é a nossa lei e alegria do mundo!! Viva!! Viva!!"

Offline AlexBR

  • Usuário Ubuntu
  • *
  • Mensagens: 391
    • Ver perfil
Re: Instalar o XFCE
« Resposta #21 Online: 18 de Setembro de 2006, 17:49 »
rapaz, mas é exatamente oq eu faço, meu amigo... ^^
daí eu entro nele pelo gerenciador de sessões do gnome.
mas os aplicativos 3d e videos ficam bugados :( (praga de sogra, só pode!!!)

Então... Só checando... Você pegou os fontes da versão 4.4 RC1 no site do XFCE e instalou no diretório /opt/xfce e seus vídeos e jogos 3D ficaram errados? Se for isso mesmo, faça um teste... Tente desabilitar o composite nas configurações do XFCE.

Offline Serj Tankian

  • Usuário Ubuntu
  • *
  • Mensagens: 291
  • "I’ll wait here Lost in Hollywood
    • Ver perfil
    • Forum de informática com muitas dicas e suporte a você
Re: Instalar o XFCE
« Resposta #22 Online: 18 de Setembro de 2006, 18:08 »
rapaz, mas é exatamente oq eu faço, meu amigo... ^^
daí eu entro nele pelo gerenciador de sessões do gnome.
mas os aplicativos 3d e videos ficam bugados :( (praga de sogra, só pode!!!)

Então... Só checando... Você pegou os fontes da versão 4.4 RC1 no site do XFCE e instalou no diretório /opt/xfce e seus vídeos e jogos 3D ficaram errados? Se for isso mesmo, faça um teste... Tente desabilitar o composite nas configurações do XFCE.

farei isso (composite)
"Viva!! Viva!! Viva a Sociedade Alternativa! À lei do forte, esta é a nossa lei e alegria do mundo!! Viva!! Viva!!"

Offline Serj Tankian

  • Usuário Ubuntu
  • *
  • Mensagens: 291
  • "I’ll wait here Lost in Hollywood
    • Ver perfil
    • Forum de informática com muitas dicas e suporte a você
Re: Instalar o XFCE
« Resposta #23 Online: 18 de Setembro de 2006, 18:39 »
Seguindo o tutorial do link aqui: http://www.guiaubuntupt.org/wiki/index.php/Ubuntu_dapper#Como_instalar_as_vers.C3.B5es_XFCE_4.4_preview_.284.3.90.1.29

eu comecei:

baixei a versão mais recente: 4.4RC1

Tentei colcar o comando abaixo inteirão no terminal e dei enter:

Citar
sudo apt-get install build-essential gcc pkg-config libglib2.0-0 \
     libglib2.0-dev libgtk2.0-0 libgtk2.0-dev libxml++2.6c2a libxml++2.6-dev \
     libvte-dev libvte4 a2ps libxpm-dev libxpm4 alsa-source alsa alsa-base \
     alsa-oss alsa-utils libxml-parser-perl libpng12-0 libpng12-dev libdbh1.0-dev

Mas, olha o que me retorna:
Citar

unix@fortaleza-digital:~$ sudo apt-get install build-essential gcc pkg-config libglib2.0-0 \
>      libglib2.0-dev libgtk2.0-0 libgtk2.0-dev libxml++2.6c2a libxml++2.6-dev \>      libvte-dev libvte4 a2ps libxpm-dev libxpm4 alsa-source alsa alsa-base \
>      alsa-oss alsa-utils libxml-parser-perl libpng12-0 libpng12-dev libdbh1.0-dev
Lendo Lista de Pacotes... Pronto
Construindo Árvore de Dependências... Pronto
pkg-config já é a versão mais nova.
libglib2.0-0 já é a versão mais nova.
libgtk2.0-0 já é a versão mais nova.
libvte4 já é a versão mais nova.
libxpm4 já é a versão mais nova.
Nota, selecionando alsa-base ao invés de alsa
alsa-base já é a versão mais nova.
alsa-base já é a versão mais nova.
alsa-utils já é a versão mais nova.
libpng12-0 já é a versão mais nova.
Você deve querer rodar `apt-get -f install' para corrigir isso:
Os pacotes a seguir têm dependências desencontradas:
  alsa-source: Depende: make mas não vai ser instalado
               Depende: dpkg-dev mas não vai ser instalado
               Depende: debhelper (>= 4.0.0) mas não vai ser instalado
               Depende: debconf-utils mas não vai ser instalado
  build-essential: Depende: libc6-dev mas não vai ser instalado ou
                            libc-dev
                   Depende: g++ (>= 4:4.0) mas não vai ser instalado
                   Depende: make mas não vai ser instalado
                   Depende: dpkg-dev (>= 1.13.5) mas não vai ser instalado
  cgwd: Depende: compiz-plugins (>= 0.2) mas não vai ser instalado ou
                 compiz-vanilla mas não vai ser instalado
  compiz-manager: Depende: compiz-core (>= 0.0.13.48) mas não vai ser instalado
                  Depende: compiz-plugins (>= 0.20-0ubuntu1) mas não vai ser instalado
  csm: Depende: compiz-plugins (>= 0.15) mas não vai ser instalado
  gcc: Depende: cpp (>= 4:4.0.3-1) mas não vai ser instalado
       Depende: gcc-4.0 (>= 4.0.3) mas não vai ser instalado
  libdbh1.0-dev: Depende: libdbh1.0-1 (= 1.0.24-1) mas não vai ser instalado
  libglib2.0-dev: Depende: libc6-dev mas não vai ser instalado ou
                           libc-dev
  libgtk2.0-dev: Depende: libpango1.0-dev (>= 1.10.0-2) mas não vai ser instalado
                 Depende: libatk1.0-dev (>= 1.9.0) mas não vai ser instalado
                 Depende: libcairo2-dev mas não vai ser instalado
                 Depende: libx11-dev mas não vai ser instalado
                 Depende: libxext-dev mas não vai ser instalado
                 Depende: libxinerama-dev mas não vai ser instalado
                 Depende: libxi-dev mas não vai ser instalado
                 Depende: libxrandr-dev mas não vai ser instalado
                 Depende: libxcursor-dev mas não vai ser instalado
                 Depende: libxfixes-dev mas não vai ser instalado
  libpng12-dev: Depende: zlib1g-dev mas não vai ser instalado
  libvte-dev: Depende: libncurses5-dev mas não vai ser instalado
              Depende: libxrender-dev mas não vai ser instalado
              Depende: libxft-dev mas não vai ser instalado
              Depende: libfreetype6-dev mas não vai ser instalado
              Depende: libatk1.0-dev mas não vai ser instalado
              Depende: libpango1.0-dev mas não vai ser instalado
              Depende: libsm-dev mas não vai ser instalado
              Depende: libice-dev mas não vai ser instalado
              Depende: zlib1g-dev mas não vai ser instalado
              Depende: libncurses5-dev mas não vai ser instalado ou
                       libncurses-dev
              Depende: libx11-dev mas não vai ser instalado
              Depende: libfontconfig1-dev mas não vai ser instalado
  libxml++2.6-dev: Depende: libc6-dev mas não vai ser instalado
                   Depende: libxml2-dev (>= 2.6.1) mas não vai ser instalado
                   Depende: libglibmm-2.4-dev mas não vai ser instalado
                   Depende: libstdc++-dev
  libxml++2.6c2a: Depende: libglibmm-2.4-1c2a mas não vai ser instalado
  libxml-parser-perl: Depende: liburi-perl mas não vai ser instalado
                      Depende: libwww-perl mas não vai ser instalado
  libxpm-dev: Depende: libx11-dev mas não vai ser instalado
              Depende: x11proto-core-dev mas não vai ser instalado
E: Dependências desencontradas. Tente `apt-get -f install' sem nenhum pacote (ou especifique uma solução).

eu nem mexi no pacote tar.bz2 que baixei do XFCE ainda, oq devo fazer? (como proceder?)

"Viva!! Viva!! Viva a Sociedade Alternativa! À lei do forte, esta é a nossa lei e alegria do mundo!! Viva!! Viva!!"

Offline Serj Tankian

  • Usuário Ubuntu
  • *
  • Mensagens: 291
  • "I’ll wait here Lost in Hollywood
    • Ver perfil
    • Forum de informática com muitas dicas e suporte a você
Re: Instalar o XFCE
« Resposta #24 Online: 19 de Setembro de 2006, 09:43 »
Olha só:
entrei como root
peguei o run previamente baixado da ultima versão
criei um diretório XFCE em opt
fui até lá
levei o run comigo pra lá.
e dei o coimando abaixo que retornou a falta de glib:

Citar
root@fortaleza-digital:/opt/xfce# sh xfce4-4.4RC1-installer.run
Verifying file integrity... OK.
Extracting the installer... OK.
Checking for usable C compiler... gcc
Checking for usable C++ compiler... g++
Checking for GNU make... GNUmake
Checking for package config tool... pkg-config
Checking for GLib (GModule) >= 2.6.0... not found, see /root/.xfce4.installer-lo g for details
Cleaning up... OK.

o bonito é que, como root, não há gerenciador de pacotes synaptic no menu administração... se eu entrar no editor de menu ele está marcado,. mas não aparece :(

vejam o arquivo de log gerado:

Citar
##
## Started installation of xfce4 at 09:36h
##
## Visit http://forum.xfce.org/ if you have problems using this installer.
##

# Environment variables
PATH is set to "/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games:/bin:/usr/bin:/usr/local/ssl/bin:/usr/local/bin:/opt/openssl/bin:/usr/local/openssl/bin:/usr/pkg/bin:/usr/ucb:/usr/X11R6/bin:/usr/X11R6/bin:/usr/openwin/bin:/usr/local/bin:/opt/local/bin:/usr/pkg/bin:/opt/gnome2/bin:/opt/gnome/bin:/opt/xfce4/bin:/opt/xfce/bin:/root/local/bin:/root/xfce/bin:/root/xfce4/bin"
PKG_CONFIG_PATH is set to ":/usr/lib/pkgconfig:/usr/lib/pkgconfig"

## Checking for usable C compiler
gcc --version
/tmp/xfce4-4.4RC1-installer/bootstrap.sh: line 36: gcc: comando não encontrado
## Checking for usable C++ compiler
g++ --version
/tmp/xfce4-4.4RC1-installer/bootstrap.sh: line 57: g++: comando não encontrado
## Checking for GNU make
gmake --version
make --version
gnumake --version
GNUmake --version
/tmp/xfce4-4.4RC1-installer/bootstrap.sh: line 82: GNUmake: comando não encontrado

## Checking for package config tool
pkg-config --version
0.20

## Checking for GLib (GModule) >= 2.6.0
pkg-config --atleast-version=2.6.0 glib-2.0 gmodule-2.0
!! Please install GLib 2.6.0 or above and the GLib development files. It is
!! important that you install GModule, which is part of GLib as well. GLib
!! can be downloaded from http://www.gtk.org/.
« Última modificação: 19 de Setembro de 2006, 09:45 por Serj Tankian »
"Viva!! Viva!! Viva a Sociedade Alternativa! À lei do forte, esta é a nossa lei e alegria do mundo!! Viva!! Viva!!"

Offline Blakermago

  • Usuário Ubuntu
  • *
  • Mensagens: 26
    • Ver perfil
Re: Instalar o XFCE
« Resposta #25 Online: 19 de Setembro de 2006, 09:54 »
Seguindo o tutorial do link aqui: http://www.guiaubuntupt.org/wiki/index.php/Ubuntu_dapper#Como_instalar_as_vers.C3.B5es_XFCE_4.4_preview_.284.3.90.1.29

eu comecei:

baixei a versão mais recente: 4.4RC1

Tentei colcar o comando abaixo inteirão no terminal e dei enter:

Citar
sudo apt-get install build-essential gcc pkg-config libglib2.0-0 \
     libglib2.0-dev libgtk2.0-0 libgtk2.0-dev libxml++2.6c2a libxml++2.6-dev \
     libvte-dev libvte4 a2ps libxpm-dev libxpm4 alsa-source alsa alsa-base \
     alsa-oss alsa-utils libxml-parser-perl libpng12-0 libpng12-dev libdbh1.0-dev

Mas, olha o que me retorna:
Citar

unix@fortaleza-digital:~$ sudo apt-get install build-essential gcc pkg-config libglib2.0-0 \
>      libglib2.0-dev libgtk2.0-0 libgtk2.0-dev libxml++2.6c2a libxml++2.6-dev \>      libvte-dev libvte4 a2ps libxpm-dev libxpm4 alsa-source alsa alsa-base \
>      alsa-oss alsa-utils libxml-parser-perl libpng12-0 libpng12-dev libdbh1.0-dev
Lendo Lista de Pacotes... Pronto
Construindo Árvore de Dependências... Pronto
pkg-config já é a versão mais nova.
libglib2.0-0 já é a versão mais nova.
libgtk2.0-0 já é a versão mais nova.
libvte4 já é a versão mais nova.
libxpm4 já é a versão mais nova.
Nota, selecionando alsa-base ao invés de alsa
alsa-base já é a versão mais nova.
alsa-base já é a versão mais nova.
alsa-utils já é a versão mais nova.
libpng12-0 já é a versão mais nova.
Você deve querer rodar `apt-get -f install' para corrigir isso:
Os pacotes a seguir têm dependências desencontradas:
  alsa-source: Depende: make mas não vai ser instalado
               Depende: dpkg-dev mas não vai ser instalado
               Depende: debhelper (>= 4.0.0) mas não vai ser instalado
               Depende: debconf-utils mas não vai ser instalado
  build-essential: Depende: libc6-dev mas não vai ser instalado ou
                            libc-dev
                   Depende: g++ (>= 4:4.0) mas não vai ser instalado
                   Depende: make mas não vai ser instalado
                   Depende: dpkg-dev (>= 1.13.5) mas não vai ser instalado
  cgwd: Depende: compiz-plugins (>= 0.2) mas não vai ser instalado ou
                 compiz-vanilla mas não vai ser instalado
  compiz-manager: Depende: compiz-core (>= 0.0.13.48) mas não vai ser instalado
                  Depende: compiz-plugins (>= 0.20-0ubuntu1) mas não vai ser instalado
  csm: Depende: compiz-plugins (>= 0.15) mas não vai ser instalado
  gcc: Depende: cpp (>= 4:4.0.3-1) mas não vai ser instalado
       Depende: gcc-4.0 (>= 4.0.3) mas não vai ser instalado
  libdbh1.0-dev: Depende: libdbh1.0-1 (= 1.0.24-1) mas não vai ser instalado
  libglib2.0-dev: Depende: libc6-dev mas não vai ser instalado ou
                           libc-dev
  libgtk2.0-dev: Depende: libpango1.0-dev (>= 1.10.0-2) mas não vai ser instalado
                 Depende: libatk1.0-dev (>= 1.9.0) mas não vai ser instalado
                 Depende: libcairo2-dev mas não vai ser instalado
                 Depende: libx11-dev mas não vai ser instalado
                 Depende: libxext-dev mas não vai ser instalado
                 Depende: libxinerama-dev mas não vai ser instalado
                 Depende: libxi-dev mas não vai ser instalado
                 Depende: libxrandr-dev mas não vai ser instalado
                 Depende: libxcursor-dev mas não vai ser instalado
                 Depende: libxfixes-dev mas não vai ser instalado
  libpng12-dev: Depende: zlib1g-dev mas não vai ser instalado
  libvte-dev: Depende: libncurses5-dev mas não vai ser instalado
              Depende: libxrender-dev mas não vai ser instalado
              Depende: libxft-dev mas não vai ser instalado
              Depende: libfreetype6-dev mas não vai ser instalado
              Depende: libatk1.0-dev mas não vai ser instalado
              Depende: libpango1.0-dev mas não vai ser instalado
              Depende: libsm-dev mas não vai ser instalado
              Depende: libice-dev mas não vai ser instalado
              Depende: zlib1g-dev mas não vai ser instalado
              Depende: libncurses5-dev mas não vai ser instalado ou
                       libncurses-dev
              Depende: libx11-dev mas não vai ser instalado
              Depende: libfontconfig1-dev mas não vai ser instalado
  libxml++2.6-dev: Depende: libc6-dev mas não vai ser instalado
                   Depende: libxml2-dev (>= 2.6.1) mas não vai ser instalado
                   Depende: libglibmm-2.4-dev mas não vai ser instalado
                   Depende: libstdc++-dev
  libxml++2.6c2a: Depende: libglibmm-2.4-1c2a mas não vai ser instalado
  libxml-parser-perl: Depende: liburi-perl mas não vai ser instalado
                      Depende: libwww-perl mas não vai ser instalado
  libxpm-dev: Depende: libx11-dev mas não vai ser instalado
              Depende: x11proto-core-dev mas não vai ser instalado
E: Dependências desencontradas. Tente `apt-get -f install' sem nenhum pacote (ou especifique uma solução).

eu nem mexi no pacote tar.bz2 que baixei do XFCE ainda, oq devo fazer? (como proceder?)





para instalar essas dependências você tem que habilitar todas as opções do sources.list, senão ele não encontra mesmo as dependências....

O meu aqui ta funcionando 99% so falta a parte do erro citado acima, ainda não tive tempo de arrumar ...
« Última modificação: 19 de Setembro de 2006, 09:57 por Blakermago »

Offline Serj Tankian

  • Usuário Ubuntu
  • *
  • Mensagens: 291
  • "I’ll wait here Lost in Hollywood
    • Ver perfil
    • Forum de informática com muitas dicas e suporte a você
Re: Instalar o XFCE
« Resposta #26 Online: 19 de Setembro de 2006, 10:24 »
Olha, nada que tivesse relação com estes pacotes estava comentado na sources.list, só alguns pacotes multimidia, easycam e pplayers...

mas vamos lá.

baixei o glib mais recente, em tar.bz2, e levei para o diretório xfce
descompactei e, na hora de rodar o ./configure, deu o seguinte erro:
Citar
root@fortaleza-digital:/opt/xfce/glib-2.12.3# ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... no
checking whether to enable maintainer-specific portions of Makefiles... no
checking build system type... i686-pc-linux-gnuoldld
checking host system type... i686-pc-linux-gnuoldld
checking for the BeOS... no
checking for Win32... no
checking whether to enable garbage collector friendliness... no
checking whether to disable memory pools... no
checking for gcc... no
checking for cc... no
checking for cc... no
checking for cl... no
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.

vou dar um apt-get update e depois tento instalar o run, mas é 99% de certeza que vai pedir glib!!! e o sinaptyc não está habilitado em modo root.
"Viva!! Viva!! Viva a Sociedade Alternativa! À lei do forte, esta é a nossa lei e alegria do mundo!! Viva!! Viva!!"

Offline Serj Tankian

  • Usuário Ubuntu
  • *
  • Mensagens: 291
  • "I’ll wait here Lost in Hollywood
    • Ver perfil
    • Forum de informática com muitas dicas e suporte a você
Re: Instalar o XFCE
« Resposta #27 Online: 19 de Setembro de 2006, 10:30 »
pronto, olha só que maravilha:
descomentei as belezas das linhas e deu pacote duplicado, ok, comentei de novo, atualizei e rodei o run novamente..

pede glib!!!!

e quem disse que eu consigo rodar e instalar o glib????? (erro àcima)

!!!!!
já estou de saco cheio!!
"Viva!! Viva!! Viva a Sociedade Alternativa! À lei do forte, esta é a nossa lei e alegria do mundo!! Viva!! Viva!!"

Offline AlexBR

  • Usuário Ubuntu
  • *
  • Mensagens: 391
    • Ver perfil
Re: Instalar o XFCE
« Resposta #28 Online: 19 de Setembro de 2006, 12:02 »
Olha... Eu instalei a versão 4.4 RC1 em um micro ainda ontem. É a coisa mais fácil do mundo!

Você não está conseguindo por estar fazendo duas coisas erradas. O comando a seguir...

Código: [Selecionar]
apt-get install build-essential gcc pkg-config libglib2.0-0 libglib2.0-dev libgtk2.0-0 libgtk2.0-dev libxml++2.6c2a libxml++2.6-dev libvte-dev libvte4 a2ps libxpm-dev libxpm4 alsa-source alsa alsa-base alsa-oss alsa-utils libxml-parser-perl libpng12-0 libpng12-dev libdbh1.0-dev
Deve ser executado sem os "\" no fim, ou seja, deve ser executado em uma única linha. Execute como está a cima. (Eu já havia falado isso pra você.)

Tem mais um pacote que deve ser instalado.

Código: [Selecionar]
apt-get install libdbus-glib-1-dev
Depois disso... Para instalar o XFCE, use o binário que automatiza todo o processo de instalação. É só ficar olhando pra ele. depois de uns 20 min, o XFCE está compilado e instalado. Não tem erro!

Boa sorte!

Offline Serj Tankian

  • Usuário Ubuntu
  • *
  • Mensagens: 291
  • "I’ll wait here Lost in Hollywood
    • Ver perfil
    • Forum de informática com muitas dicas e suporte a você
Re: Instalar o XFCE
« Resposta #29 Online: 19 de Setembro de 2006, 12:07 »
Vamos lá.
segui, agora, depois de tanta dependência mal resolvida (pior que aqueles caras de centro de recuperação, tem mais dependencia que eles estes pacotes!!!) o tutorial de instalação àbaixo:


Citar
Tenha certeza de ter esses pacotes e seus respectivos pacotes de desenvolvimento instalados em teu sistema:

    * pkgconfig
    * GTK+ 2.2 ou superior
    * libxml2
    * libdbh
    * librsvg 2.2.x ou superior
    * libstartup-notification 0.5 ou superior


Caso não tenha algum destes pacotes, baixe-os utilizando o apt-get. Os pacotes librsvg e libstartup-notification são opcionais.

Agora abra o terminal e faça login como super usuário. Abra o arquivo /etc/apt/sources.list com o editor de texto de sua preferência, neste caso usei o vi:

$ su
# vi /etc/apt/sources.list

Em seguida adicione os seguintes repositórios à lista:

deb http://www.os-works.com/debian testing main
deb-src http://www.os-works.com/debian testing main


Salve as alterações feitas no arquivo e feche teu editor de textos. Agora atualize o cache dos pacotes:

# apt-get update

Certo, agora se você pretende fazer a instalação completa do Xfld Desktop (incluindo xfmedia player, terminal emulator, rox file manager, painel), basta utilizar o seguinte comando:

# apt-get install -t testing xfld-desktop

Isso irá iniciar o processo de download de todos os pacotes para a instalação de seu novo ambiente desktop.

O parâmetro "-t testing" é opcional, ele apenas manda ao apt-get a ordem para buscar nos repositórios os pacotes em versão de teste (unstable por exemplo).

Agora, se você pretende apenas uma instalação dos componentes de desktop Xfce 4.2, use o seguinte comando:

# apt-get install -t testing xfce4

Reparem que, os primeiros destaques em negrito precisaram de chave publica, que eu consegui na manha ^^

o 2° negrito, "# apt-get install -t testing xfld-desktop" disse não poder instalar o xterminal, pq  "dbus-1" e "dbus-glib-1" não eram instaláveis (mas no synaptic disse que já estar instalado... vai entender)

estou tentando com "apt-get install -t testing xfce4", os pacotes estão sendo baixados, veremos no que dá!
"Viva!! Viva!! Viva a Sociedade Alternativa! À lei do forte, esta é a nossa lei e alegria do mundo!! Viva!! Viva!!"