Autor Tópico: Problemas com o Ubuntu  (Lida 8473 vezes)

Offline Ryderr

  • Usuário Ubuntu
  • *
  • Mensagens: 31
    • Ver perfil
Re: Problemas com o Ubuntu
« Resposta #15 Online: 14 de Maio de 2013, 18:22 »
aparecida@Aparecida:~$ uname -a
Linux Aparecida 3.8.1-030801-generic #201302280935 SMP Thu Feb 28 14:58:50 UTC 2013 i686 i686 i386 GNU/Linux
aparecida@Aparecida:~$
(aparecida é o nome da minha tia)

aparecida@Aparecida:~$ sudo apt-get --dry-run remove libc-dev
[sudo] password for aparecida:
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Note, a seleccionar 'libc6-dev' em vez de 'libc-dev'
Você deve querer executar 'apt-get -f install' para corrigí-los:
Os pacotes a seguir têm dependências desencontradas:
 libc6 : Depende: libc-bin (= 2.15-0ubuntu10.3) mas 2.15-0ubuntu10.4 está para ser instalado
 libc6-dev : Depende: libc6 (= 2.15-0ubuntu10.4) mas 2.15-0ubuntu10.3 está para ser instalado
E: Dependências desencontradas. Tente 'apt-get -f install' sem nenhum pacote (ou especifique uma solução).
aparecida@Aparecida:~$

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Problemas com o Ubuntu
« Resposta #16 Online: 14 de Maio de 2013, 18:32 »
Certo, a remoção não pareceu piorar nada. Vamos tentar à vera agora.

sudo apt-get remove libc6-dev

Depois vamos ver se a situação está mais sob controle.

sudo dpkg --reconfigure -a
sudo apt-get -f install
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Ryderr

  • Usuário Ubuntu
  • *
  • Mensagens: 31
    • Ver perfil
Re: Problemas com o Ubuntu
« Resposta #17 Online: 14 de Maio de 2013, 22:42 »
aparecida@Aparecida:~$ sudo apt-get remove libc6-dev
[sudo] password for aparecida:
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Você deve querer executar 'apt-get -f install' para corrigí-los:
Os pacotes a seguir têm dependências desencontradas:
 build-essential : Depende: libc6-dev mas não será instalado ou
                            libc-dev
 libc6 : Depende: libc-bin (= 2.15-0ubuntu10.3) mas 2.15-0ubuntu10.4 está para ser instalado
 libexpat1-dev : Depende: libc6-dev mas não será instalado ou
                          libc-dev
 libfreetype6-dev : Depende: libc6-dev mas não será instalado ou
                             libc-dev
 libncurses5-dev : Depende: libc-dev
 libpcre3-dev : Depende: libc6-dev mas não será instalado
 libstdc++6-4.5-dev : Depende: libc6-dev (>= 2.13-0ubuntu6) mas não será instalado
 libstdc++6-4.6-dev : Depende: libc6-dev (>= 2.13-0ubuntu6) mas não será instalado
 libtool : Depende: libc6-dev mas não será instalado ou
                    libc-dev
 libxft-dev : Depende: libc6-dev mas não será instalado ou
                       libc-dev
 lsb-core : Depende: libc6-dev mas não será instalado ou
                     libc-dev
 zlib1g-dev : Depende: libc6-dev mas não será instalado ou
                       libc-dev
E: Dependências desencontradas. Tente 'apt-get -f install' sem nenhum pacote (ou especifique uma solução).
aparecida@Aparecida:~$

Offline Renan Rischiotto

  • Usuário Ubuntu
  • *
  • Mensagens: 2.888
    • Ver perfil
Re: Problemas com o Ubuntu
« Resposta #18 Online: 14 de Maio de 2013, 22:47 »
"Tente 'apt-get -f install' sem nenhum pacote (ou especifique uma solução)."

Digita esse comando no terminal!
apt-get -f install

Offline Ryderr

  • Usuário Ubuntu
  • *
  • Mensagens: 31
    • Ver perfil
Re: Problemas com o Ubuntu
« Resposta #19 Online: 14 de Maio de 2013, 23:49 »

sudo apt-get -f install
(Lendo banco de dados ... 255747 ficheiros e directórios actualmente instalados.)
Preparando para substituir libc6 2.15-0ubuntu10.3 (usando .../libc6_2.15-0ubuntu10.4_i386.deb) ...

A copy of the C library was found in an unexpected directory:
  '/lib/i386-linux-gnu/libc-2.15.so'
It is not safe to upgrade the C library in this situation;
please remove that copy of the C library or get it out of
'/lib/i386-linux-gnu' and try again.

dpkg: erro processando /var/cache/apt/archives/libc6_2.15-0ubuntu10.4_i386.deb (--unpack):
 sub-processo novo script pre-installation retornou estado de saída de erro 1
Erros foram encontrados durante o processamento de:
 /var/cache/apt/archives/libc6_2.15-0ubuntu10.4_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)





Já usei esse comando está no 1º post.

Edit:
Achei um site ensinando a resolver um problema parece com este.
Não entendo inglês.
Se puderem me ajudar.

http://shearer.org/Debugging_Dpkg_Problems
« Última modificação: 14 de Maio de 2013, 23:58 por Ryderr »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Problemas com o Ubuntu
« Resposta #20 Online: 15 de Maio de 2013, 01:57 »
Citar
Não entendo inglês.
Isso não é mais problema há um bom tempo...
http://translate.google.com/
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Problemas com o Ubuntu
« Resposta #21 Online: 15 de Maio de 2013, 01:59 »
aparecida@Aparecida:~$ sudo apt-get remove libc6-dev
[sudo] password for aparecida:
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Você deve querer executar 'apt-get -f install' para corrigí-los:
Os pacotes a seguir têm dependências desencontradas:
 build-essential : Depende: libc6-dev mas não será instalado ou
                            libc-dev
 libc6 : Depende: libc-bin (= 2.15-0ubuntu10.3) mas 2.15-0ubuntu10.4 está para ser instalado
 libexpat1-dev : Depende: libc6-dev mas não será instalado ou
                          libc-dev
 libfreetype6-dev : Depende: libc6-dev mas não será instalado ou
                             libc-dev
 libncurses5-dev : Depende: libc-dev
 libpcre3-dev : Depende: libc6-dev mas não será instalado
 libstdc++6-4.5-dev : Depende: libc6-dev (>= 2.13-0ubuntu6) mas não será instalado
 libstdc++6-4.6-dev : Depende: libc6-dev (>= 2.13-0ubuntu6) mas não será instalado
 libtool : Depende: libc6-dev mas não será instalado ou
                    libc-dev
 libxft-dev : Depende: libc6-dev mas não será instalado ou
                       libc-dev
 lsb-core : Depende: libc6-dev mas não será instalado ou
                     libc-dev
 zlib1g-dev : Depende: libc6-dev mas não será instalado ou
                       libc-dev
E: Dependências desencontradas. Tente 'apt-get -f install' sem nenhum pacote (ou especifique uma solução).
aparecida@Aparecida:~$

Seu problema começou qdo vc tentou instalar o pacote build-essentials, certo? Remova todos os pacotes do grupo citado que terminem com "-dev". Deixe, por enquanto, o pacote "libc6", que é o centro do problema. Mais tarde vamos forçar a reinstalação dele, sozinho, pra ver se termina a pendenga.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Ryderr

  • Usuário Ubuntu
  • *
  • Mensagens: 31
    • Ver perfil
Re: Problemas com o Ubuntu
« Resposta #22 Online: 15 de Maio de 2013, 10:12 »
Não da para instalar nem desinstalar nada.
E no Google tradutor, a tradução fica muito confusa.
Não tem como substituir esses pacotes pelo Live DVD?
E também esqueci de dizer que esse problema aconteceu depois de uma atualização.
« Última modificação: 15 de Maio de 2013, 10:16 por Ryderr »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Problemas com o Ubuntu
« Resposta #23 Online: 15 de Maio de 2013, 13:14 »
Você lembra de ter mexido nos repositórios?

Execute os comandos abaixo, agora. Cole a saída completa de todos, por favor.

sudo apt-get update

sudo apt-get install --reinstall libc6

apt-cache policy libc6
apt-cache policy libc-bin

Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Ryderr

  • Usuário Ubuntu
  • *
  • Mensagens: 31
    • Ver perfil
Re: Problemas com o Ubuntu
« Resposta #24 Online: 15 de Maio de 2013, 16:42 »
sudo apt-get update:
http://pastebin.com/v3HYjxGx

sudo apt-get install --reinstall libc6:
http://pastebin.com/SjYWH8SB

apt-cache policy libc6:
http://pastebin.com/XArteQW1

apt-cache policy libc-bin:
http://pastebin.com/pCQdzW5L

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Problemas com o Ubuntu
« Resposta #25 Online: 15 de Maio de 2013, 17:55 »
Então... vejo que você tem vários repositórios ativados, inclusive alguns PPAs.

Providência numero zero: desative TODOS os PPAs, e TODOS os repositórios fora do padrão. Depois repita a tentativa de atualização da biblioteca problemática.

Há uma possibilidade de que essa monstrinha tenha vindo de algum dos repositórios customizados. Essa é a origem do problema.

Só que é uma biblioteca fundamental, é tipo a pedra que está segurando todo castelo de cartas. Um movimento errado, e tudo desaba.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Ryderr

  • Usuário Ubuntu
  • *
  • Mensagens: 31
    • Ver perfil
Re: Problemas com o Ubuntu
« Resposta #26 Online: 16 de Maio de 2013, 19:36 »
Continua o problema.
=/

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Problemas com o Ubuntu
« Resposta #27 Online: 16 de Maio de 2013, 20:47 »
Repita os últimos comandos que eu pedi, pra ver se os repositórios conflitantes saíram do caminho.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Ryderr

  • Usuário Ubuntu
  • *
  • Mensagens: 31
    • Ver perfil
Re: Problemas com o Ubuntu
« Resposta #28 Online: 17 de Maio de 2013, 21:38 »
Continua, parece que vou ter que formatar.
 :-[

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Problemas com o Ubuntu
« Resposta #29 Online: 18 de Maio de 2013, 08:14 »
A saída dos comandos que pedi...
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D