Autor Tópico: Problemas com a conexão wireless no Kubuntu 13.04  (Lida 6603 vezes)

Offline dbrand

  • Usuário Ubuntu
  • *
  • Mensagens: 29
  • "Só os corajosos é que vencem!" Jesus loves you!
    • Ver perfil
Problemas com a conexão wireless no Kubuntu 13.04
« Online: 28 de Abril de 2013, 22:33 »
Boa noite!

Atualizei meu Kubuntu para a versão 13.04, porém tem acontecido um problema com a conexão do wi fi,  pois sempre que inicio o sistema, ele não conecta automaticamente como acontecia antes e,  quando clico na conexão para fazer manualmente, ele não conecta e fica pedindo a senha que já está salva e aparece a mensagem "configurando interface". Só volta a funcionar quando eu excluo a conexão,  salvo novamente e  reinicio o notebook. Porém,  quando desligo e volto  ligar,  o problema volta de novo.

Obrigado pela atenção.

Offline dbrand

  • Usuário Ubuntu
  • *
  • Mensagens: 29
  • "Só os corajosos é que vencem!" Jesus loves you!
    • Ver perfil
Re: Problemas com a conexão wireless no Kubuntu 13.04
« Resposta #1 Online: 29 de Abril de 2013, 16:17 »
Uma outra coisa: quando o sistema inicia e o wireless conecta, o navegador não abre páginas, então tenho que repetir o processo descrito acima, ou seja, excluir a conexão, salvá-la novamente e reiniciar o sistema.

Offline iviarcio

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Re: Problemas com a conexão wireless no Kubuntu 13.04
« Resposta #2 Online: 26 de Maio de 2013, 22:16 »
Estou com o mesmo problema após migrar para o 13.04. Toda vez que inicio o sistema tenho que abrir um terminal e fazer:
sudo service network-manager stop
sudo service network-manager start

A partir dai o wireless funciona normalmente.

Alguém conhece uma solução definitiva ou como automatizar esta solução paliativa em algum arquivo de inicialização??

Grato,

Offline Arthur Bernardes

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re: Problemas com a conexão wireless no Kubuntu 13.04
« Resposta #3 Online: 26 de Maio de 2013, 23:46 »
Reinstale sudo apt-get install --reinstall network-manager, ou coloque os comandos que citou dentro do rc.local

Para entendermos o caso, execute os seguintes comandos e cole os resultados aqui.

Código: [Selecionar]
sudo lshw -C network
ifconfig -a
iwconfig
nm-tool
rfkill list wifi

Offline iviarcio

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Re: Problemas com a conexão wireless no Kubuntu 13.04
« Resposta #4 Online: 02 de Junho de 2013, 17:08 »
Reinstale sudo apt-get install --reinstall network-manager, ou coloque os comandos que citou dentro do rc.local

Para entendermos o caso, execute os seguintes comandos e cole os resultados aqui.

Código: [Selecionar]
sudo lshw -C network
ifconfig -a
iwconfig
nm-tool
rfkill list wifi

Olá Bernaders,

Eu reinstalei o network-manager e tbem coloquei os comandos no rc.local. nenhuma das alternativas funcionou.
Estou colando abaixo a resposta aos comandos que vc sugeriu.
Obrigado pelo retorno
-- Marcio

$sudo lshw -C network
  *-network
       description: Wireless interface
       product: Centrino Wireless-N 1030 [Rainbow Peak]
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlan0
       version: 34
       serial: 4c:80:93:1a:5d:ec
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=3.8.0-22-generic firmware=18.168.6.1 ip=192.168.1.107 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:50 memory:f1b00000-f1b01fff
  *-network
       description: Ethernet interface
       product: RTL8111/8168 PCI Express Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:06:00.0
       logical name: eth0
       version: 06
       serial: 84:8f:69:b6:2a:37
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl_nic/rtl8168e-2.fw latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:46 ioport:2000(size=256) memory:f1804000-f1804fff memory:f1800000-f1803fff

$ifconfig -a
eth0      Link encap:Ethernet  HWaddr 84:8f:69:b6:2a:37 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:192 errors:0 dropped:0 overruns:0 frame:0
          TX packets:192 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:14728 (14.7 KB)  TX bytes:14728 (14.7 KB)

wlan0     Link encap:Ethernet  HWaddr 4c:80:93:1a:5d:ec 
          inet addr:192.168.1.107  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::4e80:93ff:fe1a:5dec/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:63101 errors:0 dropped:0 overruns:0 frame:0
          TX packets:31431 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:75013977 (75.0 MB)  TX bytes:3525724 (3.5 MB)

$iwconfig
wlan0     IEEE 802.11bgn  ESSID:"linksys" 
          Mode:Managed  Frequency:2.412 GHz  Access Point: 00:16:B6:47:C0:C2   
          Bit Rate=48 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=42/70  Signal level=-68 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:3919   Missed beacon:0

$nmtool
NetworkManager Tool

State: connected (global)

- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            r8169
  State:             unavailable
  Default:           no
  HW Address:        84:8F:69:B6:2A:37

  Capabilities:
    Carrier Detect:  yes

  Wired Properties
    Carrier:         off


- Device: wlan0  [linksys] -----------------------------------------------------
  Type:              802.11 WiFi
  Driver:            iwlwifi
  State:             connected
  Default:           yes
  HW Address:        4C:80:93:1A:5D:EC

  Capabilities:
    Speed:           1 Mb/s

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points (* = current AP)
    HomeWireless:    Infra, 00:22:B0:8E:BB:CF, Freq 2417 MHz, Rate 54 Mb/s, Strength 49 WPA WPA2
    Spartacus:       Infra, 00:18:39:7C:97:63, Freq 2442 MHz, Rate 54 Mb/s, Strength 42 WPA
    netvirtuaba34:   Infra, 38:6B:BB:BA:90:B6, Freq 2462 MHz, Rate 54 Mb/s, Strength 24 WPA
    *linksys:        Infra, 00:16:B6:47:C0:C2, Freq 2412 MHz, Rate 54 Mb/s, Strength 51 WEP
    Time Capsule Casa: Infra, 38:6B:BB:B7:ED:83, Freq 2462 MHz, Rate 54 Mb/s, Strength 30 WPA
    nova_rede:       Infra, F8:D1:11:2A:C1:46, Freq 2452 MHz, Rate 54 Mb/s, Strength 27 WEP
    Portaria SCPV:   Infra, 00:1A:3F:6A:34:48, Freq 2462 MHz, Rate 54 Mb/s, Strength 37
    TORRE_2:         Infra, 00:0C:42:68:5E:B1, Freq 2432 MHz, Rate 54 Mb/s, Strength 35
    badica:          Infra, 54:E6:FC:E9:F7:26, Freq 2462 MHz, Rate 54 Mb/s, Strength 27 WPA
    FamiliaSantos:   Infra, 1C:7E:E5:BA:F9:3A, Freq 2437 MHz, Rate 54 Mb/s, Strength 39 WPA WPA2
    PDRH:            Infra, 00:21:91:71:B8:0A, Freq 2437 MHz, Rate 54 Mb/s, Strength 27 WPA WPA2

  IPv4 Settings:
    Address:         192.168.1.107
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.1.1

    DNS:             201.82.0.64
    DNS:             201.82.0.51

$rfkill list wifi

0: phy0: Wireless LAN
   Soft blocked: no
   Hard blocked: no