Autor Tópico: youtube: vídeos não são reproduzidos-Acabo de perceber que o problema é de rede!  (Lida 1766 vezes)

Offline DiogoBurgos

  • Usuário Ubuntu
  • *
  • Mensagens: 22
    • Ver perfil
Olá! Acabo de instalar (pela segunda vez) o ubuntu 13.04.
Na primeira vez, acessei o YouTube, desinstalei alguns programas que não utilizo (firebird, empathy e alguns outros), atualizei o sistema conforme solicitado pelo "Atualizador de programas" e instalei o Intel Linux Graphics (https://01.org/linuxgraphics/). Ao acessar o YouTube, já não reproduzia mais os vídeos. Pensei que isso aconteceu por causa do Intel Linux Graphics.
Resolvi instalar de novo. Mais uma vez, após concluída a instalação, acessei o youtube: funcionando perfeitamente. Atualizei o sistema conforme o "Atualizador de programas" e desinstalei o firebird e o empathy pq não uso. Não instalei o Intel Linux Graphics dessa vez. Mais uma vez o YouTube parou de reproduzir os vídeos. Acessei outros sites como vimeo e videolog.tv e todos estão reproduzindo os videos normalmente. Acessei também o ArmorGames (jogos em flash) e tudo rodou muito bem. Não é problema do flash, pelo menos.
Começo a pensar que é por causa da atualização do sistema. Antes de formatar o computador pela terceira vez, resolvi tentar o forum.
Agradeço qualquer idéia para resolver esse problema ou método para melhor avaliação. Se precisarem de maiores informações também, é só falar.

Agradeço a todos.
« Última modificação: 01 de Junho de 2013, 11:23 por Ioca100 »

Offline DiogoBurgos

  • Usuário Ubuntu
  • *
  • Mensagens: 22
    • Ver perfil
Re: youtube: vídeos não são reproduzidos
« Resposta #1 Online: 31 de Maio de 2013, 21:59 »
Acabo de perceber que o problema é de rede! Uso conexão wireless e quando tentei postar deu erro de "servidor interrompeu conexão" ou algo do tipo. Então coloquei o cabo de rede no notebook e tentei postar de novo. Funcionou! Entrei no Youtube: funcionou também!
Voltei para a wireless e os problemas voltaram. Ainda assim, falta saber se isso acontece por causa do driver ou se por causa do kernel instalado com a atualização.

Ainda assim, quem tiver alguma dica, sugestão ou idéia, favor compartilhar.

Mais uma vez agradeço!

Offline Ioca100

  • Usuário Ubuntu
  • *
  • Mensagens: 2.848
  • Rio,Brasil
    • Ver perfil
Movido para a seção de internet, redes e segurança.
Usuário Linux- 449417

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Olá Diogo,

Outros acessos funcionam normalmente, ou vc percebe algum outro problema no uso da wireless? P.ex., downloads não terminam, figuras não abrem, etc. ?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline DiogoBurgos

  • Usuário Ubuntu
  • *
  • Mensagens: 22
    • Ver perfil
Olá! Obrigado pela atenção!

Acontece com o Youtube, quando vou postar mensagens aqui no forum também (agora estou usando o cabo para conseguir postar). Não só nesse forum, mas no do Intel Linux Graphics também.
Até o momento foram nessas operações que encontrei o problema.
Para conseguir conectar na rede wireless tive que utilizar o linux-firmware-nonfree.
Estou no momento tentando outros métodos.

A placa de rede é uma broadcom bcm4311.
Segurança WPA/WPA2 Personal.

Na versão do ubuntu que estava instalada (11.04) funcionava tudo bem em relação à internet. Mas o desempenho da máquina estava uma droga. Por isso formatei e instalei o 13.04.
« Última modificação: 01 de Junho de 2013, 14:10 por DiogoBurgos »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
OK.

Execute os comandos abaixo e cole o resultado aqui.

sudo lshw -C network
iwconfig
ifconfig -a
nm-tool
rfkill list wifi
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline DiogoBurgos

  • Usuário Ubuntu
  • *
  • Mensagens: 22
    • Ver perfil
Oi, zekkerj.

Todos os camandos foram executados estando conectado apenas via wireless.
Tive que conectar via cabo para conseguir postar, já que não consigo via wireless.
Segue o solicitado:

sudo lshw -C network
Código: [Selecionar]
  *-network
       descrição: Network controller
       produto: BCM4311 802.11b/g WLAN
       fabricante: Broadcom Corporation
       ID físico: 0
       informações do barramento: pci@0000:03:00.0
       versão: 01
       largura: 32 bits
       clock: 33MHz
       capacidades: pm msi pciexpress bus_master cap_list
       configuração: driver=b43-pci-bridge latency=0
       recursos: irq:17 memória:d8000000-d8003fff
  *-network
       descrição: Ethernet interface
       produto: 88E8055 PCI-E Gigabit Ethernet Controller
       fabricante: Marvell Technology Group Ltd.
       ID físico: 0
       informações do barramento: pci@0000:05:00.0
       nome lógico: eth0
       versão: 11
       serial: 00:1b:24:4d:f6:b2
       tamanho: 100Mbit/s
       capacidade: 1Gbit/s
       largura: 64 bits
       clock: 33MHz
       capacidades: pm vpd msi pciexpress bus_master cap_list rom ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuração: autonegotiation=on broadcast=yes driver=sky2 driverversion=1.30 duplex=full latency=0 link=no multicast=yes port=twisted pair speed=100Mbit/s
       recursos: irq:43 memória:da000000-da003fff porta de E/S:4000(tamanho=256) memória:d4000000-d401ffff
  *-network
       descrição: Interface sem fio
       ID físico: 2
       nome lógico: wlan0
       serial: 00:17:c4:05:6e:1c
       capacidades: ethernet physical wireless
       configuração: broadcast=yes driver=b43 driverversion=3.8.0-23-generic firmware=666.2 ip=192.168.1.100 link=yes multicast=yes wireless=IEEE 802.11bg

iwconfig
Código: [Selecionar]
wlan0     IEEE 802.11bg  ESSID:"DB_CASA" 
          Mode:Managed  Frequency:2.462 GHz  Access Point: 54:E6:FC:A0:FC:A6   
          Bit Rate=54 Mb/s   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=67/70  Signal level=-43 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:96  Invalid misc:927   Missed beacon:0
         
lo        no wireless extensions.

eth0      no wireless extensions.

ifconfig -a
Código: [Selecionar]
eth0      Link encap:Ethernet  Endereço de HW 00:1b:24:4d:f6:b2 
          endereço inet6: fe80::21b:24ff:fe4d:f6b2/64 Escopo:Link
          UP BROADCAST MULTICAST  MTU:1500  Métrica:1
          pacotes RX:67673 erros:0 descartados:0 excesso:0 quadro:1
          Pacotes TX:47703 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:92703033 (92.7 MB) TX bytes:4719399 (4.7 MB)
          IRQ:18

lo        Link encap:Loopback Local 
          inet end.: 127.0.0.1  Masc:255.0.0.0
          endereço inet6: ::1/128 Escopo:Máquina
          UP LOOPBACK RUNNING  MTU:65536  Métrica:1
          pacotes RX:5846 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:5846 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:0
          RX bytes:565594 (565.5 KB) TX bytes:565594 (565.5 KB)

wlan0     Link encap:Ethernet  Endereço de HW 00:17:c4:05:6e:1c 
          inet end.: 192.168.1.100  Bcast:192.168.1.255  Masc:255.255.255.0
          endereço inet6: fe80::217:c4ff:fe05:6e1c/64 Escopo:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Métrica:1
          pacotes RX:97182 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:88875 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:94888784 (94.8 MB) TX bytes:14766016 (14.7 MB)


nm-tool
Código: [Selecionar]
NetworkManager Tool

State: connected (global)

- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            sky2
  State:             unavailable
  Default:           no
  HW Address:        00:1B:24:4D:F6:B2

  Capabilities:
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties
    Carrier:         off


- Device: wlan0  [DB_CASA] -----------------------------------------------------
  Type:              802.11 WiFi
  Driver:            b43
  State:             connected
  Default:           yes
  HW Address:        00:17:C4:05:6E:1C

  Capabilities:
    Speed:           54 Mb/s

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points (* = current AP)
    *DB_CASA:        Infra, 54:E6:FC:A0:FC:A6, Freq 2462 MHz, Rate 54 Mb/s, Strength 75 WPA WPA2
    CSCWIFI_SUBSOLO: Infra, 70:81:05:3A:B7:F4, Freq 2462 MHz, Rate 54 Mb/s, Strength 80 WPA
    FHFS:            Infra, FC:C8:97:7F:D2:40, Freq 2472 MHz, Rate 54 Mb/s, Strength 39 WPA2

  IPv4 Settings:
    Address:         192.168.1.100
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.1.1

    DNS:             192.168.254.254
    DNS:             192.168.1.1

rfkill list wifi
Código: [Selecionar]
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

Offline DiogoBurgos

  • Usuário Ubuntu
  • *
  • Mensagens: 22
    • Ver perfil
Essa a primeira publicação no fórum através da conexão wireless. Sim, problema resolvido!

Instalei o firebug e comparei as requisições de um blog utilizando o cabo e também a conexão wireless. Encontrei uma requisição que era bem sucedida via cabo e a mesma falhava via wireless. Observando mais de perto, via wireless, os pacotes não estavam sendo recebidos! E mais uma vez fui ao google. Cheguei ao seguinte post do fórum americano http://ubuntuforums.org/showthread.php?t=1849728.
MTU... Tá certo. Como o cara sugeriu em uma das respostas fui buscar o valor do MTU para o meu serviço de internet que é a OI Velox.
E cheguei a outro post (https://under-linux.org/showthread.php?t=144769) onde o cara dá umas explicações e fala que o MTU para conexões PPPoE é de 1492. Observei no ifconfig que o MTU estava em 1500. Fui nas configurações da minha conexão defini o MTU para os 1492.
Fui no youtube e estava funcionando! Engraçado que isso não acontecia quando eu tinha 11.04 instalado.

Só tenho mais uma dúvida: Qual a melhor configuração?
a) manter as configurações do roteador como padrão (MTU = 1500) e modificar o MTU da minha conexão apenas;
b) alterar o MTU do roteador para 1492 e deixa o da minha conexão como automático;
c) manter MTU do roteador e da minha conexão em 1492.

Detalhe: também tem máquinas windows na rede e nunca tiveram problemas desse tipo.

Valeu!
« Última modificação: 02 de Junho de 2013, 17:15 por DiogoBurgos »