Autor Tópico: Internet extremamente lenta 12.04 problemas em obter wifi em alguns sitios  (Lida 1725 vezes)

Offline Colmeia

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Carissimos foristas instalei o ubuntu 12.04.2 e estou a tornar-me um entusiasta do ubuntu, instalei o ubuntu no computador da minha esposa, mas a internet está extremamente lenta, não consigo obter uma ligação por cabo (não reconhece), e face á insistência da minha esposa em querer voltar a instalar o windows peço ajuda a todos os foristas.

JUnto envio a configuração da minha instalação:

susana@Susana:~$ sudo lshw -C network
[sudo] password for susana:  

*-network              
       description: Network controller
       product: BCM4313 802.11b/g/n Wireless LAN Controller
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=bcma-pci-bridge latency=0
       resources: irq:16 memory:c2500000-c2503fff
  *-network
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: eth1
       version: 05
       serial: 10:1f:74:b2:c1:89
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl_nic/rtl8105e-1.fw latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:42 ioport:3000(size=256) memory:c0404000-c0404fff memory:c0400000-c0403fff
  *-network
       description: Wireless interface
       physical id: 1
       logical name: wlan1
       serial: 60:d8:19:64:c0:c4
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=brcmsmac driverversion=3.5.0-23-generic firmware=N/A ip=192.168.1.68 link=yes multicast=yes wireless=IEEE 802.11bgn


susana@Susana:~$ ifconfig -a

eth1      Link encap:Ethernet  HWaddr 10:1f:74:b2:c1:89  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:782 errors:0 dropped:0 overruns:0 frame:0
          TX packets:782 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:72667 (72.6 KB)  TX bytes:72667 (72.6 KB)

wlan1     Link encap:Ethernet  HWaddr 60:d8:19:64:c0:c4  
          inet addr:192.168.1.68  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::62d8:19ff:fe64:c0c4/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:235706 errors:0 dropped:0 overruns:0 frame:0
          TX packets:145615 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:350457794 (350.4 MB)  TX bytes:13909076 (13.9 MB)


susana@Susana:~$ iwconfig

lo        no wireless extensions.

eth1      no wireless extensions.

wlan1     IEEE 802.11bgn  ESSID:"OptimusFibra50EB5A"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: A4:B1:E9:50:EB:5A  
          Bit Rate=52 Mb/s   Tx-Power=19 dBm  
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=40/70  Signal level=-70 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:2809  Invalid misc:84   Missed beacon:0

iwconfig
lo        no wireless extensions.

eth1      no wireless extensions.

wlan1     IEEE 802.11bgn  ESSID:"OptimusFibra50EB5A"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: A4:B1:E9:50:EB:5A  
          Bit Rate=52 Mb/s   Tx-Power=19 dBm  
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=40/70  Signal level=-70 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:2809  Invalid misc:84   Missed beacon:0



susana@Susana:~$ nm-tool

NetworkManager Tool

State: connected (global)

- Device: eth1 -----------------------------------------------------------------
  Type:              Wired
  Driver:            r8169
  State:             unavailable
  Default:           no
  HW Address:        10:1F:74:B2:C1:89

  Capabilities:
    Carrier Detect:  yes

  Wired Properties
    Carrier:         off


- Device: wlan1  [OptimusFibra50EB5A] ------------------------------------------
  Type:              802.11 WiFi
  Driver:            brcmsmac
  State:             connected
  Default:           yes
  HW Address:        60:D8:19:64:C0:C4

  Capabilities:
    Speed:           26 Mb/s

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points (* = current AP)
    *OptimusFibra50EB5A: Infra, A4:B1:E9:50:EB:5A, Freq 2437 MHz, Rate 54 Mb/s, Strength 49 WPA WPA2
    ZON-67A0:        Infra, 68:B6:FC:30:67:A8, Freq 2447 MHz, Rate 54 Mb/s, Strength 22 WPA WPA2
    FON_ZON_FREE_INTERNET: Infra, 68:B6:FC:30:67:A9, Freq 2447 MHz, Rate 54 Mb/s, Strength 20

  IPv4 Settings:
    Address:         192.168.1.68
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.1.254

    DNS:             192.168.1.254



susana@Susana:~$ rfkill list wifi
0: phy0: Wireless LAN
   Soft blocked: no
   Hard blocked: no
1: hp-wifi: Wireless LAN
   Soft blocked: no
   Hard blocked: no

Agradeço em antecipação toda a ajuda obtida na resolução deste problema!



Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Internet extremamente lenta 12.04 problemas em obter wifi em alguns sitios
« Resposta #1 Online: 04 de Junho de 2013, 08:43 »
Você está com o IPv6 ativo, o que pode tornar seus acessos mais lentos. Pra desativar o IPv6, use o comando:

sudo sysctl net.ipv6.conf.all.disable_ipv6=1

Pra tornar essa configuração permanente, adicione a linha abaixo ao arquivo /etc/sysctl.conf:

net.ipv6.conf.all.disable_ipv6=1

Também observei que você não está usando o driver ideal pra seu adaptador wireless. Isso pode gerar quedas e lentidão na sua conexão. Pra instalar o driver mais eficiente, siga as instruções do tópico abaixo.

http://ubuntuforum-br.org/index.php/topic,105314.msg580408.html#msg580408
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Colmeia

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Re: Internet extremamente lenta 12.04 problemas em obter wifi em alguns sitios
« Resposta #2 Online: 04 de Junho de 2013, 11:34 »
Obrigado pela ajuda preciosa Zekkerj! a ajuda foi preciosa e de facto o wifi melhorou muito quando está na mesma sala onde está o router! No entanto quando levo para o quarto (6 metros) muito lentamente vai ao google, mas qualquer endereço fica eternidades e por fim aparece a mensagem de erro a dizer que não obteve ligação!

Fiz tal e qual o sugerido com a lista de comandos que constava naquele link acima enviado, mas continua sem resultados,ou seja, continua sem reconhecer a ligação fiśica por cabo!

Agradeço antecipadamente a ajuda e disponibilidade na ajuda á resolução deste problema!


Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Internet extremamente lenta 12.04 problemas em obter wifi em alguns sitios
« Resposta #3 Online: 04 de Junho de 2013, 11:37 »
Hmmm, problema no acesso por cabo também? Interessante, não tinha registrado isso. Já tentou com outro cabo? É comum esse problema ser causado por cabos ruins.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D