Autor Tópico: WiFi não conecta [ Resolvido ]  (Lida 23810 vezes)

Offline Doug_funny

  • Usuário Ubuntu
  • *
  • Mensagens: 23
    • Ver perfil
WiFi não conecta [ Resolvido ]
« Online: 24 de Junho de 2013, 14:26 »
Boa tarde a todos. Eu venho tendo esse problema há algum tempo. Quando eu estou com o notebook Itautec W7535 ligado na WiFi ele perde a conexão constantemente. Já troquei a placa e continuo com o mesmo problema. Alguém pode me ajudar? O modelo da placa é Realtek RTL8188CE. Desde já agradeço à ajuda de todos.
« Última modificação: 02 de Julho de 2013, 08:19 por Doug_funny »

Offline Arthur Bernardes

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re: WiFi não conecta
« Resposta #1 Online: 24 de Junho de 2013, 15:00 »
Execute os seguintes comandos em terminal e cole os resultados aqui.

sudo lshw -C network
ifconfig -a
iwconfig
nm-tool
rfkill list wifi
uname -a


Obs: Use a tag "code" , que facilita a visualização das respostas dos comandos.

Offline Doug_funny

  • Usuário Ubuntu
  • *
  • Mensagens: 23
    • Ver perfil
Re: WiFi não conecta
« Resposta #2 Online: 24 de Junho de 2013, 16:11 »
Código: [Selecionar]
douglas@Douglas:~$ sudo lshw -C network
[sudo] password for douglas:
  *-network               
       descrição: Interface sem fio
       produto: RTL8188CE 802.11b/g/n WiFi Adapter
       fabricante: Realtek Semiconductor Co., Ltd.
       ID físico: 0
       informações do barramento: pci@0000:02:00.0
       nome lógico: wlan1
       versão: 01
       serial: 68:a3:c4:96:39:0d
       largura: 64 bits
       clock: 33MHz
       capacidades: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuração: broadcast=yes driver=rtl8192ce driverversion=3.8.0-25-generic firmware=N/A ip=10.240.3.2 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       recursos: irq:18 porta de E/S:e000(tamanho=256) memória:f7d00000-f7d03fff
  *-network
       descrição: Ethernet interface
       produto: JMC250 PCI Express Gigabit Ethernet Controller
       fabricante: JMicron Technology Corp.
       ID físico: 0
       informações do barramento: pci@0000:03:00.0
       nome lógico: eth0
       versão: 05
       serial: 00:40:a7:21:eb:4d
       tamanho: 10Mbit/s
       capacidade: 1Gbit/s
       largura: 32 bits
       clock: 33MHz
       capacidades: pm pciexpress msix msi bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuração: autonegotiation=on broadcast=yes driver=jme driverversion=1.0.8 duplex=half latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       recursos: irq:44 memória:f7c20000-f7c23fff porta de E/S:d100(tamanho=128) porta de E/S:d000(tamanho=256) memória:f7c10000-f7c1ffff memória:f7c00000-f7c0ffff
douglas@Douglas:~$
douglas@Douglas:~$
douglas@Douglas:~$ ifconfig -a
eth0      Link encap:Ethernet  Endereço de HW 00:40:a7:21:eb:4d 
          UP BROADCAST MULTICAST  MTU:1500  Métrica:1
          pacotes RX:0 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:0 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
          IRQ:44

lo        Link encap:Loopback Local 
          inet end.: 127.0.0.1  Masc:255.0.0.0
          endereço inet6: ::1/128 Escopo:Máquina
          UP LOOPBACK RUNNING  MTU:65536  Métrica:1
          pacotes RX:1680 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:1680 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:0
          RX bytes:151470 (151.4 KB) TX bytes:151470 (151.4 KB)

wlan1     Link encap:Ethernet  Endereço de HW 68:a3:c4:96:39:0d 
          inet end.: 10.240.3.2  Bcast:10.240.3.255  Masc:255.255.252.0
          endereço inet6: fe80::6aa3:c4ff:fe96:390d/64 Escopo:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Métrica:1
          pacotes RX:3285 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:3214 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:1298611 (1.2 MB) TX bytes:777210 (777.2 KB)

douglas@Douglas:~$
douglas@Douglas:~$
douglas@Douglas:~$ iwconfig
wlan1     IEEE 802.11bgn  ESSID:"TESTSEC" 
          Mode:Managed  Frequency:2.427 GHz  Access Point: 54:E6:FC:DC:E1:04   
          Bit Rate=150 Mb/s   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off
          Link Quality=54/70  Signal level=-56 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:37   Missed beacon:0

eth0      no wireless extensions.

lo        no wireless extensions.

douglas@Douglas:~$
douglas@Douglas:~$
douglas@Douglas:~$ nm-tool

NetworkManager Tool

State: connected (global)

- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            jme
  State:             unavailable
  Default:           no
  HW Address:        00:40:A7:21:EB:4D

  Capabilities:
    Carrier Detect:  yes

  Wired Properties
    Carrier:         off


- Device: wlan1  [TESTSEC 1] ---------------------------------------------------
  Type:              802.11 WiFi
  Driver:            rtl8192ce
  State:             connected
  Default:           yes
  HW Address:        68:A3:C4:96:39:0D

  Capabilities:
    Speed:           150 Mb/s

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points (* = current AP)
    GOIASPREV:       Infra, 1C:AF:F7:57:0A:2C, Freq 2462 MHz, Rate 54 Mb/s, Strength 94 WPA WPA2
    dlink-8CF2:      Infra, 90:94:E4:D3:8C:F2, Freq 2427 MHz, Rate 54 Mb/s, Strength 75 WPA WPA2
    GOIASPREV:       Infra, 1C:AF:F7:57:0B:D0, Freq 2462 MHz, Rate 54 Mb/s, Strength 82 WPA WPA2
    *TESTSEC:        Infra, 54:E6:FC:DC:E1:04, Freq 2427 MHz, Rate 54 Mb/s, Strength 57 WPA2

  IPv4 Settings:
    Address:         10.240.3.2
    Prefix:          22 (255.255.252.0)
    Gateway:         10.240.0.233

    DNS:             10.240.0.35
    DNS:             10.240.0.45


douglas@Douglas:~$
douglas@Douglas:~$
douglas@Douglas:~$ rfkill list wifi
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
douglas@Douglas:~$
douglas@Douglas:~$
douglas@Douglas:~$ uname -a
Linux Douglas 3.8.0-25-generic #37-Ubuntu SMP Thu Jun 6 20:47:07 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Offline Arthur Bernardes

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re: WiFi não conecta
« Resposta #3 Online: 24 de Junho de 2013, 16:17 »
Amigo, o que me parece é que há outro Roteador/AP usando o mesmo canal 4 (2.427) que o seu. Tente mudar a configuração do seu roteador e usar o canal 1 (2.412) ou colocar em modo automático. E veja se melhora sua conexão.

Offline Doug_funny

  • Usuário Ubuntu
  • *
  • Mensagens: 23
    • Ver perfil
Re: WiFi não conecta
« Resposta #4 Online: 24 de Junho de 2013, 22:52 »
Boa noite Artur. Muito obrigado pela sua atenção. O meu roteador está automático. A configuração que te mandei foi do roteador do meu serviço. Aqui em casa (estou agora) fiz os mesmos comandos e estou usando o canal 1, porém está configurado para ficar automático.

Canal: auto
Modo: 11b/g/n
Largura do canal: auto
Taxa máxima de transmissão: 300 Mbps

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: WiFi não conecta
« Resposta #5 Online: 24 de Junho de 2013, 23:32 »
Pode postar novamente a saída dos comandos

iwconfig wlan0
nm-tool


quando acessa em casa?

Outra coisa, vc tem o mesmo problema ao acessar no serviço, ou só em casa?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Renan Rischiotto

  • Usuário Ubuntu
  • *
  • Mensagens: 2.888
    • Ver perfil
Re: WiFi não conecta
« Resposta #6 Online: 24 de Junho de 2013, 23:45 »
Caro amigo Doug_funny,

Já tentou atualizar o kernel do sistema?

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: WiFi não conecta
« Resposta #7 Online: 24 de Junho de 2013, 23:51 »
Atualizar kernel por causa de uma interface wireless que não conecta direito??? :o
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Renan Rischiotto

  • Usuário Ubuntu
  • *
  • Mensagens: 2.888
    • Ver perfil
Re: WiFi não conecta
« Resposta #8 Online: 25 de Junho de 2013, 00:13 »
Sim, esses kernels do Ubuntu são muito antigos...

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: WiFi não conecta
« Resposta #9 Online: 25 de Junho de 2013, 02:43 »
E qual o problema num kernel antigo e depurado? Ou você gosta de ficar resolvendo bug de programação toda hora?

Mais novo não é sinônimo de mais rápido, nem de mais seguro, e definitivamente não é sinônimo de mais estável.

E você não sabe nem se o problema não é com o roteador dele. Daí troca o kernel por um novíssimo, e perde suporte a uma penca de coisas --- e não resolve o problema. Com que cara ficamos?

Trocar o kernel pode sim ser a solução pra alguns problemas, mas com certeza não é a solução para todos os problemas. Essencial saber qual é o problema, antes de propor alguma solução...
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline kalix

  • Usuário Ubuntu
  • *
  • Mensagens: 342
    • Ver perfil
Re: WiFi não conecta
« Resposta #10 Online: 25 de Junho de 2013, 10:55 »
qual versão do Ubuntu esta utilizando Doug_funny?

Offline Arthur Bernardes

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re: WiFi não conecta
« Resposta #11 Online: 25 de Junho de 2013, 10:57 »
Pelo que aparece nas respostas do comando, parece o Ubuntu 13.04

Mas temos que eliminar a hipótese do problema ser físico (rede) antes de passarmos outros procedimentos. ;)

Offline Doug_funny

  • Usuário Ubuntu
  • *
  • Mensagens: 23
    • Ver perfil
Re: WiFi não conecta
« Resposta #12 Online: 25 de Junho de 2013, 23:18 »
Boa noite amigos. Estou usando o Ubuntu 13.04 e o problema consiste também no meu serviço.

Código: [Selecionar]
douglas@Douglas:~$ uname -r
3.8.0-25-generic

douglas@Douglas:~$ iwconfig
wlan1     IEEE 802.11bgn  ESSID:"Douglas" 
          Mode:Managed  Frequency:2.412 GHz  Access Point: B0:48:7A:F2:09:1E   
          Bit Rate=150 Mb/s   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off
          Link Quality=63/70  Signal level=-47 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:3   Missed beacon:0


douglas@Douglas:~$ nm-tool

NetworkManager Tool

State: connected (global)

- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            jme
  State:             unavailable
  Default:           no
  HW Address:        00:40:A7:21:EB:4D

  Capabilities:
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties
    Carrier:         off


- Device: wlan1  [Douglas] -----------------------------------------------------
  Type:              802.11 WiFi
  Driver:            rtl8192ce
  State:             connected
  Default:           yes
  HW Address:        68:A3:C4:96:39:0D

  Capabilities:
    Speed:           150 Mb/s

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points (* = current AP)
    *Douglas:        Infra, B0:48:7A:F2:09:1E, Freq 2412 MHz, Rate 54 Mb/s, Strength 71 WPA2

  IPv4 Settings:
    Address:         10.0.0.105
    Prefix:          24 (255.255.255.0)
    Gateway:         10.0.0.1

    DNS:             10.0.0.1

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: WiFi não conecta
« Resposta #13 Online: 25 de Junho de 2013, 23:29 »
Bom, não é ambiental. Hora de experimentar o driver proprietário...
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Doug_funny

  • Usuário Ubuntu
  • *
  • Mensagens: 23
    • Ver perfil
Re: WiFi não conecta
« Resposta #14 Online: 25 de Junho de 2013, 23:34 »
Caro zekkerj, eu sou novato no linux. Como eu instalo o driver proprietário da placa de rede ?