Autor Tópico: Tenho um notebook philco com ubuntu 12.04 mas não está funcionando wireless  (Lida 24777 vezes)

Offline LuLy

  • Usuário Ubuntu
  • *
  • Mensagens: 29
    • Ver perfil
Oi pessoal
faz pouco tempo que comprei meu note, ai ele veio com o linux mandriva (axo q é assim, ou algo parecido), porém eu já usava no meu outro note o ubuntu 12.04, só que quando estrava com o "mandriva" a rede sem fio funcionou normal, eu aperta "Fn + F11" e ligava o wirelles.
então instalei o ubuntu e não ta funcionando, nem a luzinha do wirelles liga..
eu não sei oq fazer, só uso o ubuntu por q axo legal a interface, mas não sei mexer direito
me ajudem ai se puderem!!
Desde já agradeço!
abraços


Sayure Salles Nonnenmacher
Acadêmica de Sistemas de Informação I
Instituto Federal Farroupilha - Campus Júlio de Castilhos- RS

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Tenho um notebook philco com ubuntu 12.04 mas não está funcionando wireless
« Resposta #1 Online: 05 de Julho de 2013, 21:56 »
Execute os comandos abaixo e cole o resultado aqui.

sudo lshw -C network
iwconfig
ifconfig -a
nm-tool
rfkill list wifi
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline LuLy

  • Usuário Ubuntu
  • *
  • Mensagens: 29
    • Ver perfil
Re: Tenho um notebook philco com ubuntu 12.04 mas não está funcionando wireless
« Resposta #2 Online: 08 de Julho de 2013, 19:43 »
oie, está ai o resultado dos comandos.
o ultimo comando não apareceu nd.

luly@luly-14H:~$ sudo lshw -c network
[sudo] password for luly:
*-network UNCLAIMED
descrição: Network controller
produto: RTL8188CE 802.11b/g/n WiFi Adapter
fabricante: Realtek Semiconductor Co., Ltd.
physical id: 0
informações do barramento: pci@0000:01:00.0
versão: 01
largura: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress cap_list
configuração: latency=0
recursos: ioport:3000(tamanho=256) memória:c0100000-c0103fff
*-network
descrição: Ethernet interface
produto: JMC260 PCI Express Fast Ethernet Controller
fabricante: JMicron Technology Corp.
physical id: 0
informações do barramento: pci@0000:03:00.0
nome lógico: eth0
versão: 05
serial: 00:09:0f:50:02:09
tamanho: 10Mbit/s
capacidade: 100Mbit/s
largura: 32 bits
clock: 33MHz
capabilities: pm pciexpress msix msi bus_master cap_list rom ethernet physical tp mii 10bt
10bt-fd 100bt 100bt-fd autonegotiation
configuração: autonegotiation=on broadcast=yes driver=jme driverversion=1.0.8 duplex=half
latency=0 link=no multicast=yes port=MII speed=10Mbit/s
recursos: irq:46 memória:c0010000-c0013fff ioport:2100(tamanho=128)
ioport:2000(tamanho=256) memória:c0000000-c000ffff memória:c0900000-c090ffff

luly@luly-14H:~$ iwconfig
lo no wireless extensions.
eth0 no wireless extensions.

luly@luly-14H:~$ ifconfig -a
eth0 Link encap:Ethernet Endereço de HW 00:09:0f:50:02:09
UP BROADCAST RUNNING MULTICAST MTU:1500 Métrica:1
pacotes RX:0 erros:0 descartados:0 excesso:0 quadro:0
Pacotes TX:0 erros:0 descartados:0 excesso:0 portadora:0
colisões:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
IRQ:46
lo Link encap:Loopback Local
inet end.: 127.0.0.1 Masc:255.0.0.0
endereço inet6: ::1/128 Escopo:Máquina
UP LOOPBACK RUNNING MTU:16436 Métrica:1
pacotes RX:96 erros:0 descartados:0 excesso:0 quadro:0
Pacotes TX:96 erros:0 descartados:0 excesso:0 portadora:0
colisões:0 txqueuelen:0
RX bytes:7840 (7.8 KB) TX bytes:7840 (7.8 KB)

luly@luly-14H:~$ nm-tool
NetworkManager Tool
State: disconnected
- Device: eth0 -----------------------------------------------------------------
Type: Wired
Driver: jme
State: unavailable
Default: no
HW Address: 00:09:0F:50:02:09
Capabilities:
Carrier Detect: yes
Wired Properties
Carrier: off

 
o que devo fazer agora??

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Tenho um notebook philco com ubuntu 12.04 mas não está funcionando wireless
« Resposta #3 Online: 08 de Julho de 2013, 23:13 »
Caramba, será que todo mundo agora só usa essa placa? :(

Pra reconhecer sua placa wireless, basta carregar o módulo nativo dela:

sudo modprobe rtl8192ce

Isso deve ser suficiente pra sua rede wireless aparecer, e talvez até conectar. O problema... caramba, e que problema: muita gente reporta que ao usar essa placa wireless com esse driver, tem vários problemas de quedas na conexão.

Enfim: mesmo isso é melhor do que você tem agora (nada).
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Arthur Bernardes

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re: Tenho um notebook philco com ubuntu 12.04 mas não está funcionando wireless
« Resposta #4 Online: 08 de Julho de 2013, 23:15 »
Ô sorte de eu ter uma RT3090 que funciona de boa no Kernel 3.5.0-36.

Offline LuLy

  • Usuário Ubuntu
  • *
  • Mensagens: 29
    • Ver perfil
Re: Tenho um notebook philco com ubuntu 12.04 mas não está funcionando wireless
« Resposta #5 Online: 08 de Julho de 2013, 23:30 »
valew. daqi uns minutos ja faço isso
por enquanto agradeço
abraços

Offline LuLy

  • Usuário Ubuntu
  • *
  • Mensagens: 29
    • Ver perfil
Re: Tenho um notebook philco com ubuntu 12.04 mas não está funcionando wireless
« Resposta #6 Online: 09 de Julho de 2013, 12:03 »
bah, coloquei o comando que vc mandou, mas continuou a mesma coisa  :-[
oq eu posso fazer agora??

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Tenho um notebook philco com ubuntu 12.04 mas não está funcionando wireless
« Resposta #7 Online: 09 de Julho de 2013, 12:05 »
Repita os comandos de avaliação, sem reiniciar seu computador.

sudo lshw -C network
iwconfig
ifconfig -a
nm-tool
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline LuLy

  • Usuário Ubuntu
  • *
  • Mensagens: 29
    • Ver perfil
Re: Tenho um notebook philco com ubuntu 12.04 mas não está funcionando wireless
« Resposta #8 Online: 09 de Julho de 2013, 12:39 »
o resultado...
primeiro coloquei o comando para ativar a placa, como vc tinha me mandado antes
e em seguido, refiz a avaliação, agora eu estou conectada, com internet cabeada.
 os resultados
luly@luly-14H:~$ sudo modprobe rtl8192ce
[sudo] password for luly:
luly@luly-14H:~$ sudo lshw -C network
  *-network UNCLAIMED     
       descrição: Network controller
       produto: RTL8188CE 802.11b/g/n WiFi Adapter
       fabricante: Realtek Semiconductor Co., Ltd.
       physical id: 0
       informações do barramento: pci@0000:01:00.0
       versão: 01
       largura: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress cap_list
       configuração: latency=0
       recursos: ioport:3000(tamanho=256) memória:c0100000-c0103fff
  *-network
       descrição: Ethernet interface
       produto: JMC260 PCI Express Fast Ethernet Controller
       fabricante: JMicron Technology Corp.
       physical id: 0
       informações do barramento: pci@0000:03:00.0
       nome lógico: eth0
       versão: 05
       serial: 00:09:0f:50:02:09
       tamanho: 100Mbit/s
       capacidade: 100Mbit/s
       largura: 32 bits
       clock: 33MHz
       capabilities: pm pciexpress msix msi bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuração: autonegotiation=on broadcast=yes driver=jme driverversion=1.0.8 duplex=full ip=192.168.2.183 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       recursos: irq:46 memória:c0010000-c0013fff ioport:2100(tamanho=128) ioport:2000(tamanho=256) memória:c0000000-c000ffff memória:c0900000-c090ffff
luly@luly-14H:~$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

luly@luly-14H:~$ ifconfig -a
eth0      Link encap:Ethernet  Endereço de HW 00:09:0f:50:02:09 
          inet end.: 192.168.2.183  Bcast:192.168.2.255  Masc:255.255.255.0
          endereço inet6: fe80::209:fff:fe50:209/64 Escopo:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Métrica:1
          pacotes RX:21601 erros:0 descartados:0 excesso:0 quadro:2
          Pacotes TX:20714 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:27746052 (27.7 MB) TX bytes:2508878 (2.5 MB)
          IRQ:46

lo        Link encap:Loopback Local 
          inet end.: 127.0.0.1  Masc:255.0.0.0
          endereço inet6: ::1/128 Escopo:Máquina
          UP LOOPBACK RUNNING  MTU:16436  Métrica:1
          pacotes RX:1501 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:1501 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:0
          RX bytes:196500 (196.5 KB) TX bytes:196500 (196.5 KB)

luly@luly-14H:~$ nm-tool

NetworkManager Tool

State: connected (global)

- Device: eth0  [Conexão cabeada 1] -------------------------------------------
  Type:              Wired
  Driver:            jme
  State:             connected
  Default:           yes
  HW Address:        00:09:0F:50:02:09

  Capabilities:
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties
    Carrier:         on

  IPv4 Settings:
    Address:         192.168.2.183
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.2.1

    DNS:             192.168.2.1



E agora, o que devo fazer??

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Tenho um notebook philco com ubuntu 12.04 mas não está funcionando wireless
« Resposta #9 Online: 09 de Julho de 2013, 12:54 »
Hmmmmmmm... continua "unclaimed"...

Execute os comandos abaixo, cole o resultado aqui.

uname -r

sudo lspci -v -s 01:00.0

modinfo rtl8192ce | grep pci
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline LuLy

  • Usuário Ubuntu
  • *
  • Mensagens: 29
    • Ver perfil
Re: Tenho um notebook philco com ubuntu 12.04 mas não está funcionando wireless
« Resposta #10 Online: 09 de Julho de 2013, 13:21 »
resultados

luly@luly-14H:~$ uname -r
3.2.0-48-generic-pae
luly@luly-14H:~$ sudo lspci -v -s 01:00.0
[sudo] password for luly:
01:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)
   Subsystem: Realtek Semiconductor Co., Ltd. Device 8297
   Flags: fast devsel, IRQ 16
   I/O ports at 3000 [size=256]
   Memory at c0100000 (64-bit, non-prefetchable) [size=16K]
   Capabilities: [40] Power Management version 3
   Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit+
   Capabilities: [70] Express Endpoint, MSI 00
   Capabilities: [100] Advanced Error Reportório
   Capabilities: [140] Virtual Channel
   Capabilities: [160] Device Serial Number 01-91-81-fe-ff-4c-e0-00
   Kernel modules: rtl8192ce

luly@luly-14H:~$ modinfo rtl8192ce |grep pci
alias:          pci:v000010ECd00008176sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008177sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008178sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008191sv*sd*bc*sc*i*

ainda bem que tem um cranio que nem tu pra m ajudar hehehehehe
oq faço agora?

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Tenho um notebook philco com ubuntu 12.04 mas não está funcionando wireless
« Resposta #11 Online: 09 de Julho de 2013, 15:37 »
Que estranho... o módulo é esse mesmo, o próprio lspci reconhece. Pq não carregou, então??? ???

Mais uns comandos...

sudo modprobe -rv rtl8192ce
sudo modprobe -v rtl8192ce
dmesg | tail
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline LuLy

  • Usuário Ubuntu
  • *
  • Mensagens: 29
    • Ver perfil
Re: Tenho um notebook philco com ubuntu 12.04 mas não está funcionando wireless
« Resposta #12 Online: 09 de Julho de 2013, 15:49 »
ta ai a resposta dos comandos

luly@luly-14H:~$ sudo modprobe -rv rtlc8192ce
[sudo] password for luly:
FATAL: Module rtlc8192ce not found.

luly@luly-14H:~$ sudo modprobe -v rtl8192ce

luly@luly-14H:~$ dmesg |tail
[ 4361.908783] PM: resume of devices complete after 2968.326 msecs
[ 4361.908968] PM: resume devices took 2.972 seconds
[ 4361.909066] PM: Finishing wakeup.
[ 4361.909069] Restarting tasks ... done.
[ 4367.989504] jme 0000:03:00.0: irq 46 for MSI/MSI-X
[ 4368.015139] jme 0000:03:00.0: eth0: Link is down
[ 4368.015594] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 4369.653344] jme 0000:03:00.0: eth0: Link is up at ANed: 100 Mbps, Full-Duplex, MDI
[ 4369.654264] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 4380.536718] eth0: no IPv6 routers present

ta e agora?

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Tenho um notebook philco com ubuntu 12.04 mas não está funcionando wireless
« Resposta #13 Online: 09 de Julho de 2013, 22:47 »
O primeiro comando saiu errado. Pode executar de novo? A sequência é crítica, sem o primeiro comando os outros ficam prejudicados.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline LuLy

  • Usuário Ubuntu
  • *
  • Mensagens: 29
    • Ver perfil
Re: Tenho um notebook philco com ubuntu 12.04 mas não está funcionando wireless
« Resposta #14 Online: 09 de Julho de 2013, 23:23 »
eu sou uma tapada mesmo kkkkk  ;D
agora saiu certo :P
ta ai
luly@luly-14H:~$ sudo modprobe -rv rtl8192ce
[sudo] password for luly:
rmmod /lib/modules/3.2.0-48-generic-pae/kernel/drivers/net/wireless/rtlwifi/rtl8192ce/rtl8192ce.ko
rmmod /lib/modules/3.2.0-48-generic-pae/kernel/drivers/net/wireless/rtlwifi/rtl8192c/rtl8192ccommon.
ko
rmmod /lib/modules/3.2.0-48-generic-pae/kernel/drivers/net/wireless/rtlwifi/rtlwifi.ko
rmmod /lib/modules/3.2.0-48-generic-pae/kernel/net/mac80211/mac80211.ko
rmmod /lib/modules/3.2.0-48-generic-pae/kernel/net/wireless/cfg80211.ko
luly@luly-14H:~$ sudo modprobe -v rtl8192ce
insmod /lib/modules/3.2.0-48-generic-pae/kernel/net/wireless/cfg80211.ko
insmod /lib/modules/3.2.0-48-generic-pae/kernel/net/mac80211/mac80211.ko
insmod /lib/modules/3.2.0-48-generic-pae/kernel/drivers/net/wireless/rtlwifi/rtlwifi.ko
insmod /lib/modules/3.2.0-48-generic-pae/kernel/drivers/net/wireless/rtlwifi/rtl8192c/rtl8192ccommon.
ko
insmod /lib/modules/3.2.0-48-generic-pae/kernel/drivers/net/wireless/rtlwifi/rtl8192ce/rtl8192ce.ko
luly@luly-14H:~$ dmesg|tail
[16878.003978] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000
mBm)
[16878.003986] cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000
mBm)
[16878.003995] cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000
mBm)
[16878.039075] rtl8192ce 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[16878.039102] rtl8192ce 0000:01:00.0: setting latency timer to 64
[16878.039246] rtl8192ce:_rtl92ce_read_chip_version():<0-0> Chip Version ID: Unknown. Bug?
[16878.051330] ****** This B_CUT device may not work with kernels 3.6 and earlier
[16878.059707] rtl8192ce:rtl92c_init_sw_vars():<0-0> Failed to request firmware!
[16878.059720] rtlwifi:rtl_pci_probe():<0-0> Can't init_sw_vars.
[16878.059784] rtl8192ce 0000:01:00.0: PCI INT A disabled

ta, e agora??  ???