Autor Tópico: *Desesperado* Driver Nvidia [Resolvido]  (Lida 2692 vezes)

Offline Saishy

  • Usuário Ubuntu
  • *
  • Mensagens: 11
  • CounterDragon
    • Ver perfil
    • CounterDragon
*Desesperado* Driver Nvidia [Resolvido]
« Online: 20 de Setembro de 2006, 17:20 »
PELO AMOR DE DEUS!!! EU PRECISO DE AJUDA!!!

Eu já tentei mais de 10 veses instalar o driver nvidia-glx e NÃO CONSIGO, ou o X dá error, ou o logo da nvidia simplesmente não aparece e o driver fica como se não estivesse instalado, a tela fica "jogada para o lado" e não aparece o menu da nvidia em "Aplicações"

Como agora estou na parte em que ele parece não estar instalado, o log não tem nenhum erro...

Se eu não conseguir instalar esse drive, eu vou voltar logo pro windows, não é possivel! 2 semanas tentando instalar uma coisa! Acho que até o windows já deu menos pau em toda minha vida, doque o tanto de erro que esse driver está apresentado.

Já tentei varios tutos em vários lugares! Já li todos os tópicos do fórum, e nenhum conseguiu me ajudar.
Quando o logo da nvidia aparece, o X não funciona, só funciona se o logo não aparecer!

O linux não teria um sistema de acesso remoto parecido com o windows, teria?
« Última modificação: 20 de Setembro de 2006, 18:45 por Saishy »

boi

  • Visitante
Re: *Desesperado* Driver Nvidia
« Resposta #1 Online: 20 de Setembro de 2006, 17:45 »
Só vejo uma solução no seu caso: peça para alguém que entenda de Linux instalar para você. Ou então é voltar para o Windows mesmo.

Offline Saishy

  • Usuário Ubuntu
  • *
  • Mensagens: 11
  • CounterDragon
    • Ver perfil
    • CounterDragon
Re: *Desesperado* Driver Nvidia
« Resposta #2 Online: 20 de Setembro de 2006, 17:55 »
Só vejo uma solução no seu caso: peça para alguém que entenda de Linux instalar para você. Ou então é voltar para o Windows mesmo.

 :'(

Eu fiz um curso de linux no senac, mas lógico, nada me preparou para isso...

Vou tentar "causar" o erro denovo, para ver se o log pega ele.

Código: [Selecionar]
X Window System Version 7.0.0
Release Date: 21 December 2005
X Protocol Version 11, Revision 0, Release 7.0
Build Operating System:Linux 2.6.15.7 x86_64
Current Operating System: Linux saishy-desktop 2.6.15-27-amd64-generic #1 SMP PREEMPT Sat Sep 16 01:50:50 UTC 2006 x86_64
Build Date: 16 March 2006
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Sep 20 18:09:05 2006
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Default Layout"
(**) |-->Screen "Default Screen" (0)
(**) |   |-->Monitor "S/M 550v"
(**) |   |-->Device "NVIDIA Corporation NV40 [GeForce 6800 Ultra/GeForce 6800 GT]"
(**) |-->Input Device "Generic Keyboard"
(**) |-->Input Device "Configured Mouse"
(**) |-->Input Device "stylus"
(**) |-->Input Device "cursor"
(**) |-->Input Device "eraser"
(WW) The directory "/usr/share/X11/fonts/cyrillic" does not exist.
Entry deleted from font path.
(**) FontPath set to "/usr/share/X11/fonts/misc,/usr/share/X11/fonts/100dpi/:unscaled,/usr/share/X11/fonts/75dpi/:unscaled,/usr/share/X11/fonts/Type1,/usr/share/X11/fonts/100dpi,/usr/share/X11/fonts/75dpi,/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
(==) RgbPath set to "/etc/X11/rgb"
(==) ModulePath set to "/usr/lib/xorg/modules"
(II) Module ABI versions:
X.Org ANSI C Emulation: 0.2
X.Org Video Driver: 0.8
X.Org XInput driver : 0.5
X.Org Server Extension : 0.2
X.Org Font Renderer : 0.4
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/lib/xorg/modules/fonts/libbitmap.so
(II) Module bitmap: vendor="X.Org Foundation"
compiled for 7.0.0, module version = 1.0.0
Module class: X.Org Font Renderer
ABI class: X.Org Font Renderer, version 0.4
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/lib/xorg/modules/libpcidata.so
(II) Module pcidata: vendor="X.Org Foundation"
compiled for 7.0.0, module version = 1.0.0
ABI class: X.Org Video Driver, version 0.8
(++) using VT number 7
(II) PCI-to-ISA bridge:
(II) Bus -1: bridge is at (0:1:0), (0,-1,-1), BCTRL: 0x0008 (VGA_EN is set)
(II) Subtractive PCI-to-PCI bridge:
(II) Bus 5: bridge is at (0:9:0), (0,5,5), BCTRL: 0x0202 (VGA_EN is cleared)
(II) Bus 5 I/O range:
[0] -1 0 0x0000a000 - 0x0000afff (0x1000) IX[B]
(II) Bus 5 non-prefetchable memory range:
[0] -1 0 0xd3000000 - 0xd30fffff (0x100000) MX[B]
(II) PCI-to-PCI bridge:
(II) Bus 4: bridge is at (0:11:0), (0,4,4), BCTRL: 0x0002 (VGA_EN is cleared)
(II) PCI-to-PCI bridge:
(II) Bus 3: bridge is at (0:12:0), (0,3,3), BCTRL: 0x0002 (VGA_EN is cleared)
(II) PCI-to-PCI bridge:
(II) Bus 2: bridge is at (0:13:0), (0,2,2), BCTRL: 0x0002 (VGA_EN is cleared)
(II) PCI-to-PCI bridge:
(II) Bus 1: bridge is at (0:14:0), (0,1,1), BCTRL: 0x000a (VGA_EN is set)
(II) Bus 1 non-prefetchable memory range:
[0] -1 0 0xd0000000 - 0xd2ffffff (0x3000000) MX[B]
(II) Bus 1 prefetchable memory range:
[0] -1 0 0xc0000000 - 0xcfffffff (0x10000000) MX[B]
(II) Host-to-PCI bridge:
(II) Bus 0: bridge is at (0:24:0), (0,0,5), BCTRL: 0x0008 (VGA_EN is set)
(II) Bus 0 I/O range:
[0] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) Bus 0 non-prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x100000000) MX[B]
(II) Bus 0 prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x100000000) MX[B]
(--) PCI:*(1:0:0) nVidia Corporation NV40 [GeForce 6800 Ultra/GeForce 6800 GT] rev 162, Mem @ 0xd0000000/24, 0xc0000000/28, 0xd1000000/24, BIOS @ 0xd2000000/17
(II) LoadModule: "bitmap"
(II) Reloading /usr/lib/xorg/modules/fonts/libbitmap.so
(II) Loading font Bitmap
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
compiled for 7.0.0, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 0.2
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "ddc"
(II) Loading /usr/lib/xorg/modules/libddc.so
(II) Module ddc: vendor="X.Org Foundation"
compiled for 7.0.0, module version = 1.0.0
ABI class: X.Org Video Driver, version 0.8
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
compiled for 7.0.0, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 0.2
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "freetype"
(II) Loading /usr/lib/xorg/modules/fonts/libfreetype.so
(II) Module freetype: vendor="X.Org Foundation & the After X-TT Project"
compiled for 7.0.0, module version = 2.1.0
Module class: X.Org Font Renderer
ABI class: X.Org Font Renderer, version 0.4
(II) Loading font FreeType
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.8774
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 0.1
(II) Loading extension GLX
(II) LoadModule: "int10"
(II) Loading /usr/lib/xorg/modules/libint10.so
(II) Module int10: vendor="X.Org Foundation"
compiled for 7.0.0, module version = 1.0.0
ABI class: X.Org Video Driver, version 0.8
(II) LoadModule: "record"
(II) Loading /usr/lib/xorg/modules/extensions/librecord.so
(II) Module record: vendor="X.Org Foundation"
compiled for 7.0.0, module version = 1.13.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 0.2
(II) Loading extension RECORD
(II) LoadModule: "type1"
(II) Loading /usr/lib/xorg/modules/fonts/libtype1.so
(II) Module type1: vendor="X.Org Foundation"
compiled for 7.0.0, module version = 1.0.2
Module class: X.Org Font Renderer
ABI class: X.Org Font Renderer, version 0.4
(II) Loading font Type1
(II) LoadModule: "v4l"
(II) Loading /usr/lib/xorg/modules/drivers/v4l_drv.so
(II) Module v4l: vendor="X.Org Foundation"
compiled for 7.0.0, module version = 0.0.1
ABI class: X.Org Video Driver, version 0.8
(II) LoadModule: "vbe"
(II) Loading /usr/lib/xorg/modules/libvbe.so
(II) Module vbe: vendor="X.Org Foundation"
compiled for 7.0.0, module version = 1.1.0
ABI class: X.Org Video Driver, version 0.8
(II) LoadModule: "nvidia"
(II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.8774
Module class: X.Org Video Driver
(II) LoadModule: "kbd"
(II) Loading /usr/lib/xorg/modules/input/kbd_drv.so
(II) Module kbd: vendor="X.Org Foundation"
compiled for 7.0.0, module version = 1.0.1
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 0.5
(II) LoadModule: "mouse"
(II) Loading /usr/lib/xorg/modules/input/mouse_drv.so
(II) Module mouse: vendor="X.Org Foundation"
compiled for 7.0.0, module version = 1.0.3
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 0.5
(II) LoadModule: "wacom"
(II) Loading /usr/lib/xorg/modules/input/wacom_drv.so
(II) Module wacom: vendor="X.Org Foundation"
compiled for 4.3.99.902, module version = 1.0.0
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 0.5
(II) Wacom driver level: 47-0.7.2 $
(II) v4l driver for Video4Linux
(II) NVIDIA dlloader X Driver  1.0-8774  Tue Aug  1 21:43:53 PDT 2006
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) Primary Device is: PCI 01:00:0
(--) Assigning device section with no busID to primary device
(--) Chipset NVIDIA GPU found
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib/xorg/modules/libfb.so
(II) Module fb: vendor="X.Org Foundation"
compiled for 7.0.0, module version = 1.0.0
ABI class: X.Org ANSI C Emulation, version 0.2
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Loading /usr/lib/xorg/modules/libramdac.so
(II) Module ramdac: vendor="X.Org Foundation"
compiled for 7.0.0, module version = 0.1.0
ABI class: X.Org Video Driver, version 0.8
(II) resource ranges after xf86ClaimFixedResources() call:
[0] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[4] -1 0 0xd3000000 - 0xd30000ff (0x100) MX[B]
[5] -1 0 0xd3100000 - 0xd3100fff (0x1000) MX[B]
[6] -1 0 0xd3101000 - 0xd3101fff (0x1000) MX[B]
[7] -1 0 0xd3102000 - 0xd3102fff (0x1000) MX[B]
[8] -1 0 0xd3103000 - 0xd3103fff (0x1000) MX[B]
[9] -1 0 0xfeb00000 - 0xfeb000ff (0x100) MX[B]
[10] -1 0 0xd3104000 - 0xd3104fff (0x1000) MX[B]
[11] -1 0 0xd2000000 - 0xd201ffff (0x20000) MX[B](B)
[12] -1 0 0xd1000000 - 0xd1ffffff (0x1000000) MX[B](B)
[13] -1 0 0xc0000000 - 0xcfffffff (0x10000000) MX[B](B)
[14] -1 0 0xd0000000 - 0xd0ffffff (0x1000000) MX[B](B)
[15] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[16] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
[17] -1 0 0x0000a000 - 0x0000a0ff (0x100) IX[B]
[18] -1 0 0x0000b000 - 0x0000b007 (0x8) IX[B]
[19] -1 0 0x0000c400 - 0x0000c40f (0x10) IX[B]
[20] -1 0 0x00000b60 - 0x00000b63 (0x4) IX[B]
[21] -1 0 0x00000960 - 0x00000967 (0x8) IX[B]
[22] -1 0 0x00000be0 - 0x00000be3 (0x4) IX[B]
[23] -1 0 0x000009e0 - 0x000009e7 (0x8) IX[B]
[24] -1 0 0x0000d800 - 0x0000d80f (0x10) IX[B]
[25] -1 0 0x00000b70 - 0x00000b73 (0x4) IX[B]
[26] -1 0 0x00000970 - 0x00000977 (0x8) IX[B]
[27] -1 0 0x00000bf0 - 0x00000bf3 (0x4) IX[B]
[28] -1 0 0x000009f0 - 0x000009f7 (0x8) IX[B]
[29] -1 0 0x0000f000 - 0x0000f00f (0x10) IX[B]
[30] -1 0 0x0000e000 - 0x0000e0ff (0x100) IX[B]
[31] -1 0 0x0000dc00 - 0x0000dcff (0x100) IX[B]
[32] -1 0 0x00004c40 - 0x00004c7f (0x40) IX[B]
[33] -1 0 0x00004c00 - 0x00004c3f (0x40) IX[B]
[34] -1 0 0x0000e400 - 0x0000e41f (0x20) IX[B]
(II) resource ranges after probing:
[0] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[4] -1 0 0xd3000000 - 0xd30000ff (0x100) MX[B]
[5] -1 0 0xd3100000 - 0xd3100fff (0x1000) MX[B]
[6] -1 0 0xd3101000 - 0xd3101fff (0x1000) MX[B]
[7] -1 0 0xd3102000 - 0xd3102fff (0x1000) MX[B]
[8] -1 0 0xd3103000 - 0xd3103fff (0x1000) MX[B]
[9] -1 0 0xfeb00000 - 0xfeb000ff (0x100) MX[B]
[10] -1 0 0xd3104000 - 0xd3104fff (0x1000) MX[B]
[11] -1 0 0xd2000000 - 0xd201ffff (0x20000) MX[B](B)
[12] -1 0 0xd1000000 - 0xd1ffffff (0x1000000) MX[B](B)
[13] -1 0 0xc0000000 - 0xcfffffff (0x10000000) MX[B](B)
[14] -1 0 0xd0000000 - 0xd0ffffff (0x1000000) MX[B](B)
[15] 0 0 0x000a0000 - 0x000affff (0x10000) MS[B]
[16] 0 0 0x000b0000 - 0x000b7fff (0x8000) MS[B]
[17] 0 0 0x000b8000 - 0x000bffff (0x8000) MS[B]
[18] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[19] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
[20] -1 0 0x0000a000 - 0x0000a0ff (0x100) IX[B]
[21] -1 0 0x0000b000 - 0x0000b007 (0x8) IX[B]
[22] -1 0 0x0000c400 - 0x0000c40f (0x10) IX[B]
[23] -1 0 0x00000b60 - 0x00000b63 (0x4) IX[B]
[24] -1 0 0x00000960 - 0x00000967 (0x8) IX[B]
[25] -1 0 0x00000be0 - 0x00000be3 (0x4) IX[B]
[26] -1 0 0x000009e0 - 0x000009e7 (0x8) IX[B]
[27] -1 0 0x0000d800 - 0x0000d80f (0x10) IX[B]
[28] -1 0 0x00000b70 - 0x00000b73 (0x4) IX[B]
[29] -1 0 0x00000970 - 0x00000977 (0x8) IX[B]
[30] -1 0 0x00000bf0 - 0x00000bf3 (0x4) IX[B]
[31] -1 0 0x000009f0 - 0x000009f7 (0x8) IX[B]
[32] -1 0 0x0000f000 - 0x0000f00f (0x10) IX[B]
[33] -1 0 0x0000e000 - 0x0000e0ff (0x100) IX[B]
[34] -1 0 0x0000dc00 - 0x0000dcff (0x100) IX[B]
[35] -1 0 0x00004c40 - 0x00004c7f (0x40) IX[B]
[36] -1 0 0x00004c00 - 0x00004c3f (0x40) IX[B]
[37] -1 0 0x0000e400 - 0x0000e41f (0x20) IX[B]
[38] 0 0 0x000003b0 - 0x000003bb (0xc) IS[B]
[39] 0 0 0x000003c0 - 0x000003df (0x20) IS[B]
(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Enabling RENDER acceleration
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module! Please ensure
(EE) NVIDIA(0):     that there is a supported NVIDIA GPU in this system, and
(EE) NVIDIA(0):     that the NVIDIA device files have been created properly.
(EE) NVIDIA(0):     Please consult the NVIDIA README for details.
(EE) NVIDIA(0):  *** Aborting ***
(II) UnloadModule: "nvidia"
(II) UnloadModule: "ramdac"
(II) UnloadModule: "fb"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Eu não entendi direito, parece que ele diz que não há placa de vídeo no meu pc, porque vai tudo muito bem, até essa parte:

(**) NVIDIA(0): Enabling RENDER acceleration
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module! Please ensure
(EE) NVIDIA(0):     that there is a supported NVIDIA GPU in this system, and
(EE) NVIDIA(0):     that the NVIDIA device files have been created properly.
(EE) NVIDIA(0):     Please consult the NVIDIA README for details.
(EE) NVIDIA(0):  *** Aborting ***

(Uma parte do log, o Pci-scan, foi retirada, pois a mensagem está ultrapassando o limite de caracteres)
« Última modificação: 20 de Setembro de 2006, 18:31 por Saishy »

Offline Saishy

  • Usuário Ubuntu
  • *
  • Mensagens: 11
  • CounterDragon
    • Ver perfil
    • CounterDragon
Respondendo felizmente ^^
« Resposta #3 Online: 20 de Setembro de 2006, 18:51 »
Estou muito feliz em anunciar que consegui resolver o problema!
Estou dando um doplo post, por causa do limite maximo de caracteres, e não queria deletar o post antigo, pois dificultaria a vida de outros com o mesmo problema que eu.

Como eu não sou aqueles safados que resolvem as coisas e não diz como, para os outros terem de fazer a mesma pergunta XD, aqui vai o problema e solução:

Problema: Dois pacotes Linux-restricted-modules e Linux-image instalados, com versões diferentes.
Solução: Remoção do pacote antigo, #sudo apt-get remove nvidia-glx e #sudo apt-get install nvidia-glx , #Sudo nvidia-glx-config disable ; Sudo nvidia-glx-config enable (Pode colar os dois assim mesmo, com o ; e tudo).

Lembrando que tudo isso tem de ser feito fora do Xserver e GDM, feche a seção, aperte ctrl+alt+f1 e digite #sudo /etc/init.d/gdm stop, quando terminar de fazer tudo, digite #sudo /etc/init.d/gdm start

Se não resolver o seu problema, tente outros fórums e links.

http://www.linuxval.org/ubuntu/phpBB2/viewtopic.php?p=37587#37587
(Um tópico util)