Autor Tópico: [RESOLVIDO] Não consigo bootar SO através do Grub  (Lida 29703 vezes)

Offline Ibnny

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
[RESOLVIDO] Não consigo bootar SO através do Grub
« Online: 28 de Janeiro de 2013, 18:47 »
A história é meio longa, mas acredito que não seja tão complicada de resolver e as informações a seguir devem ser importantes para isso.

Tudo começou quando resolvi instalar o Ubuntu 12.10 no meu Netbook (Samsung, HD 250Gb, 2Gb RAM, Atom) para ele rodar em dual boot com o Windows 7 Starter que já havia na máquina. Criei então uma nova partição para instalar o Ubuntu nela, porém quando fui instalar o SO o Ubuntu me ofereceu a opção de instalá-lo 'ao lado' do Windows, para que eu escolhesse um dos dois na inicialização.

Até aí tudo bem, fiz a instalação, foi realizada com êxito, os dois SO's estavam rodando sem problemas. Daí, como eu tinha criado uma nova partição para o Ubuntu, mas não ia mais utilizá-la (uma vez que optei por instalar 'ao lado' do Windows), decidi dividir o conteúdo dessa partição nova nas duas outras já existentes (a padrão do Windows "C:" (120Gb) e uma "D:"(80Gb) que uso para guardar apenas arquivos pessoais).

Após realizar essa operação, durante a inicialização do sistema foi retornado o seguinte erro:

no such partition
grub rescue> _


Pesquisando na internet encontrei que poderia reparar este erro através do LiveCD do Ubuntu (que rodo a partir de Pendrive USB, uma vez que meu Netbook não tem unidade de CD/DVD) digitando os seguintes comandos no Terminal:

sudo fdisk -l
sudo mount /dev/sda3 /mnt
sudo grub-install --root-directory=/mnt /dev/sda


Terminado esse processo, apareceu a mensagem que a operação havia sido realizada com sucesso. Reiniciei o sistema novamente, então apareceu a seguinte tela:

GNU GRUB version 2.00-7ubuntu11

Minimal BASH-like line editing is supported. For the first word, TAB lists possible command completions. Anywhere else TAB lists possible device or file completions.

grub> _


Apertando a tecla TAB são exibidos os nomes de todos os comandos disponíveis, porém não sei qual é o correto para iniciar o sistema. Tentei digitar o comando 'boot' mas aparece a seguinte mensagem: "you need to load the kernel first".

Bom, não sei mais o que fazer. Já pesquisei em vários locais e pelo que dizem o dual boot deveria executar de primeira depois da recuperação do grub. Já vi também que haveria a possibilidade de recuperar o sistema com o CD do Windows, porém não tenho esse CD, uma vez que a instalação do SO foi através do instalador presente no próprio HD do pc (Samsung Recovery Solution), e que não consigo mais acessar.

Como devo proceder para recuperar o dual boot dos sistemas?
« Última modificação: 29 de Janeiro de 2013, 14:19 por Ibnny »

Offline Arthur Bernardes

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re: Não consigo bootar SO através do Grub
« Resposta #1 Online: 28 de Janeiro de 2013, 19:01 »
Citar
Pesquisando na internet encontrei que poderia reparar este erro através do LiveCD do Ubuntu (que rodo a partir de Pendrive USB, uma vez que meu Netbook não tem unidade de CD/DVD) digitando os seguintes comandos no Terminal:

sudo fdisk -l
sudo mount /dev/sda3 /mnt
sudo grub-install --root-directory=/mnt /dev/sda

Essa é sua partição do Ubuntu ? Tem certeza..? Refaça esse processo montando a sua partição do Linux..!

O meu está assim. Disco /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total de 976773168 setores
Unidades = setores de 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Identificador do disco: 0x1d9ed9dd

Dispositivo Boot Início Fim Blocos Id Sistema
/dev/sda1   *        2046   385509375   192753665    5  Estendida
Partition 1 does not start on physical sector boundary.
/dev/sda2       385509376   976773119   295631872    7  HPFS/NTFS/exFAT
/dev/sda5         7815168   385509375   188847104   83  Linux
/dev/sda6            4096     7813119     3904512   82  Linux swap / Solaris

Partições lógicas fora da ordem do disco


==> /dev/sda5         7815168   385509375   188847104   83  Linux

Offline Ibnny

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Re: Não consigo bootar SO através do Grub
« Resposta #2 Online: 28 de Janeiro de 2013, 19:20 »
O meu está como posto a seguir, porém, como sou iniciante no Ubuntu, peço que, se possível, me ajudem a identificar isso.  ???

Disco /dev/sda: 250.1 GB, 250059350016 bytes
255 cabeças, 63 setores/trilhas, 30401 cilindros, total de 488397168 setores
Unidades = setores de 1 * 512 = 512 bytes
Tamanho do setor (lógico/físico): 512 bytes / 512 bytes
Tamanho da E/S (mínimo/ideal): 512 bytes / 512 bytes
Identificador do disco: 0x8854d39f

Dispositivo Boot Início Fim Blocos Id Sistema
/dev/sda1            2048    31459327    15728640   27  WinRE de NTFS oculto
/dev/sda2   *    31459328    31664127      102400    7  HPFS/NTFS/exFAT
/dev/sda3        31664128   283322339   125829106    7  HPFS/NTFS/exFAT
/dev/sda4       283322408   428390767    72534180    7  HPFS/NTFS/exFAT
« Última modificação: 29 de Janeiro de 2013, 00:12 por Ibnny »

Offline Arthur Bernardes

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re: Não consigo bootar SO através do Grub
« Resposta #3 Online: 28 de Janeiro de 2013, 23:45 »
Cara, ai não tem Linux instalado não..!  :-\ :-\

Pelo menos não vi no resultado..!

Offline Ibnny

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Re: Não consigo bootar SO através do Grub
« Resposta #4 Online: 29 de Janeiro de 2013, 00:07 »
Cara, ai não tem Linux instalado não..!  :-\ :-\

Pelo menos não vi no resultado..!

 :-\
Pois tem sim.
Pelo que lembro as partições são as seguintes:

/dev/sda1 = RECOVERY
/dev/sda2 = SYSTEM
/dev/sda3 = Partição onde está o Win 7 + o Ubuntu
/dev/sda4 = Partição dos arquivos pessoais
« Última modificação: 29 de Janeiro de 2013, 14:22 por Ibnny »

Offline Arthur Bernardes

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re: Não consigo bootar SO através do Grub
« Resposta #5 Online: 29 de Janeiro de 2013, 00:24 »
==> /dev/sda5         7815168   385509375   188847104   83  Linux O meu é assim.!

O seu não tem nada relacionado..!

Offline Ibnny

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Re: Não consigo bootar SO através do Grub
« Resposta #6 Online: 29 de Janeiro de 2013, 11:06 »
Mas não tem nada que eu possa fazer para tentar bootar o Windows ou Ubuntu?
Como eu falei, aparece a seguinte tela do GRUB durante a inicialização, a qual pede que seja inserido algum comando:

Código: [Selecionar]
GNU GRUB version 2.00-7ubuntu11

Minimal BASH-like line editing is supported. For the first word, TAB lists possible command completions. Anywhere else TAB lists possible device or file completions.

grub> _

Alguém sabe qual o comando correto para bootar o sistema?  :-\
« Última modificação: 29 de Janeiro de 2013, 11:08 por Ibnny »

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: Não consigo bootar SO através do Grub
« Resposta #7 Online: 29 de Janeiro de 2013, 12:34 »
Ola

O melhor mesmo é começar do zero.

1) Inicie o seu computador com o cd do Ubuntu, escolha "testar o Ubuntu"

2) Com o sistema inicializado, abra uma janela do terminal digitando na lupa => terminal

3) com o terminal aberto digite o comando
Código: [Selecionar]
sudo fdisk -lsudo<espaço><éfe+disk><espaço><traço><éle minusculo>

4) procure por uma partição Linux

5) Caso não exista, e apenas apareçam partições HPFS/NTFS/exFAT, realmente voce apagou seu Linux.

Desligue a maquina e:

6) use seu cd original do Windows e inicie a maquina por ele, escolhendo a opção => Reparar o Windows

7) Após terminar, seu windows deve funcionar 100%

8 ) Faça um exame de disco por duas vezes usando em prompt de comandos => chkdsk /R (faça duas vezes)

9) Use o gerenciador de discos do Windows e recrie uma partição vazia para reinstalar o Ubuntu.


Caso exista uma partição Linux em seu sistema, inicie no passo 3 e siga até o passo 8

Depois de executar os passos de 3 a 8 e com o windows funcionando, inicie com o cd do Ubuntu e recupere seu GRUB.

Boa sorte e se tiver duvidas volte a postar o fdisk -l

[]'s
« Última modificação: 29 de Janeiro de 2013, 12:36 por Tota »

Offline Ibnny

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Re: Não consigo bootar SO através do Grub
« Resposta #8 Online: 29 de Janeiro de 2013, 14:17 »
É... não teve jeito, tive que formatar o PC mesmo.  :-\
Como consegui ter acesso aos meus arquivos pelo LiveCD do Ubuntu, então pude salvá-los num HD externo a tempo.

Agradeço aos que ajudaram!  :)

Offline willygm

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
Re: [RESOLVIDO] Não consigo bootar SO através do Grub
« Resposta #9 Online: 18 de Agosto de 2013, 20:34 »
Ola,

estou procurando resolver esse problema do grub tambem e encontrei este post com o meu caso: no comando sudo fdisk -l a saida e essa:

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x6534653a

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          26      204800    7  HPFS/NTFS
Partition 1 does not end on cylinder boundary.
/dev/sda2              26       12197    97762712+   7  HPFS/NTFS
/dev/sda3           12197       36988   199130625    f  W95 Ext'd (LBA)
Partition 3 does not end on cylinder boundary.
/dev/sda4           36988       38914    15471448   12  Compaq diagnostics
/dev/sda5           33203       36988    30404608    7  HPFS/NTFS

Disk /dev/sdb: 16.2 GB, 16231956480 bytes
256 heads, 54 sectors/track, 2293 cylinders
Units = cylinders of 13824 * 512 = 7077888 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xc3072e18

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1        2294    15851504    c  W95 FAT32 (LBA)

E no Gparted aparece:
http://imageshack.us/photo/my-images/541/uhn6.png/


Eu precisei reiniciar o windows 7 no modo de fabrica e depois disso o grub foi apagado. tentei os procedimentos:
http://ubuntuforum-br.org/index.php/topic,106364.0.html
http://ubuntuforum-br.org/index.php/topic,106364.0.html
e este em particular
http://ubuntuforum-br.org/index.php/topic,14614.0.html
mas o principal e saber em qual particao o linux esta instalado, mas nao tem ou nao sei qual e a particao.

« Última modificação: 18 de Agosto de 2013, 21:02 por willygm »