Autor Tópico: erro no gerenciador de atualizações do xubuntu[resolvido]  (Lida 3385 vezes)

Offline wmnunes

  • Usuário Ubuntu
  • *
  • Mensagens: 19
    • Ver perfil
erro no gerenciador de atualizações do xubuntu[resolvido]
« Online: 07 de Setembro de 2013, 20:27 »
Caros Amigos:
Utilizo o xubuntu 12.04 precise pangolin;nessa última atualização começou a aparecer um erro muito esquisito, que não sei como consertar.nã atualiza, e aparece a seguinte mensagem:

" installArchives() failed: dpkg: error: parsing file '/var/lib/dpkg/available' near line 12830 package 'libtommath0':
duplicate value for `Size' field "

PS.; Por conta desse problema, não consigo atualizar nem instalar qq. pacote deb.

Alguém saberia resolver?
desde já, agradeço
wnunes.
« Última modificação: 09 de Setembro de 2013, 03:02 por wmnunes »

Offline jkmsjq

  • Usuário Ubuntu
  • *
  • Mensagens: 3.337
  • Ubuntu Member
    • Ver perfil
Re: erro no gerenciador de atualizações do xubuntu
« Resposta #1 Online: 07 de Setembro de 2013, 20:34 »
Utilize os seguintes comandos, um de cada vez no terminal:

Código: [Selecionar]
sudo apt-get install -f
sudo dpkg --configure -a
sudo apt-get update
sudo apt-get upgrade

Se aparecer alguma mensagem de erro, poste-a aqui, por completa.
LinuxUser: 548942 / Dando um tópico como resolvido
"A verdade só é agressiva a quem vive de mentiras". Autor desconhecido.
Twitter: @jeisonkertesz

Offline wmnunes

  • Usuário Ubuntu
  • *
  • Mensagens: 19
    • Ver perfil
Re: erro no gerenciador de atualizações do xubuntu
« Resposta #2 Online: 08 de Setembro de 2013, 01:22 »
  Caro Amigo:

  Apareceu só esse erro, que é o mesmo,  no final......(abaixo, colado).

  Baixados 2.352 kB em 15s (151 kB/s)                                           
dpkg: erro: analisando arquivo '/var/lib/dpkg/available' próximo à linha 12830 pacote 'libtommath0':
 valor duplicado para o campo 'Size'
E: Sub-process /usr/bin/dpkg returned an error code (2)
ted@ted-desktop:~$

Offline NOOB Saibot

  • Usuário Ubuntu
  • *
  • Mensagens: 222
    • Ver perfil
Re: erro no gerenciador de atualizações do xubuntu
« Resposta #3 Online: 08 de Setembro de 2013, 11:41 »
Abre o terminal e digita sudo gedit /var/lib/dpkg/available vai até a linha 12830 e veja se não tem um valor duplicado
para o campo Size, se tiver adiciona um # no inicio da linha salva o arquivo e tenta denovo sudo apt-get update

O # comenta a diretiva em questão e faz com que a linha seja ignorada pelo apt-get.
 

Offline wmnunes

  • Usuário Ubuntu
  • *
  • Mensagens: 19
    • Ver perfil
Re: erro no gerenciador de atualizações do xubuntu
« Resposta #4 Online: 08 de Setembro de 2013, 13:55 »
Agora o erro foi prá linha 12832..:

installArchives() failed: dpkg: error: parsing file '/var/lib/dpkg/available' near line 12832 package 'libtommath0':
 duplicate value for `Description' field
Error in function:

Veja meu arquivo em questão:

Package: libtommath0
Priority: optional
Section: libs
Installed-Size: 160
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Architecture: i386
Source: libtommath
Version: 0.42.0-1
Depends: libc6 (>= 2.3)
Size: 47544
Description: multiple-precision integer library [runtime]
 LibTomMath is a C language library that provides a vast array of highly
 optimized functions for number theory; including:
 .
  * Simple Algebra (Addition, Subtraction, Multiplication, Division)
  * Digit Manipulation (shift, binary AND/OR/XOR)
  * Modular Reduction (Barrett, Montgomery, DR, 2k)
  * Number Theory
    - Greatest Common Divisor
    - Least Comter (>= 1.0.0-0ubuntu2)
Pre-Depends: dpkg (>= 1.15.7.2)
Recommends: xfce4-utils
Size: 19162
Description: default settings for the Xubuntu desktop
 This package contains the default settings used by Xubuntu.
Homepage: https://launchpad.net/xubuntu-default-settings

PS.:  Já coloquei # antes dos valores(2) mencionados - 1 vez cada - 47544, e 19162 - Sempre dá o mesmo erro - Só alterna a linha.


« Última modificação: 08 de Setembro de 2013, 14:05 por wmnunes »

Offline NOOB Saibot

  • Usuário Ubuntu
  • *
  • Mensagens: 222
    • Ver perfil
Re: erro no gerenciador de atualizações do xubuntu
« Resposta #5 Online: 08 de Setembro de 2013, 14:22 »
Comenta as duas, também tenho este package que foi instalado com o clamav.
Qual foi o último aplicativo que tu instalou?

Offline wmnunes

  • Usuário Ubuntu
  • *
  • Mensagens: 19
    • Ver perfil
Re: erro no gerenciador de atualizações do xubuntu
« Resposta #6 Online: 08 de Setembro de 2013, 20:27 »
  Cara, deu erro, de novo, c/ as 2 linhas comentadas..(colando)..
 
installArchives() failed: dpkg: error: parsing file '/var/lib/dpkg/available' near line 12830 package 'libtommath0':
 duplicate value for user-defined field `#Size'
Error in function:

PS.; O problema começou c/ uma atualização do google-chrome, depois, tentei instalar os seguintes navegadores, tds pacotes deb....
       SRWare - não instalou.
       Chromium - também não instalou.
       O Próprio google-chrome, que não abria - também não instalou.
       Além de não conseguir mais instalar pacotes deb., qdo. veio as atualizações, também não atualizava;Desde então o problema persiste, e não instala as atualizações.

Offline NOOB Saibot

  • Usuário Ubuntu
  • *
  • Mensagens: 222
    • Ver perfil
Re: erro no gerenciador de atualizações do xubuntu
« Resposta #7 Online: 08 de Setembro de 2013, 22:24 »
Acho que me expressei errado, comenta isso aqui do teu arquivo

Size: 19162
Description: default settings for the Xubuntu desktop

Só não recomendo desistalar este pacote porque pode ser importante

Offline wmnunes

  • Usuário Ubuntu
  • *
  • Mensagens: 19
    • Ver perfil
Re: erro no gerenciador de atualizações do xubuntu[resolvido]
« Resposta #8 Online: 09 de Setembro de 2013, 03:04 »
  Putz, cara....resolveu!!!!

 Atualizou, sem problemas, e também pude instalar o chromium; Muito Obrigado pela ajuda, amigo!!!