Autor Tópico: Problemas na instalação do Mediawiki 1.7.1  (Lida 6249 vezes)

Offline augustonunes

  • Usuário Ubuntu
  • *
  • Mensagens: 67
    • Ver perfil
Problemas na instalação do Mediawiki 1.7.1
« Online: 21 de Setembro de 2006, 14:45 »
Pessoal, estou instalando o Mediawiki 1.7.1 no Ubuntu 5.10 e logo que inica-se a instalação, na segunda tela aparece a mensagem abaixo:

    * PHP 5.0.5-2ubuntu1.4 installed
      Could not find a suitable database driver!
          o For MySQL, compile PHP using --with-mysql, or install the mysql.so module
          o For PostgreSQL, compile PHP using --with-pgsql, or install the pgsql.so module


O MySQL está instalado corretamente, o PHP está funcionando e o Apache também.

Pesquisando no Google, diversas pessoas encontraram o mesmo problema, mas nenhuma solução foi apresentada.

Alguém saberia como resolver este probleminha e/ou poderia ajudar?

Agradecendo antecipadamente qualquer ajuda,

Augusto Cesar

Offline Xterminator

  • Usuário Ubuntu
  • *
  • Mensagens: 1.279
    • Ver perfil
Re: Problemas na instalação do Mediawiki 1.7.1
« Resposta #1 Online: 21 de Setembro de 2006, 17:02 »
Não manjo nada deste assunto, mas vou perguntar você instalou os pacotes..
php5-mysql para mysql
php5-pgsql para postgre ?

Offline augustonunes

  • Usuário Ubuntu
  • *
  • Mensagens: 67
    • Ver perfil
Re: Problemas na instalação do Mediawiki 1.7.1
« Resposta #2 Online: 22 de Setembro de 2006, 13:19 »
Sim, estão instalados. Eu fiz o seguinte: deletei tudo que existia no diretório /var/www/wink, onde estava instalada a versão 1.7.1, e inicie uma instalação via apt-get (sudo apt-get install mediawink mediawink-math), já que exite repositório do Ubuntu com estes pacotes.

Quando terminou de baixar os pacotes, automaticamente iniciou-se a instalação dos mesmos.

Uma mensagem de aviso foi-me apresentada, informando que o mediawiki-math não poderia ser instalado porque o mediawiki (primeiro pacote) ainda não havia sido configurado. Ok, então saí para a configuração do mediawiki.

O grande problema está em que, seja na versão 1.7.1 ou na 1.4, a que vem do repositório do Ubuntu, na segunda janela ele(s) reclama(m) que não foi possível carregar a biblioteca dinâmica mysql.so !!!

E ela está instalada !!! Veja abaixo a mensagem de erro:

======================================================================
Warning: dl() [function.dl]: Unable to load dynamic library '/usr/lib/php5/20041030/mysql.so' - /usr/lib/php5/20041030/mysql.so: undefined symbol: OnUpdateInt in /usr/share/mediawiki/install-utils.inc on line 17
Could not load MySQL driver! Please compile php --with-mysql or install the mysql.so module.
======================================================================

Como isso pode estar acontecendo, se todas as dependências estão resolvidas?

Já procurei informações sobre isso em diversos lugares na Internet, mas, aparentemente divesos outros usuários encontraram o mesmo problema, resolveram de alguma outra forma, porém não dizem "como" solucionaram o mesmo...

Se souber de alguma coisa, agradeço imensamente a ajuda, pois preciso instalar este ambiente colaborativo até 2a. feira aqui no serviço...!!!

Um grande abraço,

Augusto Cesar

Offline Xterminator

  • Usuário Ubuntu
  • *
  • Mensagens: 1.279
    • Ver perfil
Re: Problemas na instalação do Mediawiki 1.7.1
« Resposta #3 Online: 22 de Setembro de 2006, 14:47 »
faz o seguinte

Código: [Selecionar]
sudo updatedb
e em seguida

Código: [Selecionar]
locate mysql.so
coloca a saída aqui pra ver se você tem esta biblioteca perdida em algum lugar.

Offline augustonunes

  • Usuário Ubuntu
  • *
  • Mensagens: 67
    • Ver perfil
Re: Problemas na instalação do Mediawiki 1.7.1
« Resposta #4 Online: 22 de Setembro de 2006, 15:34 »
Olha o resultado:

admin@ubuntu01:/usr/lib/php5/20041030$ locate mysql.so
/usr/lib/python2.4/site-packages/_mysql.so
/usr/lib/perl5/auto/DBD/mysql/mysql.so
/usr/lib/qt3/plugins/sqldrivers/libqsqlmysql.so
/usr/lib/apache2/modules/mod_auth_mysql.so
/usr/lib/php5/20041030/mysql.so
/usr/lib/php4/20050606/mysql.so

Observe a penúltima linha! Está lá... e ..???




Offline Xterminator

  • Usuário Ubuntu
  • *
  • Mensagens: 1.279
    • Ver perfil
Re: Problemas na instalação do Mediawiki 1.7.1
« Resposta #5 Online: 22 de Setembro de 2006, 16:18 »
Nossa cara muito estranho mesmo, recomendo você reinstalar os pacotes...
e se não tiver solução você vai ter que compilar infelizmente.

Offline augustonunes

  • Usuário Ubuntu
  • *
  • Mensagens: 67
    • Ver perfil
Re: Problemas na instalação do Mediawiki 1.7.1
« Resposta #6 Online: 22 de Setembro de 2006, 17:07 »
é... o mais estranho é que aqui o Fórum do Ubuntu, usa Wiki, descobrí que é o MoinMoin. Já baixei e estou instalando, mas será que alguém aqui, digo da parte de administração e/ou manutenção do espaço, não saberia dizer que ferramentas estão sendo usadas para Wiki do Ubuntu Fórum?

Não preciso de nada super-complexo, é para colocar aqui na Intranet e compartilhar conhecimento.

Por exemplo: estou trabalhando em um projeto de acessibilidade para portadores de necessidades especiais; tudo que eu consigo seria interessante divulgar para os outros participantes do projeto, e que sabe alguém também tem alguma coisa a compartilhar...

Não vai ser um Wiki público, pelo menos por enquanto...

Agradeço a sua ajuda e vamos continuar mantendo contato, pois agora, só na 2a. feira é que vou ter condições de dar continuidade ao trabalho...

Valeu, amigo !

Bom final-de-semana e até 2a. !!!

Offline Alysson Neto

  • Administrador
  • Official Ubuntu Member
  • Usuário Ubuntu
  • *****
  • Mensagens: 606
    • Ver perfil
Re: Problemas na instalação do Mediawiki 1.7.1
« Resposta #7 Online: 24 de Setembro de 2006, 02:11 »
Acabei de instalar a versão 1.7.1 do MediaWiki aqui para testar e foi sem problemas. Reinstale se LAMP com o seguinte comando:
 
Código: [Selecionar]
sudo apt-get install apache2 mysql-server php5 php5-mysql
Depois descompacte o pacote do MediaWiki no /var/www/ e de permissão de escrita no diretorio config com o comando chmod a+w config. Após isso é só entrar em localhost e responder as perguntas de instalação (nome do admin, senha..) e pronto.


« Última modificação: 24 de Setembro de 2006, 02:16 por n3t0 »
"Eu rejeito sua realidade e substituo pela minha" Adam Savage,

Offline augustonunes

  • Usuário Ubuntu
  • *
  • Mensagens: 67
    • Ver perfil
Re: Problemas na instalação do Mediawiki 1.7.1
« Resposta #8 Online: 25 de Setembro de 2006, 12:21 »
Ok, já refiz toda a instalação do LAMP, mas quando eu digito http://localhost/mediawiki-1.7.1, ele exibe a primeira tela (aquela com uma flor amarela), informa que eu devo configurar o programa inicialmente, e quando clico no next, ele informa: "PHP 5.0.0 or higher is required. ABORTING."

Eu agora não estou lembrando, mas qual o arquivo .ini ou .conf que eu tenho que alterar para que o libphp5.so seja carregado?