Autor Tópico: Erros no wow.  (Lida 17617 vezes)

Offline LucasGama

  • Usuário Ubuntu
  • *
  • Mensagens: 37
    • Ver perfil
Erros no wow.
« Online: 20 de Outubro de 2013, 14:36 »
Sei que já deve ter tópicos sobre isso nesse forum. Já abri vários tópicos de vários fórums mas nenhum tinha a resolução pro meu problema, então resolvi criar um para ver se alguém me ajuda.
É o seguinte, copiei os arquivos do wow do windows para o linux e abri usando o wine. Beleza, a imagem ficou toda bugada então botei para usar opengl.
O problema é que não sei se é pelo lugar mas tem personagem que eu consigo entrar e tem personagem que quando eu entro aparece aquela mensagem de erro "error #132 (0x85100084) Fatal exception!". Outro problema é que enquanto no windows eu jogava tranquilamente com o gráfico no "Bom", pelo wine várias opções de "Efeito" ficam no baixo aparecendo a mensagem de que não pode ir para alto devido à problemas relacionados a placa gráfica.
Meu notebook é um core i5 3210M com 6gb de ram e intel HD graphics 4000.

Offline yureee123

  • Usuário Ubuntu
  • *
  • Mensagens: 154
    • Ver perfil
Re: Erros no wow.
« Resposta #1 Online: 21 de Outubro de 2013, 01:19 »
Sei que já deve ter tópicos sobre isso nesse forum. Já abri vários tópicos de vários fórums mas nenhum tinha a resolução pro meu problema, então resolvi criar um para ver se alguém me ajuda.
É o seguinte, copiei os arquivos do wow do windows para o linux e abri usando o wine. Beleza, a imagem ficou toda bugada então botei para usar opengl.
O problema é que não sei se é pelo lugar mas tem personagem que eu consigo entrar e tem personagem que quando eu entro aparece aquela mensagem de erro "error #132 (0x85100084) Fatal exception!". Outro problema é que enquanto no windows eu jogava tranquilamente com o gráfico no "Bom", pelo wine várias opções de "Efeito" ficam no baixo aparecendo a mensagem de que não pode ir para alto devido à problemas relacionados a placa gráfica.
Meu notebook é um core i5 3210M com 6gb de ram e intel HD graphics 4000.



Eu tive uns problemas com gráficos no battlefield 2 um tempo atrás e as coisas que fiz pra resolver podem te ajudar a resolver os seus. Tive que fazer 2 coisas: (1) instalar os drives da intel e (2) atualizar o wine.

O tópico era esse, pra mais detalhes:
http://ubuntuforum-br.org/index.php/topic,109150.0.html
« Última modificação: 21 de Outubro de 2013, 01:27 por yureee123 »

Offline LucasGama

  • Usuário Ubuntu
  • *
  • Mensagens: 37
    • Ver perfil
Re: Erros no wow.
« Resposta #2 Online: 21 de Outubro de 2013, 22:10 »
Citar
Eu tive uns problemas com gráficos no battlefield 2 um tempo atrás e as coisas que fiz pra resolver podem te ajudar a resolver os seus. Tive que fazer 2 coisas: (1) instalar os drives da intel e (2) atualizar o wine.

O tópico era esse, pra mais detalhes:
http://ubuntuforum-br.org/index.php/topic,109150.0.html

Fiz tudo do passo a passo e instalei o wine 1.6 (o que tinha era o 1.4) e parece que deu uma melhorada sim, mas no "Bom" ainda aparecem os problemas na parte de "Efeitos" dizendo que não pode ser configurado para "Bom" devido a problemas relacionados a placa de video, o que nunca aconteceu no windows.
« Última modificação: 21 de Outubro de 2013, 22:33 por LucasGama »

Offline irtigor

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.344
  • Delete, delete, delete!
    • Ver perfil
Re: Erros no wow.
« Resposta #3 Online: 22 de Outubro de 2013, 08:16 »
Até pode ter uma solução, mas funcionar no Windows não significa nada.

Offline LucasGama

  • Usuário Ubuntu
  • *
  • Mensagens: 37
    • Ver perfil
Re: Erros no wow.
« Resposta #4 Online: 22 de Outubro de 2013, 08:31 »
Depois dessas modificações voltei a configuraçao do wow pra usar direct x9 ao inves do opengl e agora aquelas opções conseguem ser selecionadas normalmente! :D
O único problema é o desempenho que ainda está muito inferior ;/ no Bom ta 22~27 fps... no windows que eu me lembre era uns 45+...no medio aqui ta ficando 30~

Offline LucasGama

  • Usuário Ubuntu
  • *
  • Mensagens: 37
    • Ver perfil
Re: Erros no wow.
« Resposta #5 Online: 22 de Outubro de 2013, 08:35 »
Até pode ter uma solução, mas funcionar no Windows não significa nada.

É que li em alguns lugares de pessoas que conseguiram rodar esse jogo pelo linux com desempenho igual ou praticamente igual do windows, e estou tentando o mesmo.

Offline Solid One

  • Usuário Ubuntu
  • *
  • Mensagens: 276
  • Linux for human beings
    • Ver perfil
Re: Erros no wow.
« Resposta #6 Online: 22 de Outubro de 2013, 09:29 »
Sugiro que dê uma lida nos relatos de teste do World of Warcraft no Wine, conforme relatado por vários usuários no site Wine APP Database: http://appdb.winehq.org/objectManager.php?sClass=application&iId=1922

A maioria dos testes fornece resultados Platinum ou Gold, tido como mais altos no site. Talvez alguém possua alguma dica de como melhorar a performance (se possível).

Por outro lado, é normal haver perda de desempenho em jogos. Dependendo do jogo, a perda pode variar de 10 a 30% (às vezes mais).

Eu jogava StarCraft 2 pelo Wine um tempo atrás, e embora o jogo rodasse perfeitamente (finalizei até a campanha dessa maneira), ainda sim havia uma perda de desempenho de 10~15% em relação ao Windows.

Offline LucasGama

  • Usuário Ubuntu
  • *
  • Mensagens: 37
    • Ver perfil
Re: Erros no wow.
« Resposta #7 Online: 22 de Outubro de 2013, 09:52 »
Sugiro que dê uma lida nos relatos de teste do World of Warcraft no Wine, conforme relatado por vários usuários no site Wine APP Database: http://appdb.winehq.org/objectManager.php?sClass=application&iId=1922

A maioria dos testes fornece resultados Platinum ou Gold, tido como mais altos no site. Talvez alguém possua alguma dica de como melhorar a performance (se possível).

Por outro lado, é normal haver perda de desempenho em jogos. Dependendo do jogo, a perda pode variar de 10 a 30% (às vezes mais).

Eu jogava StarCraft 2 pelo Wine um tempo atrás, e embora o jogo rodasse perfeitamente (finalizei até a campanha dessa maneira), ainda sim havia uma perda de desempenho de 10~15% em relação ao Windows.

Nesse site que você passou diz que é usado o wine 1.7.3 para esse jogo. Fui tentar atualizar do 1.6 para o 1.7.3 usando o sudo apt-get install wine1.7 e deu  seguinte erro:

Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
 wine1.7 : Depende: wine1.7-amd64 (= 1.7.4-0ubuntu4) mas não será instalado
           Depende: wine1.7-i386 (= 1.7.4-0ubuntu4)
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.


Sabe resolver?

Offline Solid One

  • Usuário Ubuntu
  • *
  • Mensagens: 276
  • Linux for human beings
    • Ver perfil
Re: Erros no wow.
« Resposta #8 Online: 22 de Outubro de 2013, 11:26 »
Você está instalando o Wine 1.7.3 como? Através de PPA ou baixando os .deb direto?

Qual a versão do Ubuntu que você está utilizando?

À primeira instância, esse problema me parece ser no próprio PPA do Wine, pressupondo que você o esteja utilizando.

Offline Lucimgr

  • Usuário Ubuntu
  • *
  • Mensagens: 112
    • Ver perfil
Re: Erros no wow.
« Resposta #9 Online: 22 de Outubro de 2013, 11:39 »
já rodei WoW no ubuntu tempos atrás, roda legal! sem bugs! mas o desempenho gráfico é sempre prejudicado! se vc tem um computador que roda com sobra no windows, vai rodar tranquilo no linux! como vc já roda a 45 FPS no windows (abaixo de 60) quer dizer que já tá rodando devagar no windows! é impossível rodar com mesmo desempenho no linux (não faria sentido).

quer jogar jogos atuais --> usa Windows (dual boot é uma ótima opção).

Offline LucasGama

  • Usuário Ubuntu
  • *
  • Mensagens: 37
    • Ver perfil
Re: Erros no wow.
« Resposta #10 Online: 22 de Outubro de 2013, 11:52 »
já rodei WoW no ubuntu tempos atrás, roda legal! sem bugs! mas o desempenho gráfico é sempre prejudicado! se vc tem um computador que roda com sobra no windows, vai rodar tranquilo no linux! como vc já roda a 45 FPS no windows (abaixo de 60) quer dizer que já tá rodando devagar no windows! é impossível rodar com mesmo desempenho no linux (não faria sentido).

quer jogar jogos atuais --> usa Windows (dual boot é uma ótima opção).

Por que não faria sentido?

Você está instalando o Wine 1.7.3 como? Através de PPA ou baixando os .deb direto?

Qual a versão do Ubuntu que você está utilizando?

À primeira instância, esse problema me parece ser no próprio PPA do Wine, pressupondo que você o esteja utilizando.
Sim, estou utilizando.
« Última modificação: 22 de Outubro de 2013, 11:55 por LucasGama »

Offline Solid One

  • Usuário Ubuntu
  • *
  • Mensagens: 276
  • Linux for human beings
    • Ver perfil
Re: Erros no wow.
« Resposta #11 Online: 22 de Outubro de 2013, 15:13 »
já rodei WoW no ubuntu tempos atrás, roda legal! sem bugs! mas o desempenho gráfico é sempre prejudicado! se vc tem um computador que roda com sobra no windows, vai rodar tranquilo no linux! como vc já roda a 45 FPS no windows (abaixo de 60) quer dizer que já tá rodando devagar no windows! é impossível rodar com mesmo desempenho no linux (não faria sentido).

quer jogar jogos atuais --> usa Windows (dual boot é uma ótima opção).

Isso é relativo. Depende da forma como o jogo ou aplicação foram desenvolvidos, e de quais bibliotecas elas utilizam.

Por exemplo, se você tentar rodar jogos de Nintendo DS através do emulador No$GBA pelo Wine no Ubuntu, o desempenho em relação ao Windows será exatamente o mesmo, sem tirar nem pôr. Isso acontece porque o emulador é completamente Standalone, não precisando de nenhuma dependência externa como DotNet ou DirectX. Sem falar que o emulador foi todo desenvolvido em assembly. O resultado: qualquer computador com 2ghz consegue rodar os jogos de DS com um pé nas costas, seja pelo Windows ou seja pelo Ubuntu através do Wine. Nem precisa de placa de vídeo, pois pelo menos nesse contexto, apenas processador é utilizado.

Em suma: dependendo da forma como a aplicação foi desenvolvida, quanto a haver perda de desempenho ou não, pode ser que haja e pode ser que não. Mas uma coisa é fato: quando há perda, ela varia de 5 a 30% em relação ao desempenho da mesma aplicação quando executada pelo Windows.

Vale levar em conta também os recursos de vídeo. Se você estiver usando um driver livre, este possivelmente terá desempenho inferior em relação aos proprietários (isso se aplica a placas de vídeo da Intel, Nvidia e AMD).

Você está instalando o Wine 1.7.3 como? Através de PPA ou baixando os .deb direto?

Qual a versão do Ubuntu que você está utilizando?

À primeira instância, esse problema me parece ser no próprio PPA do Wine, pressupondo que você o esteja utilizando.
Sim, estou utilizando.

Não entendi a resposta. Você está usando qual versão do Ubuntu, e instalou o Wine 1.6 como?

De todo modo, acho que você não instalou corretamente os drivers oficiais da Intel no seu computador. Talvez você ainda esteja utilizando os drivers livres, e isso é que deve estar resultando nos bugs gráficos que está encontrando.
« Última modificação: 22 de Outubro de 2013, 15:19 por Solid One »

Offline LucasGama

  • Usuário Ubuntu
  • *
  • Mensagens: 37
    • Ver perfil
Re: Erros no wow.
« Resposta #12 Online: 22 de Outubro de 2013, 18:00 »
Você está instalando o Wine 1.7.3 como? Através de PPA ou baixando os .deb direto?

Qual a versão do Ubuntu que você está utilizando?

À primeira instância, esse problema me parece ser no próprio PPA do Wine, pressupondo que você o esteja utilizando.
Sim, estou utilizando.

Não entendi a resposta. Você está usando qual versão do Ubuntu, e instalou o Wine 1.6 como?

De todo modo, acho que você não instalou corretamente os drivers oficiais da Intel no seu computador. Talvez você ainda esteja utilizando os drivers livres, e isso é que deve estar resultando nos bugs gráficos que está encontrando.

Uso ubuntu 12.04 e instalei o wine com o ppa.
O modo como instalei o driver da intel foi o do link do primeiro cara que respondeu o tópico.

Offline Solid One

  • Usuário Ubuntu
  • *
  • Mensagens: 276
  • Linux for human beings
    • Ver perfil
Re: Erros no wow.
« Resposta #13 Online: 23 de Outubro de 2013, 09:25 »
E qual modo gráfico está utilizando? Unity? Gnome3? Gnome-Classic?

Se for o Unity, ele geralmente utiliza uma quantia razoável de recursos da placa de vídeo. Se você tentar pelo Gnome-Classic, talvez melhore o desempenho.

Se ainda sim o desempenho for o mesmo, então quer dizer que essa é a famigerada perda de desempenho que ocorre. E uma das causas é o fato de você estar utilizando OpenGL ao invés de Direct3D, pois dizem que há uma diferença de desempenho entre os dois. Aliás, se você estiver em OpenGL, você pode tentar o Direct3D depois dessas alterações, para ver se porventura o desempenho não melhora (embora não seja tanto assim).


Offline Lucimgr

  • Usuário Ubuntu
  • *
  • Mensagens: 112
    • Ver perfil
Re: Erros no wow.
« Resposta #14 Online: 23 de Outubro de 2013, 09:53 »
já rodei WoW no ubuntu tempos atrás, roda legal! sem bugs! mas o desempenho gráfico é sempre prejudicado! se vc tem um computador que roda com sobra no windows, vai rodar tranquilo no linux! como vc já roda a 45 FPS no windows (abaixo de 60) quer dizer que já tá rodando devagar no windows! é impossível rodar com mesmo desempenho no linux (não faria sentido).

quer jogar jogos atuais --> usa Windows (dual boot é uma ótima opção).

Isso é relativo. Depende da forma como o jogo ou aplicação foram desenvolvidos, e de quais bibliotecas elas utilizam.

Por exemplo, se você tentar rodar jogos de Nintendo DS através do emulador No$GBA pelo Wine no Ubuntu, o desempenho em relação ao Windows será exatamente o mesmo, sem tirar nem pôr. Isso acontece porque o emulador é completamente Standalone, não precisando de nenhuma dependência externa como DotNet ou DirectX. Sem falar que o emulador foi todo desenvolvido em assembly. O resultado: qualquer computador com 2ghz consegue rodar os jogos de DS com um pé nas costas, seja pelo Windows ou seja pelo Ubuntu através do Wine. Nem precisa de placa de vídeo, pois pelo menos nesse contexto, apenas processador é utilizado.

Em suma: dependendo da forma como a aplicação foi desenvolvida, quanto a haver perda de desempenho ou não, pode ser que haja e pode ser que não. Mas uma coisa é fato: quando há perda, ela varia de 5 a 30% em relação ao desempenho da mesma aplicação quando executada pelo Windows.

Vale levar em conta também os recursos de vídeo. Se você estiver usando um driver livre, este possivelmente terá desempenho inferior em relação aos proprietários (isso se aplica a placas de vídeo da Intel, Nvidia e AMD).


Estamos falando de jogos que usam muito dos recursos da máquina, acho que o comparativo com o emulador que roda com um pé nas costas em qualquer máquina não é válido, como não precisa de recursos, não seria notado diferença de maneira alguma. Concordo com seu comentário de que depende da forma que o programa foi construído, isso irá influenciar diretamente no desempenho, mas que seria possível rodar sem perdas eu não estou convencido, mesmo com programa escrito em linguagem de máquina como comentaste.

nos meus testes com directx9 instalado via wine, o desempenho é melhor setando o directx nas configurações do jogo.

bem pelo que comentaste, caro Lucas, não realizaste nenhuma configuração especifica no wine, certo?

tente isso:

http://www.unixmen.com/install-and-configure-wine-to-play-latest-windows-games-in-linux-ubuntu-linuxmint-fedora/

se preferir em modo gráfico / PT

http://diogosm.wordpress.com/2011/02/10/tirando-o-maximo-desempenho-para-jogos-no-wine/