Autor Tópico: PPSSPP no Ubuntu - PPA com a mais nova versao GIT ou compile a sua!!!  (Lida 91133 vezes)

Offline seatle_94

  • Usuário Ubuntu
  • *
  • Mensagens: 28
    • Ver perfil
Re: PPSSPP no Ubuntu 12.04 64bits - compilando a ultima versao GIT
« Resposta #60 Online: 09 de Maio de 2014, 23:09 »
Platao, qual emulador você usa para:

mame (eu to usando o gxmame)

cps3

Offline platao

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 5.040
    • Ver perfil
Re: PPSSPP no Ubuntu 12.04 64bits - compilando a ultima versao GIT
« Resposta #61 Online: 10 de Maio de 2014, 01:45 »
O gxmame funciona bem em versoes mais novas do mame? Porque se nao fizeram um fork ou algo do genero ele e muito antigo, lembro de ter rodado ele bem no 10.04.

Entao, o mame ele é "autonomo" vc nao precisa necessariamente de uma interface grafica para usar ele, basta apenas vc executar o executavel mame64 e ele ja abre e vc procura pelo nome da rom(nao o nome fantasia) como por exemplo, o game arcade Space Bomber é chamado de sbomber e so selecionar e apertar "enter" para executar.

Entao ao executar o Mame "puro" vc vai ver isso aqui;

http://img841.imageshack.us/img841/4107/epyq.png

Se vc quiser experimentar o mame "puro" para usar com algum front-end tem uma versao que eu compilei aqui - > https://www.dropbox.com/sh/muuek6kbj2sq842/AAAwu-BUTVUxStJTNdzplw1ma

As roms que o CPS3(System3) emula atualmente, o mame atual tbm emula, fora isso o Wine da conta de rodar tranquilo esse emulador;

http://img845.imageshack.us/img845/8409/1yj5.png

O mame e um emulador bem completo e ele tem varias pastas(como vc pode ver no mame do meu dropbox) onde ficam armazenadas as configuraçoes e os arquivos de dados das roms,cabinets,control panels e etc.

Aqui no dropbox tem o mame, gmameui,e alguns outros para testar se estiver no ubuntu 12.04 ou 14.04;

https://www.dropbox.com/sh/73a1xaizlr65ju4/AAAdR7GA84MRqR8ghvdnJ7P4a

https://www.dropbox.com/sh/jrfbi28nqy6us8n/AAAMzgkqmByu0nKyHhI_aGA5a

O problema do mame no linux e que ele tem que obedecer a politica debian de empacotamento, nao e como no Windows que vc tem a pasta e esta la tudo dentro dessa unica pasta, no linux o emulador e dividido em varias partes localizadas em varias partes do sistema, por exemplo se vc quer alterar o mame.ini vc tem que achar onde o pacote o instalou, entrar com permissao de root para poder alterar o arquivo de texto que controla o emulador, alem disso, alguns empacotadores colocam o mame em locais diferentes, gerando ainda mais confusao.

As proprias interfaces(como o Gmameui) criam as suas proprias pastas de configuração e sao colocadas em locais diferentes do sistema, se vc no prestar atenção fica a ver navios.

Os empacotadores ao meu ver ja se tocaram desse problema, no caso o do Cesare Falco fornece somente o emulador compilado, ou seja, o executavel e mais uma meia duzia de arquivos essenciais para o emulador funcionar.

Agora imagina a situação, se vc tem o gmameui que cria a sua propria estrutura de pastas para gerenciar o mame, ai vc instala o gnome video arcade que so funciona se o executavel esta em /usr/games/mame e por ai afora...vira uma confusao de pastas do mame que no final das contas vc nao vai saber mais onde configurar o emulador.

Por isso que eu deixo o mame assim compilado com todas as pastas, tudo certinho com o mame.ini setado tudo pronto e so colocar as roms na pasta roms e jogar.

O que vc esta falando é o front end, a interface grafica bonitinha, que exibe as configuraçoes,flyers, icones,marquees,snaps.

Ai vc tem as opçoes, que eu acho as mais legais, como o Gnome-video-arcade,Gmameui,Wahcade e QMC2 e ate o Cabrio cada um com suas qualidades e defeitos.

O gnome video arcade inicialmente parece super simples de configurar, e realmente é, com a versao do repositorio, ele funciona muito bem, tem interface limpa, enxuta e bastante rapida, o problema e que ele trabalha com locais pre-definidos em que ele vai procurar o executavel e se ele nao encontra nao funciona, se nao encontra o mame em /usr/games/mame por exemplo.

As vezes algumas versoes do mame da pau com esse front end.

O Gmameui é bacana, é a interface mais pacecida com o mame64UI do Windows. O problema dele e que o desenvolvimento esta um tanto lento, os bugs ficam sem correção por muito tempo. A versao 0.2.11 do Gmameui tem um bug critico e muito chato que é, ao iniciar o emulador, se vc nao esperar ele dar o "loading" das configuraçoes e vc mexer nele, por exemplo encerra-lo, ele perde todas as configuraçoes da sua lista de roms, e vc tem que novamente fazer uma varredura para ele encontrar as roms disponiveis.

http://img834.imageshack.us/img834/3623/gljs.png

Outro ponto e que ele usa Glade e GTK e houve mudanças do GTK para o GTK3 ele precisa de revisao, e tbm o gmameui cria a sua propria estrutura de pastas de configuração, ele te da a liberdade de colocar as pastas auxiliares com por exemplo, flyers(banners) onde vc quiser, mas algumas configuraçoes ficam em lugares pre-estabelecidos por ele.

A versao 0.2.13 ate agora nao saiu um .deb oficial, so para Fedora e distros que usam .rpm . Eu fiz um pacote caseiro para o ubuntu 12.04 e 14.04 do gmameui e funciona, o unico bug e que nao funciona as guias de visualização de flyers,marquees,titles, vc tem que escolher o que vai querer que o emulador mostre, como por exemplo, um snapshot e o history, alem da opção de "crop" artwork nao funcionar adequadamente, muitas vezes "tampando" a visualização do history do game, que e a informação da data de fabricação, tips and tricks,tipo de monitor que ele usa, esse tido de dado.

O Whacade e bem bacana, te da muita liberdade de configuração e nao interfere no funcionamento do mame com configuraçoes, o problema dele nas veroes anteriores era na hora de gerar a lista de roms, mas isso ja foi sanado, mas ele tem uma serie de bugs chatos e estranhos que de tanto vc ver acaba se acostumando e entendendo como tudo funciona o emulador e o bug tbm ; )

http://img834.imageshack.us/img834/230/ptga.png

Tbm esta bem lento o desenvolvimento, com o pessoal criando forks para manter as coisas funcionando. O Whacade tem um problema serio com arquivos multimidia de filmes e musica envolvendo o gstreamer, num fork eles ja retiraram essa opção ja que nao funcionava direito, e ficou bem interessante, ele e escrito em phyton e sempre crasha na primeira inicialização, quando ele cria a pasta oculta na home.

O QMC2 tem por objetivo ser um front end completaço, com trocentas opçoes de configuração, funciona muito bem é rapido, tem varias coisas legais nesse ai ; )  como acesso ao Caesar onde vc tem informaçoes do game, links para videos do Youtube bem interessante, alguns detalhes aqui e acolá nao me agradam mas e muito bom.

http://img841.imageshack.us/img841/8296/atb0.png

O Cabrio http://www.cabrio-fe.org/ e o mais elaborado na interface 3D muito bacana, ganha facil da maioria em beleza e fica muito bom em uma maquina arcade(gabinete) o problema dele e que ele nao tem uma interface para gerar a lista de roms, isso fica a cargo de outros aplicativos, tem ate varios projetos nesse sentido no GIT e so procurar tem ate versoes e forks do cabrio e um "gerador" de listas XML para as roms serem reconhecidas, nao olhei nada disso ainda por falta de tempo, mas parece que funciona sim!!! e nao tem pacote para 64 bit no site oficial eheheh vai ter que arregaçar as mangas e compilar(nada complicado) porem.

Tem tbm "Live distros" como o Piapara live cd http://goredaimon.blogspot.com.br/ que ja trazem tudo pronto e configurado so necessitando de colocar os arquivos de roms e tbm esse aqui que atualmente e o mais legal tbm o GNU/LINUX ARCADE http://www.arcadeinfo.de/showthread.php?16069-A-GNU-LINUX-ARCADE-DISTRIBUTION-0-92b

É isso basicamente, ; ) mas sendo curto e grosso eu uso para o mame o Gmameui,Whacade e QMC2

Lembrando que essa e a minha experiencia com esses aplicativos na minha maquina, podem haver algumas discrepancias de funcionamento em hardwares diferentes.
« Última modificação: 10 de Maio de 2014, 11:33 por platao »
\\\\\\\\Apostilas Dicas e Guias do Ubuntu\\\\\\\\\> http://ubuntuforum-br.org/index.php/topic,79368.msg440997.html#msg440997

Offline platao

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 5.040
    • Ver perfil
Re: PPSSPP no Ubuntu 12.04 64bits - compilando a ultima versao GIT
« Resposta #62 Online: 10 de Maio de 2014, 10:49 »
Aproveitando a oportunidade compilei uma nova versao do PPSSPP para GTK e QT, quem quiser experimentar;

https://www.dropbox.com/s/fj7lw9mj4eo1oev/ppssppsdl-Qt-07.05.2014.tar.bz2
\\\\\\\\Apostilas Dicas e Guias do Ubuntu\\\\\\\\\> http://ubuntuforum-br.org/index.php/topic,79368.msg440997.html#msg440997

Offline seatle_94

  • Usuário Ubuntu
  • *
  • Mensagens: 28
    • Ver perfil
Re: PPSSPP no Ubuntu 12.04 64bits - compilando a ultima versao GIT
« Resposta #63 Online: 15 de Maio de 2014, 20:02 »
Obrigado pelas dicas, o gxmame funciona bem para mim, não tem erros. Sobre o cps3 e o wine é o que estou usando atualmente, vou continuar pelo visto kkk.


Sinto falta de um emulador decente de Dreamcast :(

Offline platao

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 5.040
    • Ver perfil
Re: PPSSPP no Ubuntu 12.04 64bits - compilando a ultima versao GIT
« Resposta #64 Online: 15 de Maio de 2014, 20:40 »
E isso que e importante, que o aplicativo te atenda bem, que de para testar as roms. Tem algum fork do gxmame recente? ou pelo menos menos antigo que o original?

Posta umas screens ai do seu gxmame!!!

O de Dreancast nao procurei se atualizaram, parece que bom mesmo so para o android...

http://jeremywininger.blogspot.com.br/

http://jeremywininger.blogspot.com.br/2013/12/reicast-dreamcast-for-your-android.html

Olha que interessante o cabrio..hehehe quem sabe semana que vem dou uma olhada nisso....

https://github.com/search?q=cabrio&type=Repositories&ref=searchresults

« Última modificação: 15 de Maio de 2014, 20:55 por platao »
\\\\\\\\Apostilas Dicas e Guias do Ubuntu\\\\\\\\\> http://ubuntuforum-br.org/index.php/topic,79368.msg440997.html#msg440997

Offline seatle_94

  • Usuário Ubuntu
  • *
  • Mensagens: 28
    • Ver perfil
Re: PPSSPP no Ubuntu 12.04 64bits - compilando a ultima versao GIT
« Resposta #65 Online: 16 de Maio de 2014, 22:06 »
O emulador para Windows do Dreamcast funciona bem, esse do android dizem que é bom, mas não testei. Outro que peca é Saturn :S

O que é esse cabrio ai? Não tentendi.

Aqui as prints do meu gxmame (versão que uso, desde os tempos do slack 11 haha)





E isso que e importante, que o aplicativo te atenda bem, que de para testar as roms. Tem algum fork do gxmame recente? ou pelo menos menos antigo que o original?

Posta umas screens ai do seu gxmame!!!

O de Dreancast nao procurei se atualizaram, parece que bom mesmo so para o android...

http://jeremywininger.blogspot.com.br/

http://jeremywininger.blogspot.com.br/2013/12/reicast-dreamcast-for-your-android.html

Olha que interessante o cabrio..hehehe quem sabe semana que vem dou uma olhada nisso....

https://github.com/search?q=cabrio&type=Repositories&ref=searchresults



Offline platao

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 5.040
    • Ver perfil
Re: PPSSPP no Ubuntu 12.04 64bits - compilando a ultima versao GIT
« Resposta #66 Online: 18 de Maio de 2014, 11:42 »
Muito interessante!!! ficou bom, qual a versao do mame vc esta usando? vou testar ele novamente. ; )

cabrio

https://github.com/SteveMaddison/cabrio
« Última modificação: 18 de Maio de 2014, 11:45 por platao »
\\\\\\\\Apostilas Dicas e Guias do Ubuntu\\\\\\\\\> http://ubuntuforum-br.org/index.php/topic,79368.msg440997.html#msg440997

Offline seatle_94

  • Usuário Ubuntu
  • *
  • Mensagens: 28
    • Ver perfil
Re: PPSSPP no Ubuntu 12.04 64bits - compilando a ultima versao GIT
« Resposta #67 Online: 21 de Maio de 2014, 23:45 »
mame 0.146-5
mame tools 0.1.46-4

Offline Sergio Benjamim

  • Usuário Ubuntu
  • *
  • Mensagens: 2.902
    • Ver perfil
Re: PPSSPP no Ubuntu 12.04 64bits - compilando a ultima versao GIT
« Resposta #68 Online: 09 de Junho de 2014, 12:04 »
Parece que tem PPA do PPSSPP, usando a última versão 0.9.8, na verdade é o PPA do noobslab, tem vários pacotes além do PPSSPP (portanto cuidado ao instalar, eu instalaria o emulador e depois desativaria):

Apps collection by NoobsLab.com

Mais: http://www.noobslab.com/2014/02/ppsspp-psp-emulator-available-for.html

Nesse link tem algo do empacotamento debian. Alguém (tipo eu, quando tiver tempo :) ) podia ver se dá para aproveitar e mandar para os desenvolvedores do emulador, e tentar integrar no próprio código deles. Daí fica mais fácil fazer o próprio pacote debian (e eles podem fazer oficialmente, para a gente não ficar dependendo de outras fontes).

O pacote deles tem alguns (vários...) erros no lintian:

Código: [Selecionar]
lintian ppsspp_0.9.8-1028~trusty~NoobsLab.com_amd64.deb
E: ppsspp: unstripped-binary-or-object opt/ppsspp/PPSSPPSDL
E: ppsspp: binary-or-shlib-defines-rpath opt/ppsspp/PPSSPPSDL /home/karen/Development/ppsspp/ffmpeg/linux/x86_64/lib
E: ppsspp: embedded-library opt/ppsspp/PPSSPPSDL: glew
E: ppsspp: embedded-library opt/ppsspp/PPSSPPSDL: libavutil
E: ppsspp: embedded-library opt/ppsspp/PPSSPPSDL: libpng
W: ppsspp: hardening-no-relro opt/ppsspp/PPSSPPSDL
E: ppsspp: missing-dependency-on-libc needed by opt/ppsspp/PPSSPPSDL
E: ppsspp: copyright-file-contains-full-gpl-license
E: ppsspp: copyright-should-refer-to-common-license-file-for-gpl
E: ppsspp: description-starts-with-package-name
W: ppsspp: non-standard-dir-perm opt/ 0775 != 0755
E: ppsspp: dir-or-file-in-opt opt/ppsspp/
W: ppsspp: non-standard-dir-perm opt/ppsspp/ 0775 != 0755
E: ppsspp: dir-or-file-in-opt opt/ppsspp/Karen_angelXwind/
W: ppsspp: non-standard-dir-perm opt/ppsspp/Karen_angelXwind/ 0775 != 0755
E: ppsspp: dir-or-file-in-opt opt/ppsspp/Karen_angelXwind/Version.txt
W: ppsspp: non-standard-file-perm opt/ppsspp/Karen_angelXwind/Version.txt 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/PPSSPPSDL
W: ppsspp: non-standard-executable-perm opt/ppsspp/PPSSPPSDL 0775 != 0755
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/
W: ppsspp: non-standard-dir-perm opt/ppsspp/assets/ 0775 != 0755
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/flash0/
W: ppsspp: non-standard-dir-perm opt/ppsspp/assets/flash0/ 0775 != 0755
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/flash0/font/
W: ppsspp: non-standard-dir-perm opt/ppsspp/assets/flash0/font/ 0775 != 0755
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/flash0/font/jpn0.pgf
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/flash0/font/jpn0.pgf 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/flash0/font/kr0.pgf
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/flash0/font/kr0.pgf 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/flash0/font/ltn0.pgf
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/flash0/font/ltn0.pgf 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/flash0/font/ltn1.pgf
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/flash0/font/ltn1.pgf 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/flash0/font/ltn10.pgf
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/flash0/font/ltn10.pgf 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/flash0/font/ltn11.pgf
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/flash0/font/ltn11.pgf 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/flash0/font/ltn12.pgf
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/flash0/font/ltn12.pgf 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/flash0/font/ltn13.pgf
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/flash0/font/ltn13.pgf 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/flash0/font/ltn14.pgf
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/flash0/font/ltn14.pgf 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/flash0/font/ltn15.pgf
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/flash0/font/ltn15.pgf 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/flash0/font/ltn2.pgf
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/flash0/font/ltn2.pgf 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/flash0/font/ltn3.pgf
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/flash0/font/ltn3.pgf 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/flash0/font/ltn4.pgf
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/flash0/font/ltn4.pgf 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/flash0/font/ltn5.pgf
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/flash0/font/ltn5.pgf 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/flash0/font/ltn6.pgf
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/flash0/font/ltn6.pgf 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/flash0/font/ltn7.pgf
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/flash0/font/ltn7.pgf 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/flash0/font/ltn8.pgf
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/flash0/font/ltn8.pgf 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/flash0/font/ltn9.pgf
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/flash0/font/ltn9.pgf 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/lang/
W: ppsspp: non-standard-dir-perm opt/ppsspp/assets/lang/ 0775 != 0755
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/lang/.git
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/lang/.git 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/lang/README.md
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/lang/README.md 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/lang/ar_AE.ini
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/lang/ar_AE.ini 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/lang/az_AZ.ini
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/lang/az_AZ.ini 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/lang/ca_ES.ini
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/lang/ca_ES.ini 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/lang/cz_CZ.ini
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/lang/cz_CZ.ini 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/lang/da_DK.ini
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/lang/da_DK.ini 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/lang/de_DE.ini
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/lang/de_DE.ini 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/lang/dr_ID.ini
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/lang/dr_ID.ini 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/lang/en_US.ini
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/lang/en_US.ini 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/lang/es_ES.ini
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/lang/es_ES.ini 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/lang/es_LA.ini
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/lang/es_LA.ini 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/lang/fa_IR.ini
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/lang/fa_IR.ini 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/lang/fi_FI.ini
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/lang/fi_FI.ini 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/lang/fr_FR.ini
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/lang/fr_FR.ini 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/lang/gl_ES.ini
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/lang/gl_ES.ini 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/lang/gr_EL.ini
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/lang/gr_EL.ini 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/lang/he_IL.ini
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/lang/he_IL.ini 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/lang/he_IL_invert.ini
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/lang/he_IL_invert.ini 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/lang/hu_HU.ini
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/lang/hu_HU.ini 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/lang/id_ID.ini
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/lang/id_ID.ini 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/lang/it_IT.ini
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/lang/it_IT.ini 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/lang/ja_JP.ini
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/lang/ja_JP.ini 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/lang/ko_KR.ini
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/lang/ko_KR.ini 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/lang/ms_MY.ini
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/lang/ms_MY.ini 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/lang/nl_NL.ini
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/lang/nl_NL.ini 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/lang/no_NO.ini
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/lang/no_NO.ini 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/lang/pl_PL.ini
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/lang/pl_PL.ini 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/lang/pt_BR.ini
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/lang/pt_BR.ini 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/lang/pt_PT.ini
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/lang/pt_PT.ini 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/lang/ro_RO.ini
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/lang/ro_RO.ini 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/lang/ru_RU.ini
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/lang/ru_RU.ini 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/lang/sv_SE.ini
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/lang/sv_SE.ini 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/lang/tg_PH.ini
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/lang/tg_PH.ini 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/lang/tr_TR.ini
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/lang/tr_TR.ini 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/lang/uk_UA.ini
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/lang/uk_UA.ini 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/lang/vi_VN.ini
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/lang/vi_VN.ini 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/lang/zh_CN.ini
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/lang/zh_CN.ini 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/lang/zh_TW.ini
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/lang/zh_TW.ini 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/langregion.ini
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/langregion.ini 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/ppge_atlas.zim
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/ppge_atlas.zim 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/shaders/
W: ppsspp: non-standard-dir-perm opt/ppsspp/assets/shaders/ 0775 != 0755
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/shaders/4xhqglsl.fsh
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/shaders/4xhqglsl.fsh 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/shaders/4xhqglsl.vsh
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/shaders/4xhqglsl.vsh 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/shaders/aacolor.fsh
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/shaders/aacolor.fsh 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/shaders/aacolor.vsh
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/shaders/aacolor.vsh 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/shaders/bloom.fsh
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/shaders/bloom.fsh 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/shaders/cartoon.fsh
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/shaders/cartoon.fsh 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/shaders/cartoon.vsh
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/shaders/cartoon.vsh 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/shaders/crt.fsh
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/shaders/crt.fsh 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/shaders/defaultshaders.ini
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/shaders/defaultshaders.ini 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/shaders/fxaa.fsh
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/shaders/fxaa.fsh 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/shaders/fxaa.vsh
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/shaders/fxaa.vsh 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/shaders/grayscale.fsh
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/shaders/grayscale.fsh 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/shaders/inversecolors.fsh
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/shaders/inversecolors.fsh 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/shaders/natural.fsh
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/shaders/natural.fsh 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/shaders/natural.vsh
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/shaders/natural.vsh 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/shaders/scanlines.fsh
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/shaders/scanlines.fsh 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/shaders/sharpen.fsh
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/shaders/sharpen.fsh 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/shaders/upscale_spline36.fsh
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/shaders/upscale_spline36.fsh 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/shaders/upscale_spline36.vsh
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/shaders/upscale_spline36.vsh 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/shaders/vignette.fsh
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/shaders/vignette.fsh 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/ui_atlas.zim
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/ui_atlas.zim 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/assets/unknown.png
W: ppsspp: non-standard-file-perm opt/ppsspp/assets/unknown.png 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/ppsspp.desktop
W: ppsspp: non-standard-file-perm opt/ppsspp/ppsspp.desktop 0664 != 0644
E: ppsspp: dir-or-file-in-opt opt/ppsspp/ppsspp.png
W: ppsspp: non-standard-file-perm opt/ppsspp/ppsspp.png 0664 != 0644
W: ppsspp: non-standard-dir-perm usr/ 0775 != 0755
W: ppsspp: non-standard-dir-perm usr/bin/ 0775 != 0755
W: ppsspp: non-standard-executable-perm usr/bin/ppsspp 0775 != 0755
W: ppsspp: file-in-unusual-dir usr/ppsspp~
W: ppsspp: backup-file-in-package usr/ppsspp~
W: ppsspp: non-standard-executable-perm usr/ppsspp~ 0775 != 0755
W: ppsspp: binary-without-manpage usr/bin/ppsspp
W: ppsspp: postinst-has-useless-call-to-update-menus

---

Parece que vai sair a versão 0.9.9, o github tá bem movimentado.
É novo no Ubuntu? Já leu o Ubuntu – Guia do Iniciante 2.0 ?
Experimente o Xubuntu 14.04 !

Offline Sergio Benjamim

  • Usuário Ubuntu
  • *
  • Mensagens: 2.902
    • Ver perfil
Re: PPSSPP no Ubuntu 12.04 64bits - compilando a ultima versao GIT
« Resposta #69 Online: 15 de Julho de 2014, 19:15 »
Platao, há uma outra forma de compilar o PPSSPP que é mais indicada, estava conversando com os desenvolvedores no IRC.

A compilação com o ./b.sh só compila a versão SDL. Para compilar a versão Qt, primeiro tem que instalar os seguintes pacotes:

Código: [Selecionar]
sudo apt-get install libsdl1.2-dev libglew-dev qt4-qmake libqt4-dev libqt4-opengl
Depois baixa o repositório, igual o que você passou antes:

Código: [Selecionar]
git clone https://github.com/hrydgard/ppsspp.git
cd ppsspp
git submodule update --init

E para compilar:

Código: [Selecionar]
mkdir build-qt && cd build-qt
qmake ../Qt/PPSSPPQt.pro
make

Dessa forma o ppsspp com o Qt frontend é compilado dentro da pasta build-qt, o nome do executável é PPSSPPQt.

Segue a diferença entre ppssppQt e a versão SDL:

Citar
Cmake only builds the sdl version which has no menus, no fullscreen toggle, no screenshot functionality
<xsacha_> Qt one works on a lot more platforms and handles a lot of the opengl stuff automatically

A versão Qt tem menus, alternância de tela cheia, screenshot, e consegue manipular várias coisas relacionadas ao OpenGL.
« Última modificação: 15 de Julho de 2014, 19:21 por Sergio Benjamim »
É novo no Ubuntu? Já leu o Ubuntu – Guia do Iniciante 2.0 ?
Experimente o Xubuntu 14.04 !

Offline platao

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 5.040
    • Ver perfil
Re: PPSSPP no Ubuntu 12.04 64bits - compilando a ultima versao GIT
« Resposta #70 Online: 15 de Julho de 2014, 21:31 »
E isso mesmo Sergiovisk!!!! ; ) nas paginas anteriores desse topico tem la o modo de compilar para QT tbm e eu estava compilando as duas e colocando no dropbox a partir de entao.

Aqui eu compilo assim(depois de ter todas as dependencias instaladas)

sudo apt-get install libsdl1.2-dev git build-essential unrar ; sleep 3 ; git clone git://github.com/hrydgard/ppsspp.git && cd ppsspp ; sleep 4 ; git submodule update -i ; sleep 4 ; ./b.sh ; sleep 5 ; qmake-qt4 Qt/PPSSPPQt.pro ; cd Qt/ ; make

e saio para tomar um café eheheheh

**estou preparando uma coleção de "capas de games" ou "box arts" de mega drive,snes,nintendinho,sega CD e outros para podermos utilizar no cabrio! As principais ja estao prontas e so fazer um tar com todas elas!!!
« Última modificação: 15 de Julho de 2014, 21:38 por platao »
\\\\\\\\Apostilas Dicas e Guias do Ubuntu\\\\\\\\\> http://ubuntuforum-br.org/index.php/topic,79368.msg440997.html#msg440997

Offline Sergio Benjamim

  • Usuário Ubuntu
  • *
  • Mensagens: 2.902
    • Ver perfil
Re: PPSSPP no Ubuntu 12.04 64bits - compilando a ultima versao GIT
« Resposta #71 Online: 16 de Julho de 2014, 03:36 »
Passa pra mim  ::) ?

Jogando Kingdom Hearts Birth by Sleep, roda bem heim!





E tem opção para filtro xBRZ!
É novo no Ubuntu? Já leu o Ubuntu – Guia do Iniciante 2.0 ?
Experimente o Xubuntu 14.04 !

Offline platao

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 5.040
    • Ver perfil
Re: PPSSPP no Ubuntu 12.04 64bits - compilando a ultima versao GIT
« Resposta #72 Online: 16 de Julho de 2014, 12:08 »
Sim, se vc nao quiser esperar eu preparar o pacote tar com as caixas dos games eu pequei aqui;

https://www.youtube.com/user/GamingHistorySource

Esse filtro vc pegou onde? ou ja esta vindo no emulador compilado? qual a versao do PPSSPP que vc esta usando?

\\\\\\\\Apostilas Dicas e Guias do Ubuntu\\\\\\\\\> http://ubuntuforum-br.org/index.php/topic,79368.msg440997.html#msg440997

Offline Sergio Benjamim

  • Usuário Ubuntu
  • *
  • Mensagens: 2.902
    • Ver perfil
Re: PPSSPP no Ubuntu 12.04 64bits - compilando a ultima versao GIT
« Resposta #73 Online: 16 de Julho de 2014, 14:39 »
Sim, se vc nao quiser esperar eu preparar o pacote tar com as caixas dos games eu pequei aqui;

https://www.youtube.com/user/GamingHistorySource

Esse filtro vc pegou onde? ou ja esta vindo no emulador compilado? qual a versao do PPSSPP que vc esta usando?



ah, blz.

Estou usando a última versão git dele. Você acha em Settings, na aba Graphics, vai descendo até chegar na seção Texture Scalling, em Upscale type. Tem que habilitar primeiro, na opção acima, Upscale Level, eu deixei em Auto.
É novo no Ubuntu? Já leu o Ubuntu – Guia do Iniciante 2.0 ?
Experimente o Xubuntu 14.04 !

Offline platao

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 5.040
    • Ver perfil
Re: PPSSPP no Ubuntu 12.04 64bits - compilando a ultima versao GIT
« Resposta #74 Online: 17 de Julho de 2014, 09:04 »
Eu acho engraçado no PPSSPP......as configraçoes padrao para mim funcionam melhor do que se eu for la em settings e tentar deixar mais leve, com configurações mais simples, que nao exijam tanto do hardware.....vai entender......

LINK para as "BOX ARts"

https://mega.co.nz/#!V0xV3L7T!sE5CIYIEubp04y4-BRCWE9TZqD8cWrUOFwcczaYCm_Q

O pacote inclui capas de;

SEga CD,turbografix16,nes,super nes,mega drive,playstation,atari2600 e outros.
\\\\\\\\Apostilas Dicas e Guias do Ubuntu\\\\\\\\\> http://ubuntuforum-br.org/index.php/topic,79368.msg440997.html#msg440997