Autor Tópico: Problema ao utilizar Core Network Emulator  (Lida 4345 vezes)

Offline Cleber TXR

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
    • Blog
Problema ao utilizar Core Network Emulator
« Online: 20 de Abril de 2014, 20:55 »
Fala galera blz?!  ;D
Estou com um problema para utilizar o Core Network Emulator, toda vez que monto um 'modelo' de rede e dou um 'play' pra executar recebo uma mensagem de erro ao iniciar o Daemon...

https://lh4.googleusercontent.com/-n1jWEBzseEE/U1GMOIvcDNI/AAAAAAABR5E/nFLJvUUJnLI/w1044-h587-no/Captura+de+tela+de+2014-04-18+17%253A19%253A17.png
https://lh5.googleusercontent.com/-ebCoMlhdRGo/U1GMPzJ0iJI/AAAAAAABR5c/Jc2urmgxtzE/w1044-h587-no/Captura+de+tela+de+2014-04-18+17%253A19%253A24.png

Pra funcionar eu tenho que ir ao terminal e dar o comando 'sudo core-daemon start'.

https://lh3.googleusercontent.com/-IcZ2nmFq1TI/U1GMSBGbkpI/AAAAAAABR54/QNB5yc4sog0/w1044-h587-no/Captura+de+tela+de+2014-04-18+17%253A20%253A38.png

Depois desse comando funciona...

https://lh5.googleusercontent.com/-altpqxQE9zQ/U1GMTGGJpJI/AAAAAAABR6A/88WLXdVv4so/w1044-h587-no/Captura+de+tela+de+2014-04-18+17%253A26%253A49.png

Alguém sabe como eu posso fazer para não precisar ir ao terminal e ter que fazer isso manualmente toda vez?

Abraço
« Última modificação: 20 de Abril de 2014, 22:04 por platao »

Offline Renan Rischiotto

  • Usuário Ubuntu
  • *
  • Mensagens: 2.888
    • Ver perfil
Re: Problema ao utilizar Core Network Emulator
« Resposta #1 Online: 21 de Abril de 2014, 21:27 »
Olá,

Tente editar o atalho do programa, e nas suas propriedades colocar o comando "sudo core-daemon start".

Abraços!

Offline Cleber TXR

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
    • Blog
Re: Problema ao utilizar Core Network Emulator
« Resposta #2 Online: 23 de Abril de 2014, 08:39 »
Olá Renan,

Tentei editar o atalho mas não encontrei o arquivo certo...  :-\

Eu uso o Ubuntu 14 e baixei o programa e  a interface desse link --> http://downloads.pf.itd.nrl.navy.mil/core/packages/4.6 mas não havia na lista o Trusty Tahr. Será que pode ser esse o problema?

Dessa lista o mais adequado pro Ubuntu 14 é a versão 'core-daemon_4.6-0ubuntu1_raring_amd64.deb' e 'core-gui_4.6-0ubuntu1_raring_all.deb' certo?

Desde já muito obrigado!  :)

Offline Renan Rischiotto

  • Usuário Ubuntu
  • *
  • Mensagens: 2.888
    • Ver perfil
Re: Problema ao utilizar Core Network Emulator
« Resposta #3 Online: 23 de Abril de 2014, 15:38 »
Bom, pode ser isso (vai saber rsrs), mas já que não existe versão para o Ubuntu 14.04, fique com a versão do Raring mesmo.

Tente usar o Menu Libre ou Alacarte para criar um atalho do Core Network Emulator, mas você coloca o comando "sudo" na parte de comando.

Offline Cleber TXR

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
    • Blog
Re: Problema ao utilizar Core Network Emulator
« Resposta #4 Online: 25 de Abril de 2014, 00:37 »
Renan, acabei tendo vários pacotes quebrados ao tentar reinstalar o Core.  :(

Vou tentar reparar antes de seguir a dica. rsrs

Muito obrigado por toda ajuda.  :D

Grande Abraço!