Autor Tópico: Notebook desligando ao passar dos 60°C  (Lida 10811 vezes)

Offline Arthur Bernardes

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Notebook desligando ao passar dos 60°C
« Online: 12 de Maio de 2014, 11:22 »
Olá amigos, estou com um certo problema aqui.

Tenho um notebook LG A410 com Intel Core i5, 4GB de RAM e Geforce 310M.

Segue o hardware abaixo.

Código: [Selecionar]
*-cpu                  
       descrição: CPU
       produto: Intel(R) Core(TM) i5 CPU       M 480  @ 2.67GHz
       fabricante: Intel Corp.
       ID físico: 2a
       informações do barramento: cpu@0
       versão: 6.5.5
       serial: 0002-0655-0000-0000-0000-0000
       slot: CPU
       tamanho: 1199MHz
       capacidade: 1199MHz
       largura: 64 bits
       clock: 1066MHz

Com um uso normal (somente navegação, office e etc) a temperatura fica normal aos 48°C (aqui em SP anda quente), mas ao assistir vídeos no Youtube ou no VLC ou até mesmo ouvir música, a temperatura sobe para 60-70°C e nisso ele desliga, comecei a desconfiar do TLP que uso aqui para otimizar minha bateria, mas não anda virando.

Uso em dual-boot com Windows$ 7 e lá isso não acontece.

O que posso fazer para o notebook não desligar? Isso me atrapalha demais.

O meu TLP está em default.

Código: [Selecionar]
# ------------------------------------------------------------------------------
# tlp - Parameters for power save

# Hint: some features are disabled by default, remove the leading # to enable them

# Set to 0 to disable/1 to enable TLP
TLP_ENABLE=1

# Seconds laptop mode has to to wait after the disk goes idle before doing a sync.
# Non-zero value enables, zero disables laptop mode.
DISK_IDLE_SECS_ON_AC=0
DISK_IDLE_SECS_ON_BAT=2

# Dirty page values (timeouts in secs).
MAX_LOST_WORK_SECS_ON_AC=15
MAX_LOST_WORK_SECS_ON_BAT=60

# Select a cpu frequency scaling governor: ondemand/powersave/performance/conservative
# Important:
# - You *must* disable your distribution's governor settings or conflicts will occur
# - ondemand is sufficient for *almost all* workloads, you should know what you're doing!
#CPU_SCALING_GOVERNOR_ON_AC=ondemand
#CPU_SCALING_GOVERNOR_ON_BAT=ondemand

# Set the min/max frequency available for the scaling governor.
# Possible values strongly depend on your cpu. For available frequencies see
# tlp-stat output, Section "+++ Processor".
# Hint: Parameters are disabled by default, remove the leading # to enable them,
#       otherwise kernel default values are used.
#CPU_SCALING_MIN_FREQ_ON_AC=0
#CPU_SCALING_MAX_FREQ_ON_AC=0
#CPU_SCALING_MIN_FREQ_ON_BAT=0
#CPU_SCALING_MAX_FREQ_ON_BAT=0

# Set the cpu "turbo boost" feature: 0=disable / 1=allow
# Requires an Intel Core i processor and kernel 3.7 or later.
# Important:
# - This may conflict with your distribution's governor settings
# - A value of 1 does *not* activate boosting, it just allows it
#CPU_BOOST_ON_AC=1
#CPU_BOOST_ON_BAT=0

# Minimize number of used cpu cores/hyper-threads under light load conditions
SCHED_POWERSAVE_ON_AC=0
SCHED_POWERSAVE_ON_BAT=1

# Kernel NMI Watchdog
# 0=disable (default, saves power) / 1=enable (for kernel debugging only)
NMI_WATCHDOG=0

# Change CPU voltages aka "undervolting" - Kernel with PHC patch required
# Freq:voltage pairs are written to /sys/devices/system/cpu/cpu0/cpufreq/phc_controls
# CAUTION: only use this, if you thoroughly understand what you are doing!
#PHC_CONTROLS="F:V F:V F:V F:V"

# Hard disk devices, separate multiple devices with spaces (default: sda).
# Devices can be specified by disk id too (lookup with: tlp diskid).
DISK_DEVICES="sda sdb"

# Hard disk advanced power management level: 1(max saving)..254(off)
# Levels 1..127 may spin down the disk.
# Separate values for multiple devices with spaces.
DISK_APM_LEVEL_ON_AC="254 254"
DISK_APM_LEVEL_ON_BAT="128 128"

# Hard disk spin down timeout:
# 0:        spin down disabled
# 1..240:   timeouts from 5s to 20min (in units of 5s)
# 241..251: timeouts from 30min to 5.5 hours (in units of 30min)
# (see 'man hdparm' for details)
#DISK_SPINDOWN_TIMEOUT_ON_AC="0 0"
#DISK_SPINDOWN_TIMEOUT_ON_BAT="0 0"

# Select io scheduler for the disk devices: noop/deadline/cfq (Default: cfq)
# Separate values for multiple devices with spaces.
#DISK_IOSCHED="cfq cfq"

# SATA aggressive link power management (ALPM):
# min_power/medium_power/max_performance
SATA_LINKPWR_ON_AC=max_performance
SATA_LINKPWR_ON_BAT=min_power

# PCI Express Active State Power Management (PCIe ASPM):
# default/performance/powersave
# Hint: needs kernel boot option pcie_aspm=force on some machines
PCIE_ASPM_ON_AC=performance
PCIE_ASPM_ON_BAT=powersave

# Radeon graphics clock speed (profile method): low/mid/high/auto/default
# auto = mid on BAT, high on AC; default = use hardware defaults
# (Kernel >= 2.6.35 only, not with fglrx driver!)
RADEON_POWER_PROFILE_ON_AC=high
RADEON_POWER_PROFILE_ON_BAT=low

# New radeon dynamic power management method (dpm): battery/performance
# (Kernel >= 3.11 only, requires boot option radeon.dpm=1)
RADEON_DPM_STATE_ON_AC=performance
RADEON_DPM_STATE_ON_BAT=battery

# New radeon dpm performance level: auto/low/high (auto is recommended)
RADEON_DPM_PERF_LEVEL_ON_AC=auto
RADEON_DPM_PERF_LEVEL_ON_BAT=auto

# WiFi power saving mode: 1=disable/5=enable
# (Linux 2.6.32 and later, some adapters only!)
WIFI_PWR_ON_AC=1
WIFI_PWR_ON_BAT=5

# Disable wake on lan: Y/N
WOL_DISABLE=Y

# Enable audio power saving for Intel HDA, AC97 devices (timeout in secs).
# A value of 0 disables / >=1 enables power save.
SOUND_POWER_SAVE_ON_AC=0
SOUND_POWER_SAVE_ON_BAT=1

# Disable controller too (HDA only): Y/N
SOUND_POWER_SAVE_CONTROLLER=Y

# Set to 1 to power off optical drive in UltraBay (ThinkPads only)
# when running on battery. A value of 0 disables this Feature (Default).
# Drive can be powered on again by releasing (and reinserting) the
# eject lever or by pressing the disc eject button on newer models.
# Note: an UltraBay hard disk is never powered off.
BAY_POWEROFF_ON_BAT=0
# Optical drive device to power off (default sr0)
BAY_DEVICE="sr0"

# Runtime Power Management for pci(e) bus devices
# (Kernel >= 2.6.35 only): on=disable/auto=enable
RUNTIME_PM_ON_AC=on
RUNTIME_PM_ON_BAT=auto

# Runtime PM for *all* pci(e) bus devices, expect backlisted ones:
# 0=disable / 1=enable
# Warning: experimental option, could cause system instabilities
RUNTIME_PM_ALL=0

# Exclude pci(e) device adresses the following list from Runtime PM
# (separate with spaces). Use lspci to get the adresses (1st column).
#RUNTIME_PM_BLACKLIST="bb:dd.f 11:22.3 44:55.6"

# Set to 0 to disable/1 to enable usb autosuspend feature
USB_AUTOSUSPEND=1

# Devices from the following list are excluded from usb autosuspend
# (separate with spaces). Use lsusb to get the ids.
# Note: input devices (usbhid) are excluded automatically
#USB_BLACKLIST="1111:2222 3333:4444"

# WWAN devices are excluded from usb autosuspend:
# 0=do not exclude / 1=exclude
# Note: works for ids 05c6:* 0bdb:* 1199:* only
USB_BLACKLIST_WWAN=1

# Set to 1 to disable autosuspend before shutdown/0 to do nothing
# (workaround for usb devices that cause shutdown problems)
#USB_AUTOSUSPEND_DISABLE_ON_SHUTDOWN=1

# Restore radio device state (bluetooth, wifi, wwan) from previous shutdown
# on system startup: 0=disable/1=enable
# Hint: the parameters DEVICES_TO_DISABLE/ENABLE_ON_STARTUP/SHUTDOWN below
#       are ignored when this is enabled!
RESTORE_DEVICE_STATE_ON_STARTUP=0

# Radio devices to disable on startup: bluetooth wifi wwan
#DEVICES_TO_DISABLE_ON_STARTUP="bluetooth wifi wwan"

# Radio devices to enable on startup: bluetooth wifi wwan
#DEVICES_TO_ENABLE_ON_STARTUP="wifi"

# Radio devices to disable on shutdown: bluetooth wifi wwan
# (workaround for devices that are blocking shutdown)
#DEVICES_TO_DISABLE_ON_SHUTDOWN="bluetooth wifi wwan"

# Radio devices to enable on shutdown: bluetooth wifi wwan
# (to prevent other operating systems from missing radios)
#DEVICES_TO_ENABLE_ON_SHUTDOWN="wwan"

# Radio devices to enable when wireless radio switch is turned on:
# bluetooth wifi wwan (Ubuntu + ThinkPad only)
#DEVICES_TO_ENABLE_ON_RADIOSW="wifi wwan"

# Battery charge thresholds (ThinkPad only, tp-smapi or acpi-call kernel module required)
# Charging starts when the remaining capacity falls below the START_CHARGE_TRESH
# value and stops when exceeding the STOP_CHARGE_TRESH value.
# Main battery (values in %)
#START_CHARGE_THRESH_BAT0=75
#STOP_CHARGE_THRESH_BAT0=80
# Ultrabay or slice battery (values in %)
#START_CHARGE_THRESH_BAT1=75
#STOP_CHARGE_THRESH_BAT1=80

# Set to 1 to disable use of tpacpi-bat on Sandy Bridge or newer Thinkpads
# and force usage of tp-smapi instead
#DISABLE_TPACPIBAT=1

# ------------------------------------------------------------------------------
# tlp-rdw - Parameters for the radio device wizard
# Possible devices: bluetooth/wifi/wwan

# Hint: parameters are disabled by default, remove the leading # to enable them

# Radio devices to disable on connect
#DEVICES_TO_DISABLE_ON_LAN_CONNECT="wifi wwan"
#DEVICES_TO_DISABLE_ON_WIFI_CONNECT="wwan"
#DEVICES_TO_DISABLE_ON_WWAN_CONNECT="wifi"

# Radio devices to enable on disconnect
#DEVICES_TO_ENABLE_ON_LAN_DISCONNECT="wifi wwan"
#DEVICES_TO_ENABLE_ON_WIFI_DISCONNECT=""
#DEVICES_TO_ENABLE_ON_WWAN_DISCONNECT=""

# Radio devices to enable/disable when docked
#DEVICES_TO_ENABLE_ON_DOCK=""
#DEVICES_TO_DISABLE_ON_DOCK=""

# Radio devices to enable/disable when undocked
#DEVICES_TO_ENABLE_ON_UNDOCK="wifi"
#DEVICES_TO_DISABLE_ON_UNDOCK=""

Obs: Estou usando o Linux Mint 13 com Mate.
« Última modificação: 12 de Maio de 2014, 11:37 por Arthur Bernardes »

Offline rihoem

  • Usuário Ubuntu
  • *
  • Mensagens: 123
    • Ver perfil
Re: Notebook desligando ao passar dos 60°C
« Resposta #1 Online: 12 de Maio de 2014, 12:21 »
Para o sistema desligar, deve estar acontecendo algum problema de refrigeração no próprio computador. No Windows não acontece pois por padrão mais programas são configurados ou mesmo criados com suporte para usar aceleração por hardware (que provavelmente deve diminuir o uso do processador e o calor produzido). Talvez até exista algum problema de configuração no seu sistema (talvez o pulseaudio consumindo muito do processador, por exemplo), mas o importante é que o notebook deveria aguentar a refrigeração.

Eu tenho um LG também e, pelo menos no meu, o sistema de resfriamento não é lá muito eficiente. Por isso é bom garantir a limpeza das saídas e entradas de ar, ou mesmo abrir e dar uma verificada nas ventoinhas.

Não acho que o TLP tenha algo a ver com isso. As configurações padrão são bastante seguras. Rode o comando "top" a partir de um terminal para verificar qual o programa está consumindo recursos do sistema.

Offline Arthur Bernardes

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re: Notebook desligando ao passar dos 60°C
« Resposta #2 Online: 12 de Maio de 2014, 12:30 »
Está menos de 18% de 3,97 de RAM.

Eu começo a achar também que seja a alta do CPU, visto que no Linux Mint está na frequência máxima.

Antes no Ubuntu não acontecia isso, mudei pro Linux Mint e coloque o TLP + Jupiter e virou isso.

Estou providenciando um suporte de notebook, porque minha base miserável com dois cooler's de derma aqui não resolve nada, pelo menos no ar ajuda a dissipar mais o calor.

A única coisa que não gostei no LG foi o resfriamento.

Obrigado pela ajuda amigo.

Agora estou no computador do meu irmão, mas mais tarde estarei de volta ao meu e posto o resultado do "top".

Só tenho o Firefox aberto com bastante abas aberto, mesmo assim o consumo não passa de 20%.

Vou assistir algum vídeo ou tocar música e posto aqui os eventos.
« Última modificação: 12 de Maio de 2014, 12:33 por Arthur Bernardes »

Offline hugoleal85

  • Usuário Ubuntu
  • *
  • Mensagens: 509
    • Ver perfil
    • Recanto do Tux
Re: Notebook desligando ao passar dos 60°C
« Resposta #3 Online: 12 de Maio de 2014, 12:37 »
Eu acho que o problema está nas duas placas de vídeo (Intel onboard e NVidia dedicada).

Muito provavelmente seu sistema está ativando-as simultaneamente, o que está sobreaquecendo o PC.

Se o PC é utilizado apenas para navegação web e tarefas que não exigem tanto poder gráfico, sugiro desativar a NVidia, utilizando para isso o Bumblebee. Lembre-se também de atualizar o kernel, pois as novas versões (especialmente as versões 3.13 e 3.14) possuem melhor suporte a esta tecnologia.

Outra sugestão é limitar o clock máximo da CPU, o que pode ser feito com a dica no arquivo abaixo:
http://www.4shared.com/file/4pEMm-EBce/Colocar_comando_na_inicializao.html

Abraço.
« Última modificação: 12 de Maio de 2014, 14:44 por hugoleal85 »
"Cada homem que encontro é superior a mim em alguma coisa; e nisto posso aprender dele." [Ralph W. Emerson]
Meu blog

Offline Arthur Bernardes

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re: Notebook desligando ao passar dos 60°C
« Resposta #4 Online: 12 de Maio de 2014, 12:42 »
Obrigado Hugo, mas quando comprei não me lembro de ter placa de vídeo híbrida, pelo que conheço meu notebook é somente Geforce 310M.

Nunca foi listado no lspci uma segunda placa de vídeo.

Só estou acabando de descompactar um arquivo de 10GB (divido em 6 partes) e começo a rodar filmes e música nele para ver o comportamento dele, faz meses que não arrisco nem a assistir vídeo no Facebook usando Linux Mint.

Offline hugoleal85

  • Usuário Ubuntu
  • *
  • Mensagens: 509
    • Ver perfil
    • Recanto do Tux
Re: Notebook desligando ao passar dos 60°C
« Resposta #5 Online: 12 de Maio de 2014, 14:49 »
Obrigado Hugo, mas quando comprei não me lembro de ter placa de vídeo híbrida, pelo que conheço meu notebook é somente Geforce 310M.

Nunca foi listado no lspci uma segunda placa de vídeo.

Só estou acabando de descompactar um arquivo de 10GB (divido em 6 partes) e começo a rodar filmes e música nele para ver o comportamento dele, faz meses que não arrisco nem a assistir vídeo no Facebook usando Linux Mint.

Verifique isso com calma, porque até onde sei esse seu PC utiliza uma CPU Core i5 480M, com gráficos onboard Intel HD onboard. Ao menos é a versão que conheço do LG A410. Se este for realmente o caso, utilize o Bumblebee. Se não for, dê uma olhada nas dicas de limitação de clock que indiquei no post anterior.

Abraço.
"Cada homem que encontro é superior a mim em alguma coisa; e nisto posso aprender dele." [Ralph W. Emerson]
Meu blog

Offline kalix

  • Usuário Ubuntu
  • *
  • Mensagens: 342
    • Ver perfil
Re: Notebook desligando ao passar dos 60°C
« Resposta #6 Online: 12 de Maio de 2014, 16:12 »
uma coisa que observei no meu notebook é que ao assistir video do youtube o cooler da uma acelerada estou com a ultima versão do Ubuntu e o processador é  core i 3 3110

Offline hugoleal85

  • Usuário Ubuntu
  • *
  • Mensagens: 509
    • Ver perfil
    • Recanto do Tux
Re: Notebook desligando ao passar dos 60°C
« Resposta #7 Online: 12 de Maio de 2014, 17:35 »
uma coisa que observei no meu notebook é que ao assistir video do youtube o cooler da uma acelerada estou com a ultima versão do Ubuntu e o processador é  core i 3 3110

Sugiro que abra um tópico de suporte, lembrando de dar o máximo de detalhes sobre o hardware e SO de seu sistema.

Caso seja um notebook com duas placas gráficas (sendo uma delas NVidia), o Bumblebee deve ajudá-lo. Em caso contrário, as dicas de limitação de clock máximo da CPU que dei mais acima muito provavelmente irão ajudá-lo.
"Cada homem que encontro é superior a mim em alguma coisa; e nisto posso aprender dele." [Ralph W. Emerson]
Meu blog

Offline Arthur Bernardes

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re: Notebook desligando ao passar dos 60°C
« Resposta #8 Online: 12 de Maio de 2014, 18:03 »
Hugo, obrigado pelas informações.

Amanhã à tarde vou averiguar o hardware desse notebook.

Estou usando o kernel 3.8, o que acha de atualizar para o kernel 3.11 e atualizar a versão do Nvidia também?

Sim, estou parado no tempo, e desejo mudar do Linux Mint 13 daqui 1 ano.

Offline hugoleal85

  • Usuário Ubuntu
  • *
  • Mensagens: 509
    • Ver perfil
    • Recanto do Tux
Re: Notebook desligando ao passar dos 60°C
« Resposta #9 Online: 12 de Maio de 2014, 18:33 »
Hugo, obrigado pelas informações.

Amanhã à tarde vou averiguar o hardware desse notebook.

Estou usando o kernel 3.8, o que acha de atualizar para o kernel 3.11 e atualizar a versão do Nvidia também?

Sim, estou parado no tempo, e desejo mudar do Linux Mint 13 daqui 1 ano.

Eu já atualizaria para a versão 3.14 (ou ao menos a 3.13).

Aqui estou com a versão 3.14.3 do Kernel no momento é o sistema está ótimo.

Abraço.
"Cada homem que encontro é superior a mim em alguma coisa; e nisto posso aprender dele." [Ralph W. Emerson]
Meu blog

Offline platao

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 5.040
    • Ver perfil
Re: Notebook desligando ao passar dos 60°C
« Resposta #10 Online: 12 de Maio de 2014, 21:24 »
Ola, parece que ha problema se vc usar o tlp e o jupiter juntos, nao sei se isso e recomendavel, li que ou vc escolhe um ou outro nunca os dois juntos.

Os processadores i5 tem grafica integrada no processador, e vc disse que tem ainda a nvidia dedicada entao quando e necessario mais processamento de video provavelmente vc tera a nvidia e a intel juntas trabalhando ao mesmo tempo e isso que esta gerando o problema.

O kernel 3.13 e o ultimo driver de video nvidia dao o suporte a troca de placa como no windows, porem nao sei se a implementação é 100 por cento.

O sergio benjamin parece que tem uma nvidia e um hardware parecido entre em contato com ele e poste para vermos de onde vem esse problema.
\\\\\\\\Apostilas Dicas e Guias do Ubuntu\\\\\\\\\> http://ubuntuforum-br.org/index.php/topic,79368.msg440997.html#msg440997

Offline Arthur Bernardes

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re: Notebook desligando ao passar dos 60°C
« Resposta #11 Online: 12 de Maio de 2014, 21:36 »
Obrigado Platão, acho que vou desinstalar ou desativar o Jupiter para ver.

No Window$ ainda não cheguei a trocar de vídeo (entre on-board para off-board).

Mas vou instalar amanhã o kernel 3.11 e a última versão da Nvidia para ver como se comporta.

O kernel 3.13 ou 3.14 é do novo LTS? Já está disponível pelo backport?

Offline platao

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 5.040
    • Ver perfil
Re: Notebook desligando ao passar dos 60°C
« Resposta #12 Online: 12 de Maio de 2014, 21:55 »
platao@platao-ubuntu:~$ uname -a
Linux platao-ubuntu 3.13.0-24-generic #47~precise2-Ubuntu SMP Fri May 2 23:30:46 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
platao@platao-ubuntu:~$


O kernel 3.13 ja esta disponivel se vc estiver no 12.04, eu nao sei se no 3.11 com o ultimo driver nvidia vc vai ter esse suporte, entao e melhor pegar o 3.13 ao invez do 3.11, qualquer coisa de uma olhada no log dos kerneis, mas no 3.13 em diante e certeza.

Se vc estiver no 14.04 ele deve usar o 3.13 tbm.
\\\\\\\\Apostilas Dicas e Guias do Ubuntu\\\\\\\\\> http://ubuntuforum-br.org/index.php/topic,79368.msg440997.html#msg440997

Offline Arthur Bernardes

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re: Notebook desligando ao passar dos 60°C
« Resposta #13 Online: 12 de Maio de 2014, 22:19 »
Ainda estou no Linux Mint 13 (12.04), amanhã vou pro 3.13, e a última versão do driver da Nvidia tem nos repositórios ou é necessário correr pro PPA?

Offline platao

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 5.040
    • Ver perfil
Re: Notebook desligando ao passar dos 60°C
« Resposta #14 Online: 13 de Maio de 2014, 09:28 »
Entra la no site da nvidia e veja qual e a ultima versao do driver de video, e compara com o oferecido pelo ubuntu, sugiro que teste e por fim se nada resultar, use o kernel 3.13 ou 3.14 e instale manualmente o ultimo driver de video disponivel da nvidia, se for instalar pelo arquivo .run nao esqueça de isntalar os pacotes necessarios para compilar o driver.
\\\\\\\\Apostilas Dicas e Guias do Ubuntu\\\\\\\\\> http://ubuntuforum-br.org/index.php/topic,79368.msg440997.html#msg440997