Autor Tópico: Após atualização sistema não levanta mais placa wifi (Resolvido)  (Lida 8935 vezes)

Offline flavioml

  • Usuário Ubuntu
  • *
  • Mensagens: 126
    • Ver perfil
Após a úlrima atualização o sistema (Kubuntu 14.04) parou de levantar o adaptador wireless, obrigando-me a fazê-lo manualmente (sudo modprobe ath9k).
Uso o network manager que, após levantar a placa, conecta automaticamente na minha rede.
Abaixo transcrevo a configuração do /etc/modprobe.d/iwlwifi.conf:

# /etc/modprobe.d/iwlwifi.conf
# iwlwifi will dyamically load either iwldvm or iwlmvm depending on the
# microcode file installed on the system.  When removing iwlwifi, first
# remove the iwl?vm module and then iwlwifi.
remove iwlwifi \
(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
&& /sbin/modprobe -r mac80211

Qual a forma correta de corrigir o problema, não criando um script que rode na inicialização e levante o módulo?
« Última modificação: 26 de Agosto de 2014, 15:28 por flavioml »
Flavio ML

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Após atualização sistema não levanta mais placa wifi
« Resposta #1 Online: 18 de Agosto de 2014, 13:41 »
Quem criou esse arquivo?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline flavioml

  • Usuário Ubuntu
  • *
  • Mensagens: 126
    • Ver perfil
Re: Após atualização sistema não levanta mais placa wifi
« Resposta #2 Online: 18 de Agosto de 2014, 13:59 »
Eu imagino que tenha sido criado em alguma nova versão do networkmanager, quando da atualização.
Flavio ML

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Após atualização sistema não levanta mais placa wifi
« Resposta #3 Online: 18 de Agosto de 2014, 14:13 »
Ah, não foi mesmo... removendo o módulo "mac80211" vc vai remover junto os drivers que dependem dele. Isso parece mais ter sido criado por algum driver Staging ou proprietário.

Minha sugestão é que vc faça um backup desse arquivo e depois o remova. Depois reinicie a máquina pra ver se o problema se resolve.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline flavioml

  • Usuário Ubuntu
  • *
  • Mensagens: 126
    • Ver perfil
Re: Após atualização sistema não levanta mais placa wifi
« Resposta #4 Online: 18 de Agosto de 2014, 14:21 »
Imediatamente antes da sua sugestão eu removi o referido arquivo para ver o que acontecia mas nada mudou. Continuo tendo que levantar o módulo na mão.
Flavio ML

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Após atualização sistema não levanta mais placa wifi
« Resposta #5 Online: 18 de Agosto de 2014, 15:08 »
Então filtre os logs do sistema para ver se há alguma indicação de porque isso acontece.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.683
    • Ver perfil
Re: Após atualização sistema não levanta mais placa wifi
« Resposta #6 Online: 19 de Agosto de 2014, 10:43 »
Problemas antigos dessa placa com o Ubuntu, desde o 11:04 : conexões lentas, falta de estabilidade na conexão ou não sobe o módulo do driver.

Tente esta possível solução:

http://www.htpcbeginner.com/how-to-fix-atheros-ar9285-ar9287-wireless-problems-in-ubuntu-1104/

Essa solução funcionava até o Ubuntu 13:10, não sei agora com tantas mudanças na parte de rede.

BigLinux no Notebook  / Várias Distros Virtualizadas no PC.

Offline flavioml

  • Usuário Ubuntu
  • *
  • Mensagens: 126
    • Ver perfil
Re: Após atualização sistema não levanta mais placa wifi
« Resposta #7 Online: 19 de Agosto de 2014, 12:33 »
Na verdade, esta placa sempre funcionou muito bem, desde o 13.04, quando ela veio substituir uma velhíssima realtek 8169 que se desmilinguiu fisicamente de velha, literalmente.
A atual versão do Kubuntu, 14.04, eu instalei recentemente em uma partição que estava sobrando, após uma tentativa mal sucedida de fazer o upgrade do 13.10, que ainda mantenho na máquina. Assim, venho fazendo a atualização aos poucos e nem mesmo os dados e demais arquivos eu transferi para a nova partição, o que eu faria após estar tudo nos trinques. O que aconteceu é que na última atualização que fiz, algo correu mal e o muon travou, após praticamente finalizar o update, obrigando-me a matar o programa. Mesmo assim, o kernel foi atualizado de 3.13.0-32 para 0-34 e tudo parecia estar ok, exceto pelo wifi.
Como tenho também o Fedora 20 instalado e o os-prober não conseguia atualizar corretamente a entrada para aquela distro, que ficava sempre rodando com o kernel anterior ao mais atual, fui obrigado a desativar o os-prober e usar o 40-custom, via grub-customizer, para manter o grub certinho.
Ontem, após atualização do Fedora, ao atualizar o grub, o kernel 3.13.0-34 passou a dar kernel panic e estou tendo que usar o 0-32. E ontem, ainda, constatei que não só a placa wireless parou de levantar como também uma porção de outros módulos também não estão sendo levantados, como os de som.
Depois de tudo isso, penso que a solução menos trabalhosa talvez seja a de reinstalar o 14.04.
Flavio ML

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Após atualização sistema não levanta mais placa wifi
« Resposta #8 Online: 19 de Agosto de 2014, 12:51 »
... kernel panic costuma ter motivos mais profundos que uma simples atualização. Como está a saúde de sua máquina?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.683
    • Ver perfil
Re: Após atualização sistema não levanta mais placa wifi
« Resposta #9 Online: 19 de Agosto de 2014, 14:44 »
Além da sugestão do zekkerj, já tentou usar um Live-CD ou Live-Pendrive do Kubuntu ou do Fedora para ter certeza dos problemas de hardware? Se os problemas persistirem então tem coisa errada com a sua máquina. Eu faria uma instalação do zero se não tiver problema de hardware.
BigLinux no Notebook  / Várias Distros Virtualizadas no PC.

Offline flavioml

  • Usuário Ubuntu
  • *
  • Mensagens: 126
    • Ver perfil
Re: Após atualização sistema não levanta mais placa wifi
« Resposta #10 Online: 21 de Agosto de 2014, 09:06 »
A máquina é relativamente nova, montada por mim, com componentes de boa qualidade, e nada indica que tenha problemas de hardware, pois outros sistemas rodam na mesma, sem problemas.
Acredito que a razão de tudo foi a barbeiragem que fiz, matando um processo de atualização não concluido.
Creio que o melhor a fazer é, de fato, reinstalar o sistema, conforme sugerido.
Agradeço à turma a boa vontade comigo.
Flavio ML

Offline flavioml

  • Usuário Ubuntu
  • *
  • Mensagens: 126
    • Ver perfil
Re: Após atualização sistema não levanta mais placa wifi (Resolvido)
« Resposta #11 Online: 26 de Agosto de 2014, 15:27 »
Após reinstalar o sistema, como havia referido na última postagem, na primeira atualização pós-instalação, revivi todo o acontecido, com o atualizador exibindo a msg de erro de que não haviam sido atualizados todos os pacotes.
Dessa vez fiz o certo e examinei as mensagens de eeo, que eram as seguintes:

/var/cache/apt/archives/plasma-desktop_4%3a4.11.10-0ubuntu0.1_amd64.deb
cannot copy extracted data for './usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so' to '/usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so.dpkg-new': unexpected end of file or stream


/var/cache/apt/archives/linux-firmware_1.127.5_all.deb
cannot copy extracted data for './lib/firmware/iwlwifi-3160-8.ucode' to '/lib/firmware/iwlwifi-3160-8.ucode.dpkg-new': unexpected end of file or stream


Como da primeira vez, ao fechar a janela de erro, a janela do muon continuava sugerindo a atualização dos pacotes plasma-desktop e linux-firmware e novamente eu cliquei em "Instalar atualizações" e novamente o muon travou, obrigando-me a dar um kill no mesmo.

Dessa vez porém, ao invés de reiniciar o sistema eu fui ao console para tentar reparar o erro. Após um "sudo apt-get update", obtive o seguinte:

(Lendo banco de dados ... 145105 ficheiros e directórios actualmente instalados.)
Preparing to unpack .../plasma-desktop_4%3a4.11.10-0ubuntu0.1_amd64.deb ...
Unpacking plasma-desktop (4:4.11.10-0ubuntu0.1) over (4:4.11.8-0ubuntu6) ...
dpkg-deb (sub-processo): a descomprimir membro do arquivo: erro de lzma: os dados comprimidos estão corrompidos
dpkg-deb: erro: sub-processo <descompressão> retornou estado de saída de erro 2
dpkg: error processing archive /var/cache/apt/archives/plasma-desktop_4%3a4.11.10-0ubuntu0.1_amd64.deb (--unpack):
 não pode copiar dados extráidos para './usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so' para '/usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so.dpkg-new': fim de ficheiro ou stream inesperado
Erros foram encontrados durante o processamento de:
 /var/cache/apt/archives/plasma-desktop_4%3a4.11.10-0ubuntu0.1_amd64.deb
Log ended: 2014-08-26  12:06:31"


Após examinar o manual do apt-cache executei o comando "sudo apt-cache gencaches" obtive uma msg de erro sobre dependências desencontradas e sugerindo o uso do apt-get -f install, o que fiz, tendo o seguinte resultado:

Start-Date: 2014-08-26  12:01:03
Commandline: apt-get -f install
Upgrade: plasma-desktop:amd64 (4.11.8-0ubuntu6, 4.11.10-0ubuntu0.1)
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2014-08-26  12:01:03


Pesquisando sobre erros no cache, encontrei o seguinte link: http://askubuntu.com/questions/310471/erroropening-the-cache

Seguindo uma das respostas do tópico, comandei em sequência:

sudo rm -rf /var/lib/apt/lists
sudo mkdir /var/lib/apt/lists
sudo apt-get clean
sudo apt-get update


Após o último comando, o sistema foi totalmente atualizado, inclusive os pacotes "problemáticos" e agora tudo está funcionando perfeitamente.

Agradeço a todos que tentaram ajudar.
Flavio ML