Autor Tópico: [Resolvido] Ubuntu 14.04 sem internet (problemas na internet após instalação)  (Lida 20413 vezes)

Offline daniela mpm

  • Usuário Ubuntu
  • *
  • Mensagens: 18
    • Ver perfil
Olá,

Há algum tempo atrás eu iniciei um tópico aqui sobre o ubuntu 13.10 que instalei e não consegui acesso a internet.
Pois, como me aconselharam, esperei lançamento o ubuntu 14.04 e instalei.
Resultado, mesmo problema!
A internet funcina alguns segundos e cai.
Depois, volta e cai de novo.

Observação: no iphone a internet tá normal.
Quando eu instalo o ubuntu 12 tudo fica normal.
O problema é so com os novos ubuntus.


Observação 2: instalei o ubuntu 14.04 no meu notebook, em que uso internet através de wifi, e também está acontecendo o mesmo problema.

POR FAVOR ME AJUDEM!
Sou uma usuária leiga.
Então expliquem com carinho, para alguém que não sabe nada, ok?

Mando aqui algumas informações que peguei no terminal, após ler um tópico parecido com o meu.
(as informações que mando agora são as do computador desktop, e não do notebook)





sudo lshw -C network
  *-network              
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: eth0
       version: 06
       serial: 90:2b:34:fb:c7:9a
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8168e-3_0.0.4 03/27/12 ip=192.168.1.65 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:41 ioport:de00(size=256) memory:fdaff000-fdafffff memory:fdaf8000-fdafbfff








ifconfig -a

eth0      Link encap:Ethernet  HWaddr 90:2b:34:fb:c7:9a  
          inet addr:192.168.1.65  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::922b:34ff:fefb:c79a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:14708 errors:0 dropped:0 overruns:0 frame:0
          TX packets:14610 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:11078628 (11.0 MB)  TX bytes:2096863 (2.0 MB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:3357 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3357 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:279617 (279.6 KB)  TX bytes:279617 (279.6 KB)







iwconfig
eth0      no wireless extensions.

lo        no wireless extensions.








nm-tool

NetworkManager Tool

State: connected (global)

- Device: eth0  [Wired connection 1] -------------------------------------------
  Type:              Wired
  Driver:            r8169
  State:             connected
  Default:           yes
  HW Address:        90:2B:34:FB:C7:9A

  Capabilities:
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties
    Carrier:         on

  IPv4 Settings:
    Address:         192.168.1.65
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.1.1

    DNS:             192.168.1.1






Agurado resposta e agradeço desde já.
« Última modificação: 13 de Junho de 2014, 16:21 por daniela mpm »

Offline daniela mpm

  • Usuário Ubuntu
  • *
  • Mensagens: 18
    • Ver perfil
Re: Ubuntu 14.04 sem internet (problemas na internet após instalação)
« Resposta #1 Online: 18 de Maio de 2014, 20:17 »
Olá, novamente.

Eu consegui resolver!!!!!

Encontrei a solução aqui:
http://forum.ubuntued.info/viewtopic.php?f=24&t=5361#p56241

vou copiar aqui embaixo o que precisa ser feito:



No terminal, edite o arquivo /etc/NetworkManager/NetworkManager.conf

Para editar, digite o comando:
sudo gedit /etc/NetworkManager/NetworkManager.conf


No arquivo NetworkManager.conf adicione # antes de dns para desativa o dnsmasq. Deve ficar assim:
#dns=dnsmasq

Depois, no terminal, digite o seguinte:
sudo rm -f /etc/resolv.conf
sudo ln -s /run/resolvconf/interface/NetworkManager /etc/resolv.conf


E para finalizar, reinicie o NetworkManager com:
sudo service network-manager restart


Obrigada, vitorfelipe!

Offline moacircostajr

  • Usuário Ubuntu
  • *
  • Mensagens: 13
    • Ver perfil
Re: Ubuntu 14.04 sem internet (problemas na internet após instalação)
« Resposta #2 Online: 19 de Maio de 2014, 23:00 »
No meu caso, a internet conecta diretamente com o roteador wi fi comum, mas quando tento usar a função de roteador no celular Android, para usar a internet advinda do chip 3g, o ubuntu nao conecta. Na versão 12.10 conecta normalmente. Alguém poderia me dar uma orientação sobre como resolver esse problema?

eth0      Link encap:Ethernet  Endereço de HW 00:23:5a:74:1e:28 
          UP BROADCAST MULTICAST  MTU:1500  Métrica:1
          pacotes RX:0 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:0 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

lo        Link encap:Loopback Local 
          inet end.: 127.0.0.1  Masc:255.0.0.0
          endereço inet6: ::1/128 Escopo:Máquina
          UP LOOPBACK RUNNING  MTU:65536  Métrica:1
          pacotes RX:5473 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:5473 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:0
          RX bytes:538821 (538.8 KB) TX bytes:538821 (538.8 KB)

wlan0     Link encap:Ethernet  Endereço de HW 7c:4f:b5:b8:b0:7e 
          inet end.: 192.168.0.102  Bcast:192.168.0.255  Masc:255.255.255.0
          endereço inet6: fe80::7e4f:b5ff:feb8:b07e/64 Escopo:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Métrica:1
          pacotes RX:49887 erros:0 descartados:0 excesso:0 quadro:856928
          Pacotes TX:49305 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:50696745 (50.6 MB) TX bytes:6487777 (6.4 MB)
          IRQ:17


eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11abg  ESSID:"dlink" 
          Mode:Managed  Frequency:2.437 GHz  Access Point: 14:D6:4D:B7:84:96   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

Celular Motorola RAZR D1 em modo roteador com a internet 3g ligada não conecta com o notebook
Obrigado pela atenção.

Offline CMessage

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
Re: Ubuntu 14.04 sem internet (problemas na internet após instalação)
« Resposta #3 Online: 20 de Maio de 2014, 18:24 »
poxa, instalei o Ubuntu 14.04 na esperança de voltar a conectar a internet via  ethernet, mas não consegui.
tentei essa solução, mas não funcionou.
agora consigo conectar, mas ainda não navego.
alguém tem mais alguma ideia?

aguardo.obrigada :)
« Última modificação: 20 de Maio de 2014, 18:52 por CMessage »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Não dá pra saber sem conhecer a situação de sua máquina. Execute os comandos que a daniela mpm executou na primeira mensagem e cole o resultado aqui pra gente analisar.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline CMessage

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
Não dá pra saber sem conhecer a situação de sua máquina. Execute os comandos que a daniela mpm executou na primeira mensagem e cole o resultado aqui pra gente analisar.

sudo lshw -c network

  *-network               
       descrição: Ethernet interface
       produto: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       fabricante: Realtek Semiconductor Co., Ltd.
       ID físico: 0
       informações do barramento: pci@0000:01:00.0
       nome lógico: eth0
       versão: 02
       serial: 00:21:85:e9:2d:80
       tamanho: 100Mbit/s
       capacidade: 100Mbit/s
       largura: 64 bits
       clock: 33MHz
       capacidades: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuração: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       recursos: irq:42 porta de E/S:c000(tamanho=256) memória:ffd10000-ffd10fff memória:ffd00000-ffd0ffff memória:dfd00000-dfd0ffff
  *-network
       descrição: Interface sem fio
       produto: RTL8187SE Wireless LAN Controller
       fabricante: Realtek Semiconductor Co., Ltd.
       ID físico: 0
       informações do barramento: pci@0000:02:00.0
       nome lógico: wlan0
       versão: 22
       serial: 00:21:85:b4:3b:00
       largura: 32 bits
       clock: 33MHz
       capacidades: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuração: broadcast=yes driver=r8180 ip=192.168.0.14 latency=0 multicast=yes wireless=802.11b/g  link
       recursos: irq:17 porta de E/S:b000(tamanho=256) memória:dfc00000-dfc03fff


ifconfig -a
eth0      Link encap:Ethernet  Endereço de HW 00:21:85:e9:2d:80 
          endereço inet6: fe80::221:85ff:fee9:2d80/64 Escopo:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Métrica:1
          pacotes RX:8 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:203 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:1373 (1.3 KB) TX bytes:40748 (40.7 KB)

lo        Link encap:Loopback Local 
          inet end.: 127.0.0.1  Masc:255.0.0.0
          endereço inet6: ::1/128 Escopo:Máquina
          UP LOOPBACK RUNNING  MTU:65536  Métrica:1
          pacotes RX:32 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:32 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:0
          RX bytes:2400 (2.4 KB) TX bytes:2400 (2.4 KB)

wlan0     Link encap:Ethernet  Endereço de HW 00:21:85:b4:3b:00 
          inet end.: 192.168.0.14  Bcast:192.168.0.255  Masc:255.255.255.0
          endereço inet6: fe80::221:85ff:feb4:3b00/64 Escopo:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Métrica:1
          pacotes RX:14103 erros:9 descartados:10523 excesso:0 quadro:0
          Pacotes TX:10856 erros:18 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:16454428 (16.4 MB) TX bytes:1543081 (1.5 MB)
          IRQ:17 Memória:f8558000-f8558100





iwconfig

wlan0     802.11b/g  link  ESSID:"netvirtuaA401" 
          Mode:Managed  Frequency=2.462 GHz  Access Point: CC:35:40:77:25:07   
          Bit Rate=18 Mb/s   
          Retry min limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=84/100  Signal level=-37 dBm  Noise level=-111 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

lo        no wireless extensions.

eth0      no wireless extensions.



nm-tool

NetworkManager Tool

State: connected (global)

- Device: wlan0  [netvirtuaA401] -----------------------------------------------
  Type:              802.11 WiFi
  Driver:            r8180
  State:             connected
  Default:           yes
  HW Address:        00:21:85:B4:3B:00

  Capabilities:
    Speed:           18 Mb/s

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points (* = current AP)
    *netvirtuaA401:  Infra, CC:35:40:77:25:07, Freq 2462 MHz, Rate 54 Mb/s, Strength 83 WPA WPA2
    netvirtua1227301A: Infra, 00:1D:D5:16:F2:10, Freq 2412 MHz, Rate 54 Mb/s, Strength 75 WPA2
    netvirtua1852 BL A APT309: Infra, 00:25:F1:ED:FE:90, Freq 2462 MHz, Rate 54 Mb/s, Strength 64 WPA

  IPv4 Settings:
    Address:         192.168.0.14
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.0.1

    DNS:             189.7.168.15
    DNS:             189.7.168.16
    DNS:             201.6.4.116


- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            r8169
  State:             disconnected
  Default:           no
  HW Address:        00:21:85:E9:2D:80

  Capabilities:
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties
    Carrier:         on

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Tente criar uma conexão automática na interface eth0 usando o Gerenciador de Redes.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline jgama

  • Usuário Ubuntu
  • *
  • Mensagens: 175
    • Ver perfil
estes DNS  estão validos?

 DNS:             189.7.168.15
    DNS:             189.7.168.16
    DNS:             201.6.4.116

tenta trocar por DNS do google  para fazer um teste

8.8.8.8
8.8.4.4