Autor Tópico: O segundo hd do meu computador (/dev/sdb1) não monta  (Lida 6089 vezes)

Offline vfarias

  • Usuário Ubuntu
  • *
  • Mensagens: 141
    • Ver perfil
O segundo hd do meu computador (/dev/sdb1) não monta
« Online: 10 de Junho de 2014, 20:14 »
Amigos, instalei um segundo HD na minha máquina com Linux Mint, para armazenar meus arquivos de vídeo. Criei uma tabela de partição e formatei com sistema de arquivos ext4 utilizando o Gparted, de dentro do sistema. No início deu tudo certo. Inclusive gravei vários vídeos e acessava-os sem problemas. Agora, não sei por qual motivo, não estou conseguindo montar a partição única contida no HD. No Gparted a partição é detectada como /dev/sdb1 e adiante desta referência tem um quadrado e um círculo branco com um sinal de exclamação. Na coluna Flags está escrito msftdata. Será necessário editar os arquivos fstab e mtab para que a partição seja montada? Agradeço orientação.

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: O segundo hd do meu computador (/dev/sdb1) não monta
« Resposta #1 Online: 11 de Junho de 2014, 06:13 »
Antes de tudo, faça um fsck (cheque o disco por erros)

Use um live dvd/pendrive ou entre nas opções avançadas do grub

Offline vfarias

  • Usuário Ubuntu
  • *
  • Mensagens: 141
    • Ver perfil
Re: O segundo hd do meu computador (/dev/sdb1) não monta
« Resposta #2 Online: 11 de Junho de 2014, 07:20 »
Caro Tota, após rodar o comando "sudo fdisk -l /dev/sdb1" o sistema retornou "o disco /dev/sdb1 não contém uma tabela de partição válida" e após rodar o comando "sudo fsck /dev/sda1 -y" o sistema retornou "dev/sda1: clean, 171397/1921360 files, 1355453/7679931 blocks". A partição continua sem montar. E agora? Relembrando: o disco em questão tem 3 terabytes e foi particionado com uma partição somente, formatada com o sistema de arquivos ext4. Estou tentando montá-la para ver se recupero os vídeos que foram gravados nela. Caso contrário já teria formatado o HD. Quando tento acessá-lo recebo a seguinte mensagem:
"Error mounting /dev/sdb1 at /media/vbarros/381b58df-c98d-4d01-a42c-5edfc592e574: Command-line `mount -t "ext4" -o "uhelper=udisks2,nodev,nosuid" "/dev/sdb1" "/media/vbarros/381b58df-c98d-4d01-a42c-5edfc592e574"' exited with non-zero exit status 32: mount: wrong fs type, bad option, bad superblock on /dev/sdb1,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so"
« Última modificação: 11 de Junho de 2014, 07:33 por vfarias »

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: O segundo hd do meu computador (/dev/sdb1) não monta
« Resposta #3 Online: 11 de Junho de 2014, 11:55 »
Isto é muito ruim

Citar
após rodar o comando "sudo fdisk -l /dev/sdb1" o sistema retornou "o disco /dev/sdb1 não contém uma tabela de partição válida"

Vá na central de programas e instale o pacote testdisk

Recupere seus dados para outra midia.

Com seus dados seguros pode-se tentar recuperar a partição, não antes disto, pois erros de superbloco geralmente se corrigem com dificuldades, podendo "sumir" com seus dados.

Tem um bom tutorial sobre o testdisk no site da cgsecurity, desenvolvedora do projeto.

[]'s

clodoaldops

  • Visitante
Re: O segundo hd do meu computador (/dev/sdb1) não monta
« Resposta #4 Online: 12 de Junho de 2014, 01:34 »
Desktop de trabalho tem 2 HD's.
No sda temos windows e Linux em dual boot.
O sdb deixamos para Bkp em ntfs.
Usamos há 3 anos e nunca tivemos problemas com esse esquema.