Autor Tópico: Squid respondendo sem formatação  (Lida 12101 vezes)

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Squid respondendo sem formatação
« Resposta #30 Online: 02 de Julho de 2014, 19:59 »
Hmmmmmmmm..... acho que já sei o que rolou.

Vc tem essa partição "/srv/Storage1", certo?
Citar
editora@bkp-editora:~$ df -h
Sist. Arq.       Tam  Usad Dispon. Uso% Montado em
/dev/sda1       226G  226G       0 100% /
udev            1,9G  8,0K    1,9G   1% /dev
tmpfs           771M  9,7M    762M   2% /run
none            5,0M     0    5,0M   0% /run/lock
none            1,9G     0    1,9G   0% /run/shm
none            100M     0    100M   0% /run/user
overflow        1,0M     0    1,0M   0% /tmp
/dev/sdb1       2,7T  1,7T    971G  63% /srv/Storage1

Quando vc criou/montou, observou se a pasta /srv/Storage1 estava vazia? Pq se não estiver, o conteúdo do sistema de arquivos montado se sobrepõe ao conteúdo da pasta, que fica completamente inacessível.

Uma forma de confirmar isso é desmontar a partição (supondo que não haja processo usando, é só mandar um "sudo umount /srv/Storage1"), e ver se fica alguma coisa lá dentro.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline g4p

  • Usuário Ubuntu
  • *
  • Mensagens: 262
    • Ver perfil
Re: Squid respondendo sem formatação
« Resposta #31 Online: 02 de Julho de 2014, 20:02 »
Sempre falei que você é o gênio do Forum. Sempre conseguiu desvendar mistérios, hahaha.

Exatamente isso que aconteceu!

Citar
root@bkp-editora:/# sudo umount /srv/Storage1
root@bkp-editora:/# cd /srv/Storage1/
root@bkp-editora:/srv/Storage1# ls
BACKUPS INDD  BANCO DE ILUSTRAS  BANCO DE IMAGEM  CONSULTA TEMPORARIA  EDITORA  ILUSTRAS RECUPERADAS  MATERIAL DE APOIO  NAT5I  Tati  TESTE ILUSTRADOR  TI
root@bkp-editora:/srv/Storage1# df -h
Sist. Arq.       Tam  Usad Dispon. Uso% Montado em
/dev/sda1       226G  226G       0 100% /
udev            1,9G  8,0K    1,9G   1% /dev
tmpfs           771M  9,7M    762M   2% /run
none            5,0M     0    5,0M   0% /run/lock
none            1,9G     0    1,9G   0% /run/shm
none            100M     0    100M   0% /run/user
overflow        1,0M     0    1,0M   0% /tmp
root@bkp-editora:/srv/Storage1#

Offline g4p

  • Usuário Ubuntu
  • *
  • Mensagens: 262
    • Ver perfil
Re: Squid respondendo sem formatação
« Resposta #32 Online: 02 de Julho de 2014, 20:05 »
Citar
root@bkp-editora:/srv/Storage1# du -lhs /srv/Storage1/
221G   /srv/Storage1/

Vou da um rm -rf /srv/Storage1/ e montar novamente..

Offline g4p

  • Usuário Ubuntu
  • *
  • Mensagens: 262
    • Ver perfil
Re: Squid respondendo sem formatação
« Resposta #33 Online: 02 de Julho de 2014, 20:09 »
/srv/Storage1/ é um HD externo que fica o backup.

Acredito que quando eu reiniciei a máquina, por algum motivo, ele não montou automáticamente e eu tive que montar manualmente depois. Nisso, nesse meio termo, o rsync entrou em ação e saiu detonando..

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Squid respondendo sem formatação
« Resposta #34 Online: 02 de Julho de 2014, 20:28 »
Sempre falei que você é o gênio do Forum. Sempre conseguiu desvendar mistérios, hahaha.

Genial ou Genioso? ;D
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Squid respondendo sem formatação
« Resposta #35 Online: 02 de Julho de 2014, 20:33 »
/srv/Storage1/ é um HD externo que fica o backup.

Acredito que quando eu reiniciei a máquina, por algum motivo, ele não montou automáticamente e eu tive que montar manualmente depois. Nisso, nesse meio termo, o rsync entrou em ação e saiu detonando..

Se estiver fazendo o backup por script, pode verificar, antes de começar a cópia, se o sistema de arquivos está mesmo montado. Supondo que é um sistema de arquivos ext3, tem que haver uma pasta "lost+found" lá dentro. Se ela não existir, não está montado, daí não faça o backup.

Outra forma seria executar o comando "mount | grep /srv/Storage1 > /dev/null". O resultado vai ser verdadeiro se estiver montado, ou falso caso contrário. Assim pode ser usado num script parecido com isso:

Código: [Selecionar]
#/bin/bash

...
if mount | grep /srv/Storage1 > /dev/null
then
   echo Está montado, manda bala no backup
   ...
else
   echo Não está montado, vou cair fora...
fi
...
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline g4p

  • Usuário Ubuntu
  • *
  • Mensagens: 262
    • Ver perfil
Re: Squid respondendo sem formatação
« Resposta #36 Online: 02 de Julho de 2014, 20:38 »
Massa. Valeu mesmo, cara!

Só achei estranho meus scripts terem sumido de ~/scripts. Eu tinha um bkp.sh e sarg.sh. :(

Sumiu também minhas chaves em ~/.ssh. Que estranho!

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Squid respondendo sem formatação
« Resposta #37 Online: 02 de Julho de 2014, 20:57 »
Aí tem que chamar o Sherlock Holmes... nenhuma chance de ter sobreposto esses arquivos ou deixado de montar mais alguma coisa em /home?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline g4p

  • Usuário Ubuntu
  • *
  • Mensagens: 262
    • Ver perfil
Re: Squid respondendo sem formatação
« Resposta #38 Online: 04 de Julho de 2014, 10:12 »
Acredito que sobreescreveu. Deixado de montar não. Ficava em /home/usuario/scripts. HD interno.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Squid respondendo sem formatação
« Resposta #39 Online: 04 de Julho de 2014, 11:38 »
Claro que vc tinha backup deles, não? ;D

Voltando ao assunto do título... normalizou o funcionamento do Squid?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline g4p

  • Usuário Ubuntu
  • *
  • Mensagens: 262
    • Ver perfil
Re: Squid respondendo sem formatação
« Resposta #40 Online: 04 de Julho de 2014, 11:42 »
Tinha sim!

Normalizou. Ta tranquilo agora!

Tava sem espaço pra receber o resultado do GET que o proxy solicitava. Valeu mesmo, zek! :)

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Squid respondendo sem formatação
« Resposta #41 Online: 06 de Julho de 2014, 14:09 »
Interessante, as versões antigas do squid crashavam "graciosamente" quando ficavam sem espaço pra gerar o log.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D