Autor Tópico: Ubuntu 14.04 LTS nao reconhece cabo ethernet  (Lida 44300 vezes)

Offline Mendoka

  • Usuário Ubuntu
  • *
  • Mensagens: 18
    • Ver perfil
Re:Ubuntu 14.04 LTS nao reconhece cabo ethernet
« Resposta #60 Online: 23 de Maio de 2015, 13:33 »
Beleza, Druida! As coisas tão um.pouco corridas aqui, mas quando ru sossegar no meu canto eu vou fazer esses procedimentos. Já vorto daqui algumas horas. o/
E obrigado por tudo aew! :D

Offline Mendoka

  • Usuário Ubuntu
  • *
  • Mensagens: 18
    • Ver perfil
Re:Ubuntu 14.04 LTS nao reconhece cabo ethernet
« Resposta #61 Online: 23 de Maio de 2015, 16:56 »
Olá! Vortei...

Vamos lá! A primeira coisa que eu fiz foi editar os arquivos e deixei as duas linhas de comando somente no rc.local e aí eu só conseguia reiniciar a máquina através do recovery mode. Eu vi um log aqui e a máquina travava justamente na parte na parte em que aparecia "stoping network algumacoisalá". Complicado...
Detalhe: Quando eu coloco o comando "rmmod..." lá no rc.local, o rmmod não muda de cor, assim como o comando "modprobe". Isso não tem nada a ver?
Deixando somente a linha de comando "modprobe..." no rc.local já é o suficiente p/ eu suspender a máquina e, depois que ela volta, a internet vem junto. Nem preciso colocar a outra linha de comando no kmod.conf, porém só suspendendo e acordando a máquina p/ fazer a internet funcionar.

Interrompidos pela manutenção do Fórum, estamos de volta, vamos adiante.

De toda forma estamos numa situação melhor do que antes, pois no início dessa conversa você tinha nada de internet, agora já consegue conectar, ainda que de uma forma tortuosa, indo pelo Recovery Mode, mas o fato é que consegue estabelecer uma conexão onde antes não havia nada, o que já é um primeiro alento.

O problema é decorrente de um conflito entre a placa de rede e ACPI.

Execute, por favor, o seguinte comando, pois quero confirmar um raciocínio.

Código: [Selecionar]
dmesg | grep -i "acpi warning"

Resultado do comando acima:
Código: [Selecionar]
[   11.255178] ACPI Warning: SystemIO range 0x0000000000000700-0x000000000000073f conflicts with OpRegion 0x0000000000000700-0x000000000000073f (\_SB_.PCI0.SM00) (20140424/utaddress-258)
Vamos tentar três caminhos para resolver o problema, vamos ver se dá certo.

1) Primeira forma:

Mantendo as alterações feitas no rc.local conforme indicado no post #55, faça o bloqueio do driver forcedeth.

Código: [Selecionar]
sudo gedit /etc/modprobe.d/blacklist.conf
Após a linha onde consta 'blacklist evbug', acrescente:

blacklist forcedeth

Salvar e sair

Reiniciar pelo Modo Normal e vamos ver se tem internet.

Aqui não rolou por causa do mesmo motivo que eu citei: Não reinicia. Depois que eu escolho p/ bootar normalmente lá no grub, a máquina trava. D:

Citar
2) Segunda forma:

Caso não tenha tido sucesso na forma anterior (primeira), tendo reiniciado o sistema e mantidas aquelas alterações, abra uma janela do terminal (Ctrl Alt T) e execute manualmente os comandos:


Código: [Selecionar]
rmmod forcedeth

modprobe forcedeth msi=0 msix=0

Verifique se há internet após a execução manual dos comandos acima.

Quando eu faço o primeiro comando, a máquina trava completamente! \o\
No segundo simplesmente não acontece nada e a internet não volta. (ou, se acontece algum processo interno, não aparece nem no terminal)

Citar
3) Terceira forma:

Mantendo as alterações feitas no arquivo blacklist.conf, isto é, mantendo o bloqueio do driver forcedeth, apague as alterações feitas no arquivo rc.local, ou seja, exclua os comandos que foram lá acrescentados.

reinicie o sistema

Após o sistema ter reiniciado e retornado ao ambiente gráfico, execute manualmente através de uma janela do terminal os comandos (Ctrl Alt T) mencionados:


Código: [Selecionar]
rmmod forcedeth

modprobe forcedeth msi=0 msix=0

Verifique se agora há internet após a execução manual dos comandos acima.

O raciocínio obviamente está baseado no fato de que é possível estabelecer a conexão indo pelo Recovery Mode, portanto, tornando assíncrono o conflito ACPI.

Vamos ver os resultados disso.

Trava também. D:

Complicado... É esquisito o fato do negócio funcionar somente quando eu suspendo a máquina. Se eu deixar só o comando "modprobe..." no rc.local ele faz isso. Se eu colocar a outra linha de comando no kmod. conf, não diferencia em nada. Eu acho que o grande lance tá nesse "modprobe...". Vou fazer mais alguns testes aqui. Se alguém aí tiver mais uma luz, por favor compartilhe... D:
E valew novamente, Druida!

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.554
    • Ver perfil
Re:Ubuntu 14.04 LTS nao reconhece cabo ethernet
« Resposta #62 Online: 23 de Maio de 2015, 17:09 »
Se está travando quando usa o [rmmod forcedeth], que serve para baixar (arrancar) o driver da memória, então é fazer uma variação disso usando apenas o segundo comando, que é a carga (subida) do driver para a memória.

Mantenha o bloqueio do driver forcedeth no blacklist.conf, como já explicado.

Após o boot completo pelo modo Normal, carregue manualmente fazendo apenas:

Código: [Selecionar]
modprobe forcedeth msi=0 msix=0
Use somente esse, não o outro.

Usando apenas esse faça igualmente as três variações sugeridas no post anterior.
« Última modificação: 23 de Maio de 2015, 17:11 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Mendoka

  • Usuário Ubuntu
  • *
  • Mensagens: 18
    • Ver perfil
Re: Ubuntu 14.04 LTS nao reconhece cabo ethernet
« Resposta #63 Online: 23 de Maio de 2015, 17:19 »
Druida, meu fih! Funcionou. Eu deixei os dois comandos em seus respectivos arquivos. O problema é que antes de tentar usar essa solução, eu fiz algumas alterações em outros arquivos (foi nesse mesmo tópico que eu vi essas alterações, no post #22). Eu lembrei delas, alterei novamente os arquivos, fiz novamente as alterações no kmod.conf e no rc.local, reiniciei e... FINALMENTE! Internet disponível no meu Ubuntu.
Muito obrigado pela atenção, cara. Essas dicas são muito valiosas! Tem que guardar esse tópico p/a posterioridade, hehehe... Valew mesmo!

Só p/ reforçar os comandos e alterações:

Em...:
Código: [Selecionar]
sudo gedit /etc/init/kmod.conf... adicionar depois de "script" o comando...:
Código: [Selecionar]
rmmod forcedeth
E em...:
Código: [Selecionar]
sudo gedit /etc/rc.local... adicionar antes do "exit"  o comando...:
Código: [Selecionar]
modprobe forcedeth msi=0 msix=0
Reiniciar e partir p/o abraço!

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.554
    • Ver perfil
Re:Ubuntu 14.04 LTS nao reconhece cabo ethernet
« Resposta #64 Online: 23 de Maio de 2015, 17:39 »
Ótimo que tenha funcionado!

Quer dizer que não está utilizando a blacklist.conf? Tem certeza disso?

Confirme, por favor, pois é importante para outros usuários com o mesmo problema o registro exato do que precisa ser alterado.

Estou achando estranho que tenha que deixar o 'rmmod forcedeth' no arquivo kmod.conf, mas enfim....

www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Mendoka

  • Usuário Ubuntu
  • *
  • Mensagens: 18
    • Ver perfil
Re:Ubuntu 14.04 LTS nao reconhece cabo ethernet
« Resposta #65 Online: 23 de Maio de 2015, 17:55 »
Isso mesmo, Druida.  A alteração no blacklist.conf não é necessária. Eu tirei o forcedeth de lá, reiniciei a máquina e continua funcionando normalmente.  ;)

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.554
    • Ver perfil
Re:Ubuntu 14.04 LTS nao reconhece cabo ethernet
« Resposta #66 Online: 23 de Maio de 2015, 17:55 »
Então, /Mendoka/,

Mais um ponto que, por favor, necessita esclarecer: quando fez a instalação do Ubuntu no seu sistema, fez sem atualização e depois também permaneceu assim até agora, isto é, sem atualizar, ou você utilizou algum outro meio para atualizar (por exemplo, um dispositivo wireless externo)?

Nesse ponto que estivemos alterando e testando os arquivos de configuração o sistema já estava atualizado ou não?
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Mendoka

  • Usuário Ubuntu
  • *
  • Mensagens: 18
    • Ver perfil
Re:Ubuntu 14.04 LTS nao reconhece cabo ethernet
« Resposta #67 Online: 23 de Maio de 2015, 18:30 »
Não tava atualizado não. Larguei de mão de qualquer atualização até conseguir configurar a internet. To atualizando tudo só agora. o/

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.554
    • Ver perfil
Re:Ubuntu 14.04 LTS nao reconhece cabo ethernet
« Resposta #68 Online: 23 de Maio de 2015, 18:50 »
Citar
Não tava atualizado não. Larguei de mão de qualquer atualização até conseguir configurar a internet. To atualizando tudo só agora. o/

Obrigado pelo feedback, pelo retorno da informação, /Mendoka/,

Se puder nos manter informado após todas as atualizações se tudo continua a funcionar corretamente, agradeço.

Qual é a placa-mãe (motherboard) do seu computador? Por acaso uma ASRock?

Caso no futuro queira ir para a versão 15.04 do Ubuntu (o que não seria lá muito recomendado, porque não é uma LTS como é a 14.04), talvez o esquema seja outro, ou até é possível que o problema não venha a se manifestar, vez que a carga do sistema deixou de ser feita pelo Upstart e passou a ser feita pelo Systemd, em todo caso, é algo a se considerar.

www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.554
    • Ver perfil
Re:Ubuntu 14.04 LTS nao reconhece cabo ethernet
« Resposta #69 Online: 23 de Maio de 2015, 19:02 »
Agora para o colega /alimnez/,

Se e quando você puder confirmar a solução aqui proposta, seria útil como informação de registro para o Fórum, para outros usuários que igualmente tenham ou venham a ter esse problema, já que esse chipset e driver (forcedeth) não é assim tão comum.

Confirme inicialmente se a placa de rede onboard (o chipset na verdade) é também do mesmo modelo desse do /Mendoka/, para isso use o comando:

Código: [Selecionar]
lspci -nnk | grep -iA2 net
Também se puder informar a motherboard (placa-mãe) e versão do BIOS é útil:

Código: [Selecionar]
sudo dmidecode -t0,1
Após o que, se puder, implemente a solução aqui adotada, conforme resumo no post #63, e por favor nos informe o resultado.

« Última modificação: 23 de Maio de 2015, 20:57 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Mendoka

  • Usuário Ubuntu
  • *
  • Mensagens: 18
    • Ver perfil
Re:Ubuntu 14.04 LTS nao reconhece cabo ethernet
« Resposta #70 Online: 23 de Maio de 2015, 19:19 »
Isso! ASRock N68-S3 FX. Oh, plaquinha difícil de lidar... Mas é possível! rs...

Até agora as atualizações tão de boa. Só preciso correr atrás de bons softwares, agora. Tá bacana. o/

Offline Mendoka

  • Usuário Ubuntu
  • *
  • Mensagens: 18
    • Ver perfil
Re: Ubuntu 14.04 LTS nao reconhece cabo ethernet
« Resposta #71 Online: 25 de Maio de 2015, 01:35 »
Então, né? Andei fazendo uns testes aqui e vi que não era só essas alterações que fizeram a minha internet voltar com essa placa. Faltou uma outra alteração. Então além dessas abaixo...:


Em...:
Código: [Selecionar]
sudo gedit /etc/init/kmod.conf... adicionar depois de "script" o comando...:
Código: [Selecionar]
rmmod forcedeth
E em...:
Código: [Selecionar]
sudo gedit /etc/rc.local... adicionar antes do "exit"  o comando...:
Código: [Selecionar]
modprobe forcedeth msi=0 msix=0

... tem essa daqui também:
Código: [Selecionar]
sudo echo "options forcedeth msi=0 msix=0" | sudo tee /etc/modprobe
E aí sim! Reiniciar e partir p/o abraço!!

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.554
    • Ver perfil
Re:Ubuntu 14.04 LTS nao reconhece cabo ethernet
« Resposta #72 Online: 25 de Maio de 2015, 04:25 »
Então, /Mendoka/,

Esse último comando que você menciona parece ser aquele passado lá no post #37, sendo dessa forma:

Código: [Selecionar]
echo "options forcedeth msi=0 msix=0" | sudo tee /etc/modprobe.d/forcedeth.conf

Verifique, por favor, se é isso mesmo, pois você está relatando aqui no post #71 que seja:

sudo echo "options forcedeth msi=0 msix=0" | sudo tee /etc/modprobe

o que não faz sentido, pois não existe no sistema esse caminho apontado acima (/etc/modprobe) e sim aquele antes mencionado (/etc/modprobe.d) no qual se cria o arquivo forcedeth.conf.

Confirme isso, por favor, para deixar claro o que realmente funcionou.


« Última modificação: 25 de Maio de 2015, 04:27 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Mendoka

  • Usuário Ubuntu
  • *
  • Mensagens: 18
    • Ver perfil
Re:Ubuntu 14.04 LTS nao reconhece cabo ethernet
« Resposta #73 Online: 25 de Maio de 2015, 05:48 »
Rapaz! Eu também achei muito estranho, principalmente pelo fato de que nenhum dos 2 arquivos existem aqui. Mas fazendo as alterações anteriores e não dando resultado, eu fiz esse arquivo, reiniciei e deu certo. É um lance estranho, isso... Mas comigo foi o que fez dar certo. Vai entender...  :o