Autor Tópico: [Resolvido]Placa de video parace não funcionar Vostro 5470  (Lida 5386 vezes)

Offline luandraco

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
[Resolvido]Placa de video parace não funcionar Vostro 5470
« Online: 26 de Setembro de 2014, 18:54 »
Fala pessoal,

Estou com alguns problemas e gostaria de ajuda.

Bom tenho um vostro 5470, nvidia 740m 2gb. Instalei o bumblebee e fui fazer alguns testes ver se realmente estava funcionando, ela me parece que está instalada mas não está funcionando normalmente. Utilizei os seguintes comandos:


optirun glxinfo:
OpenGL version string: 4.4.0 NVIDIA 331.89
OpenGL shading language version string: 4.40 NVIDIA via Cg compiler
OpenGL context flags: (none)
OpenGL profile mask: (none)


optirun glxgears
293 frames in 5.0 seconds = 58.412 FPS
301 frames in 5.0 seconds = 60.009 FPS
301 frames in 5.0 seconds = 60.009 FPS
294 frames in 5.0 seconds = 58.619 FPS
301 frames in 5.0 seconds = 60.010 FPS
301 frames in 5.0 seconds = 60.009 FPS
301 frames in 5.0 seconds = 60.007 FPS

glxgears
306 frames in 5.0 seconds = 61.146 FPS
301 frames in 5.0 seconds = 60.014 FPS
301 frames in 5.0 seconds = 60.010 FPS
301 frames in 5.0 seconds = 60.010 FPS



sudo lshw -C video
  *-display              
       descrição: VGA compatible controller
       produto: Haswell-ULT Integrated Graphics Controller
       fabricante: Intel Corporation
       ID físico: 2
       informações do barramento: pci@0000:00:02.0
       versão: 09
       largura: 64 bits
       clock: 33MHz
       capacidades: msi pm vga_controller bus_master cap_list rom
       configuração: driver=i915 latency=0
       recursos: irq:62 memória:f1000000-f13fffff memória:e0000000-efffffff porta de E/S:6000(tamanho=64)

optirun sudo lshw -C video
  *-display              
       descrição: VGA compatible controller
       produto: Haswell-ULT Integrated Graphics Controller
       fabricante: Intel Corporation
       ID físico: 2
       informações do barramento: pci@0000:00:02.0
       versão: 09
       largura: 64 bits
       clock: 33MHz
       capacidades: msi pm vga_controller bus_master cap_list rom
       configuração: driver=i915 latency=0
       recursos: irq:62 memória:f1000000-f13fffff memória:e0000000-efffffff porta de E/S:6000(tamanho=64)
  *-display
       descrição: 3D controller
       produto: GK208M [GeForce GT 740M]
       fabricante: NVIDIA Corporation
       ID físico: 0
       informações do barramento: pci@0000:09:00.0
       versão: a1
       largura: 64 bits
       clock: 33MHz
       capacidades: pm msi pciexpress bus_master cap_list
       configuração: driver=nvidia latency=0
       recursos: irq:65 memória:f0000000-f0ffffff memória:c0000000-cfffffff memória:d0000000-d1ffffff porta de E/S:3000(tamanho=128)


Utilizei os seguintes passos para instalar:
Adicione a PPA para os drivers da NVIDIA e Bumblebee (economia de energia¹):

$ sudo add-apt-repository ppa:xorg-edgers/ppa && sudo add-apt-repository ppa:bumblebee/stable
$ sudo apt-get update

Remoção do Bumblebee anteriormente instalado e/ou drivers da NVIDIA:

$ sudo apt-get purge bbswitch-dkms bumblebee-nvidia
$ sudo apt-get purge nvidia*

Instalação do driver NVIDIA 331 e Bumblebee

$ sudo apt-get install nvidia-331 bumblebee bumblebee-nvidia primus

Reinicie o sistema.

Veja se o driver da NVIDIA e o Bumblebee se estão funcionando (não testei²).

$ optirun glxgears

« Última modificação: 26 de Setembro de 2014, 20:01 por luandraco »

Offline Sergio Benjamim

  • Usuário Ubuntu
  • *
  • Mensagens: 2.902
    • Ver perfil
Re: Placa de video parace não funcionar Vostro 5470
« Resposta #1 Online: 26 de Setembro de 2014, 19:20 »
Você seguiu o passo à passo desse link? http://www.linux.org/threads/nvidia-optimus-on-linux.4415/

Tem que alterar alguns arquivos, para fazer funcionar.
É novo no Ubuntu? Já leu o Ubuntu – Guia do Iniciante 2.0 ?
Experimente o Xubuntu 14.04 !

Offline luandraco

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Re: Placa de video parace não funcionar Vostro 5470
« Resposta #2 Online: 26 de Setembro de 2014, 20:00 »
Não tinha feito, fiz agora e funcionou muito obrigado  Sergio.

Offline bakhtinjf

  • Usuário Ubuntu
  • *
  • Mensagens: 110
    • Ver perfil
Re: [Resolvido]Placa de video parace não funcionar Vostro 5470
« Resposta #3 Online: 29 de Setembro de 2014, 15:30 »
Tentei instalar esse Bumblee mas deu muito pau no meu computador. Não consegui ter mais acesso ao wifi, caia constantemente. Alguem sabe me dizer o motivo? Tenho a mesma maquina que vc.

Offline bakhtinjf

  • Usuário Ubuntu
  • *
  • Mensagens: 110
    • Ver perfil
Re: [Resolvido]Placa de video parace não funcionar Vostro 5470
« Resposta #4 Online: 29 de Setembro de 2014, 18:08 »
Seu Vostro esta funcionando direitinho? A internet com Wifi e através do cabo RJ45 esta ok?

Offline luandraco

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Re: [Resolvido]Placa de video parace não funcionar Vostro 5470
« Resposta #5 Online: 07 de Outubro de 2014, 13:06 »
Desculpa bakhtinjf, só vi agora a mensagem, sim está tudo funcionando.