Autor Tópico: [Resolvido] Partição SWAP não inicia junto com SO  (Lida 2696 vezes)

Offline Jeferson Otto Ebel

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
    • Facebook
[Resolvido] Partição SWAP não inicia junto com SO
« Online: 01 de Maio de 2015, 19:57 »
Olá


Meu computador possuía muitas partições, resolvi então reorganizar tudo então apaguei todas as excedentes a principal que está instalado o sistema, e criei uma só, para guardar arquivos de backup, nisto, aproveitei e apaguei a partição de SWAP e também a recriei com um pouco mais de memória e alocando-a entre as duas partições existentes atualmente (ver imagens), mas acabei notando que cometi um erro ao perceber isso, além de causar mais lentidão na inicialização do sistema, a partição SWAP acaba não iniciando junto com o sistema, tendo que ser iniciada manualmente.
Informações adicionais:

Atualmente estou usando Ubuntu 15.04 e é o único sistema instalado no computador.

Links
Imagem gerenciador de disco: https://www.flickr.com/photos/127153378@N06/17148928278/lightbox/
imagem Terminal: https://www.flickr.com/photos/127153378@N06/17336323591/in/photostream/lightbox/
Não sei se tem alguma importância relevante, mas segue print do arquivo fstab também (Este arquivo está localizado em /etc) https://www.flickr.com/photos/127153378@N06/17129443247/

Deixo também meu email para contato: jefersonebel@gmail.com

segue conteúdo do arquivo

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=3b893c85-a01d-4b8d-8160-7d5a7842eac7 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=d5924004-a10e-4f80-896a-a876f4978d4f none            swap    sw              0       0
/dev/disk/by-uuid/9E466CFD466CD813 /mnt/9E466CFD466CD813 auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/disk/by-uuid/f997eb53-4f87-4c15-ac48-df4aa3fe6e2e /mnt/f997eb53-4f87-4c15-ac48-df4aa3fe6e2e auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/disk/by-uuid/887A-9197 /mnt/887A-9197 auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/disk/by-uuid/1D41-0BAC /mnt/1D41-0BAC auto nosuid,nodev,nofail,x-gvfs-show 0 0

« Última modificação: 02 de Maio de 2015, 14:41 por Jeferson Otto Ebel »

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.553
    • Ver perfil
Re: Partição SWAP não inicia junto com SO
« Resposta #1 Online: 01 de Maio de 2015, 21:50 »
Use o comando abaixo para verificar o UUID (identificador universal) da partição swap

Código: [Selecionar]
sudo blkid
(depois do bê é letra ele no comando acima)

Depois compare com o UUID que está assinalado no seu fstab

Evidentemente o UUID da partição swap real precisa estar no fstab para que ocorra a montagem no boot.

« Última modificação: 01 de Maio de 2015, 21:51 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Jeferson Otto Ebel

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
    • Facebook
Re: Partição SWAP não inicia junto com SO
« Resposta #2 Online: 02 de Maio de 2015, 10:13 »
Executei o código, retornou o seguinte então a respeito do SWAP:
/dev/sda2: LABEL="LINUX-SWAP" UUID="c8b0f078-77f7-4889-86f3-ade3c6efdfc8" TYPE="swap" PARTUUID="f8f1ebed-02"
(como pode ser visto na imagem do link abaixo)
Isso quer dizer que tenho que deixar o código do arquivo fstab da seguinte forma:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=3b893c85-a01d-4b8d-8160-7d5a7842eac7 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=c8b0f078-77f7-4889-86f3-ade3c6efdfc8 none            swap    sw              0       0
/dev/disk/by-uuid/9E466CFD466CD813 /mnt/9E466CFD466CD813 auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/disk/by-uuid/f997eb53-4f87-4c15-ac48-df4aa3fe6e2e /mnt/f997eb53-4f87-4c15-ac48-df4aa3fe6e2e auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/disk/by-uuid/887A-9197 /mnt/887A-9197 auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/disk/by-uuid/1D41-0BAC /mnt/1D41-0BAC auto nosuid,nodev,nofail,x-gvfs-show 0 0


(os lugares alterados estão em negrito)

Correto isso?
Devo fazer algo mais?

Conteúdo do terminal:
Link: https://www.flickr.com/photos/127153378@N06/17340572482/in/photostream/lightbox/

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.553
    • Ver perfil
Re: Partição SWAP não inicia junto com SO
« Resposta #3 Online: 02 de Maio de 2015, 12:46 »
Código: [Selecionar]
Devo fazer algo mais?
Quanto ao swap está correto, é isso mesmo a fazer.

Entretanto, deve fazer uma cópia do fstab antes de alterá-lo e ainda ter um live-iso (pendrive ou dvdroom) disponível caso algo errado aconteça.

Um alteração errada no fstab pode deixar o sistema inacessível.

Para copiar:

Código: [Selecionar]
sudo cp /etc/fstab /etc/fstab-bkup
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Jeferson Otto Ebel

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
    • Facebook
Re: Partição SWAP não inicia junto com SO
« Resposta #4 Online: 02 de Maio de 2015, 14:05 »
Cara deu certo aqui, vlw, muito obrigado.