Autor Tópico: Re: Ícone Wi-fi sumiu!  (Lida 18852 vezes)

Offline Natan2014

  • Usuário Ubuntu
  • *
  • Mensagens: 98
    • Ver perfil
Re: Ícone Wi-fi sumiu!
« Online: 04 de Julho de 2015, 22:37 »
Oi pessoal, estou usando o ubuntu 15.04 num HP 2GB, processador AMD E 350, e de repente o Ícone sumiu da barra de ferramentas! Como recupero?
« Última modificação: 10 de Julho de 2015, 18:53 por Natan2014 »

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.552
    • Ver perfil
Re:Ícone Wi-fi sumiu!
« Resposta #1 Online: 05 de Julho de 2015, 01:58 »
Estou supondo que se trata de ter desaparecido apenas o ícone da conexão, isto é, a conexão continua ocorrendo normalmente, é apenas o ícone da barra superior.

Não sei como resolve isso de verdade, nunca me aconteceu de desaparecer o ícone da conexão de rede e, por consequência, nunca me debrucei realmente sobre o problema. O que tenho visto é periodicamente aparecer essa questão aqui no Fórum.

Tem um tópico aqui com várias soluções apontadas, não sei dizer se ainda são válidas:

Restaurar ícone de conexões de rede no painel do ubuntu.

http://ubuntuforum-br.org/index.php/topic,62839.15.html

Tem um outro tópico recente, bem recente, porém na verdade, a meu ver, não aponta uma solução real que vá na origem do problema, mas sim um "workaround", mas enfim, resolveu, então considere o que dizem lá:

Ícone da Rede sumiu: Ubuntu 14.04

http://ubuntuforum-br.org/index.php?topic=115784.0

Não fiz uma pesquisa extensiva no Fórum sobre o problema, o que quer dizer que podem existir outros tópicos relevantes no assunto e que podem ajudar. Use a ferramenta de pesquisa do Fórum (Busca).
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.552
    • Ver perfil
Re:Ícone Wi-fi sumiu!
« Resposta #2 Online: 05 de Julho de 2015, 01:59 »
Apenas como sugestão, na verdade simples palpite , além dos links acima mencionados e antes de verificar aquelas sugestões, experimente o seguinte:

Supondo que seu sistema esteja atualizado (e não estiver atualize), instale o DConf-editor:

Código: [Selecionar]
sudo apt-get install dconf-editor
Para chamar bastar digitar dconf na caixa do Dash.
Aparece um ícone de uma lupa como 'Editor do dconf'.

Use a ferramente de pesquisa que existe nele (teclas Ctrl + F ou no menu dele) e abra "Pesquisar"

Na caixa de pesquisa digite:

nm-applet

click em próximo

No campo que se abre do Esquema org.gnome,nm-applet

Verifique se está marcada a opção "show applet"

Apenas essa opção deverá estar marcada, todas as demais estão desmarcadas e stamp está com valor igual a 0 (zero)

Eventualmente click em 'Definir padrão'

Fecha o DConf-editor

Reinicie o sistema (talvez só reiniciar a sessão já resolva).

Aqui apliquei experimentalmente isso numa instalação do Ubuntu 15.04 e com isso consegui fazer aparecer e desaparecer o ícone da conexão, então tente aí para vermos o que acontece.
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.552
    • Ver perfil
Re:Ícone Wi-fi sumiu!
« Resposta #3 Online: 05 de Julho de 2015, 02:00 »
Se o procedimento anterior não funcionou, pode ainda experimente editar o arquivo:

Código: [Selecionar]
sudo gedit /etc/xdg/autostart/nm-applet.desktop
Na linha onde consta:

 Exec=nm-applet


Substitua por:

Exec=dbus-launch nm-applet

Salvar o arquivo e reiniciar

Há uma observação nesse ponto:

Caso existe no seu sistema o arquivo (está no /home, arquivo oculto, vem com um . (ponto) antes)

~/.config/autostart/nm-applet.desktop

Ele irá sobrescrever o arquivo existente em /etc/xdg/autostart/nm-applet.desktop, então, se o caso, renomeia o arquivo neutralizando-o para que não sobrescreva aquele.

Caso não produza o efeito desejado, retorne o arquivo ao que estava.
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.552
    • Ver perfil
Re:Ícone Wi-fi sumiu!
« Resposta #4 Online: 05 de Julho de 2015, 02:01 »
Uma outra possibilidade:

Paralise o network-manager:

Código: [Selecionar]
sudo /etc/init.d/network-manager stop
Altere o nome do arquivo NetworkManager.state (o que equivale e eliminá-lo, porém sem fazer realmente isso, só renomeando):

Código: [Selecionar]
cd /var/lib/NetworkManager/
Código: [Selecionar]
sudo mv NetworkManager.state NetworkManager.state-bak
Reinicie o network-manager:

Código: [Selecionar]
sudo /etc/init.d/network-manager start
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.552
    • Ver perfil
Re:Ícone Wi-fi sumiu!
« Resposta #5 Online: 05 de Julho de 2015, 02:03 »
Existe ainda um outro caminho é instalar o "Indicator Systemtray Unity", o que basicamente é feito da seguinte forma:

Código: [Selecionar]
sudo apt-add-repository ppa:fixnix/indicator-systemtray-unity
Código: [Selecionar]
sudo apt-get update
Código: [Selecionar]
sudo apt-get install indicator-systemtray-unity
Por falta de tempo não testei e não tenho no momento como avaliar a eficácia desse procedimento, entretanto, se necessário desinstalar, use:

Código: [Selecionar]
sudo apt-get purge indicator-systemtray-unity
A fonte da informação, nesse caso, está aqui, onde é possível colher maiores informações:

Install Indicator Systemtray Unity in Ubuntu

http://www.webupd8.org/2015/05/on-demand-system-tray-for-ubuntu.html


No momento é apenas isso que tenho a sugerir, mas parece ser mesmo necessário estudar essa questão um pouco mais a fundo pois se trata de uma questão recorrente. Informe caso alguma dessas soluções venha a funcionar para o seu sistema, pois o registro da solução é útil para o Fórum em consultas futuras de outros usuários que possam vir a ter igual problema.

www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Natan2014

  • Usuário Ubuntu
  • *
  • Mensagens: 98
    • Ver perfil
Re:Ícone Wi-fi sumiu!
« Resposta #6 Online: 05 de Julho de 2015, 22:19 »
druidaobelix, agradeço sua tentativa, mas nenhuma das suas sugestões deu certo comigo. A internet funciona normalmente, o único problema é a ausência do ícone que mostra o nível do sinal wi-fi.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.552
    • Ver perfil
Re:Ícone Wi-fi sumiu!
« Resposta #7 Online: 06 de Julho de 2015, 03:38 »
Mais um caminho, embora essa alternativa originalmente seja para a versão 14.04, mas enfim, experimente na 15.04, vai que funciona.

Pelo Dash procure e acione o ícone "Aplicativos de sessão".

Verifique se consta e está assinalado (ticado) "Indicator Application", se não estiver, marque.

Em seguida instale:

Código: [Selecionar]
sudo apt-get install indicator-applet indicator-network
Reinicie o sistema.
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Natan2014

  • Usuário Ubuntu
  • *
  • Mensagens: 98
    • Ver perfil
Re:Ícone Wi-fi sumiu!
« Resposta #8 Online: 07 de Julho de 2015, 22:50 »
Mais um caminho, embora essa alternativa originalmente seja para a versão 14.04, mas enfim, experimente na 15.04, vai que funciona.

Pelo Dash procure e acione o ícone "Aplicativos de sessão".

Verifique se consta e está assinalado (ticado) "Indicator Application", se não estiver, marque.

Em seguida instale:

Código: [Selecionar]
sudo apt-get install indicator-applet indicator-network
Reinicie o sistema.

Em relação ao que colocou  até a 3ª linha, já está assinalado, e o ícone não voltou! Em relação à 5ª, deu erro! E pra piorar, a conexão também não está funcionando!

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.552
    • Ver perfil
Re:Ícone Wi-fi sumiu!
« Resposta #9 Online: 08 de Julho de 2015, 02:50 »
Agora ficou realmente ruim, ter perdido a conexão.  :(

Use os seguintes comandos:

Código: [Selecionar]
sudo stop network-manager
Código: [Selecionar]
sudo start network-manager
Veja se com isso é possível restabelecer a conexão.

Se não conseguir, execute os comandos abaixo e cole os resultados aqui:

Código: [Selecionar]
nmcli -f all nm
Código: [Selecionar]
nmcli -f all c
Código: [Selecionar]
nmcli -f all d

Caso consiga avise que então seguimos adiante na questão do tópico, que é o ícone de conexão da barra de tarefas.
« Última modificação: 08 de Julho de 2015, 03:23 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline platao

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 5.052
    • Ver perfil
Re:Ícone Wi-fi sumiu!
« Resposta #10 Online: 08 de Julho de 2015, 10:46 »
Amigos ja tentaram reinstalar os pacotes network-manager e network-manager-gnome?
\\\\\\\\Apostilas Dicas e Guias do Ubuntu\\\\\\\\\> http://ubuntuforum-br.org/index.php/topic,79368.msg440997.html#msg440997

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.552
    • Ver perfil
Re:Ícone Wi-fi sumiu!
« Resposta #11 Online: 08 de Julho de 2015, 14:55 »
Quanto ao aspecto da conexão propriamente dita que parou de funcionar, caso ainda não funcione após os comandos de stop/start mencionados, chame pelo terminal:

Código: [Selecionar]
nm-connection-editor
No quadro que se abre verifique a conexão relacionada, marque com o mouse e click no botão editar.
Observe se na aba Geral está assinalado:

Conectar automaticamente a esta rede quando ela estiver disponível
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Natan2014

  • Usuário Ubuntu
  • *
  • Mensagens: 98
    • Ver perfil
Re:Ícone Wi-fi sumiu!
« Resposta #12 Online: 09 de Julho de 2015, 11:37 »
Agora ficou realmente ruim, ter perdido a conexão.  :(

Use os seguintes comandos:

Código: [Selecionar]
sudo stop network-manager
Código: [Selecionar]
sudo start network-manager
Veja se com isso é possível restabelecer a conexão.

Se não conseguir, execute os comandos abaixo e cole os resultados aqui:

Código: [Selecionar]
nmcli -f all nm
Código: [Selecionar]
nmcli -f all c
Código: [Selecionar]
nmcli -f all d

Caso consiga avise que então seguimos adiante na questão do tópico, que é o ícone de conexão da barra de tarefas.

O primeiro comando que mencionou mal digitei e já deu erro, como pode conferir abaixo! Mas percebi depois que a conexão voltou a funcionar.

O resultado dos outros comandos mencionados é:

natanael@natanael-HP-Pavilion-dm1-Notebook-PC:~$ sudo stop network-manager
[sudo] password for natanael:
stop: Não foi possível conectar ao Upstart: Failed to connect to socket /com/ubuntu/upstart: Conexão recusada
natanael@natanael-HP-Pavilion-dm1-Notebook-PC:~$ nmcli -f all c
NOME               UUID                                  TIPO             HORÁRIO     HORÁRIO-REAL                  AUTOCONECTAR  SOMENTE-LEITURA  CAMINHO DBUS                                ATIVO  DISPOSITIVO  ESTADO   ACTIVE-PATH                                       
Conexão cabeada 1  ee0563be-a3bf-46bf-9062-5453fb750edd  802-3-ethernet   1436451127  Qui 09 Jul 2015 11:12:07 BRT  sim           não              /org/freedesktop/NetworkManager/Settings/1  não    --           --       --                                                 
GVT-9179           ec94f651-1436-4ba9-b494-0c572c59618f  802-11-wireless  1436451130  Qui 09 Jul 2015 11:12:10 BRT  sim           não              /org/freedesktop/NetworkManager/Settings/0  sim    wlan0        ativado  /org/freedesktop/NetworkManager/ActiveConnection/0

natanael@natanael-HP-Pavilion-dm1-Notebook-PC:~$ nmcli -f all nm
Erro: Objeto "nm" é desconhecido, tente "nmcli help".

natanael@natanael-HP-Pavilion-dm1-Notebook-PC:~$ nmcli -f all d
DISPOSITIVO  TIPO      ESTADO           CAMINHO DBUS                               CONEXÃO   CON-UUID                              CAMINHO CON                                       
wlan0        wifi      conectado        /org/freedesktop/NetworkManager/Devices/2  GVT-9179  ec94f651-1436-4ba9-b494-0c572c59618f  /org/freedesktop/NetworkManager/ActiveConnection/0
eth0         ethernet  não disponível   /org/freedesktop/NetworkManager/Devices/1  --        --                                    --                                                 
lo           loopback  não gerenciável  /org/freedesktop/NetworkManager/Devices/0  --        --                                    --                           

Porém o ícone continua sumido!

Offline Natan2014

  • Usuário Ubuntu
  • *
  • Mensagens: 98
    • Ver perfil
Re:Ícone Wi-fi sumiu!
« Resposta #13 Online: 09 de Julho de 2015, 11:39 »
Amigos ja tentaram reinstalar os pacotes network-manager e network-manager-gnome?

Acredito que foi depois de reinstalar esses pacotes que a conexão retornou Platao, obg!

Offline Natan2014

  • Usuário Ubuntu
  • *
  • Mensagens: 98
    • Ver perfil
Re:Ícone Wi-fi sumiu!
« Resposta #14 Online: 09 de Julho de 2015, 11:40 »
Quanto ao aspecto da conexão propriamente dita que parou de funcionar, caso ainda não funcione após os comandos de stop/start mencionados, chame pelo terminal:

Código: [Selecionar]
nm-connection-editor
No quadro que se abre verifique a conexão relacionada, marque com o mouse e click no botão editar.
Observe se na aba Geral está assinalado:

Conectar automaticamente a esta rede quando ela estiver disponível

A opção mencionada já estava assinalada.