Autor Tópico: MD300 Claro no UBUNTU 8.10 não consegue completar a conexão [RESOLVIDO]  (Lida 3779 vezes)

Offline Lúcio Sales

  • Usuário Ubuntu
  • *
  • Mensagens: 39
    • Ver perfil
Meu problema é o seguinte:
Todas as configurações foram feitas para que o Ubuntu 8.10 reconhecesse o MD300 como modem, porém quando tento conectar pelo GNOME-PPP o seguinte histórico é apresentado:

--> Ignoring malformed input line: ";Do NOT edit this file by hand!"
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
OK
--> Sending: AT+CFUN=1
AT+CFUN=1
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Sending: AT+CGDCONT=1,"IP","bandalarga.claro.com.br"
AT+CGDCONT=1,"IP","bandalarga.claro.com.br"
OK
--> Modem initialized.
--> Sending: ATM1L3DT*99***1#
--> Waiting for carrier.
ATM1L3DT*99***1#
~[7f]}#@!}!}!} }9}#}%B#}%}(}"}'}"}"}&} } } } }%}&0/Z.x[~
CONNECT
--> Carrier detected.  Waiting for prompt.
~[7f]}#@!}!}"} }9}#}%B#}%}(}"}'}"}"}&} } } } }%}&0/Z.46~
--> PPP negotiation detected.
--> Unable to run /usr/sbin/pppd.
--> Check permissions, or specify a "PPPD Path" option in wvdial.conf.
~[7f]}#@!}!}#} }9}#}%B#}%}(}"}'}"}"}&} } } } }%}&0/Z.pm~
--> PPP negotiation detected.
--> Unable to run /usr/sbin/pppd.
--> Check permissions, or specify a "PPPD Path" option in wvdial.conf.
~[7f]}#@!}!}$} }9}#}%B#}%}(}"}'}"}"}&} } } } }%}&0/Z.=e~
--> PPP negotiation detected.
--> Unable to run /usr/sbin/pppd.
--> Check permissions, or specify a "PPPD Path" option in wvdial.conf.
~[7f]}#@!}!}%} }9}#}%B#}%}(}"}'}"}"}&} } } } }%}&0/Z.y>~
--> PPP negotiation detected.
--> Unable to run /usr/sbin/pppd.
--> Check permissions, or specify a "PPPD Path" option in wvdial.conf.
~[7f]}#@!}!}&} }9}#}%B#}%}(}"}'}"}"}&} } } } }%}&0/Z.5S~
--> PPP negotiation detected.
--> Unable to run /usr/sbin/pppd.
--> Check permissions, or specify a "PPPD Path" option in wvdial.conf.
~[7f]}#@!}!}'} }9}#}%B#}%}(}"}'}"}"}&} } } } }%}&0/Z.q}(~
--> PPP negotiation detected.
--> Unable to run /usr/sbin/pppd.
--> Check permissions, or specify a "PPPD Path" option in wvdial.conf.
~[7f]}#@!}!}(} }9}#}%B#}%}(}"}'}"}"}&} } } } }%}&0/Z.>J~
--> PPP negotiation detected.
--> Unable to run /usr/sbin/pppd.
--> Check permissions, or specify a "PPPD Path" option in wvdial.conf.
~[7f]}#@!}!})} }9}#}%B#}%}(}"}'}"}"}&} } } } }%}&0/Z.z}1~
--> PPP negotiation detected.
--> Unable to run /usr/sbin/pppd.
--> Check permissions, or specify a "PPPD Path" option in wvdial.conf.
~[7f]}#@!}!}*} }9}#}%B#}%}(}"}'}"}"}&} } } } }%}&0/Z.6|~
--> PPP negotiation detected.
--> Unable to run /usr/sbin/pppd.
--> Check permissions, or specify a "PPPD Path" option in wvdial.conf.
--> Connected, but carrier signal lost!  Retrying...
--> Sending: ATM1L3DT*99***1#
--> Waiting for carrier.
NO CARRIER
ATM1L3DT*99***1#
~[7f]}#@!}!}!} }9}#}%B#}%}(}"}'}"}"}&} } } } }%}&}(p}"}6(:~
--> No Carrier!  Trying again.
--> Maximum Attempts Exceeded..Aborting!!
--> Disconnecting at Thu Apr  9 06:47:45 2009
« Última modificação: 30 de Abril de 2009, 21:57 por Lúcio Sales »

Offline hedbruno

  • Usuário Ubuntu
  • *
  • Mensagens: 193
    • Ver perfil
Re: MD300 Claro no UBUNTU 8.10 não consegue completar a conexão
« Resposta #1 Online: 17 de Abril de 2009, 10:24 »
Citar
PPP negotiation detected.
--> Unable to run /usr/sbin/pppd.
--> Check permissions, or specify a "PPPD Path" option in wvdial.conf.
--> Connected, but carrier signal lost!  Retrying...
--> Sending: ATM1L3DT*99***1#
--> Waiting for carrier.


Tente fazer assim no terminal

Código: [Selecionar]
sudo Wvdial

alarcon

  • Visitante
Re: MD300 Claro no UBUNTU 8.10 não consegue completar a conexão
« Resposta #2 Online: 17 de Abril de 2009, 14:33 »
Já tentou assim, abrir um terminal (menu Aplicações > Acessórios > Consola ou Terminal) e digitar:

sudo gedit /etc/wvdial.conf

no arquivo que abrir, se não estiver em branco, substituir por isso aqui:

Citar
[Dialer 3g]
Modem = /dev/ttyUSB0
Baud = 921600
DialCommand = ATDT
Check Def Route = on
FlowControl = Hardware(CRTSCTS)
Username = claro
Password = claro
Phone = *99***1#
Stupid mode = 1
Auto Reconnect = on
Auto DNS = on
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2
Init3 = AT+CGDCONT=1,"IP","bandalarga.claro.com.br"
ISDN = 0
Modem Type = Analog Modem

salve e feche o arquivo e depois ainda pelo terminal digitar:

sudo wvdial 3g

para fazer a conexão e veja se funciona.


Caso não funcione leia mais isso:

Citar
Para a maioria dos modems essa configuração é suficiente, mas muitos modelos, como o Aiko 82D e o Huawei E156 precisam de um conjunto de opções adicionais. Originalmente o modem chega a discar e iniciar a conexão, mas desconecta sozinho logo depois. Para solucionar o problema, é necessário voltar ao "/etc/ppp/options" e adicionar também as linhas "asyncmap 0xa0000", "mru 1500" e "refuse-chap" no final do arquivo.

Caso o sistema não esteja obtendo automaticamente os endereços DNS da operadora ao ativar a conexão, edite o arquivo "/etc/ppp/options" e adicione a opção "ipcp-max-failure 30" no final do arquivo. Essa opção orienta o discador a esperar mais tempo pelas configurações da conexão antes de desistir, dando mais tempo ao servidor remoto.

Ele é um daqueles arquivos grandes e intimidadores, com mais de 350 linhas de opções, mas você não precisa se preocupar com elas. Basta adicionar as linhas no final do arquivo "/etc/ppp/options", logo depois do "# ---<End of File>---", como em:
# ---<End of File>---
asyncmap 0xa0000
mru 1500
refuse-chap
ipcp-max-failure 30

Depois de fazer as alterações, é só discar novamente, usando o comando sudo wvdial 3g.
fonte: http://www.guiadohardware.net/tutoriais/3g-linux/


Se mesmo assim você preferir usar o discador gráfico gnome-ppp veja este artigo aqui:

http://linuxnanet.com/2008/09/claro-3g-modem-e226-no-ubuntu-e-vrias.html

lá mostra como configurar o discador gnome-ppp, o kppp dentre outras coisas.
« Última modificação: 17 de Abril de 2009, 15:20 por alarcon »

Offline Lúcio Sales

  • Usuário Ubuntu
  • *
  • Mensagens: 39
    • Ver perfil
Re: MD300 Claro no UBUNTU 8.10 não consegue completar a conexão
« Resposta #3 Online: 21 de Abril de 2009, 22:20 »
Prezados hedbruno e alarcon,

Vou seguir essas dicas e depois retorno o resultado.

Obrigado pela atenção.

Lúcio

Offline Lúcio Sales

  • Usuário Ubuntu
  • *
  • Mensagens: 39
    • Ver perfil
Re: MD300 Claro no UBUNTU 8.10 não consegue completar a conexão
« Resposta #4 Online: 28 de Abril de 2009, 22:52 »
Muito bem,

Fiz as tentativas com as sugestões acima. Não tinham surtido efeito. Mas depois de algum tempo percebi que o problema resultou de um detalhe:

O arquivo wvdial.conf está na pasta etc:

A instrução que segui para configuração do wvdial iniciava com o seguinte comando:

vim .wvdial.conf

Observei que dessa forma o arquivo wvdial.conf da pasta etc não era afetado com as configurações e portanto para alguns computadores isso não faz o modem funcionar. Então experimentei executar o comando mudando o endereço, para que o arquivo existente na pasta etc ficasse alterado com as configurações. Para facilitar usei o gedit, pois o vim é muito difícil de entender pois não existe menu de comandos, são apenas teclas de atalho.

Dei o seguinte comando:

sudo gedit /etc/wvdial.conf

e deixei os seguintes argumentos no arquivo:

[Dialer Defaults]
Modem = /dev/ttyACM0
ISDN = off
Modem Type = USB Modem
Baud = 460800
Init = ATZ
Init2 = AT+CFUN=1
Init3 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Init4 = AT+CGDCONT=1,"IP","bandalarga.claro.com.br"
Init5 =
Init6 =
Init7 =
Init8 =
Init9 =
Phone = *99***1#
Phone1 =
Phone2 =
Phone3 =
Phone4 =
Dial Prefix =
Dial Attempts = 1
Dial Command = ATM1L3DT
Ask Password = off
Password = claro
Username = claro
Auto Reconnect = off
Abort on Busy = off
Carrier Check = on
Check Def Route = on
Abort on No Dialtone = on
Stupid Mode = off
Idle Seconds = 0
Auto DNS = on
;Minimize = off
;Dock = off
;Do NOT edit this file by hand!

Salvei, sai e testei. Funcionou. Vale lembrar que o comando wvdial nunca funciona da primeira vez. Tem que tentar duas vezes.

Bom, não entendo muito o que acontece. Mas foi assim que resolvi o problema da conexão.

Obrigado pela boa vontade de vocês!
« Última modificação: 28 de Abril de 2009, 22:57 por Lúcio Sales »

Offline Lúcio Sales

  • Usuário Ubuntu
  • *
  • Mensagens: 39
    • Ver perfil
Re: MD300 Claro no UBUNTU 8.10 não consegue completar a conexão
« Resposta #5 Online: 28 de Abril de 2009, 23:03 »
Como é que faz para colocar [RESOLVIDO] no título do tópico?

Offline lunga

  • Usuário Ubuntu
  • *
  • Mensagens: 366
  • Visitem: www.mundolunga.com
    • Ver perfil
    • O mundo de lunga
Re: MD300 Claro no UBUNTU 8.10 não consegue completar a conexão
« Resposta #6 Online: 29 de Abril de 2009, 19:04 »
acho q  pelo editar..na primeira mensagem.
Se sua dúvida foi resolvida, por favor,  edite o título do tópico para indicar isso!

"Na União Soviética, a rosca é que queima você!!!