Autor Tópico: Erro ao dar Start no Apache  (Lida 8949 vezes)

Offline tsqueiroz

  • Usuário Ubuntu
  • *
  • Mensagens: 0
    • Ver perfil
Erro ao dar Start no Apache
« Online: 08 de Abril de 2016, 10:48 »
Bom dia pessoal!

Não estou conseguindo dar o start no serviço do Apache. Vocês podem me ajudar, por favor?
Seguem abaixo o status e a mensagem de erro que aparece ao startar.

root@debian-glpi:/home/tsqueiroz-debian# /etc/init.d/apache2 start
[....] Starting apache2 (via systemctl): apache2.serviceJob for apache2.service failed. See 'systemctl status apache2.service' and 'journalctl -xn' for details.
 failed!


root@debian-glpi:/home/tsqueiroz-debian# /etc/init.d/apache2 status
● apache2.service - LSB: Apache2 web server
   Loaded: loaded (/etc/init.d/apache2)
   Active: failed (Result: exit-code) since Sex 2016-04-08 10:39:29 BRT; 2min 46s ago
  Process: 3782 ExecStart=/etc/init.d/apache2 start (code=exited, status=1/FAILURE)

Abr 08 10:39:08 debian-glpi apache2[3782]: Starting web server: apache2AH00558: apache2: Could no...age
Abr 08 10:39:08 debian-glpi apache2[3782]: (98)Address already in use: AH00072: make_sock: could ...443
Abr 08 10:39:29 debian-glpi apache2[3782]: failed!
Abr 08 10:39:29 debian-glpi apache2[3782]: The apache2 instance did not start within 20 seconds. ...g).
Abr 08 10:39:29 debian-glpi systemd[1]: apache2.service: control process exited, code=exited status=1
Abr 08 10:39:29 debian-glpi systemd[1]: Failed to start LSB: Apache2 web server.
Abr 08 10:39:29 debian-glpi systemd[1]: Unit apache2.service entered failed state.
Hint: Some lines were ellipsized, use -l to show in full.


Obrigado,

Tarcisio




Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re:Erro ao dar Start no Apache
« Resposta #1 Online: 08 de Abril de 2016, 10:49 »
Execute os comandos abaixo e cole o resultado aqui.

apache2ctl -DSSL -S

netstat -atunpe | egrep ":80|:443"
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline tsqueiroz

  • Usuário Ubuntu
  • *
  • Mensagens: 0
    • Ver perfil
Re:Erro ao dar Start no Apache
« Resposta #2 Online: 08 de Abril de 2016, 10:55 »
Bom dia zekkerj. Segue abaixo o que solicitou. Agradeço a atenção.

root@debian-glpi:/home/tsqueiroz-debian# apache2 -DSSL -S
[Fri Apr 08 10:53:09.126834 2016] [core:warn] [pid 4331] AH00111: Config variable ${APACHE_LOCK_DIR} is not defined
[Fri Apr 08 10:53:09.126940 2016] [core:warn] [pid 4331] AH00111: Config variable ${APACHE_PID_FILE} is not defined
[Fri Apr 08 10:53:09.126962 2016] [core:warn] [pid 4331] AH00111: Config variable ${APACHE_RUN_USER} is not defined
[Fri Apr 08 10:53:09.126971 2016] [core:warn] [pid 4331] AH00111: Config variable ${APACHE_RUN_GROUP} is not defined
[Fri Apr 08 10:53:09.126994 2016] [core:warn] [pid 4331] AH00111: Config variable ${APACHE_LOG_DIR} is not defined
[Fri Apr 08 10:53:09.151779 2016] [core:warn] [pid 4331] AH00111: Config variable ${APACHE_RUN_DIR} is not defined
[Fri Apr 08 10:53:09.152287 2016] [core:warn] [pid 4331] AH00111: Config variable ${APACHE_LOG_DIR} is not defined
[Fri Apr 08 10:53:09.152794 2016] [core:warn] [pid 4331] AH00111: Config variable ${APACHE_LOG_DIR} is not defined
[Fri Apr 08 10:53:09.152812 2016] [core:warn] [pid 4331] AH00111: Config variable ${APACHE_LOG_DIR} is not defined
AH00526: Syntax error on line 74 of /etc/apache2/apache2.conf:
Invalid Mutex directory in argument file:${APACHE_LOCK_DIR}


root@debian-glpi:/home/tsqueiroz-debian# netstat -atunpe | egrep ":80|:443"
tcp        0    382 10.129.188.252:40651    78.140.186.7:80         ESTABELECIDA 1000       42953       2787/iceweasel 
tcp        0      0 10.129.188.252:58643    216.58.222.98:80        TIME_WAIT   0          0           -               
tcp        0      0 10.129.188.252:33183    172.217.28.131:80       TIME_WAIT   0          0           -               
tcp        0      0 10.129.188.252:43859    216.58.222.110:443      ESTABELECIDA 1000       43700       2787/iceweasel 
tcp        0      0 10.129.188.252:36012    97.107.142.88:80        TIME_WAIT   0          0           -               
tcp        0      0 10.129.188.252:56849    216.58.222.174:443      ESTABELECIDA 1000       43699       2787/iceweasel

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re:Erro ao dar Start no Apache
« Resposta #3 Online: 08 de Abril de 2016, 11:24 »
Vc instalou esse apache manualmente, ou veio dos repositórios?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline tsqueiroz

  • Usuário Ubuntu
  • *
  • Mensagens: 0
    • Ver perfil
Re:Erro ao dar Start no Apache
« Resposta #4 Online: 08 de Abril de 2016, 12:54 »
Desculpe-me a ignorância. Instalei utilizando os comandos via terminal.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re:Erro ao dar Start no Apache
« Resposta #5 Online: 08 de Abril de 2016, 14:05 »
Quais comandos via terminal?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline tsqueiroz

  • Usuário Ubuntu
  • *
  • Mensagens: 0
    • Ver perfil
Re:Erro ao dar Start no Apache
« Resposta #6 Online: 08 de Abril de 2016, 14:15 »
Meu nobre,

Devido a algumas mudanças que devem ser implementadas, resolvi começar a levantar o servidor do zero. De qualquer forma, muito obrigado pela atenção.

Se precisar peço ajuda novamente.


Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re:Erro ao dar Start no Apache
« Resposta #7 Online: 08 de Abril de 2016, 14:23 »
É Ubuntu Server, certo?
Sendo Ubuntu Server, a instalação vai te oferecer pra incluir o Apache durante a instalação. Aceite, é muito mais fácil.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline tsqueiroz

  • Usuário Ubuntu
  • *
  • Mensagens: 0
    • Ver perfil
Re:Erro ao dar Start no Apache
« Resposta #8 Online: 08 de Abril de 2016, 14:29 »
Não, eu estava com o Debian.

Talvez eu suba com o ubuntu e seguirei a dica.

Obrigado.


Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re:Erro ao dar Start no Apache
« Resposta #9 Online: 08 de Abril de 2016, 14:29 »
Nosso fórum é exclusivo para problemas com o Ubuntu.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D