Autor Tópico: drivers MSI  (Lida 23768 vezes)

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.552
    • Ver perfil
Re:drivers MSI
« Resposta #15 Online: 01 de Outubro de 2016, 13:33 »
Tendo o portátil  6 anos o kernel que tenho
Não deviria ser o problema destas teclas. Estou errado?

Mais ou menos, nem sempre é essa a lógica no mundo Linux.

Lembre-se que o desenvolvimento no Linux é feito por abnegados membros da comunidade de software, conforme se interessem por isso ou por aquilo. Se um determinado modelo é lançado no mercado e acaba ganhando grande projeção, aumenta a probabilidade de que algum desenvolvedor se interesse por ele e resolve algumas questões de drivers, mas enfim, nenhum sistema operacional funciona para a totalidade do parque de máquinas existentes no mundo, nem mesmo o Windows, que tem 85% do market share do segmento personal computer, e que obviamente os fabricante fazem computadores pensando no Windows (caso contrário iriam vender para quem?), mas aqui e acolá acaba existindo problemas.

Bem, isso são apenas divagações, vamos aos fatos.

1) Vejo aqui um uma fonte de software que pode ser interessante, precisa estudar o conteúdo (não fiz):

MSI Keyboard LED Controller

https://github.com/stevelacy/msi-keyboard

2) Acrescentar ou remover um kernel no Linux através de um arquivo binário .deb é coisa para 10 minutos de trabalho, se tanto, não há efeitos colaterais, não funcionou para o que se quer, basta remover, não estraga nada, não altera nada.


« Última modificação: 01 de Outubro de 2016, 13:37 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline luis lopes

  • Usuário Ubuntu
  • *
  • Mensagens: 57
    • Ver perfil
Re:drivers MSI
« Resposta #16 Online: 01 de Outubro de 2016, 16:13 »
obg
vou analizar esse link, e depois pensar em colocar o ultimo kernel a ver?...

Offline luis lopes

  • Usuário Ubuntu
  • *
  • Mensagens: 57
    • Ver perfil
Re:drivers MSI
« Resposta #17 Online: 01 de Outubro de 2016, 16:26 »
fiz o download da pasta zip.
abri e fiquei á toa... não percebi nada....

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.552
    • Ver perfil
Re:drivers MSI
« Resposta #18 Online: 01 de Outubro de 2016, 18:03 »
fiz o download da pasta zip.
abri e fiquei á toa... não percebi nada....

Desculpe, não entendi, que pasta zip?
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline luis lopes

  • Usuário Ubuntu
  • *
  • Mensagens: 57
    • Ver perfil
Re:drivers MSI
« Resposta #19 Online: 01 de Outubro de 2016, 18:21 »
do link que envias-te,
tinha a opcão de download...
não percebi lá muito bem de como se fazia...
entendi que se colocava o programa nodejs e pouco mais...
isto não é o meu forte, desculpa.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.552
    • Ver perfil
Re:drivers MSI
« Resposta #20 Online: 01 de Outubro de 2016, 18:34 »
Em rápida vista, muito interessante essa solução proposta pelo /stevelacy/ nesse link do github.

Não sei dizer se isso se aplicaria de fato ao modelo de teclado que você tem aí, pois ele menciona na descrição o hardware com MSI GE, GT Steelseries Keyboard, porém a série do seu parece ser GX, não conheço esse hardware para avaliar se há similaridade e se seria efetivo e nem tenho como testar, mas só vai descobrir se estudar a lógica desenvolvida e tentar aplicar.

Na essência, o que há lá é uma rotina em JavaScript utilizada pelo node.js, que é um interpretador de código JavaScript.

Observe que ele está dizendo que testou no Ubuntu 16.04 (além do Debian 8 e Arch Linux).

Confirmed Systems

OS: Ubuntu 16.04
Kernel: 4.4.14
Node: v6
libusb v0.1.12

A biblioteca libusb-dev está de acordo, a versão que está no Ubuntu 16.04.1 é mesmo a 0.1.12-28, confere aí se no Mint Cinnamon aí instalado também está dessa forma.

Código: [Selecionar]
apt-cache policy libusb-dev
Entretanto o Node no repositório universe está na versão 4.2.6 e não na 6 que ele menciona, embora lá no Information na página esteja dito que a Node Version basta ser >= 0.4, então dá para arriscar inicialmente com os recursos da própria distribuição, antes de ir buscar o pacote no site do nodejs.org. Igualmente confira aí no Mint a versão que tem instalada do nodejs

Código: [Selecionar]
apt-cache policy nodejs
Existe claramente duas formas de implementar aquilo, uma é a que ele descreve na própria página e a outra e onde ele referencia um link dessa forma:

Use it as command line:

https://github.com/Kwaadpepper/msi-keyboard-CLI

Bem, em princípio, parece mais simples ir inicialmente por aí, tentando por CLI (cli é command line interface, isto é, linha de comando)

« Última modificação: 01 de Outubro de 2016, 18:36 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.552
    • Ver perfil
Re:drivers MSI
« Resposta #21 Online: 01 de Outubro de 2016, 18:42 »
Então, seguindo aquele link, estamos do github numa págia do / Kwaadpepper/, que desenvolveu uma solução em CLI, o que ele fez foi um script, implementando a solução proposta pelo /stevelacy/.

Pelo que dá pra ver serão necessários os seguintes recuros:

Código: [Selecionar]
sudo apt install libusb-dev
Código: [Selecionar]
sudo apt install nodejs
Código: [Selecionar]
sudo apt install npm
Código: [Selecionar]
sudo apt install git
Parece que isso seja suficiente, em todo caso se aparecer mais algum requerimento, instale também.

www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.552
    • Ver perfil
Re:drivers MSI
« Resposta #22 Online: 01 de Outubro de 2016, 18:48 »
Ao depois, feitas as intalações retro da infraestrutura necessária, veja o bloco "Installation (in short)"

A primeira linha não precisa, porque já fizemos aí acima.

Em seguida ele propõe:
Código: [Selecionar]
sudo ln -s `which nodejs` /usr/bin/node
Código: [Selecionar]
git clone https://github.com/Kwaadpepper/msi-keyboard-CLI.git ~/.msi-klm
Código: [Selecionar]
cd ~/.msi-klm
Código: [Selecionar]
npm install
Aqui já é rodar a solução propriamente dita, de uma forma ou de outra.

msibacklight -k on

ou

sudo nodejs msi-keyboard-CLI.js -k on

Na verdade se estiver dentro do diretório criado ~/.msi-klm e fizer um ls vai ver o script lá presente.

Então, como se trata de um script em bash, também deveria ser possível executar fazendo:

./msibacklight

Talvez adicionando algum parâmetro (ele diz que é o -k on, mas não olhei direito isso)

De qualquer forma, se executo aqui obtenho um erro porque não tenho o hardware:

Error: cannot open device with vendor id 0x1770 and product id 0xff00
etc, etc...

Digamos que você, que tem o hardware, obtenha um erro semelhante, bem então precisa analisar o código fonte e no seu equipamento tentar identificar o product id correto do seu caso, talvez funcione.

Agora precisaria de um pouco mais de tempo para estudar isso melhor, mas sempre há a insuperável dificuldade de que não tenho o hardware para ver se isso ou aquilo funciona, em todo caso mais tarde tentarei olhar isso com mais vagar.
« Última modificação: 01 de Outubro de 2016, 18:58 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline luis lopes

  • Usuário Ubuntu
  • *
  • Mensagens: 57
    • Ver perfil
Re:drivers MSI
« Resposta #23 Online: 01 de Outubro de 2016, 18:50 »
ibusb-dev:
  Instalado: (nenhum)
  Candidato: 2:0.1.12-28
  Tabela de Versão:
     2:0.1.12-28 500
        500 http://ubuntu.dcc.fc.up.pt xenial/main amd64 Packages

vou continuar a tua leitura...

Offline luis lopes

  • Usuário Ubuntu
  • *
  • Mensagens: 57
    • Ver perfil
Re:drivers MSI
« Resposta #24 Online: 01 de Outubro de 2016, 18:58 »
bem no segundo deu erro
The following additional packages will be installed:
  libuv1
Serão instalados os seguintes NOVOS pacotes:
  libuv1 nodejs
0 pacotes actualizados, 2 pacotes novos instalados, 0 a remover e 17 não actualizados.
É necessário obter 3161 kB/3218 kB de arquivos.
Após esta operação, serão utilizados 13,4 MB adicionais de espaço em disco.
Deseja continuar? [S/n] s
Err:1 http://ubuntu.dcc.fc.up.pt xenial-updates/universe amd64 nodejs amd64 4.2.6~dfsg-1ubuntu4.1
  404  Not Found
E: Falhou obter http://ubuntu.dcc.fc.up.pt/pool/universe/n/nodejs/nodejs_4.2.6~dfsg-1ubuntu4.1_amd64.deb  404  Not Found

E: Não foi possível obter alguns arquivos, tente talvez correr apt-get update ou tente com --fix-missing?

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.552
    • Ver perfil
Re:drivers MSI
« Resposta #25 Online: 01 de Outubro de 2016, 19:11 »
Aí já é outra coisa, comece verificando se os repositórios padrão do Ubuntu estão habilitados no Mint Cinnamon e depois force uma atualização geral do sistema.

Para ver os repositórios:

Código: [Selecionar]
sudo software-properties-gtk
ou antão vai pelo modo gráfico mesmo que é igualmente fácil Configurações do Sistema/Programas e Atualizações

Depois use o recurso normal do sistema para atualizar tudo (em algum canto aí tem um ícone para isso).

Finalmente confirme se tudo está atualizado fazendo:

Código: [Selecionar]
sudo apt update
Código: [Selecionar]
sudo apt upgrade
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline luis lopes

  • Usuário Ubuntu
  • *
  • Mensagens: 57
    • Ver perfil
Re:drivers MSI
« Resposta #26 Online: 01 de Outubro de 2016, 19:24 »
isto está uma dor de cabeca....
nos repositorios não tenho nada.
e já tinha actualizado tudo.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.552
    • Ver perfil
Re:drivers MSI
« Resposta #27 Online: 01 de Outubro de 2016, 19:42 »
Só agora vi que seu sistema está usando um repositório local, experimente trocar para o servidor principal.

Veja que numa instalação do Ubuntu padrão 16.04.1 (=Unity) segui exatamente aqueles passos e tudo se instalou sem nenhuma dificuldade.

Entretanto, no seu caso é o Mint Cinnamon, então não tenho como verificar.

Editando:

Na janela "Administration/Software Sources" use o botao "Restore the default setting"
« Última modificação: 01 de Outubro de 2016, 22:41 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.552
    • Ver perfil
Re:drivers MSI
« Resposta #28 Online: 01 de Outubro de 2016, 19:59 »
Muito curioso isso, subi aqui um live-iso do Mint Mate 16.04.1 e tambem nao consegui instalar, entretanto, em seguida subi um live-iso do Ubuntu 16.04.1 padrao e tudo se instalou facilmente.  >:(

Vou tentar apurar melhor o que possa estar ocorrendo, eh algo com os repositorios que o Mint estah buscando.

Editando:

Agora conseguiu fazer tambem no live-iso do Mate.
Nao estava encontrando esse servidor:

E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/g/gcc-5/libstdc++-5-dev_5.4.0-6ubuntu1~16.04.1_amd64.deb  404  Not Found [IP: 91.189.88.162 80]

mas o apt update resolveu.

Deu certo de novo, instalou tudo.  :-[

Na execucao soh funciona fazendo:

sudo nodejs msi-keyboard-CLI.js -k on

Resulta um erro dessa forma:

/home/ubuntu-mate/.msi-klm/node_modules/node-hid/nodehid.js:28
   this._raw = new (Function.prototype.bind.apply(binding.HID,
               ^

Error: cannot open device with vendor id 0x1770 and product id 0xff00
    at Error (native)
    at new HID (/home/ubuntu-mate/.msi-klm/node_modules/node-hid/nodehid.js:28:14)
    at module.exports (/home/ubuntu-mate/.msi-klm/node_modules/msi-keyboard/lib/findKeyboard.js:7:14)
    at Object.<anonymous> (/home/ubuntu-mate/.msi-klm/msi-keyboard-CLI.js:37:40)
    at Module._compile (module.js:410:26)
    at Object.Module._extensions..js (module.js:417:10)
    at Module.load (module.js:344:32)
    at Function.Module._load (module.js:301:12)
    at Function.Module.runMain (module.js:442:10)
    at startup (node.js:136:18)


ou estando dentro do diretorio ~/.msi-klm chamando o script diretamente (ponto-barra-nome_script):

./msibacklight -k on

Nao conclui, precisa cortar a execucao com Ctrl C, mas resulta um erro dessa forma:

Resulta um erro dessa forma:

/home/ubuntu-mate/.msi-klm/node_modules/node-hid/nodehid.js:28
   this._raw = new (Function.prototype.bind.apply(binding.HID,
               ^

Error: cannot open device with vendor id 0x1770 and product id 0xff00
    at Error (native)
    at new HID (/home/ubuntu-mate/.msi-klm/node_modules/node-hid/nodehid.js:28:14)
    at module.exports (/home/ubuntu-mate/.msi-klm/node_modules/msi-keyboard/lib/findKeyboard.js:7:14)
    at Object.<anonymous> (/home/ubuntu-mate/.msi-klm/msi-keyboard-CLI.js:37:40)
    at Module._compile (module.js:410:26)
    at Object.Module._extensions..js (module.js:417:10)
    at Module.load (module.js:344:32)
    at Function.Module._load (module.js:301:12)
    at Function.Module.runMain (module.js:442:10)
    at startup (node.js:136:18)

Como nao ha de fato o hardware, nao haveria como executar mesmo.

« Última modificação: 01 de Outubro de 2016, 20:34 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.552
    • Ver perfil
Re:drivers MSI
« Resposta #29 Online: 01 de Outubro de 2016, 22:24 »
Pois entao,  /luis lopes/,

Baixei aqui e subi um live-iso do Mint Cinnamon:

mint@mint ~ $ lsb_release -rd
Description:   Linux Mint 18 Sarah
Release:   18


mint@mint ~ $ inxi -FxZ
System:    Host: mint Kernel: 4.4.0-21-generic x86_64 (64 bit gcc: 5.3.1)
           Desktop: Cinnamon 3.0.6 (Gtk 3.18.9-1ubuntu3)
           Distro: Linux Mint 18 Sarah

Consegui nele instalar todo o procedimento proposto.

Apresentou o seguinte erro na instalacao do libusb-dev

Processing triggers for man-db (2.7.5-1) ...
Processing triggers for doc-base (0.10.7) ...
Processing 35 changed doc-base files, 1 added doc-base file...
Error in `/usr/share/doc-base/xapian-python3-docs', line 9: all `Format' sections are invalid.
Note: `install-docs --verbose --check file_name' may give more details about the above error.
Registering documents with scrollkeeper...

Toquei em frente assim mesmo, pois se trata de erro nao essencial, relativo a documentacao.

O fato eh que no final instalou tudo e conseguiu executar o script.

Os repositorios nele (Administration/Software Sources) sao aqueles que vem por padrao no live-iso, nao alterei nada:

Main (sarah) http://packages.linuxmint.com

Base (xenial) http://archive.ubuntu.com/ubuntu

O que no live-iso originalmente corresponde ao /etc/sources.list que rastreia apenas o cdrom:

mint@mint /etc/apt $ cat sources.list
#/etc/apt/sources.list

deb cdrom:[Linux Mint 18 _Sarah_ - Release amd64 20160628]/ xenial contrib main non-free

E no diretorio de configuracao adicional do apt consta:

mint@mint /etc/apt/sources.list.d $ ls
official-package-repositories.list

Essa lista dita "official" contem:

mint@mint /etc/apt/sources.list.d $ cat official-package-repositories.list
deb http://packages.linuxmint.com sarah main upstream import backport

deb http://archive.ubuntu.com/ubuntu xenial main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu xenial-updates main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu xenial-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu/ xenial-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ xenial partner

Compare com o que voce tem instalado ai nos respectivos arquivos de configuracao das souces.list

« Última modificação: 01 de Outubro de 2016, 22:44 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.