Autor Tópico: Não consigo instalar esse programa "PonyProg" no Mate 17.04  (Lida 1138 vezes)

Offline Jose Emilio

  • Usuário Ubuntu
  • *
  • Mensagens: 210
  • Além da Imaginação
    • Ver perfil
Não consigo instalar esse programa "PonyProg" no Mate 17.04
« Online: 14 de Novembro de 2017, 18:01 »
Descompactei o tar-gz  e estou meio perdido aqui.

tentei um duplo click nos arquivos .sh e tbm tentei no terminal,  mas fica dando erro.
Não quero arriscar muito para não fazer mais besteiras, rsrsrs

vejam  a pasta :
root@oficina-System-Product-Name:/home/oficina/Downloads/ponyprog# ls
astyle.sh       create_deb_package.sh    desktop       LICENSE
build           create_elf_binary.sh     distribution  ponyprog.pro
build-deb       create_exe_binary.bat    doxygen       qhexedit2
cmake           create_inno_package.bat  HISTORY       README
CMakeLists.txt  create_nsis_package.bat  icons         SrcPony
copyright       create_rpm_package.sh    INSTALL
cppcheck.sh     create_src_tar.sh        lang
root@oficina-System-Product-Name:/home/oficina/Downloads/ponyprog# ls -l
total 140
-rwxrwxr-x 1 oficina oficina  1144 Out 14 21:37 astyle.sh
drwxr-xr-x 3 root    root     4096 Nov 14 17:43 build
drwxr-xr-x 3 root    root     4096 Nov 14 17:41 build-deb
drwxr-xr-x 2 oficina oficina  4096 Out 14 21:37 cmake
-rw-rw-r-- 1 oficina oficina 11233 Out 14 21:37 CMakeLists.txt
-rw-rw-r-- 1 oficina oficina   133 Out 14 21:37 copyright
-rwxrwxr-x 1 oficina oficina   412 Out 14 21:37 cppcheck.sh
-rwxrwxr-x 1 oficina oficina  1393 Out 14 21:37 create_deb_package.sh
-rwxrwxr-x 1 oficina oficina   547 Out 14 21:37 create_elf_binary.sh
-rw-rw-r-- 1 oficina oficina   707 Out 14 21:37 create_exe_binary.bat
-rw-rw-r-- 1 oficina oficina   742 Out 14 21:37 create_inno_package.bat
-rw-rw-r-- 1 oficina oficina   742 Out 14 21:37 create_nsis_package.bat
-rwxrwxr-x 1 oficina oficina   751 Out 14 21:37 create_rpm_package.sh
-rwxrwxr-x 1 oficina oficina   650 Out 14 21:37 create_src_tar.sh
drwxr-xr-x 2 oficina oficina  4096 Out 14 21:37 desktop
drwxr-xr-x 7 oficina oficina  4096 Out 14 21:37 distribution
drwxr-xr-x 2 oficina oficina  4096 Out 14 21:37 doxygen
-rw-rw-r-- 1 oficina oficina    59 Out 14 21:37 HISTORY
drwxr-xr-x 2 oficina oficina  4096 Out 14 21:37 icons
-rw-rw-r-- 1 oficina oficina  1701 Out 14 21:37 INSTALL
drwxr-xr-x 2 oficina oficina  4096 Out 14 21:37 lang
-rw-rw-r-- 1 oficina oficina 17982 Out 14 21:37 LICENSE
-rw-rw-r-- 1 oficina oficina 12295 Out 14 21:37 ponyprog.pro
drwxr-xr-x 7 oficina oficina  4096 Out 14 21:37 qhexedit2
-rw-rw-r-- 1 oficina oficina   230 Out 14 21:37 README
drwxr-xr-x 4 oficina oficina  4096 Out 14 21:37 SrcPony
root@oficina-System-Product-Name:/home/oficina/Downloads/ponyprog#

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.555
    • Ver perfil
Re:Não consigo instalar esse programa "PonyProg" no Mate 17.04
« Resposta #1 Online: 14 de Novembro de 2017, 22:41 »
Então, @Jose Emilio,

No Mate 17.04 não tenho como testar, porque não tenho instalado, além do que a versão 17.04, que é uma versão transitória, na prática já era.

Usando o Ubuntu 17.10 Artful padrão (Gnome), com X11 (não testei com Wayland) a compilação do código fonte baixado deu erro, porém consegui instalar a partir de um pacote deb baixado daqui, originalmente para o Ubuntu 16.04, mas funcionou também no 17.10

PonyProg: serial device programmer

https://sourceforge.net/projects/ponyprog/files/Ubuntu16.04/

Vai baixar o arquivo:

ponyprog-3.0.0-ubuntu16.04-amd64.deb

Depois é a forma padrão para instalar:

Código: [Selecionar]
sudo dpkg -i ponyprog-3.0.0-ubuntu16.04-amd64.deb
Como irá dar erro na instalação, então precisa fazer:

Código: [Selecionar]
sudo apt-get install -f
repita para confirmar:

Código: [Selecionar]
sudo dpkg -i ponyprog-3.0.0-ubuntu16.04-amd64.deb
Dessa vez deve terminar corretamente.

Instalado aparece assim:

ponyprog:
  Installed: 3.0.0
  Candidate: 3.0.0
  Version table:
 *** 3.0.0 100
        100 /var/lib/dpkg/status

Experimenta aí, há uma boa possibilidade de que também funcione no praticamente extinto Mate 17.04.








« Última modificação: 14 de Novembro de 2017, 22:47 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.555
    • Ver perfil
Re:Não consigo instalar esse programa "PonyProg" no Mate 17.04
« Resposta #2 Online: 15 de Novembro de 2017, 00:37 »
Em complemento: como teste, instalei também num Ubuntu 17.04 padrão (=Unity) bem como num Mate 16.04.3, em ambos instalou e funcionou de primeira, sequer precisou fazer aquele segundo comando de ajuste, bastou o primeiro de instalação e tudo certo e funcionando.

Acredito que vá funcionar também de primeira aí na sua instalação com o Mate 17.04
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Jose Emilio

  • Usuário Ubuntu
  • *
  • Mensagens: 210
  • Além da Imaginação
    • Ver perfil
Re:Não consigo instalar esse programa "PonyProg" no Mate 17.04
« Resposta #3 Online: 16 de Novembro de 2017, 13:30 »
 Druida,

sem chance,  tentei,  mas a minha arquitetura é i386

Estou tentando pelo Wine,   instalou,  mas não aparecem as portas seriais.

parece que é o ponyprog  ou o wine que não está enxergando as portas.

root@oficina-System-Product-Name:/home/oficina# cd /home/oficina/Downloads
root@oficina-System-Product-Name:/home/oficina/Downloads# sudo dpkg -i ponyprog-3.0.0-ubuntu16.04-amd64.deb
dpkg: erro ao processar o arquivo ponyprog-3.0.0-ubuntu16.04-amd64.deb (--install):
 arquitetura do pacote (amd64) não combina com a do sistema (i386)
Erros foram encontrados durante o processamento de:
 ponyprog-3.0.0-ubuntu16.04-amd64.deb

root@oficina-System-Product-Name:/home/oficina/Downloads# dmesg | grep tty
[    0.000000] console [tty0] enabled
[    0.957598] 00:07: ttyS0 at I/O 0x3f8 (irq = 4, base_baud = 115200) is a 16550A
root@oficina-System-Product-Name:/home/oficina/Downloads#


Eu já instalei esse programa em outra máquina no Mate adaptado em cima do Ubuntu Unity sem problemas.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.555
    • Ver perfil
Re:Não consigo instalar esse programa "PonyProg" no Mate 17.04
« Resposta #4 Online: 16 de Novembro de 2017, 14:09 »
sem chance,  tentei,  mas a minha arquitetura é i386

Não, aí não dá mesmo, o pacote deb é para 64-bit, como se vê no próprio nome do pacote amd64

Se é um trabalho específico que precisa fazer com o gravador de EEPROM PonyProg, não tem uma partição disponível nessa máquina onde possa instalar em dual boot outro Linux em 64-bit?

Não é interessante fazer essa espécie de trabalho através de emuladores (wine, virtualmachine), sempre é melhor máquina física, isto é, sem intermediários para acessar e gravar o hardware do dispositivo alvo.

Se conseguir abrir um espaço de uns 10GB já dá e sobra para instalar e fazer o serviço.

« Última modificação: 16 de Novembro de 2017, 14:11 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Jose Emilio

  • Usuário Ubuntu
  • *
  • Mensagens: 210
  • Além da Imaginação
    • Ver perfil
Re:Não consigo instalar esse programa "PonyProg" no Mate 17.04
« Resposta #5 Online: 23 de Novembro de 2017, 15:52 »
Druida,

Instalei o  64bits,  instalou certinho o Pony sem o Wine,  mas continua não reconhecendo a porta Serial.

Instalei o minicom   e modifiquei o /dev/tty8 para /dev/tty0

e ainda não reconhece as portas

Tem alguma outra opção no Minicom que possa ser alterada?     

OBS: peguei um HD vekho que eu tinha aqui e instalei o XP e  depois o Pony e a porta Serial foi reconhecida
sem mexer em nada.
Sinal que não tenho problema na placa mãe 
Mas eu não quero o ruindows,  É ruim ter que ficar conectando e desconectando  HD  toda hora.   

olha aí:                               
                                                                         
OPÇÕ+-----------------------------------------------------------------------+
Comp| A - Dispositivo Serial            : /dev/tty0                         |
Port| B - Localização do Arquivo de Travamento : /var/lock                  |
    | C - Programa de Entrada           :                                   |
Pres| D - Programa de Saída             :                                   |
    | E - Bps/Paridade/Bits             : 115200 8N1                        |
    | F - Controle de Fluxo por Hardware: Sim                               |
    | G - Controle de Fluxo por Software: Não                               |
    |                                                                       |
    |    Alterar qual configuração?                                         |
    +-----------------------------------------------------------------------+
            | Tela e teclado                           |                 
            | Salvar configuração como dfl             |                 
            | Salvar configuração como..               |                 
            | Sair                                     |                 
            +------------------------------------------+                 
                                                                         


Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.555
    • Ver perfil
Re:Não consigo instalar esse programa "PonyProg" no Mate 17.04
« Resposta #6 Online: 24 de Novembro de 2017, 12:54 »
Instalei o  64bits,  instalou certinho o Pony sem o Wine,  mas continua não reconhecendo a porta Serial.
Instalei o minicom   e modifiquei o /dev/tty8 para /dev/tty0
e ainda não reconhece as portas

Como é que o kernel identifica?

Traz aí:

Código: [Selecionar]
dmesg | grep tty


www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Jose Emilio

  • Usuário Ubuntu
  • *
  • Mensagens: 210
  • Além da Imaginação
    • Ver perfil
Re:Não consigo instalar esse programa "PonyProg" no Mate 17.04
« Resposta #7 Online: 24 de Novembro de 2017, 15:14 »
Aí vai >

root@oficina-System-Product-Name:/home/oficina# dmesg | grep tty
[    0.000000] console [tty0] enabled
[    1.533070] 00:07: ttyS0 at I/O 0x3f8 (irq = 4, base_baud = 115200) is a 16550A

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.555
    • Ver perfil
Re:Não consigo instalar esse programa "PonyProg" no Mate 17.04
« Resposta #8 Online: 25 de Novembro de 2017, 04:03 »
[    1.533070] 00:07: ttyS0 at I/O 0x3f8 (irq = 4, base_baud = 115200) is a 16550A

Então, @Jose Emilio,

Não parece existir problema em relação ao minicom, o kernel está identificando como ttyS0, que é o que interessa saber, então é só entrar com esse id no minicom.

Não entendi muito bem quando você disse "[...] modifiquei o /dev/tty8 para /dev/tty0"

O parâmetro de entrada no minicom é ttyS0 que é como o kernel identificou.

Se quero deixar configurado é fazer:

Código: [Selecionar]
sudo minicom -s
Depois usa a entrada "Serial port setup" e em "Change which setting?" a opção A - Serial Device deve ser alterado para ttyS0, dá um <enter> e utiliza "Save setup as dfl".

Isso na verdade é apenas para não ter que ficar configurando a cada vez que usa.

A forma direta de acessar, já sabendo o id, é fazendo:

Código: [Selecionar]
sudo minicom -D /dev/ttyS0
Dê uma olhada nesses dois textos, talvez possa ajudar:

Minicom

https://help.ubuntu.com/community/Minicom

Configurando equipamentos via porta serial com o Minicom

http://blog.welrbraga.eti.br/?p=2131

« Última modificação: 25 de Novembro de 2017, 04:06 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.