Autor Tópico: Internet ruim  (Lida 1215 vezes)

Offline paparoxo

  • Usuário Ubuntu
  • *
  • Mensagens: 10
    • Ver perfil
Internet ruim
« Online: 05 de Dezembro de 2017, 13:46 »
Olá, eu gostaria de uma ajuda, eu sempre utilizei minha internet com um roteador e estava tudo ok, só que agora eu estou usando conectada direto no modem utilizando dsl/pppoe, com isso a rede não está usando toda largura de banda para streaming e os downloads ficam muito lentos de qualquer servidor, eu já desativei o ipv6 e mudei o dns e o mtu e nada, o estranho é que eu testei em um notebook com windows 8 e estava tudo normal.
obrigado!

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.955
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Internet ruim
« Resposta #1 Online: 05 de Dezembro de 2017, 14:43 »
Olá @paparoxo, qual é o seu provedor de internet? Qual é a velocidade de conexão?
Já verificou se o cabo que utiliza pra se conectar ao modem está íntegro?

Execute os comandos abaixo com a conexão problemática e cole o resultado aqui.

sudo lshw -C network
ifconfig -a


(anote o nome da interface cabeada, que deve ser algo parecido com "enp2s0". Substitua esse nome no próximo comando)

sudo apt install ethtool
sudo ethtool enp2s0

route -n

ping -c 4 8.8.8.8
ping -c 4 www.google.com
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline paparoxo

  • Usuário Ubuntu
  • *
  • Mensagens: 10
    • Ver perfil
Re:Internet ruim
« Resposta #2 Online: 05 de Dezembro de 2017, 19:16 »
Obrigado pela resposta, eu ultilizo internet vivo 2mb, mas eu não acho que esse seja o problema porque quando eu uso a conexão no notebook com windows ou quando eu testei com um roteador ficou normal

Settings for enp0s7:
   Supported ports: [ MII ]
   Supported link modes:   10baseT/Half 10baseT/Full
                           100baseT/Half 100baseT/Full
   Supported pause frame use: No
   Supports auto-negotiation: Yes
   Advertised link modes:  10baseT/Half 10baseT/Full
                           100baseT/Half 100baseT/Full
   Advertised pause frame use: No
   Advertised auto-negotiation: Yes
   Speed: 100Mb/s
   Duplex: Full
   Port: MII
   PHYAD: 1
   Transceiver: external
   Auto-negotiation: on
   Supports Wake-on: g
   Wake-on: d
   Link detected: yes

ping -c 4 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=2 ttl=60 time=33.2 ms
64 bytes from 8.8.8.8: icmp_seq=4 ttl=60 time=33.6 ms

--- 8.8.8.8 ping statistics ---
4 packets transmitted, 2 received, 50% packet loss, time 3042ms
rtt min/avg/max/mdev = 33.249/33.471/33.694/0.288 ms

ping -c3 www.google.com
PING www.google.com (172.217.28.196) 56(84) bytes of data.
64 bytes from eze03s30-in-f4.1e100.net (172.217.28.196): icmp_seq=1 ttl=57 time=61.1 ms
64 bytes from eze03s30-in-f4.1e100.net (172.217.28.196): icmp_seq=2 ttl=57 time=61.6 ms
64 bytes from eze03s30-in-f4.1e100.net (172.217.28.196): icmp_seq=3 ttl=57 time=61.6 ms

--- www.google.com ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2003ms
rtt min/avg/max/mdev = 61.172/61.492/61.689/0.366 ms


Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.955
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Internet ruim
« Resposta #3 Online: 05 de Dezembro de 2017, 19:52 »
Obrigado pela resposta, eu ultilizo internet vivo 2mb, mas eu não acho que esse seja o problema porque quando eu uso a conexão no notebook com windows ou quando eu testei com um roteador ficou normal
Saber a velocidade da conexão é importante, pois dependendo do valor alguns problemas podem surgir (ou não). No seu caso, como a conexão é de menos de 10Mbps, já dá pra descartar alguns problemas com o cabo.

Citar
Settings for enp0s7:
   Supported ports: [ MII ]
   Supported link modes:   10baseT/Half 10baseT/Full
                           100baseT/Half 100baseT/Full
   Supported pause frame use: No
   Supports auto-negotiation: Yes
   Advertised link modes:  10baseT/Half 10baseT/Full
                           100baseT/Half 100baseT/Full
   Advertised pause frame use: No
   Advertised auto-negotiation: Yes
   Speed: 100Mb/s
   Duplex: Full
   Port: MII
   PHYAD: 1
   Transceiver: external
   Auto-negotiation: on
   Supports Wake-on: g
   Wake-on: d
   Link detected: yes

ping -c 4 8.8.8.8
PING 8.8.8.8 (8.8.8.8 ) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=2 ttl=60 time=33.2 ms
64 bytes from 8.8.8.8: icmp_seq=4 ttl=60 time=33.6 ms

--- 8.8.8.8 ping statistics ---
4 packets transmitted, 2 received, 50% packet loss, time 3042ms
rtt min/avg/max/mdev = 33.249/33.471/33.694/0.288 ms

ping -c3 www.google.com
PING www.google.com (172.217.28.196) 56(84) bytes of data.
64 bytes from eze03s30-in-f4.1e100.net (172.217.28.196): icmp_seq=1 ttl=57 time=61.1 ms
64 bytes from eze03s30-in-f4.1e100.net (172.217.28.196): icmp_seq=2 ttl=57 time=61.6 ms
64 bytes from eze03s30-in-f4.1e100.net (172.217.28.196): icmp_seq=3 ttl=57 time=61.6 ms

--- www.google.com ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2003ms
rtt min/avg/max/mdev = 61.172/61.492/61.689/0.366 ms

Eu pedi mais alguns comandos (lshw, ifconfig, route -n). Você os executou? Preciso da saída deles também.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline paparoxo

  • Usuário Ubuntu
  • *
  • Mensagens: 10
    • Ver perfil
Re:Internet ruim
« Resposta #4 Online: 06 de Dezembro de 2017, 06:44 »
Obrigado de novo , o comando lshw -C network não esta mostrando nada.

ifconfig -a
enp0s7    Link encap:Ethernet  Endereço de HW xxxxxxxx
          endereço inet6: fe80::2ec3:6f2f:a292:a31a/64 Escopo:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Métrica:1
          pacotes RX:6080 erros:98 descartados:0 excesso:1 quadro:96
          Pacotes TX:6158 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:4346757 (4.3 MB) TX bytes:740898 (740.8 KB)

lo        Link encap:Loopback Local 
          inet end.: 127.0.0.1  Masc:255.0.0.0
          UP LOOPBACK RUNNING  MTU:65536  Métrica:1
          pacotes RX:1715 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:1715 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1
          RX bytes:171041 (171.0 KB) TX bytes:171041 (171.0 KB)

ppp0      Link encap:Protocolo Ponto-a-Ponto 
          inet end.: 179.228.146.9  P-a-P:187.100.231.16  Masc:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Métrica:1
          pacotes RX:5920 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:5979 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:3
          RX bytes:4206497 (4.2 MB) TX bytes:601178 (601.1 KB)

route -n
Tabela de Roteamento IP do Kernel
Destino         Roteador        MáscaraGen.    Opções Métrica Ref   Uso Iface
0.0.0.0         187.100.231.16  0.0.0.0         UG    100    0        0 ppp0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 ppp0
187.100.231.16  0.0.0.0         255.255.255.255 UH    100    0        0 ppp0
« Última modificação: 06 de Dezembro de 2017, 09:09 por paparoxo »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.955
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Internet ruim
« Resposta #5 Online: 06 de Dezembro de 2017, 11:01 »
Mais alguns comandos.

ping -c 10 187.100.231.16

ping -c 10 8.8.8.8

tracepath -n 8.8.8.8
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline paparoxo

  • Usuário Ubuntu
  • *
  • Mensagens: 10
    • Ver perfil
Re:Internet ruim
« Resposta #6 Online: 06 de Dezembro de 2017, 19:17 »
ping -c 10 187.100.231.16
PING 187.100.231.16 (187.100.231.16) 56(84) bytes of data.

--- 187.100.231.16 ping statistics ---
10 packets transmitted, 0 received, 100% packet loss, time 9068ms

and@and-desktop:~$ ping -c 10 187.100.231.16
PING 187.100.231.16 (187.100.231.16) 56(84) bytes of data.

--- 187.100.231.16 ping statistics ---
10 packets transmitted, 0 received, 100% packet loss, time 9078ms


 ping -c 10 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=2 ttl=60 time=33.0 ms
64 bytes from 8.8.8.8: icmp_seq=5 ttl=60 time=33.9 ms
64 bytes from 8.8.8.8: icmp_seq=6 ttl=60 time=33.0 ms
64 bytes from 8.8.8.8: icmp_seq=7 ttl=60 time=33.3 ms
64 bytes from 8.8.8.8: icmp_seq=8 ttl=60 time=32.9 ms
64 bytes from 8.8.8.8: icmp_seq=9 ttl=60 time=34.7 ms
64 bytes from 8.8.8.8: icmp_seq=10 ttl=60 time=33.6 ms

--- 8.8.8.8 ping statistics ---
10 packets transmitted, 7 received, 30% packet loss, time 9045ms
rtt min/avg/max/mdev = 32.989/33.550/34.746/0.633 ms



 tracepath -n 8.8.8.8
 1?: [LOCALHOST]                                         pmtu 1492
 1:  no reply
 2:  187.100.178.238                                      65.553ms
 3:  187.100.186.172                                      65.077ms
 4:  187.100.35.9                                         65.213ms
 5:  no reply
 6:  no reply
 7:  no reply
 8:  no reply
 9:  no reply
10:  no reply
11:  no reply
12:  no reply
13:  no reply
14:  no reply
15:  no reply
16:  no reply
17:  no reply
18:  no reply
19:  no reply
20:  no reply
21:  no reply
22:  no reply
23:  no reply
24:  no reply
25:  no reply
26:  no reply
27:  no reply
28:  no reply
29:  no reply
30:  no reply
     Too many hops: pmtu 1492
     Resume: pmtu 1492

ta ai, obrigado!

« Última modificação: 06 de Dezembro de 2017, 19:19 por paparoxo »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.955
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Internet ruim
« Resposta #7 Online: 06 de Dezembro de 2017, 22:28 »
Essas perdas que a gente percebe quando testa o ping do DNS do google podem ser a origem da lentidão que você sente, se estiverem ocorrendo pra todos os destinos.

Eu só não consigo determinar pelas saídas que tivemos até agora se o problema é local ou remoto.

Diga uma coisa, quando você desativou o roteador, você aproveitou os mesmos cabos? Aliás, pq você desativou o roteador?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline paparoxo

  • Usuário Ubuntu
  • *
  • Mensagens: 10
    • Ver perfil
Re:Internet ruim
« Resposta #8 Online: 07 de Dezembro de 2017, 11:36 »
Sim são os mesmos cabos, o roteador ficou com meu irmão porque ele usa um notebook, e como a distância é meio grande, se eu usasse no meu pc a internet dele fica meio lenta, por exemplo hoje eu fui atualizar o Ubuntu usando o modem e a taxa de download ficava no 30, 40 kbps e não subia, dai eu testei com o roteador e ficou tudo normal, estranho.
Você recomendaria eu comprar um roteador, não teria nenhuma configuração que eu poderia fazer ligando direto no modem?

e obrigado de novo.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.955
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Internet ruim
« Resposta #9 Online: 07 de Dezembro de 2017, 14:18 »
O roteador foi pro seu irmão... mas ele continua conectado no mesmo modem???
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline paparoxo

  • Usuário Ubuntu
  • *
  • Mensagens: 10
    • Ver perfil
Re:Internet ruim
« Resposta #10 Online: 07 de Dezembro de 2017, 15:39 »
Sim, eu tinha dois cabos ethernet ligados um  no modem e roteador e o outro no meu pc e o roteador, mas o cabo que ligava meu pc no roteador deu problema, dai eu tive que ligar o pc direto no modem, porque a distância é grande eu não queria comprar outro cabo de 20 metros mais ou menos,  resumindo ele ficou com o roteador ligado no modem e quando eu vou entrar na internet eu uso outro cabo e ligo direto,  entendeu mais ou menos?
« Última modificação: 07 de Dezembro de 2017, 15:41 por paparoxo »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.955
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Internet ruim
« Resposta #11 Online: 07 de Dezembro de 2017, 16:11 »
Qual é a marca e modelo desse modem, mesmo?...

E explica outra coisa melhor pra mim: os dois ficam conectados ao modem ao mesmo tempo? Ou vc desconecta o cabo dele, e conecta o seu, no lugar?
« Última modificação: 07 de Dezembro de 2017, 16:24 por zekkerj »
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline paparoxo

  • Usuário Ubuntu
  • *
  • Mensagens: 10
    • Ver perfil
Re:Internet ruim
« Resposta #12 Online: 07 de Dezembro de 2017, 16:51 »
Huawei SmartAX MT880.
Eu desconecto o dele e conecto o meu.
« Última modificação: 07 de Dezembro de 2017, 17:01 por paparoxo »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.955
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Internet ruim
« Resposta #13 Online: 07 de Dezembro de 2017, 17:04 »
Esse modem só tem uma porta ethernet. Estou supondo que quando você quer conectar, você desconecta seu irmão, certo?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline paparoxo

  • Usuário Ubuntu
  • *
  • Mensagens: 10
    • Ver perfil
Re:Internet ruim
« Resposta #14 Online: 07 de Dezembro de 2017, 17:07 »
isso mesmo.