Autor Tópico: Numlock  (Lida 979 vezes)

Offline Nelson Quintanilha

  • Usuário Ubuntu
  • *
  • Mensagens: 520
  • "O mundo não deve ter fronteiras, mas horizontes."
    • Ver perfil
Numlock
« Online: 15 de MAR?O de 2018, 18:36 »
Olá colegas,
alguém sabe como fazer o Numlock funcionar na inicialização Ubuntu 17.10?
Obrigado

Offline jrkamil

  • Usuário Ubuntu
  • *
  • Mensagens: 412
  • Cabo Frio - RJ - Brasil
    • Ver perfil
Re:Numlock
« Resposta #1 Online: 16 de MAR?O de 2018, 08:42 »
ECS A890GXM-A , Athlon II X3 440, 8 Gb DDR3, nvidia GF 8400GS,  ubuntu  18.04  gnome, ssd 120G, hd 500 g

Offline Nelson Quintanilha

  • Usuário Ubuntu
  • *
  • Mensagens: 520
  • "O mundo não deve ter fronteiras, mas horizontes."
    • Ver perfil
Re:Numlock
« Resposta #2 Online: 16 de MAR?O de 2018, 22:03 »
Já tentei, mas quando dou o segundo comando:
sudo gedit /usr/share/lightdm/lightdm.conf.d/50-unity-greeter.conf
Ele retorna:
[sudo] senha para nelson:
No protocol specified
Unable to init server: Não foi possível conectar: Conexão recusada
(gedit:24520): Gtk-WARNING **: cannot open display: :0

Offline jrkamil

  • Usuário Ubuntu
  • *
  • Mensagens: 412
  • Cabo Frio - RJ - Brasil
    • Ver perfil
Re:Numlock
« Resposta #3 Online: 19 de MAR?O de 2018, 08:15 »
o gedit está instalado ?

sudo apt-get install gedit
ECS A890GXM-A , Athlon II X3 440, 8 Gb DDR3, nvidia GF 8400GS,  ubuntu  18.04  gnome, ssd 120G, hd 500 g

Offline Nelson Quintanilha

  • Usuário Ubuntu
  • *
  • Mensagens: 520
  • "O mundo não deve ter fronteiras, mas horizontes."
    • Ver perfil
Re:Numlock
« Resposta #4 Online: 19 de MAR?O de 2018, 20:44 »
sudo apt-get install gedit
[sudo] senha para nelson:
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
gedit is already the newest version (3.22.1-1ubuntu1).
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.

Já estava instalado!

Offline jrkamil

  • Usuário Ubuntu
  • *
  • Mensagens: 412
  • Cabo Frio - RJ - Brasil
    • Ver perfil
Re:Numlock
« Resposta #5 Online: 21 de MAR?O de 2018, 09:47 »
OOPs , no meu 17.10 ele já ficou ativo na instalação. tá usando xorg ou wayland ? aqui estou com o xorg. com o wayland tem que configurar para rodar sudo. Troca para xorg. Inclusive o 18.04 já vem com ele por default novamente.

 https://imgur.com/a/dXxr3
« Última modificação: 21 de MAR?O de 2018, 14:37 por jrkamil »
ECS A890GXM-A , Athlon II X3 440, 8 Gb DDR3, nvidia GF 8400GS,  ubuntu  18.04  gnome, ssd 120G, hd 500 g

Offline Nelson Quintanilha

  • Usuário Ubuntu
  • *
  • Mensagens: 520
  • "O mundo não deve ter fronteiras, mas horizontes."
    • Ver perfil
Re:Numlock
« Resposta #6 Online: 21 de MAR?O de 2018, 23:11 »
Olá,
Troquei para o xorg, mas quando chamo o gedit com o comando:
sudo gedit /usr/share/lightdm/lightdm.conf.d/50-unity-greeter.conf
Ele abre o arquivo completamente vazio.
Salvei a seguinte linha nele: greeter-setup-script=/usr/bin/numlockx on
Dei boot no note e nada do numlock funcionar.

Offline DidBrother

  • Usuário Ubuntu
  • *
  • Mensagens: 50
  • Avante. sempre em frente
    • Ver perfil
Re:Numlock
« Resposta #7 Online: 22 de MAR?O de 2018, 09:31 »
Olá,
Troquei para o xorg, mas quando chamo o gedit com o comando:
sudo gedit /usr/share/lightdm/lightdm.conf.d/50-unity-greeter.conf
Ele abre o arquivo completamente vazio.
Salvei a seguinte linha nele: greeter-setup-script=/usr/bin/numlockx on
Dei boot no note e nada do numlock funcionar.


No meu ubuntu 16.04 o arquivo  modificado  foi o    /usr/share/lightdm/lightdm.conf.d/60-lightdm-gtk-greeter.conf    cujo contéudo atual é o seguinte :

[Seat:*]
greeter-session=lightdm-gtk-greeter
greeter-setup-script=/usr/bin/numlockx on



Usando um explorador de arquivos  navegue até a pasta  /usr/share/lightdm/lightdm.conf.d/ e verifique os arquivos dentro da pasta.    possivelmente a modificação se dará no mesmo arquivo 60-lightdm-gtk-greeter.conf

DidBrother.



Offline jrkamil

  • Usuário Ubuntu
  • *
  • Mensagens: 412
  • Cabo Frio - RJ - Brasil
    • Ver perfil
Re:Numlock
« Resposta #8 Online: 06 de Abril de 2018, 08:51 »
no 18.04 eu executei "ajustes", "teclado e mouse", "opções adicionais de layout", "disposição do teclado numerico" e marquei  "adições unicode (setas e operadores matematicos)"
vem marcado por padrão como "desativado".

tá funcionando...    é provável que tambem funcione no 17.10 gnome

o "ajustes" foi instalado via Ubuntu software acho que "ajustes do gnome"

ECS A890GXM-A , Athlon II X3 440, 8 Gb DDR3, nvidia GF 8400GS,  ubuntu  18.04  gnome, ssd 120G, hd 500 g

Offline jrkamil

  • Usuário Ubuntu
  • *
  • Mensagens: 412
  • Cabo Frio - RJ - Brasil
    • Ver perfil
Re:Numlock
« Resposta #9 Online: 11 de Abril de 2018, 10:38 »
no terminal :

gsettings set org.gnome.settings-daemon.peripherals.keyboard remember-numlock-state true
ECS A890GXM-A , Athlon II X3 440, 8 Gb DDR3, nvidia GF 8400GS,  ubuntu  18.04  gnome, ssd 120G, hd 500 g